The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

План реализации новшеств для десктоп-редакции Ubuntu 11.10

31.05.2011 21:20

Вслед за списком приоритетных задач для серверной сборки Ubuntu, определен основной план реализации новых функций для десктоп-редакции Ubuntu 11.10.

Из опубликованного списка задач можно выделить следующие возможности:

  • Интеграция в дистрибутив GNOME 3 и GTK+ 3 (оболочка Unity по прежнему будет использоваться по умолчанию). Портирование созданных для Ubuntu приложений и апплетов на базе GTK2 и PyGtk2, разработка визуальной темы на базе технологий GTK3, интеграция indicator-appmenu и технологии всплывающих полос прокрутки в GTK3, миграция от gconf к gsettings (dconf);
  • Включение в базовую поставку упрощенной оболочки Unity 2D и библиотеки Qt. Использование по умолчанию Unity 2D при невозможности использования Unity 3D, например для видеокарт без должной поддержки OpenGL (для работы Unity 2D не требуется наличие современных видеокарт). Код Unity 2D написан с использованием Qt и технологии декларативного описания интерфейса Qt Quick;
  • Замена дисплейного менеджера GDM на проект LightDM, который отныне будет использоваться для запуска пользовательской сессии (ввода логина/пароля, выбор графической оболочки и языковых настроек).

    Особенности LightDM:

    • Универсальный API, позволяющий работать с разными GUI (gdm создавался для GNOME, а kdm для KDE). LightDM можно будет использовать во всех вариантах Ubuntu (Kubuntu, Lubuntu и т.п.). Поддерживаются фронтэнды GTK и Qt, кроме поддержки X.Org в LightDM обеспечены функции интеграции с дисплейным сервером Wayland;
    • Поддержка всех возможных аспектов использования дисплейного менеджера, включая поддержку XDMCP, многомониторных рабочих мест (multihead) и возможность реализации дополнительных функций через плагины;
    • Более высокая производительность, для запуска LightDM нет необходимости в инициировании отдельной сессии GNOME;
    • Поддержка визуальных тем, в том числе созданных с использованием обычной HTML/CSS-разметки, и наличие средств для людей с ограниченными возможностями;
    • Легковесная кодовая база: при похожих возможностях, LightDM содержит примерно 5 тыс. строк кода, в то время как код GDM вырос уже до 50 тыс. строк.
  • Включение в базовую поставку и использование по умолчанию интерфейса для организации резервного копирования Deja Dup, отличающегося простотой использования и интеграцией с технологиями GNOME. Программа позволяет сохранять бэкапы на локальной системе, копировать их на удаленный сервер или сохранять в облачных сервисах, таких как Amazon S3 и Rackspace Cloud Files. Данные в резервной копии сжимаются и шифруются. Имеются функции инкрементального резервного копирования, создания бэкапов по расписанию и выборочного восстановления данных или восстановления файлов, помещенных в бэкап в заданный отрезок времени;
  • Создание набора инструментов для создания локализованных iso-образов, адаптированных для использования в определенном регионе. В локализованных сборках планируется не только включение соответствующего определенному языку и региону локалей и переводов, но и адаптация настроек. В частности, упоминается поставка в браузере другого набора закладок, ссылок на поисковики и другую стартовую страницу по умолчанию, использование иного фонового изображения, включение в Banshee и Rhythmbox специальных подборок радиостанций, включение в поставку дополнительных пакетов (например, мультимедиа кодеков);
  • Переработка пользовательского интерфейса клиента микроблогинга Gwibber, предназначенного для интеграции с социальными сетями (Twitter, Identi.ca, Facebook, Flickr и т.п.). В настоящее время Gwibber написан на языке Python с использованием PyGTK, но так как PyGTK прекращает развитие и не будет поддерживать GTK3, решено переписать Gwibber на языке Vala, т.е. по сути создать совершенно новое приложение;
  • Проведение чистки содержимого установочного CD для высвобождения места под Qt, Unity 2D, GTK 3, deja-dup, новых драйверов. Из возможных способов нахождения дополнительного пространства отмечаются:
    • Исключение Perl (придется исключить из базовой поставки написанные на perl административные утилиты AppArmor);
    • Удаление лишних драйверов, поставляемых с Linux-ядром (драйверы для устаревших звуковых и сетевых карт, специфичные ФС, такие как gfs2 и ocfs2);
    • Исключение дублирования модулей в основной системе и в initramfs;
    • Чистка /usr/share/icons/ (сейчас там 91 Мб пиктограмм);
    • Удаление локалей для непопулярных языков;
    • поставка только Python 3, удаление Python 2.6;
    • Организация загрузки фоновых изображений из сети;
    • Чистка излишних компонентов LibreOffice;
  • Использование Thunderbird вместо Evolution в качестве почтового клиента по умолчанию.
  • Улучшение удобства работы в Центре установки приложений (Software Center): визуальная переработка интерфейса (создание новых пиктограмм); улучшение интеграции с Unity; увеличение скорости работы; обеспечение возможности управления с сенсорных экранов; увеличение стабильности и юзабилити; реализация недостающих полезных функций, которые есть в Synaptic; переработка организации рейтинга и рецензирования приложений;
  • Адаптация дистрибутива под новый цикл разработки Firefox (новый релиз Firefox будет выходить каждые 6 недель). Задача Ubuntu - обеспечить возможность установки свежих версий Firefox. Уход от использования пакета xulrunner;
  • Уменьшение числа дополнительных патчей, форсирование продвижения исправлений в upstream;
  • Портирование специфичных для Ubuntu дополнительных настроек в штатный gnome-control-center ("System Settings"). Среди таких настроек: источники приложений (software-properties-gtk), поддержка языка (gnome-language-selector), общесистемное применение настроек клавиатуры, настройка экрана входа в системы (gdmsetup), изменение времени и даты (indicator-datetime-preferences), управление работой сервиса Ubuntu One (ubuntuone-control-panel-gtk).
  • Улучшение средств для организации работы многомониторных конфигураций. В идеале, все должно оптимально работать сразу после подключения дополнительного монитора, с учетом таких нюансов, как подключение проектора или добавление второго монитора к ПК или ноутбуку;
  • Интеграция в базовую поставку средств для работы с удаленным рабочим столом на базе x2go.
  • Замена написанных на языке Java визардов LibreOffice на аналоги на языке Python, что позволит включить визарды в базовую поставку и использовать их без установки пакета libreoffice-java;
  • Обеспечение интеграции (например, быстрый вызов функций, индикатор прогресса, отображение статуса и т.п.) с оболочкой Unity всех приложений, поставляемых в базовой системе. В Ubuntu 11.04 интеграция с новым API панели запуска была проведена только для таких программ, как Empathy, Evolution, Firefox, GNOME screenshot, Deja Dup и Inkscape. Из по умолчанию доступных в панели запуска приложений, которые планируется интегрировать с Unity, отмечены: Gwibber; Update-Manager; Banshee; Nautilus; Tomboy; Transmission; Terminal; Brasero; Software Center; Totem Gedit; Thunderbird.


  1. Главная ссылка к новости (https://lists.ubuntu.com/archi...)
  2. OpenNews: Canonical готовит версию Ubuntu для автомобильных информационно-развлекательных систем
  3. OpenNews: Orchestra и Ensemble - два новых приоритетных серверных проекта Ubuntu
  4. OpenNews: Ubuntu планирует отвоевать 200 млн пользователей к 2015 году. Обсуждение замены установочного CD на DVD
  5. OpenNews: Планы Ubuntu: переход на LightDM, улучшение поддержки Btrfs и интеграция новых приложений с Unity
  6. OpenNews: Дистрибутив Lubuntu принят в число официальных проектов Ubuntu
Лицензия: CC-BY
Тип: Обобщение
Короткая ссылка: https://opennet.ru/30727-ubuntu
Ключевые слова: ubuntu, desktop
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (86) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, Anonus (?), 22:34, 31/05/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    Мне больше интересна Kubuntu, есть кто-то по 11.10?
     
     
  • 2.5, Аноним (-), 22:56, 31/05/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Кубунту - это хорошо, а со стабильным гном 2.32 больше не остается дистров?
     
     
  • 3.9, Anonus (?), 23:43, 31/05/2011 [^] [^^] [^^^] [ответить]  
  • –2 +/
    Я так понял нет, хотя насчет гнома я не сильно просвещен.
     
  • 3.12, EuPhobos (ok), 00:03, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Кубунту - это хорошо, а со стабильным гном 2.32 больше не остается дистров?

    debian

     
     
  • 4.78, Аноним (-), 13:40, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    stable? так там 2.30 и поддержка не очень длинная, хотя конечно, лучше чем ничего.
     
  • 3.34, Satori (?), 03:11, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Кубунту - это хорошо, а со стабильным гном 2.32 больше не остается
    > дистров?

    Linux Mint 11 же. Ирландские парни принципиально на гноме 2.32 остаются.

     
     
  • 4.79, Аноним (-), 13:41, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> Кубунту - это хорошо, а со стабильным гном 2.32 больше не остается
    >> дистров?
    > Linux Mint 11 же. Ирландские парни принципиально на гноме 2.32 остаются.

    Сколько они еще выдержат? Может, у них это был последний релиз с 2.32.

     
  • 3.43, Аноним (-), 07:57, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    В арче gnome-fallback выглядит и работает как gnome2. Различий не вижу. Те же панельки и значки на них. Все так же работает. Недавно обновление пришло и все стало нормально:)
     
     
  • 4.80, Аноним (-), 13:41, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > В арче gnome-fallback выглядит и работает как gnome2. Различий не вижу. Те
    > же панельки и значки на них. Все так же работает. Недавно
    > обновление пришло и все стало нормально:)

    Лично я не риску:)

     
  • 3.56, Аноним (-), 10:44, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    После 3х недель на новом гноме перешел на lxde. Всем доволен и советую.
     

  • 1.2, Аноним (-), 22:36, 31/05/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +7 +/
    Ай молодцы, лишь бы не забыли сделать что бы это работало.
     
  • 1.3, klalafuda (?), 22:37, 31/05/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    > # Исключение Perl (придется исключить из базовой поставки написанные на perl административные утилиты AppArmor);
    > # поставка только Python 3, удаление Python 2.6;

    Чудный, чудный выйдет компотег :)))
    'Вот и выросло поколение...' (c)..

     
     
  • 2.13, Stax (ok), 00:06, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    И ведь сделают, точно сделают! Как говорят, космонавт сказал - космонавт сделал :)

    Зато для Unity 2D место освободят, и для других разработок убунты...

     
  • 2.45, Gular (ok), 08:19, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Мнда, согласен. Наглые питонщики.
     
  • 2.72, Аноним (-), 12:39, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Ну питон ладно, юзерам оно не нужно, все кому надо поставят. Но выпилить AppArmor это жестко.
     
     
  • 3.81, Аноним (-), 13:43, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Утилиты просто перепишут на питон 3 и все.:)
     
  • 2.86, vov (??), 13:54, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Стоило perl у начать клепать новые релизы, всякие новый и не очень штуки типа Moose и Plack как начали выпиливать.. И ради чего? unity?
     
  • 2.91, Клыкастый (?), 15:25, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    да, мне тоже глаз резануло. Но если выпиливание питона 2.6 это скорее плюс (нечего плодить 100 версий) то перл выпилили совершенно напрасно.
     

  • 1.4, Аноним (-), 22:37, 31/05/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    >>Адаптация дистрибутива под новый цикл разработки Firefox (новый релиз Firefox будет выходить каждые 6 недель). Задача Ubuntu - обеспечить возможность установки свежих версий Firefox. Уход от использования xulrunner.

    Как это понимать? Лиса без xulrunner? Разве это возможно?

     
     
  • 2.6, fa (??), 23:02, 31/05/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Как это понимать? Лиса без xulrunner? Разве это возможно?

    Наверное, просто не будет идти отдельным пакетом

     
     
  • 3.7, Аноним (-), 23:22, 31/05/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Те же яйц^W фаберже, только в профиль.
     
  • 3.20, Аноним (-), 00:27, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    лиса не отделима от xulrunner'a
    он то есть по отдельности, но лисы в виде xul - приложения нет
     
  • 3.118, Аноним (-), 17:15, 27/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Отдельное шпашибо тогда им от пользователей того же MongoDB, который пользуется xulrunner для Spidermonkey.

    Firefox-то без GTK-зависимостей хрен вытянешь. Значит будут все линковаться статически. Или штавить поверх Убанты Шлакварь путем ./configure && make && sudo make install.

     

  • 1.8, Толстый (ok), 23:25, 31/05/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Отличный дистрибутив должен получиться, а обновление до 11.04 можно спокойно пропустить.
     
     
  • 2.66, Elhana (ok), 11:30, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Я уже до 11.04 думал, но судя по 11.10 уже точно проще будет запилить все нужное в Debian Testing, чем выпилить все ненужное из Ubuntu.
     
  • 2.67, rezzet (?), 11:36, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    В принципе да, такое чувство что в нем чего-то не хватает, так часто бывает когда происходит что-то революционное в данном случае Юнити. Старое уже забрали а новое не везде дали.
     

  • 1.18, Аноним (-), 00:23, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Включение в базовую поставку упрощенной оболочки Unity 2D  и библиотеки Qt.
    > Использование по умолчанию Unity 2D при невозможности использования Unity 3D,
    > например для видеокарт без должной поддержки OpenGL (для работы Unity 2D не
    > требуется наличие современных видеокарт). Код Unity 2D написан с
    > использованием Qt и технологии декларативного описания интерфейса Qt Quick;

    только вот в Qt 5, насколько я понял, собрались внедрить ускорение с помощью OpenGL 2.0
    причем без него работать не будет, мол компов без поддержки OpenGL 2.0 уже почти не осталось

     
     
  • 2.22, Name (?), 00:30, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Qt5 появится еще не скоро.
     
     
  • 3.39, mapron (ok), 05:43, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    бета к концу этого года ЕМНИП
     
     
  • 4.40, Аноним (-), 06:21, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Ну вообще-то ветка 3.3.х поддерживалась еще около двух лет после выхода Qt 4.0. А 4.8 я думаю проживает еще дольше.
     

  • 1.19, jura12 (??), 00:25, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –2 +/
    херня какая-то. зачем заморачиваться с экономией места если инет становится все быстрее и быстрее. не лучше-ли потратить это время на устранение болевых точек и интеграцию с чем-то еще для расширения рынка использования дистрибутива.
     
     
  • 2.23, Аноним (-), 00:38, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    А СД как был 700, так и остался.
     
  • 2.24, ascrzy (?), 00:43, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Потому что ещё много где используются именно CD дисководы, и убунточка должна влазить в этот самый CD диск
     
     
  • 3.62, Аноним (-), 11:02, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    Ага. На каждом компе, как они считают, опенгл, сильная видяха и многоядерный проце - и при этом CD-дисковод
     
     
  • 4.89, Аноним (-), 14:12, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Ага. На каждом компе, как они считают, опенгл, сильная видяха

    Нынче видеокарта способная потянуть это часто встроена просто в чипсет. Например у интела.

     
  • 3.102, Аноним (-), 20:41, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    Вы где последний раз видели приводы, которые не умеют читать DVD? На старых компах, купленных 10-15 лет назад? Так ведь там не только Убунта, но и Лубунта вряд ли запустится.

    Я уж не говорю про то, что уже давно можно поставить систему с флешки.

     
  • 2.26, MeGaGURu (?), 00:57, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Это у вас он становиться "быстрее и быстрее", а у какого-нибудь Васи из Урюпинска он может только появился и его провайдер ему дает скорость, например, 64 кбит/сек или другая проблема - лимитный интернет.
     

  • 1.25, ascrzy (?), 00:45, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +4 +/
    Я никогда не прощу им удаление перла с CD.
     
     
  • 2.28, szh (ok), 01:07, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +2 +/
    программируешь с livecd ? Программы в рам диск сохраняешь ? :)
     
     
  • 3.33, ананим (?), 03:04, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    угу.
    на моно.
     
  • 2.110, Гм (?), 23:03, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Я никогда не прощу им удаление перла с CD.

    Как же они без твоего прощения жить будут.

     

  • 1.27, develop7 (ok), 01:03, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > переписать Gwibber на языке Vala

    давно пора
    > Исключение Perl (придется исключить из базовой поставки написанные на perl административные утилиты AppArmor);

    всего-то? тогда, конечно, нафиг. благо и юзерлэнд можно переписать на чём-нибудь нормальном, вроде той же vala. ну или питоне, на худой конец.

     
  • 1.29, Vladjmir (ok), 01:19, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Марк медленно но верно мигрирует с GTK на QT?
     
     
  • 2.68, Аноним (-), 11:43, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Нет.
     

  • 1.38, prokoudine (??), 03:44, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Сколько можно мучить труп gwibber? Hotot решает :)
     
     
  • 2.101, малой (?), 18:39, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Там локализации и половины нет. А так в целом удобно.
     
     
  • 3.103, paulus (ok), 22:17, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    + Hotot доступен в виде расширения для Google Chrome
     
     
  • 4.106, Гм (?), 22:56, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > + Hotot доступен в виде расширения для Google Chrome

    Им комбайн подавай, а не просто твитер-клиент.

     

  • 1.54, fresco (ok), 10:08, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    pidgin где?
    зря они его выпилили.
     
     
  • 2.57, ано (?), 10:49, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    на его месте, кажись, empathy давно, не?
     
     
  • 3.58, fresco (ok), 10:50, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    то то и оно, что empathy.
     
     
  • 4.59, ано (?), 10:54, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > то то и оно, что empathy.

    помоему всё одно: empathy, pidgin ...
    или комбайн или psi

     
     
  • 5.61, fresco (ok), 10:59, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> то то и оно, что empathy.
    > помоему всё одно: empathy, pidgin ...
    > или комбайн или psi

    ну то по вам. а мне пиджина во все времена хватало с головой (в отличие от всяких empathy, qutim и прочих psi), и менять его на что-то по прихоти шаттлворта нет никакого желания.

    впрочем, поддержку unity должны и сами разработчики сделать -- вон в дропбоксе в выходные уже появилась.

     
     
  • 6.64, ано (?), 11:17, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >>> то то и оно, что empathy.
    >> помоему всё одно: empathy, pidgin ...
    >> или комбайн или psi
    > ну то по вам. а мне пиджина во все времена хватало с
    > головой (в отличие от всяких empathy, qutim и прочих psi), и
    > менять его на что-то по прихоти шаттлворта нет никакого желания.
    > впрочем, поддержку unity должны и сами разработчики сделать -- вон в дропбоксе
    > в выходные уже появилась.

    хм, мне казалось empathy с библиотекой pidginовской работает

     
     
  • 7.75, arachnid (ok), 13:02, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    нет - пидгиновская libpurple в зависимостях эмпати не значится
     
  • 6.76, NGAGE13 (ok), 13:28, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >>и менять его на что-то по прихоти шаттлворта

    А пидгин что убрали из реп или запретили ставить?сам постоянно удаляю эмпаси и сравлю пидгин.

     
     
  • 7.77, fresco (ok), 13:29, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > А пидгин что убрали из реп или запретили ставить?сам постоянно удаляю эмпаси
    > и сравлю пидгин.

    я там ниже ниписал, что в 11.04 он нативно не поддерживается, и приходится добавлять к unity классический трэй.

     
     
  • 8.95, paulus (ok), 17:44, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    не добавлять трей в юнити, а разрешить приложению использовать существующий трей... текст свёрнут, показать
     
  • 6.82, Аноним (-), 13:46, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >>> то то и оно, что empathy.
    >> помоему всё одно: empathy, pidgin ...
    >> или комбайн или psi
    > ну то по вам. а мне пиджина во все времена хватало с

    pidgin всеравно из ppa лучше ставить. очень часто релизят.

     
     
  • 7.83, fresco (ok), 13:48, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > pidgin всеравно из ppa лучше ставить. очень часто релизят.

    а там уже есть поддержка unity?

     
  • 5.92, Клыкастый (?), 15:41, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > помоему всё одно: empathy, pidgin ...

    не видел работающую empathy

     
     
  • 6.107, Гм (?), 22:56, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >> помоему всё одно: empathy, pidgin ...
    > не видел работающую empathy

    Посмотри.

     
     
  • 7.114, Клыкастый (?), 00:21, 03/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >>> помоему всё одно: empathy, pidgin ...
    >> не видел работающую empathy
    > Посмотри.

    не получается. на 2 сборках (для нетбуков и гномовсий десктоп) картина та же. на icq акках работает но не всё, жаббер не работает в принципе.

     
  • 2.63, Alinaki (ok), 11:16, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Pidgin заменён в Gnome был принципиально уже давно.
     
     
  • 3.65, fresco (ok), 11:24, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Pidgin заменён в Gnome был принципиально уже давно.

    это так, но до 11.04 он без проблем поддерживался в ubuntu, а сейчаc для его работы надо обратно включать классический трей, что делается нифига не в одно нажатие.

     
     
  • 4.99, Аноним (-), 18:34, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Не пользуйся убунту. Меня вот тоже мелочи достали и я перешел на другой дистр, на основе убунту - уж больно хороша пакетная база.
     
     
  • 5.112, fresco (ok), 09:14, 02/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Не пользуйся убунту. Меня вот тоже мелочи достали и я перешел на
    > другой дистр, на основе убунту - уж больно хороша пакетная база.

    я тоже в сторону минта смотрю, но пока лень, да и unity нравится, как ни странно.

     
  • 2.69, Аноним (-), 11:45, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    лучше qutim раз qt протащили
     
     
  • 3.70, fresco (ok), 11:47, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    да, согласен, юзал я его, даже по-фичастее пиджина будет. но с год назад еще глючноватый был порядочно. да и сейчас с jabber'ом у знакомых косячит нередко.
     
     
  • 4.73, ребус (?), 12:41, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    стремно то, что он на qip сильно похож, к которому доверие вообще в минусах
     
     
  • 5.100, zhuk (?), 18:36, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +1 +/
    > стремно то, что он на qip сильно похож, к которому доверие вообще
    > в минусах

    ага. и миранда, и пингвин, и копыто, и эмпати... все очень сильно похожи на кип. у всех контакт лист, окно сообщений, девкам в ацку писать можно.

     

  • 1.60, Аноним (60), 10:57, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • –1 +/
    Отличный план, в юнити будет то что так не хватал от гнома 2
     
     
  • 2.116, vanoc (ok), 14:25, 07/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    и не будет того, чего хватало.
     

  • 1.71, upyx (ok), 12:23, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    После прочтения новости, смотреть на это уже не хочется.

    Если уберут из базовой поставки перл и кучу драйверов, как диск восстановления уже не пойдет. А жаль, диск с убунтой обычно чаще всего попадается под руку, когда нужно что-то срочно чинить.

    Вообще ubuntu хорош своими LTS - кому надо работать, а не компьютер настраивать очень удобно. Но с такими планами развития становится страшно, что делать, когда срок поддержки LTS закончится.

    А пока, не заглядывая в далекое будущее, хочу попробовать Fedora 15...

     
     
  • 2.74, Аноним (-), 12:53, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > Если уберут из базовой поставки перл и кучу драйверов, как диск восстановления
    > уже не пойдет. А жаль, диск с убунтой обычно чаще всего
    > попадается под руку, когда нужно что-то срочно чинить.

    Не используйте диск 11.10 для восстановления, мало что изменится за пару лет в этом плане. А если необходимо, то и самому закинуть можно.

    > А пока, не заглядывая в далекое будущее, хочу попробовать Fedora 15...

    Недавно как раз пробовал. Из убунты по умолчанию приходилось выкидывать меньше чем в федоре закидывать, но само использование норм, правда к yum так и не привык.

     
  • 2.108, Гм (?), 22:59, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > После прочтения новости, смотреть на это уже не хочется.
    > Если уберут из базовой поставки перл и кучу драйверов, как диск восстановления
    > уже не пойдет. А жаль, диск с убунтой обычно чаще всего
    > попадается под руку, когда нужно что-то срочно чинить.

    Ну конечно если в комплекте не будет перла и 25-килограммовой кувалды то а каком восстановлении может идти речь.

     
     
  • 3.111, upyx (ok), 08:09, 02/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > Ну конечно если в комплекте не будет перла и 25-килограммовой кувалды то
    > а каком восстановлении может идти речь.

    Никогда не знаешь, что понадобится, поэтому для восстановления делают специальные CD/DVD/USB-flash с кучей всего на все случаи жизни. Просто диск с Ubuntu, который есть, лучше диска с "каким-нибудь Franzy", которого нет. И чем меньше драйверов и системных утилит на диске, тем больше шансов, что диск окажется бесполезен.

    К слову, на Sun Fire X4240 из нескольких опробованных LiveCD, только диск с Ubuntu 9.10 заработал с raid контроллером и сетью одновременно :)

     
     
  • 4.113, малой (?), 12:52, 02/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    >Никогда не знаешь, что понадобится, поэтому для восстановления делают специальные CD/DVD/USB-flash с кучей всего на все случаи жизни. Просто диск с Ubuntu, который есть, лучше диска с "каким-нибудь Franzy", которого нет. И чем меньше драйверов и системных утилит на диске, тем больше шансов, что диск окажется бесполезен.

    Cannonical никогда не позиционировал свой дистрибутив как livecd для восстановления.

     
  • 2.115, SYLion (?), 01:48, 05/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    > После прочтения новости, смотреть на это уже не хочется.
    > Если уберут из базовой поставки перл и кучу драйверов, как диск восстановления
    > уже не пойдет. А жаль, диск с убунтой обычно чаще всего
    > попадается под руку, когда нужно что-то срочно чинить.
    > Вообще ubuntu хорош своими LTS - кому надо работать, а не компьютер
    > настраивать очень удобно. Но с такими планами развития становится страшно, что
    > делать, когда срок поддержки LTS закончится.
    > А пока, не заглядывая в далекое будущее, хочу попробовать Fedora 15...

    Так то оно так, но кто тебе мешает скачать DVD образ с кучей пакетов, или накрайняк собрать своё.

    А насчёт спешки космонавта, то он всё правильно делает, это опенсорц всё таки, если их не шевелить то на месте всё тупо стоять будет. Многие вещи в Linux давно менять надо, так как их постоянно допиливают годами, они стают тяжолыми, неповротливыми и фиксить баги стаёт сложнее - это я как программист говорю (из примеров вышеупомянутые GDM и Xorg). Марк старается внести все инновации которые давно ввели (или уже вводятся) в Windows и MacOS X, ибо иначе линуху габа придёт. А так сам только убунту манит пользователей на "праведный путь" и скоро Mac обгонит по популярности, я думаю тут радоваться надо т.к. Это принесет много нового софта и т.д.

    Одно сейчас пугает, скоро в SoftwareCenter разрешат добавлять свой софт (как в AppsStore) открытый и неочень... Так вот, страшно что убунту может в очередной рынок превратится...

    Ну и на последок кого не устраивают новшества, кто не хочет привыкать к Gnome3-shell и unity покупайте себе винду и не парьте мозги, ни себе ни людям на форумах...

     

  • 1.84, crypt (??), 13:50, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Всем, кто переживает, что состав CD изменится: есть же проект UCK - закидывай, что нужно, без проблем. Я так например mdadm в десктоп поставку включаю.
     
  • 1.85, Аноним (-), 13:51, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Замена написанных на языке Java визардов LibreOffice на аналоги

    +ну_очень_много

     
     
  • 2.93, fefefw (?), 16:05, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    чему радуемся то? тому что прожорливую тормозную жабу заменили на прожорливый тормозной питон?
     
     
  • 3.98, Аноним (-), 18:22, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • +/
    Ну хоть меньше будет разнообразия. Один вид питона, вместо двух и жабы.
     

  • 1.90, Аноним (-), 14:24, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Радует убунта. Больше ее релизы не напоминают дебиан тестинг. :)
     
  • 1.96, paulus (ok), 17:56, 01/06/2011 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    unity 2d страшненький и нафиг был бы не нужен, если бы Unity сделали а-ля гном (с компизом и без). LightDM жутко глючный и недопиленный. Космонавт спешит, а автор нет. Сколько не пытаюсь - жуть! Для нормальной работы не с Unity/Gnome нужно специально конфигурировать Х.орг. Где это виданно, чтобы Х подстраивался под менеджер загрузки и это без всяких 3Д, которые там тоже не нужны... Сделан через Ж. = глюкавое Г.

    Rhythmbox лучше бы новый уже собрали, а не радиостанции втюхивали. Приходится с рра гном3 ставить и еще "кучу" софта. Thunderbird вместо Evolution наверное будет интереснее, все равно не пользуюсь, НО там куча зависимостей на Evolution, например тот же indicator-datetime. perl лично мне не особо нужен, но лучше бы они выкинули mono с banshee и tomboy (gnote быстрее и легче) - места и ресурсов было бы валом. IMHO

     
     
  • 2.109, Гм (?), 23:02, 01/06/2011 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > unity 2d страшненький и нафиг был бы не нужен, если бы Unity
    > сделали а-ля гном (с компизом и без).

    В каком месте он страшненький.

    > Rhythmbox лучше бы новый уже собрали, а не радиостанции втюхивали.

    Откуда это в свежей Ubuntu Rhytmbox

    >Приходится с
    > рра гном3 ставить и еще "кучу" софта.

    Может тогда вам не нужна Ubuntu.

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру