The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Как получить VLAN'ы от провайдера на Catalyst 2950"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco маршрутизаторы)
Изначальное сообщение [ Отслеживать ]

"Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от Андрей (??) on 13-Фев-12, 09:36 
Доброго времени суток, уважаемые!

Имеется Cisco 2951 c тремя езернет-портами и 4 провайдера от которых приходят каналы удаленных офисов. От каждого провайдера приходит несколько VLANов, так же имеется Catalys 2950, появилась мысль подключить всех провайдеров к коммутатору, а его к роутеру.
Вопрос: возможно ли на Catalys 2950 принять VLANы от провайдеров и пробросить их на Cisco 2951 для дальнейшей маршрутизации. Если да, то как?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от rus_admin on 13-Фев-12, 09:52 
> Доброго времени суток, уважаемые!
> Имеется Cisco 2951 c тремя езернет-портами и 4 провайдера от которых приходят
> каналы удаленных офисов. От каждого провайдера приходит несколько VLANов, так же
> имеется Catalys 2950, появилась мысль подключить всех провайдеров к коммутатору, а
> его к роутеру.
> Вопрос: возможно ли на Catalys 2950 принять VLANы от провайдеров и пробросить
> их на Cisco 2951 для дальнейшей маршрутизации. Если да, то как?

Транком

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от shadow_alone (ok) on 13-Фев-12, 10:35 
Запросто.
порты в транк, и разрешенные VLAN на транках.
на рутере порт в транк и поднимайте саб-интерфейсы.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от none (??) on 13-Фев-12, 10:41 
vlan-ы не пересекаются ?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от none (??) on 13-Фев-12, 10:42 
vlan-ы не пересекаются ?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от StSphinx (??) on 13-Фев-12, 11:03 
> Доброго времени суток, уважаемые!
> Имеется Cisco 2951 c тремя езернет-портами и 4 провайдера от которых приходят
> каналы удаленных офисов. От каждого провайдера приходит несколько VLANов, так же
> имеется Catalys 2950, появилась мысль подключить всех провайдеров к коммутатору, а
> его к роутеру.
> Вопрос: возможно ли на Catalys 2950 принять VLANы от провайдеров и пробросить
> их на Cisco 2951 для дальнейшей маршрутизации. Если да, то как?

Я так полагаю провайдеры отдают вам трафик не тэгированным?
Если так то, включаете каждого оператора в отдельный порт на 2950, делаете этот порт access, в нужный вам vlan. А сторону 2951 одним портом в режиме trunk, куда прописываете эти самые vlan'ы. Ну а на 2951 создаете для каждого vlan'а subinterface.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от Андрей (??) on 15-Фев-12, 07:17 
Большое спасибо всем ответившим, наша проблем оказалась в непонимании разницы меж VLAN и interface VLAN, сказалось отсутствие опыта работы со свичами:) Ниже конфиг, может в будущем пригодится кому-нибудь.

Свич:
interface FastEthernet0/1
!
interface FastEthernet0/2
description Connected to Cisco 2951
switchport access vlan 13
switchport mode trunk
!
interface FastEthernet0/3
description Connected to Provider One
switchport access vlan 13
switchport mode trunk
!
interface FastEthernet0/4
description Connected to Provider Two
switchport access vlan 12
switchport mode trunk
Cat7kab#sh vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/5, Fa0/6, Fa0/7, Fa0/8, Fa0/9, Fa0/10, Fa0/11, Fa0/12, Fa0/13, Fa0/14, Fa0/15, Fa0/16, Fa0/17, Fa0/18, Fa0/19, Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
12   VLAN0012                         active    Fa0/4
13   VLAN0013                         active    Fa0/3

Маршрутизатор:
interface GigabitEthernet0/0
description Connected to Cat2950
no ip address
!
interface GigabitEthernet0/0.12
encapsulation dot1Q 12
!
interface GigabitEthernet0/0.13
encapsulation dot1Q 13

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от crash (ok) on 15-Фев-12, 16:06 
> Большое спасибо всем ответившим, наша проблем оказалась в непонимании разницы меж VLAN
> и interface VLAN, сказалось отсутствие опыта работы со свичами:) Ниже конфиг,
> может в будущем пригодится кому-нибудь.
> Свич:
> interface FastEthernet0/1
> !
> interface FastEthernet0/2
>  description Connected to Cisco 2951
>  switchport access vlan 13
>  switchport mode trunk

так все таки trunk или access? Вы бы как-то попробовали определиться. А то похоже непонимание не только в разнице между vlan и interface vlan


Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от Андрей (??) on 19-Фев-12, 19:24 
>[оверквотинг удален]
>> Свич:
>> interface FastEthernet0/1
>> !
>> interface FastEthernet0/2
>>  description Connected to Cisco 2951
>>  switchport access vlan 13
>>  switchport mode trunk
> так все таки trunk или access? Вы бы как-то попробовали определиться. А
> то похоже непонимание не только в разнице между vlan и interface
> vlan

А ты юморист, хе-хе! (с)  наркоман Павлик
Работает как есть, если где-то ошибка - покажи.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Как получить VLAN'ы от провайдера на Catalyst 2950"  +/
Сообщение от jied83 on 22-Фев-12, 12:52 
>[оверквотинг удален]
>>> !
>>> interface FastEthernet0/2
>>>  description Connected to Cisco 2951
>>>  switchport access vlan 13
>>>  switchport mode trunk
>> так все таки trunk или access? Вы бы как-то попробовали определиться. А
>> то похоже непонимание не только в разнице между vlan и interface
>> vlan
> А ты юморист, хе-хе! (с)  наркоман Павлик
> Работает как есть, если где-то ошибка - покажи.

по красоте

interface FastEthernet0/2
description Connected to Cisco 2951
  switchport trunk allo vlan 13,14
  switchport mode trunk

interface FastEthernet0/3
description Connected to Provider One
switchport access vlan 13
switchport mode access

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру