The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]



"Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от opennews (?), 24-Окт-18, 12:26 
Опубликован (https://www.mail-archive.com/announce@httpd.apache.org/...) релиз HTTP-сервера Apache 2.4.37 (выпуск 2.4.36 был пропущен), в котором представлено 17 изменений (http://www.apache.org/dist/httpd/CHANGES_2.4.37).


Наиболее заметные изменения:


-  В mod_ssl добавлена поддержка OpenSSL 1.1.1 и протокола TLSv1.3;
-  Устранены проблемы с работой HTTP/2 при сборке с OpenSSL 1.1.1;
-  Устранён крах mod_ssl при повторном согласовании SSL-соединения  при выставленной опции OptRenegotiate, в случае если клиентский сертификат тот же, что в изначальном соединении, но требует верификации;
-  В  mod_brotli и mod_deflate восстановлена раздельная обработка ответов "304 Not Modified";
-  Улучшена обработка ошибок в mod_proxy_scgi и mod_proxy_uwsgi;
-  В mod_http2 в обработчик конца потока добавлен код для защиты от ситуации пропуска сигнала окончания потока (eos buckets) от обработчика запроса;

-  В утилиту ab добавлена поддержка клиентских сертификатов;
-  В mod_status и mod_echo налажено отображение клиентских IPv6-адресов (ранее адрес обрезался до 31 символа, что недостаточно для IPv6). Вместо поля 'client' в worker_score добавлено новое поле 'client64'.

URL: https://www.mail-archive.com/announce@httpd.apache.org/...
Новость: https://www.opennet.ru/opennews/art.shtml?num=49486

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от ОМЖ (?), 24-Окт-18, 12:26 
А все браузеры-то 1.3 уже поддерживают?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +2 +/
Сообщение от xl32 (ok), 24-Окт-18, 12:26 
Firefox 63 и Chrome 70 - да. Waterfox на подходе.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  –6 +/
Сообщение от Аноним (4), 24-Окт-18, 13:22 
> Waterfox на подходе
> Waterfox

А каковы дела с TLSv1.3 в Яндекс.Браузере и Амиго?

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от xl32 (ok), 24-Окт-18, 16:08 
Поддержкой TLSv1.3 в MS Internet Isportil я тоже не особо интересовался, если что.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

10. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от Аноним (10), 26-Окт-18, 02:25 
https://en.wikipedia.org/wiki/Transport_Layer_Security#Web_b...
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +2 +/
Сообщение от xl32 (ok), 24-Окт-18, 12:27 
OpenSSL 1.1.1 поддерживается с 2.4.35, а не с 2.4.37. Конечно, TLS 1.3 не работал. Сейчас всё отлично, работает в конфигурации по умолчанию.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

6. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от Jkeksemail (?), 24-Окт-18, 20:00 
Что все это значит? Домены на https из коробки будут работать?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +/
Сообщение от xl32 (ok), 24-Окт-18, 20:50 
Поскольку mod_ssl включён в тарболл, они и так из коробки работают.
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +1 +/
Сообщение от А (??), 24-Окт-18, 22:56 
Ещё бы поддержка tls 1.3 в дистры добавилось,в тот же centos, а то системная openssl там до 1.1.1 ещё когда доберется...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Релиз http-сервера Apache 2.4.37 с поддержкой TLSv1.3"  +1 +/
Сообщение от xl32 (ok), 25-Окт-18, 12:30 
Зачем? А бинарная совместимость?
А Nginx и Apache мы собираем. https://codeit.guru/ru_RU/
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor