The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

21.07.2016 22:47  Корректирующие выпуски PHP 5.5.38, 5.6.24 и 7.0.9. Первая бета-версия PHP 7.1

Опубликованы корректирующие выпуски языка программирования PHP 7.0.9, 5.6.24 и 5.5.38, в которых внесено 34 изменения, в том числе устранено несколько уязвимостей. В частности, устранена уязвимость Httpoxy, позволяющая организовать MITM-атаку через манипуляции с http-заголовком "Proxy". Кроме того, устранены переполнения буфера в функции virtual_file_ex и расширениях curl, XMLRPC, Session, Zips и mcrypt, разыменования нулевого указателя в расширении Exif, серия уязвимостей в библиотеке GD и обращение к памяти после её освобождения в SNMP и MBString.

В то же время опубликован первый бета-выпуск новой ветки PHP 7.1. По сравнению с прошлым альфа-выпуском в бета-версии добавлена возможность асинхронной обработки сигналов в ext/pcntl и поддержка дополнительного контекста в обработчике pcntl_signal.

  1. Главная ссылка к новости (http://php.net/index.php#id201...)
  2. OpenNews: Началось альфа-тестирование PHP 7.1
  3. OpenNews: Обновление PHP 5.5.36, 5.6.22 и 7.0.7 с устранением уязвимостей
  4. OpenNews: Корректирующие выпуски PHP 5.5.35, 5.6.21 и 7.0.6 с устранением уязвимостей
  5. OpenNews: Доступен Composer 1.0.0, менеджер зависимостей для PHP
  6. OpenNews: Релиз языка программирования PHP 7.0
Лицензия: CC-BY
Тип: Программы
Ключевые слова: php
При перепечатке указание ссылки на opennet.ru обязательно
 Добавить комментарий
Имя:
E-Mail:
Заголовок:
Текст:


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor