The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

21.06.2016 09:03  Релиз клиента для мгновенного обмена сообщениями Pidgin 2.11.0

Спустя почти пять лет с момента прошлого значительного выпуска представлен релиз клиента для мгновенного обмена сообщениями Pidgin 2.11.0, поддерживающего работу с такими сетями как AIM, ICQ, XMPP, Google Talk, Gadu-Gadu, IRC, MSN и Yahoo. Графический интерфейс Pidgin написан с использованием библиотеки GTK+ и поддерживает такие возможности как единая адресная книга, одновременная работа в нескольких сетях, интерфейс на базе вкладок, работа с аватарами и интеграция с областью уведомлений Windows, GNOME и KDE.

Поддержка подключения плагинов позволяет легко расширять функциональность Pidgin, а реализация базовой поддержки протоколов в отдельной библиотеке libpurple дает возможность создавать на базе технологий Pidgin собственные реализации. Например, для платформы macOS (новое название OS X) на базе данной библиотеки создан клиент Adium. Имеется порт библиотеки libpurple для платформы Android.

Смена значительной версии обусловлена изменением API. По недосмотру изменённый API первоначально был опубликован в составе выпуска 2.10.12 вместо 2.11.0. Другие изменения в Pidgin 2.11.0:

  • В состав включен набор сертификатов Mozilla, что решило проблемы с подключением к серверам, использующим сертификаты Let's Encrypt;
  • Удалены все 1024-разрядные сертификаты удостоверяющих центров;
  • В libpurple портирована разработанная проектом Instantbird поддержка CommandUiOps. Решены проблемы с ximagesink, приводящие к отображению лишь части видео с web-камеры. В mediamanager обновлён код удаления окна;
  • В реализации протокола AIM добавлена поддержка аутентификации на основе Kerberos, представленная в AIM 8.x;
  • В реализации ICQ прекращено обрезание паролей до 8 символов (ранее повторялось поведение старых клиентов ICQ);
  • В реализации IRC обеспечено Base64-декодирование сообщений SASL перед их передачей в libsasl;
  • Устранено 17 уязвимостей в реализации MXit (zero-day отчёты c TALOS-CAN-0118 по TALOS-CAN-0143), среди которых проблемы, позволяющие удалённо выполнить код в системе клиента и прочитать/записать содержимое памяти за границей буфера.

Дополнение: раскрыты подробности по устранённым уязвимостям.

  1. Главная ссылка к новости (https://pidgin.im/...)
  2. OpenNews: Представлен порт Pidgin libpurple для Android
  3. OpenNews: Выпуск клиента для мгновенного обмена сообщениями Pidgin 2.10.12
  4. OpenNews: В чате Facebook прекращена поддержка Empathy, Pidgin и других XMPP-клиентов
  5. OpenNews: Доступен Instantbird 1.4, IM-клиент на базе технологий Mozilla
  6. OpenNews: Релиз клиента для мгновенного обмена сообщениями Pidgin 2.10.0
Лицензия: CC-BY
Тип: Программы
Ключевые слова: pidgin, im
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Линейный вид | Ajax | Показать все | RSS
 
  • 1.1, GetAid, 09:18, 21/06/2016 [ответить] [смотреть все]
  • +6 +/
    Приятная новость, что пациент всё-таки жив, и его немного причесали.
     
  • 1.2, Какаянахренразница, 09:19, 21/06/2016 [ответить] [смотреть все]
  • +1 +/
    Хорошенький.
     
  • 1.3, LeNiN, 09:24, 21/06/2016 [ответить] [смотреть все]
  • +4 +/
    >В состав включен набор сертификатов Mozilla

    Не понимаю: почему каждая программа пытается держать свой набор сертификатов? Не правильнее ли использовать набор из ОС?

     
     
  • 2.11, Crazy Alex, 10:26, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]
  • +9 +/
    Ну так это как раз  забота маинтайнеров - подкрутить на использование всего, чего можно, из ОС . А забота автора - полностью рабочая независимая софтина.
     
  • 2.17, 5kbps, 11:00, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]
  • +/
    Не правильнее. Они различаются от дистра к дистру.
     
  • 2.31, DmA, 09:36, 22/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    я вообще не понимаю роли этих десятков сертификатов Кто его знает, кому чи то ... весь текст скрыт [показать] [показать ветку]
     
  • 1.4, Аноним, 09:25, 21/06/2016 [ответить] [смотреть все]  
  • –1 +/
    программа для простой пересылки сообщений весит около 10 мб это как-то странно ... весь текст скрыт [показать]
     
     
  • 2.5, Аноним, 09:28, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +6 +/
    мультипротокольная же
     
  • 2.24, Аноним, 12:42, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +2 +/
    ну не так уж и мало, чтоб удивляться. хотя могло бы быть и больше, это да
     
  • 2.32, DmA, 09:39, 22/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    можно в принципе ftp клиентом пользоваться и дописывать на каком-либо фтп-сервер... весь текст скрыт [показать] [показать ветку]
     
  • 2.35, Аноним, 22:27, 22/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    Так ты посмотри сколько эта программа умеет А так то можно и netcat ом сообщени... весь текст скрыт [показать] [показать ветку]
     
  • 1.6, Варфаламей, 09:40, 21/06/2016 [ответить] [смотреть все]  
  • +2 +/
    Для аськи и жаббера я использую только его, даже в те редкие моменты, когда пользуюсь виндой. Так что однозначно хорошая новость.
     
  • 1.7, анонко, 09:45, 21/06/2016 [ответить] [смотреть все]  
  • +/
    Хоть бы поддержка ВК появилась
     
     
  • 2.8, NyakoMimi, 09:49, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • –1 +/
    > Хоть бы поддержка ВК появилась

    Вроде были плагины....

     
     
  • 3.13, paulus, 10:40, 21/06/2016 [^] [ответить] [смотреть все]  
  • +/
    Ага и на фейсбучок тоже, но то работают, то нет То автор забивает, то фб специа... весь текст скрыт [показать]
     
  • 3.30, anonymous, 23:22, 21/06/2016 [^] [ответить] [смотреть все]  
  • +/
    были и отвалились в прошлом релизе, приходится на 2 10 11 сидеть... весь текст скрыт [показать]
     
  • 2.12, Аноним, 10:39, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    приехали Я уже месяца четыре как пользуюсь плагином для вк Да, пришлось поиска... весь текст скрыт [показать] [показать ветку]
     
  • 2.15, 5kbps, 10:57, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    purple-vk-plugin
     
  • 1.9, Аноним, 10:12, 21/06/2016 [ответить] [смотреть все]  
  • +/
    Поддержка есть, только в старых версиях, но автор плагина забросил его ... весь текст скрыт [показать]
     
     
  • 2.14, Аноним, 10:41, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +1 +/
    Pidgin 2 10 9-1 el7 libpurple 2 10 7 - это старая версия Использую плагин для... весь текст скрыт [показать] [показать ветку]
     
  • 1.10, robux, 10:23, 21/06/2016 [ответить] [смотреть все]  
  • +5 +/
    > По недосмотру изменённый API первоначально был опубликован в составе выпуска 2.10.12 вместо 2.11.0.

    Тут Мозилла И Хром иконки добавляют и уже мажорный номер версии сразу меняют, а эти ребята посыпают голову пеплом при смене API и изменении минора.

    Вот это выдержка! Вот это стальные яички!

     
     
  • 2.23, Аноним, 12:30, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +1 +/
    Возможно я чего-то не догоняю, но если это была смена API с потерей обратной сов... весь текст скрыт [показать] [показать ветку]
     
  • 1.16, DmA, 10:57, 21/06/2016 [ответить] [смотреть все]  
  • +1 +/
    поддержки Watch Apps нет ?
    Есть же какой-то клиент на Линукс, который можно пройдя регистрацию на андроиде перенести потом это всё на Линукс.
     
     
  • 2.25, Kott, 14:37, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    whatsapp-purple но, автор перестал его пилить, хотя плугин рабочий, второе - мог... весь текст скрыт [показать] [показать ветку]
     
  • 1.18, Аноним, 11:17, 21/06/2016 [ответить] [смотреть все]  
  • +1 +/
    Все ещё хранит пароли в plaintext?
     
     
  • 2.19, DmA, 11:31, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • –1 +/
    вроде бы уже все поняли, что клиент мгновенных сообщений просто обязан по сегодняшним скандалам поддерживать оконечное шифрование, а нет...
     
     
  • 3.20, злобный аноним, 11:39, 21/06/2016 [^] [ответить] [смотреть все]  
  • +2 +/
    Он и умеет. Плагин OTR включи.
     
     
  • 4.22, DmA, 12:28, 21/06/2016 [^] [ответить] [смотреть все]  
  • –1 +/
    > Он и умеет. Плагин OTR включи.

    а почему не из коробки работает с шифрованием?

     
     
  • 5.33, Аноним, 14:57, 22/06/2016 [^] [ответить] [смотреть все]  
  • +/
    В современных *бунтах и т.п. он из коробки с плагином OTR :)
     
  • 4.26, dr Equivalent, 17:56, 21/06/2016 [^] [ответить] [смотреть все]  
  • +/
    Их плагин OTR лучше не включать. Есть вещи, которые не стоит видеть. Это - одна из них.
     
  • 2.21, iPony, 12:09, 21/06/2016 [^] [ответить] [смотреть все] [показать ветку]  
  • +/
    Есть плагин для Gnome Keyring
    https://launchpad.net/ubuntu/+source/pidgin-gnome-keyring
     
  • 1.27, Аноним, 20:26, 21/06/2016 [ответить] [смотреть все]  
  • +/
    к сожалению из-за отсутствия адекватной системы оповещения в чате пришлось перей... весь текст скрыт [показать]
     
  • 1.28, Аноним, 22:40, 21/06/2016 [ответить] [смотреть все]  
  • +/
    А что с треем под plasma? всё никак?
     
  • 1.29, anonymous, 23:21, 21/06/2016 [ответить] [смотреть все]  
  • +1 +/
    > По недосмотру изменённый API первоначально был опубликован в составе выпуска 2.10.12 вместо 2.11.0.

    Так вот почему вдруг vk-purple отвалился в 2.10.12

     
  • 1.34, Аноним, 21:15, 22/06/2016 [ответить] [смотреть все]  
  • +1 +/
    Спасибо, что живой.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2017 by Maxim Chirkov  
    ДобавитьРекламаВебмастеруГИД  
    Hosting by Ihor