The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Обновление проприетарных драйверов NVIDIA 310.32 и AMD Catalyst Legacy 13.1

22.01.2013 13:33

Компания NVIDIA опубликовала сертифицированную версию проприетарного драйвера NVIDIA 310.32 в котором добавлена поддержка GPU GeForce GTX 680MX и Tesla K20Xm; улучшена поддержка HDMI 3D; в модуль ядра добавлена опция NVreg_EnablePCIeGen3 для включения поддержки PCI Express 3.0; добавлена поддержка ABI-интерфейса X.Org Server 1.14; увеличена производительность OpenGL-объектов фреймбуфера при работе режима Xinerama (ускорение на 2000-3000% в случае, если окно приложения выходит за границы экрана); устранено несколько ошибок.

Одновременно компания AMD выпустила драйвер Catalyst Legacy (102 Мб) с поддержкой старых видеокарт Radeon HD 2000/3000/4000, базирующихся на GPU R600 и R700. В новой версии драйвера добавлена поддержка X.Org-сервера 1.13 и обеспечена совместимость со свежими выпусками ядра Linux. Напомним, что в штатном драйвере AMD Catalyst, начиная с версии 12.6 оставлена поддержка только карт Evergreen и более новых серий.

  1. Главная ссылка к новости (http://www.nvidia.com/object/l...)
  2. OpenNews: Выпуск проприетарного драйвера AMD Catalyst 13.1
  3. OpenNews: Компания NVIDIA заявила о существенном увеличении производительности видеодрайвера для Linux
  4. OpenNews: Обновление видеодрайверов NVIDIA 313.18 и xf86-video-intel 2.20.18
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/35892-amd
Ключевые слова: amd, nvidia, driver
При перепечатке указание ссылки на opennet.ru обязательно


Обсуждение (29) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, няша (?), 13:47, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Непонятно. А до этого PCI-E 3.0 начинало работать только в иксах, что-ли? У меня и раньше в nvidia-settings показывало "Gen3".
     
     
  • 2.5, Аноним (-), 14:36, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    PCIe gen3 заблокирован почти везде. Опция скорее всего на будущее или на принудительное включение GEN3 для 690/K10 карт.
     

  • 1.3, rshadow (ok), 14:07, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    > ускорение на 2000-3000% в случае, если окно приложения выходит за границы экрана

    Я так понимаю они наконец то проверять стали координаты окна и выбрасывать из рендеринга то что не влезло на экран? <facepalm>

     
     
  • 2.6, КЭП (?), 15:09, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Если запущено 2 окна в границах экрана и одно перекрывает другое на 1/3 тогда оптимизации нет
     
     
  • 3.7, Zush (?), 15:10, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +2 +/
    > Если запущено 2 окна в границах экрана и одно перекрывает другое на
    > 1/3 тогда оптимизации нет

    Побежал покупать правильную nvidia

     

  • 1.4, Аноним (-), 14:16, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +2 +/
    >NVIDIA 310.32 - добавлена поддержка ABI-интерфейса X.Org Server 1.14
    >Catalyst Legacy  - добавлена поддержка X.Org-сервера 1.13

    Мда.

     
  • 1.9, Стас2 (?), 15:35, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Скажите, почему когда выходят драйвера одного из вендоров, то сразу же одновременно выходят и второго?
     
     
  • 2.10, няша (?), 15:40, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +4 +/
    Нуу.. наверняка, всё одной и той же масонской ложей координируется же.
     
     
  • 3.11, Zush (?), 16:04, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    одни за другими подтянулись

    все равно все эти релизы из репозитария

     
  • 3.29, Андрей (??), 08:54, 23/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    AMD не захотели узреть фак Торвальдса, адресованный им...
     
  • 2.12, ещё один анонимус (?), 16:37, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Наверное, у них сговор выпускать драйвера раз в месяц.
     

  • 1.13, Аноним (-), 17:08, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +1 +/
    Легаси дров не будет, амд - сволочи. Ну и где вы теперь ? Хотя не вижу смысла для старых карточек его юзать, но опция есть.
     
     
  • 2.15, Аноним (-), 17:26, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > Легаси дров не будет, амд - сволочи.

    Линус что-нибудь говорил об этом?


     
     
  • 3.17, Zush (?), 17:35, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >>> Линус что-нибудь говорил об этом?

    Плачет в углу

     
     
  • 4.19, Аноним (-), 18:04, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • –2 +/
    > Плачет в углу

    Не надо плакать, давайте лучше смеяться.. нет, плохо смеяться над бомжами.


     
     
  • 5.20, Аноним (-), 18:52, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >> Плачет в углу
    > Не надо плакать, давайте лучше смеяться.. нет, плохо смеяться над бомжами.

    Ути, какой толстенький.

     
  • 5.26, Карбофос (ok), 01:41, 23/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    ... кричал менеджер уборной из макдональдса
     
  • 3.30, Андрей (??), 08:55, 23/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    >> Легаси дров не будет, амд - сволочи.
    > Линус что-нибудь говорил об этом?

    Пока нет :)

     

  • 1.14, meequz (ok), 17:23, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Отлично, смогу наконец удовлетворить Steam, который так хотел 310 версию вместо 304, а я не разрешал, опасаясь статуса беты.
     
     
  • 2.16, Аноним (-), 17:28, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    > смогу наконец удовлетворить Steam

    Хотите удовлетворить Steam? Опишите процесс удовлетворения поподробней, пожалуйста?


     
     
  • 3.22, Аноним (-), 19:29, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    >Хотите удовлетворить Steam? Опишите процесс удовлетворения поподробней, пожалуйста?

    Steam при запуске в Linux выводит окошко с предложением обновить драйвера NVidia до версии 310, при установленной версии 304 (эта версия будет стабильной в Ubuntu если подключить ppa:ubuntu-x-swat/x-updates), обещая увеличение производительности.

    Самое обидное, что я бы и рад обновится до версии 310, но поскольку у меня ноут с технологией Optimus, а NVidia до сих пор официально не поддерживает её в Linux, приходится пользоваться проектом bumblebee, а он жёстко завязан на стабильном пакете с именем nvidia-current (сейчас это 304) и не умеет использовать пакет с именем nvidia-current-updates (сейчас это 310) и уж тем более beta-версии дров NVidia.

     
     
  • 4.24, Аноним (-), 20:48, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • –3 +/
    Вот вам и.. Виндовз ставить пробовали? Там со стимовскими играми вообще нет никаких проблем. Но не религиозно, понимаю.


     
     
  • 5.27, Аноним (-), 02:44, 23/01/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    а синие экраны от Баллмера пользователям нвидии просто так показывают, да
     
  • 4.25, Wormik (ok), 23:48, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +/
    Пересобери из DEB-SRC.
     
  • 2.18, Аноним (-), 17:47, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • +1 +/
    310, вроде как, давным давно стал long term support. Статус беты имеют 313-ые (которые у меня без проблем работают со дня выхода).
     
     
  • 3.21, Аноним (-), 19:03, 22/01/2013 [^] [^^] [^^^] [ответить]  
  • –1 +/
    > А у меня под виндой вообще 304 дрова до сих пор - все стимовские игры работают. Да, что-то не то сказал, не гик-революшен.
     

  • 1.23, skybon (ok), 20:21, 22/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Ждём в xorg-edgers
     
  • 1.28, EuPhobos (ok), 08:41, 23/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > ускорение на 2000-3000%

    Неа-неа.. всего на 146%

     
  • 1.31, RiF (ok), 11:44, 23/01/2013 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > В новой версии драйвера добавлена поддержка X.Org-сервера 1.13

    цитата с сайта:
    > Description:

    Automated installer and Display Drivers for Xorg 6.9 to Xserver 1.12 and Kernel version up to 3.4

    Так что поддержки иксов 1.13 нет :(
    Сам только что попробовал установить на 18 федору, и меня постигла неудача в виде всё той же ошибки, что и на 12.6-legacy
    (EE) Failed to load /usr/lib64/xorg/modules/drivers/fglrx_drv.so: /usr/lib64/xorg/modules/drivers/fglrx_drv.so: undefined symbol: noXFree86DRIExtension

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    PostgresPro
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2022 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру