The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

21.04.2011 09:23  Уязвимости во FreeBSD mountd, RT, Joomla, MyBB, Thunar, Wireshark, СУБД Oracle и PolicyKit

Несколько новых уязвимостей:

  • Во FreeBSD найдена недоработка в реализации демона mountd, используемого при монтировании NFS-разделов. Суть проблемы в том, что при указании в файле exports в блоке "-network=сеть/префикс" маски не кратной 8, итоговая подсеть рассчитывается с ошибкой. Например, при указании "-network 192.0.2.0/23" вычисляется маска 255.255.127.0 вместо 255.255.254.0. В итоге клиентская машина из другого сегмента подсети может получить доступ к NFS. Проблема не проявляется при использовании опции "-netmask";
  • В релизах RT (Request Traсker) 3.6.11 и 3.8.10 исправлено 6 опасных уязвимостей, среди которых присутствуют ошибки способные привести к выполнению кода на сервере, подстановке SQL-запросов, доступу к файлам за пределами рабочей директории и утечке закрытой информации, такой как хэши паролей пользователей;
  • В системе управления web-контентом Joomla 1.6.2 исправлено 8 уязвимостей, большинство из которых связано с возможностью подстановки JavaScript-кода на страницы (XSS). Две уязвимости можно отнести к категории опасных: возможность подстановки SQL-кода и получение неавторизированного доступа к системе;
  • В web-форуме MyBB 1.6.3 и 1.4.16 исправлены две уязвимости, которые могли привести к подстановке SQL-кода (через форму поиска и через параметр cookie "mybb[forumread]" в showthread.php);
  • В файловом менеджере Thunar, используемом в окружении Xfce, найдена уязвимость, которая может привести к выполнению кода злоумышленника при копировании специально файла, в имени которого содержатся специальные символы, используемые в функциях форматирования срок. Исправление пока доступно только в виде патча;
  • В анализаторе трафика Wireshark 1.2.16 и 1.4.5 устранены 3 уязвимости, которые могут привести к переполнению буфера и теоретической возможности выполнения кода в системе при анализе специально оформленных сетевых пакетов с использованием диссекторов NFS, X.509if и DECT;
  • В очередном обновлении СУБД Oracle устранено 8 уязвимостей, среди которых присутствуют проблем, которые могут привести к утечке закрытой информации, манипулированию некоторыми видами служебных данных (через C Oracle SSL API, а также компоненты Oracle Help, Database Vault и Application Service Level Management) и организации выполнения кода на сервере (через компонент Oracle Warehouse Builder);
  • В системе PolicyKit, используемой в большинстве Linux-дистрибутивов для предоставления расширенных прав доступа, найдена уязвимость, которая позволяет локальному пользователю повысить свои привилегии в системе при определенном стечении обстоятельств (эффект гонки в момент определения привилегий родительского процесса, через запуск suid-приложения из этого процесса). Исправление пока доступно в виде патча.

Лицензия: CC-BY
Тип: Проблемы безопасности
Ключевые слова: security, FreeBSD, mountd, RT, Joomla, MyBB, Thunar, Wireshark, Oracle, PolicyKit
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение Ajax/Линейный | Показать все | RSS
 
  • 1.1, Sadok, 13:22, 21/04/2011 [ответить] [смотреть все]    [к модератору]
  • –1 +/
    Фря.. Ну, елы-палы. Детский сад. Не ожидал, обидно. И маска дикая какая-то ) Впрочем, патч уже приехал
     
     
  • 2.2, iZEN, 13:42, 21/04/2011 [^] [ответить] [смотреть все]    [к модератору]
  • +/
    "Проблема не проявляется при использовании опции "-netmask";"

    Кто-то для NFS использовал неудачный копи-пасте вместо использования библиотечного кода.

     
     
  • 3.9, Ytch, 19:59, 21/04/2011 [^] [ответить] [смотреть все]    [к модератору]
  • +/
    >Кто-то для NFS использовал неудачный копи-пасте вместо использования библиотечного кода.

    Ну это, конечно, в корне меняет все дело.
    "Это не наш код, ваша честь, нам его подбросили".

     
  • 2.4, Великий линуксоид, 15:15, 21/04/2011 [^] [ответить] [смотреть все]    [к модератору]
  • +/
    > Фря.. Ну, елы-палы. Детский сад.

    Интересно сколько лет этой проблеме? Судя по описанию секурити "All supported versions of FreeBSD", подозреваю что проблема есть и в 6-ой, и в 5-ой ветке и т. д., просто они ныне уже не поддерживаются.

     
     
  • 3.7, Аноним, 18:26, 21/04/2011 [^] [ответить] [смотреть все]     [к модератору]
  • +/
    я с этой проблемой сталкивался давно, причем на уровне не работает почему-то к... весь текст скрыт [показать]
     
  • 1.3, Аноним, 14:37, 21/04/2011 [ответить] [смотреть все]    [к модератору]  
  • +/
    А чего ж в MyBB такие детские проблемы? Давно пора плейсхолдерами пользоваться.
     

     Добавить комментарий
    Имя:
    E-Mail:
    Заголовок:
    Текст:


      Закладки на сайте
      Проследить за страницей
    Created 1996-2018 by Maxim Chirkov  
    ДобавитьПоддержатьВебмастеруГИД  
    Hosting by Ihor