The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

Релиз SANE 1.0.20 с поддержкой новых сканеров

04.05.2009 15:00

После 15 месяцев разработки выпущен релиз пакета sane-backends 1.0.20 в котором представлено более 500 изменений. В сумме пакетом поддерживается 835 моделей сканеров, из которых 248 имеют статус полной поддержки всех функций, для 459 уровень поддержки оценен как хороший, для 101 - приемлемый, а для 27 - минимальный. Дополнительно для 172 устройств имеется не до конца протестированная реализация драйверов.

В новой версии представлены следующие улучшения:

  • Добавлены новые драйверы: canon_dr для серия устройств Canon DR, coolscan3 для сканеров Nikon LS и Coolscan, rts8891 для Umax и HP 44xx, xerox_mfp для многофункциональных устройств Samsung, Xerox и Dell;
  • Обновлены многие из уже существующих драйверов, добавлена поддержка 75 новых моделей устройств.
  • Добавлена новая система сборки из исходных текстов;
  • Реализована поддержка фреймворка Avahi, свободной реализации протокола ZeroConf;
  • Расширена поддержка сетевых сканеров;
  • Драйверы epson и coolscan2 признаны устаревшими и заменены на полностью переписанные epson2 и coolscan3;
  • Переработан код для работы со SCSI, USB, TCP и UDP;
  • Обновлена поддержка HAL (Hardware Abstraction Layer) и udev;
  • Улучшены средства конфигурации saned, доработана утилита scanimage;
  • Обновлены файлы с переводом интерфейса на различные языки, дополнена документация, исправлены накопившиеся ошибки.


  1. Главная ссылка к новости (http://lists.alioth.debian.org...)
Лицензия: CC-BY
Тип: Программы
Короткая ссылка: https://opennet.ru/21587-sane
Ключевые слова: sane, scanner
При перепечатке указание ссылки на opennet.ru обязательно
Обсуждение (49) Ajax | 1 уровень | Линейный | +/- | Раскрыть всё | RSS
  • 1.1, _stx_ (?), 15:10, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    мдя, всё равно не густо.
    оба моих сканера до сих пор не поддерживаются.
     
     
  • 2.22, yantux (??), 19:24, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Надо было покупать Xerox - цу нихЛинуксовые дрова и софт скачать можно. Правда поддержка не такая как под виндой.
     
     
  • 3.23, _stx_ (?), 19:38, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    нет уж, спасибо ))
    копир (мфу) рассыпался за пол года.
     
     
  • 4.29, _stx_ (?), 22:53, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    раз уж цензура пошла на опеннете, повторю то, что убрали из моего коммента.

    технику этой не очень хорошей (экскрементальной) фирмы (Xerox), постараюсь больше не покупать.

     

  • 1.2, vadiml (?), 15:50, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    ScanJet 2400c  USB  0x03f0/0x0a01  Unsupported  
    жаль
     
     
  • 2.3, uldus (ok), 16:19, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >ScanJet 2400c  USB  0x03f0/0x0a01  Unsupported
    >жаль

    Был очень удивлен, когда увидел, что HP-шные сканеры ScanJet не поддерживаются родными hplip драйверами (http://hplipopensource.com/). Пришлось взять МФУ для которого в hplip есть поддержка.

     
     
  • 3.25, Аноним (-), 20:53, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    А мой HP ScanJet 3800 работает уже давно;)
     
  • 2.4, slek (??), 16:21, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Вот-вот. Сейчас пользуюсь каким-то модицированный билдом sane и закрытой либой - в нете валяется. А хотелось бы открытую поддержку. К слову, интересно почему именно этот сканер (хотя он вроде распространен) трудноизучаемый?
     

  • 1.5, Аноним (-), 17:27, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Да когда же они CanoScan LiDE 90 сделают!
    Надоело жить с вендой в кармане :(
     
     
  • 2.7, Inspirra (ok), 17:58, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Да когда же они CanoScan LiDE 90 сделают!
    >Надоело жить с вендой в кармане :(

    VueScan - Вам помоежт: http://www.hamrick.com/vsm.html

     
     
  • 3.13, хакир (?), 18:12, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>Да когда же они CanoScan LiDE 90 сделают!
    >>Надоело жить с вендой в кармане :(
    >
    >VueScan - Вам помоежт: http://www.hamrick.com/vsm.html

    а зачем я покупал сканер если софт к нему нужно покупать отдельно?

     
     
  • 4.14, Inspirra (ok), 18:23, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>>Да когда же они CanoScan LiDE 90 сделают!
    >>>Надоело жить с вендой в кармане :(
    >>
    >>VueScan - Вам помоежт: http://www.hamrick.com/vsm.html
    >
    >а зачем я покупал сканер если софт к нему нужно покупать отдельно?
    >

    А что - за винду в кармане - платить не надо?

     
     
  • 5.24, _stx_ (?), 19:41, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    это совсем другой вопрос.
    устройство должно сопровождаться драйверами от производителя, а не от сторонних разработчиков.
     
  • 4.59, Glaf (?), 10:08, 17/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >>>Да когда же они CanoScan LiDE 90 сделают!
    >>>Надоело жить с вендой в кармане :(
    >>
    >>VueScan - Вам помоежт: http://www.hamrick.com/vsm.html
    >
    >а зачем я покупал сканер если софт к нему нужно покупать отдельно?
    >

    Обратите внимание, LiDE 90 "supported on Windows and Mac OS X". Под линукс поддержки не заявлено.
    http://www.hamrick.com/vuescan/vuescan.htm#canon

     
     
  • 5.60, Inspirra (??), 10:36, 17/01/2010 [^] [^^] [^^^] [ответить]  
  • +/
    >Обратите внимание, LiDE 90 "supported on Windows and Mac OS X". Под
    >линукс поддержки не заявлено.
    >http://www.hamrick.com/vuescan/vuescan.htm#canon

    Увы, значит не повезло. Остается только какой-нибудь эмулятор, типа VirtualBox'а, с Win98.

     

  • 1.6, хакир (?), 17:41, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Посмотрим реальности в глаза.
    Из новых моделей сканеров, которые существуют в продаже, те которые поддерживаются sane можно пересчитать одной рукой. Выбор очень маленький.
    Экстрасенсов прошу не беспокоиться, это не ругательство в сторону sane.
    Просто маркетинг, меня лично, достал уже.
    Зачем менять все каждый год, ведь есть нормальные модели, так нет их уже не выпускают.
     
     
  • 2.8, хакир (?), 18:02, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    и вот пример, взял из прайс из обычного магазина:

    Сканер Canon CanoScan LiDE 100 - unsupported
    Сканер Canon CanoScan LiDE 200 - unsupported
    Сканер Canon CanoScan 4400F - нет в списке
    Сканер Canon CanoScan 5600F - нет в списке
    Сканер Epson Perfection 4490 - нет в списке
    Сканер Epson Perfection V10 - работает помоему через бинарный модуль iscan
    Сканер Epson Perfection V200 - нет в списке
    Сканер Epson Perfection V30 - нет в списке
    Сканер Epson Perfection V300 - нет в списке
    Сканер Epson Perfection V350 - нет в списке
    Сканер Epson Perfection V500 - нет в списке
    Сканер HP ScanJet G2410 - нет в списке
    Сканер HP ScanJet G2710 - basic
    Сканер HP ScanJet G3110 - basic
    Сканер HP ScanJet G4010 - unsupported
    Сканер Mustek Be@rPaw 1200 CU - good
    Сканер Mustek Be@rPaw 2400 CU - basic
    Сканер Mustek Be@rPaw 2448 CS - basic
    Сканер Mustek Be@rPaw 2448 TA - basic

    ситуация очень плачевная, используем на предприятии АРМы со сканерами, сканеры меняем раз в полтора года (из за износа), сначала использовали mustek 2448, все померли (сначала блоки питания потом сам механизм заюзали до дыр), сейчас стоят epson 1270 (но скоро наработка на отказ пойдет и у них) и в продаже их уже нет, уже нужно планировать закупку, что выбирать Х.З.

     
  • 2.10, Inspirra (ok), 18:05, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Посмотрим реальности в глаза.
    ><...>
    >Просто гребанный маркетинг, меня лично, достал уже.

    Посмотрите пристальнее в глаза реальности... Это рынок, а не коммунизм - не нравится - вперед, на Смольный. (-; Только, боюсь новые глаза реальности вам тоже не понравятся.

     
     
  • 3.12, хакир (?), 18:09, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >нравится - вперед, на Смольный. (-; Только, боюсь новые глаза реальности
    >вам тоже не понравятся.

    вы случайно не маркетолог, которого из за кризиса выкинули на помойку?

     
     
  • 4.18, Inspirra (ok), 18:36, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>нравится - вперед, на Смольный. (-; Только, боюсь новые глаза реальности
    >>вам тоже не понравятся.
    >
    >вы случайно не маркетолог, которого из за кризиса выкинули на помойку?

    Нет, я вовсе не случайно - не маркетолог. А вот вы, используя sane в производственном процессе - могли бы и профинансировать разработку, хотя бы одного драйвера.
    А то, ишь - маркетологи не нравятся...
    Маркетологам до лампочки ваши потребности - их интересуют быдло-потребители, а быдло-потребителей интересуют маркетологи - они и построили меж собой отношения - хотите жить по их законам - становитесь либо маркетологом, либо быдло-потребителем. А не хотите - стройте свой мир.

     

  • 1.9, Аноним (-), 18:03, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    да, со сканерами в линукс беда просто
     
     
  • 2.11, Inspirra (ok), 18:07, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >да, со сканерами в линукс беда просто

    Купите VueScan и все беды у Вас кончатся.

     
     
  • 3.16, alexxx (??), 18:30, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    А с какого рожна для КУПЛЕННОГО сканера нужно покупать софт? - разводка, не находите. Пусть продают софт, никто не против, но РАСШИРЯЮЩИЙ БАЗОВЫЙ функционал. Т.е. для работы не обязательный.
     
  • 3.32, geekkoo (ok), 01:29, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Не уверен, что кончатся. Я как-то смотрел vuescan с прицелом на одну модель сканера - так там ситуация полностью аналогичная - в виндовой версии драйвер для него есть, а в линуксовой - фиг. При этом, разумеется, повсюду написано, что эта модель поддерживается VueSCAN-ом ...
     

  • 1.15, Аноним (-), 18:26, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Моего Canon Lide 70 нет в VueScan
     
  • 1.17, Аноним (-), 18:35, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Купите VueScan и все беды у Вас кончатся.

    Если в Linux'е покупать как в винде архиваторы по 30 USD и проги для сканирование за 80 USD, то проще купить винду и не мучиться ( там проги для сканирования поставляются вендором сканера за бесплатно ( ну или точнее уже включена в стоимость сканера))

     
     
  • 2.31, szh (ok), 23:25, 04/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    > то проще купить винду и не мучиться

    проще "купить" Линукс за 100$ чем мучаться с виндой

    > там проги для сканирования поставляются вендором сканера за бесплатно
    > ( ну или точнее уже включена в стоимость сканера)

    Это неприятно, оплачивать ненужную и вредоносную ОС.

     

  • 1.26, scsnow (?), 21:58, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    да чего уж говорить. сканеры - это беда линукса. мой старенький hp 5370 висит как supported, однако год назад в течение более полугода он был нерабочим - segfault...
     
  • 1.27, Аноним (-), 22:17, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >У меня не работает...

    Купите б/у сканер и б/у комп (3-x летней давности).
    И нет проблем. И дешево и сердито.

     
  • 1.28, scsnow (?), 22:20, 04/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    > Купите б/у сканер

    перечитайте, что я написал. моему сканеру лет 7...

     
  • 1.33, Timka (??), 02:03, 05/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    VueScan программа стоящая своих денег. Она куда лучше стандартных драйверов и позволяет выжать из железа максимум. Так что если используете в производстве - купите, не пожалейте, сумма-то копеечная.
     
     
  • 2.35, pure (?), 03:15, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>VueScan программа стоящая своих денег. Она куда лучше стандартных драйверов и позволяет >>выжать из железа максимум. Так что если используете в производстве - купите, не >>пожалейте, сумма-то копеечная.

    Ну что Вы! Линуксоиды с рождения знают только одно слово - ХАЛЯВА. Понятия заплатить за что-то они не приемлют по определению. Для них, видите ли, весь софт должен быть бесплатным, да еще к тому же и с исходниками, выложенными для свободного скачивания.
    У них, знаете-ли, коммунизм, в отдельно взятой стране... ой тоесть ОСи. И поклоняются они своему отдельно взятому Ленину... ой тоесть Линусу...

     
     
  • 3.40, Zenitur (?), 06:11, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Ага, ты прав. А ещё графической оболочки нет, врут они всё. Это консоль. Это для матёрых программистов, и чтобы хотя бы пустой файл создать, надо 8 толстых книг прочитать. Калькулятор и тот требует прочтения руководства! Компилируется из исходников, и запускается с пятого раза. Да ещё и глючит со страшной силой и считает неправильно! И всё - с клавиатуры! Даже арканоид.
     
     
  • 4.48, tipa_admin (?), 09:05, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    touch имя.файла - на 8 толстых книг не тянет
     
     
  • 5.50, asa (??), 10:01, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Для некоторых может может и не тянет, а вот другим действительно надо как минимум столько прочитать чтобы правильно формулировать просьбу продиктовать им команду побуквено...
     
     
  • 6.56, Hettikus (??), 22:10, 06/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    : > имяфайла

    Так легче диктовать :)

     
  • 2.37, Inspirra (ok), 03:59, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >VueScan программа стоящая своих денег. Она куда лучше стандартных драйверов и позволяет
    >выжать из железа максимум. Так что если используете в производстве -
    >купите, не пожалейте, сумма-то копеечная.

    +1

    http://radikal.ru/F/i011.radikal.ru/0905/75/4da2d6e802fb.png.html
    Если картинку увеличить в три-четыре раза, то легко увидеть, что VueScan позволяет сканировать фактически без шумов. А еще есть множественная экспозиция позволяющая увеличить динамический диапазон сканера - за что в железном варианте пришлось бы заплатить сотни баксов за соответствующий сканер. Т.е. за эти деньги получается не просто драйвер, а реально увеличивающий возможности сканера софт.

    Да, ситуация не самая приятная, что производители не делают (или делают залепы) драйвера под Linux. Но ведь - ни разработчики линукса, ни разработчики Sane, ни производители сканеров - ничего, никому не обещали...
    Так что надо радоваться, что Еd Hаmrick пишет (и профессионально пишет) программу и продает ее за гроши, по сравнению с аналогичными программами такого класса (разница почти в десять раз).


    А если идет речь только о тексте - то нытье некоторых совсем не понятно, так как все современные сканера Epson поддерживаются через "sane-epkowa", он же ущербный "iscan".

     

  • 1.39, Zenitur (?), 05:48, 05/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Как здесь много идиотов. Неужели непонятно, что SANE - это не единственная программа для сканирования! Их полно! Для моего Epson я использую фирменные.
     
     
  • 2.41, Inspirra (ok), 06:15, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Как здесь много идиотов. Неужели непонятно, что SANE - это не единственная
    >программа для сканирования! Их полно! Для моего Epson я использую фирменные.

    Поаккуратнее с выражениями! )-;

    Во-первых: фирменных драйверов от Epson, под Linux, ни для принтеров, ни для сканеров - не существует! Вот официальный их ответ на мой запрос (09-12-2008):

    > EPSON не заявляет поддержку Linux.
    > Не могли бы Вы уточнить откуда информация о поддержке?
    > Если Вы имеете ввиду ссылки на нашем сайте, то они на сайт стороннего
    > производителя.
    >
    > Официально, компания Epson не поддерживает ОС Linux.
    >

    Во-вторых: я уже привел ссылку на сканы с VueScan и Sane. Только забыл дополнить - что sane использовало драйвер от "avasys.jp" - рекомендую обратить внимание на разницу в качестве!
    Более того - возможности sane-epkowa - не дотягивают до заявленного функционала сканера. В частности - не реализует доступное разрешение сканера V700, не говоря уже о дополнительном функционале.

    Так что рекомендую Вам извиниться за оскорбления!


     

  • 1.42, Hawk (??), 06:33, 05/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Добавили xerox_mfp? просто отлично. У меня xerox pe 220, подключен к asus wl500gp, надо поковырять...
    Многие кстати кто жалуется на отсутствие поддержки, попробуйте разобраться как и на чем построен ваш сканер. В свое время на работу был куплен genius vivid 4, поддержки которого в SANE не было. Построен он на gt68xx, но нормально не работал даже после ручного добавления и прочих плясок. В общем, связался я с разработчиком плагина, и вуаля - после 2-х дней общения на IRC сканер заработал, парень че-то там поправил, и теперь поддержка этого сканера в sane есть ;)
     
     
  • 2.43, Hawk (??), 06:40, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    ;(
    посмотрел на сайт - для моего ксерокса поддержки нет :(


     
  • 2.49, Аноним (-), 09:52, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    Да уж... Знать, что такое микросхема, уметь разобраться, какая же именно используется в твоем сканере. Поискать автора, кто писал что-то для нее, пару дней общаться с ним, и потом, может быть, сканер чего-то там отсканирует. И кому это надо, кроме кружка юных техников? :D
     
     
  • 3.55, Hawk (??), 08:32, 06/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Да уж... Знать, что такое микросхема, уметь разобраться, какая же именно используется
    >в твоем сканере. Поискать автора, кто писал что-то для нее, пару
    >дней общаться с ним, и потом, может быть, сканер чего-то там
    >отсканирует. И кому это надо, кроме кружка юных техников? :D

    ну наверное как минимум мне и другим владельцам такого сканера. Или им не надо?

     

  • 1.51, Аноним (-), 11:01, 05/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    Да, как не пахал мой старенький Mustek 2400 Cu Plus под SANE так и не пашет...
    Хорошо, что есть у меня Winda XP и FineReader 9(лицензионные, конечно). А споры зачем платить деньги за Soft напоминают мне рассуждения на тему: зачем платить большие деньги за BMW, если есть Авто ВАЗ.
    Короче пора заканчивать с этим Linux (5 лет уже играюсь с ним).
     
     
  • 2.54, Дмитрий (??), 17:43, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >Да, как не пахал мой старенький Mustek 2400 Cu Plus под SANE
    >так и не пашет...
    >Хорошо, что есть у меня Winda XP и FineReader 9(лицензионные, конечно). А
    >споры зачем платить деньги за Soft напоминают мне рассуждения на тему:
    >зачем платить большие деньги за BMW, если есть Авто ВАЗ.
    >Короче пора заканчивать с этим Linux (5 лет уже играюсь с ним).

    Если мне не изменяет память, то Мустековские сканеры вообще-то давно не мустековские а Асеровские. И насколько помнится, то довольно много моделей Мустека таки поддерживаются САНЕ. Вы лучше пишите производителю раз в месяц по сообщению - напоминанию - мол: предоставте для модели такой-то поддержку линукс драйвера. Когда критическая маса надоест производителю - он начнёт супорт. Думаю причин неподдержки несколько (основных):
    1. доп.затраты (програмисты, тесты)
    2. приплаты и договорённости с МС (по лицензированию драйверов). Вы же не видели никогда договора по лицензированию драйверов под виндовс? Может там прямиком прописано отказ от производства драйверов Линукса?
    3. практически невозможно спрятать код работы с устройством и реальные параметры устройства при использовании в Линукс, ведь потому так нагло нас обманывают производители сканеров насчёт реального (хард) и програмного разрешения сканеров и насчёт других параметров (скорости, цветности, и т.д.).

    Я всегда всем говорю  - "В этой системе не нужны лишние дураки, лохи, и незнающие!" - для этого есть Виндовс, где каждый может возомнить себя "специалистом", "админом". Главное у Вас есть выбор, а воспользовались ли Вы им - дело Ваше.

     

  • 1.52, Аноним (-), 12:09, 05/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    >Да, как не пахал мой старенький Mustek 2400 Cu Plus под SANE так и не пашет...

    Хорошо, что есть у меня Winda XP и FineReader 9(лицензионные, конечно). А споры зачем платить деньги за Soft напоминают мне рассуждения на тему: зачем платить большие деньги за BMW, если есть Авто ВАЗ.
    Короче пора заканчивать с этим Linux (5 лет уже играюсь с ним).

    Действительно зачем платить за Linux когда есть Windows, да и стоит дёшево ( вот правда ездит как Авто ВАЗ, глючит, тормозит, завирусевает)?

     
     
  • 2.53, rico (?), 15:24, 05/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>Да, как не пахал мой старенький Mustek 2400 Cu Plus под SANE так и не пашет...
    >
    >Хорошо, что есть у меня Winda XP и FineReader 9(лицензионные, конечно). А
    >споры зачем платить деньги за Soft напоминают мне рассуждения на тему:
    >зачем платить большие деньги за BMW, если есть Авто ВАЗ.
    >Короче пора заканчивать с этим Linux (5 лет уже играюсь с ним).
    >
    >
    >Действительно зачем платить за Linux когда есть Windows, да и стоит дёшево
    >( вот правда ездит как Авто ВАЗ, глючит, тормозит, завирусевает)?

    у некоторых и BMW "ездит как Авто ВАЗ, глючит, тормозит, завирусевает"
    тут же дело не в машине - ....
    =)

     

  • 1.57, polkan (ok), 05:42, 07/05/2009 [ответить] [﹢﹢﹢] [ · · · ]  
  • +/
    почитал тут крики "мой сканер не поддерживается SANE(Linux)! когда же его будут поддерживать?" и как то стыдно стало за качество пользователей линукса.

    Был у меня мустек А3усб, на тот момент А3скази только поддерживался в САНЕ, казалось бы "сиди и плакайся".. одначе в те суровые годины, когда любой софт МС для россиян был "фриваре", пользователи линукса не ставили во главу угла "бесплатность" линукса, а ставили его открытость и возможность самостоятельной доводки до ума, а также возможность реального понимания происходящих в ПО процессов... в применении к моему сканеру это выразилось в разборке исходников от А3скази и 1200усб и сотворении из этих 2 драйверов одного работающего с А3усб :)

    ось тогда у меня была редхат 8.0, знаний намного меньше чем сейчас, а желания заниматься открытым софтом намного больше... сейчас я сам себя все чаще ловлю на "виндовом" отношении к ПО по типу "не пашеть? подождем-поплачем... глядишь напишут" - и это очень печально...

     
     
  • 2.58, geekkoo (ok), 09:21, 07/05/2009 [^] [^^] [^^^] [ответить]  
  • +/
    >>в применении к моему сканеру это выразилось в разборке исходников от А3скази и 1200усб и сотворении из этих 2 драйверов одного работающего с А3усб :)

    Все подобные пенки сняли ещё году в 2000. Сейчас ситуация иная - приходится разрабатывать драйвера для устройств, под которые производители принципиально не дают спецификаций. Что приводит к необходимости взламывания бинарного протокола, вычленения фирмваря и прочих радостей ... Причем зачастую устройства даже в qemu  не пашут, так что даже поток с них нормально не перехватишь!

    Это вам не порт со скази на усб ...

     

     Добавить комментарий
    Имя:
    E-Mail:
    Текст:



    Спонсоры:
    Inferno Solutions
    Hosting by Hoster.ru
    Хостинг:

    Закладки на сайте
    Проследить за страницей
    Created 1996-2020 by Maxim Chirkov
    Добавить, Поддержать, Вебмастеру