The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Cisco 2801 низкая скорость передачи"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Учет трафика и статистика)
Изначальное сообщение [ Отслеживать ]

"Cisco 2801 низкая скорость передачи"  +/
Сообщение от ALDOR (ok) on 01-Окт-12, 08:21 
Доброго времени суток! Подскажите пожалуста.
Собираю сеть на тестовом стенде. Маршрутизатор Cisco 2801  и Debian 6.0 Squeeze, за каждым из них по компьютеру. Связь пока по простым интерфейсам. Проблема в низкой скорости в одну сторону.
Между циской и дебианом настроил туннель (пока без шифрования без ничего) 192.168.100.14/30 (дебиан) и 192.168.100.13/30 (циска), настроил маршрутизацию так чтобы все шло через туннель.
При замере скорости (программой iperf.exe)  связь от компа за дебианом до компа за циской около 65 Мбит/с (если тестировать TCP траффиком). А в обратную сторону от компа за циской до компа за дебианом еле еле набирается 64 кбит/с (TCP траффиком), и около 1.05 Мбит/с UDP траффиком. Что это может быть и  чем это связано?
Все соединено обычной витой парой 100Мбит/с (в циску все тыкается кроссовером).  

Схема сети:
           10.0.0.1/24 (192.168.100.14/30
       _           ___   192.168.100.13    |-----------|192.168.1.1/24        ___
      |_| --------|   |--------------------|_Cisco_____|---------------------|___|
  комп за         |   |172.16.0.2/24   172.16.0.1/24          192.168.1.2/24        
дебианом          |___|                                                 Комп за циской
   10.0.0.2/24     Debian


пробовал разные настройки : Auto, 100Мбит full duplex, Mtu 1400-1500-1600, все без толку.
Файл размером 300 Мбайт с компа за дебианом льется на комп за циской где то за минуту, а с компа за циской в комп за дебианом 222 минуты. Оба компа по разные стороны чистые, стоит голый windows, все брендамауэры/авири отключены.
Помогите пожалуста.


Логи:
cisco2801#show  running-config
Building configuration...

Current configuration : 1590 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cisco2801
!
boot-start-marker
boot-end-marker
!
enable secret level 2 5 $1$OngG$nHkta2I.t7WUWlZkQNYtM.
enable secret 5 $1$7aA5$NBZevRoZqdgvxeSMP0vVT.
!
aaa new-model
!
!
!
!
aaa session-id common
!
!
dot11 syslog
ip cef
!
!
!
!
ip domain name Cisco2801
!
multilink bundle-name authenticated
!
!
!
username admin secret 5 $1$zD1K$UFot0Xw2kShUZ8/00CyHo1
username pooruser privilege 2 secret 5 $1$qZT/$SoRQBTl4OuErtrn0n6mVc.
!
crypto isakmp key 6 kolanart address 80.249.178.146
!
!
crypto ipsec transform-set 3DES.MD5.HMAC esp-3des esp-md5-hmac
mode transport
!
crypto ipsec profile VPN
set transform-set 3DES.MD5.HMAC
!
archive
log config
  hidekeys
!
!
!
!
!
interface Tunnel3
description Tunnel to ep-gw
ip address 192.168.100.13 255.255.255.252
ip mtu 1400
tunnel source FastEthernet0/1
tunnel destination 172.16.0.2
!
interface FastEthernet0/0
description LAN
ip address 192.168.1.1 255.255.255.0
speed 100
full-duplex
!
interface FastEthernet0/1
description Debian
ip address 172.16.0.1 255.255.255.0
duplex auto
speed 100
!
ip forward-protocol nd
ip route 10.0.0.0 255.255.255.0 192.168.100.14
!
!        
ip http server
no ip http secure-server
!
access-list 5 permit 192.168.1.2
access-list 101 permit ip 0.0.0.0 255.255.255.0 0.0.0.1 255.255.255.0
!
!
!
!
control-plane
!
privilege exec level 2 show running-config
privilege exec level 2 show
!
line con 0
line aux 0
line vty 0 4
transport input ssh
!
scheduler allocate 20000 1000
end

sho interfaces stats
cisco2801#show  interfaces stats
FastEthernet0/0
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor        150      27831        464      48303
             Route cache      81565  122206735      73469   13908438
                   Total      81715  122234566      73933   13956741
FastEthernet0/1
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor       3582     290904       2615     400104
             Route cache      73483   14201630     161700  128805143
                   Total      77065   14492534     164315  129205247
Tunnel3
          Switching path    Pkts In   Chars In   Pkts Out  Chars Out
               Processor          3        252         22       8790
             Route cache      12089    2415504     161708  126547607
                   Total      12092    2415756     161730  126556397

cisco2801#show  processes cpu  history

cisco2801   04:09:08 AM Monday Oct 1 2012 UTC

                                                                
                                                                
            22222     111112222211111111111111122222111111111122
100                                                            
90                                                            
80                                                            
70                                                            
60                                                            
50                                                            
40                                                            
30                                                            
20                                                            
10                                                            
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per second (last 60 seconds)

                                                                
     4  3         3          3                                  
    213342      118111 2222 23 1  22222222222223242133111  1 222
100                                                            
90                                                            
80                                                            
70                                                            
60                                                            
50                                                            
40  *            *                                            
30  *  *         *          *                                  
20  *  *         *          *                                  
10  *  *         *          *                                  
   0....5....1....1....2....2....3....3....4....4....5....5....6
             0    5    0    5    0    5    0    5    0    5    0
               CPU% per minute (last 60 minutes)
              * = maximum CPU%   # = average CPU%

                                                                            
    9                                                                      
    3                                                                      
100                                                                        
90 *                                                                      
80 *                                                                      
70 *                                                                      
60 *                                                                      
50 *                                                                      
40 *                                                                      
30 *                                                                      
20 *                                                                      
10 *                                                                      
   0....5....1....1....2....2....3....3....4....4....5....5....6....6....7..
             0    5    0    5    0    5    0    5    0    5    0    5    0  
                   CPU% per hour (last 72 hours)
                  * = maximum CPU%   # = average CPU%

cisco2801# show  ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.0.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
S       10.0.0.0 [1/0] via 192.168.100.14
C    192.168.1.0/24 is directly connected, FastEthernet0/0
     192.168.100.0/30 is subnetted, 1 subnets
C       192.168.100.12 is directly connected, Tunnel3


root@debian:/home/dennis# route -n //таблица маршрутизации на дебиане
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.100.0   0.0.0.0         255.255.255.252 U     0      0        0 tun0
10.0.0.0        0.0.0.0         255.255.255.0   U     0      0        0 eth2
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 tun0
172.16.0.0      0.0.0.0         255.255.255.0   U     0      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth2
0.0.0.0         172.16.0.1      0.0.0.0         UG    0      0        0 eth0


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от Andrey (??) on 01-Окт-12, 08:28 
> Проблема в низкой скорости в одну сторону.

Проверяйте дуплексы на интерфейсах.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от ALDOR (ok) on 01-Окт-12, 09:53 
>> Проблема в низкой скорости в одну сторону.
> Проверяйте дуплексы на интерфейсах.

Проверил, на интерфейсе 172.16.0.1 стояло в auto, выставил все в 100 Мб / full дуплекс.
На компе 10.0.0.2 в настройках сетевой выключил flow control.
Скорость стала 1,2 Мбит/с в обе стороны.

Перевел все обратно на auto, убрал flow control, qos на СК 10.0.0.2/24, скорость стала 92,6 Мбит/с  от компа за дебианом к компу за циской,  а обратно 557 Кбит/с ((
Может дело в том что у компьютеров разные сетевые карточки? За дебианом стоит ноут, в нем Broadcom 440x, а за циской обычная Realtek RTL8139  в которой настроек на половину меньше?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от ALDOR (ok) on 01-Окт-12, 11:31 
думал проблема в открывающихся окнах TCP ( на компе за циской размер окна был 64 кб, а на компе за дебианом 8 кб), попробовал порегулировать TCP optimizeroм - тоже не особо дало эффекта,  скорость максимум 3,72 Мбит /с в сторону компа за дебианом.
Что ещё может быть не так?
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от Pve1 (ok) on 01-Окт-12, 14:56 
> думал проблема в открывающихся окнах TCP ( на компе за циской размер
> окна был 64 кб, а на компе за дебианом 8 кб),
> попробовал порегулировать TCP optimizeroм - тоже не особо дало эффекта,  
> скорость максимум 3,72 Мбит /с в сторону компа за дебианом.
> Что ещё может быть не так?

MTU трогать не надо.

На тунельном интерфейсе сделайте:

ip tcp adjust-mss 1360
tunnel path-mtu-discovery

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от ALDOR (ok) on 02-Окт-12, 07:51 

> MTU трогать не надо.
> На тунельном интерфейсе сделайте:
> ip tcp adjust-mss 1360
> tunnel path-mtu-discovery

попробовал, не помогло
Также, 3,56 Мбит/с

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Cisco 2801 низкая скорость передачи"  +/
Сообщение от ALDOR (ok) on 02-Окт-12, 09:24 

> попробовал, не помогло
> Также, 3,56 Мбит/с

Вообщем проблема решилась тем что я поменял сетевуху на компе за циской. вместо встроенного риалтека 8139 поставил компекс. Скорость стала 81 Мбит/с в обе стороны.
Вообще странно почему риалтек с драйвером 2009 года напрочь не хотел подниматься больше чем на 3,2 Мбит/с

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру