The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Балансировка входящего траффика с использованием BGP на Cisc..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от ivanbks email(ok) on 18-Янв-07, 13:21 
Ситуация такая - работаем с 2мя провайдерами по BGP, анонсировали свою PI сеть. Весь исходящий траф уходит обоим провайдерам, и приходит (примерно) поровну на 2 канала.
Задача в следующем - проанонсировать свою AS'ку 2му провайдеру таким образом, что бы траффик от него приходил лишь в том случае, когда пропал (или загружен) канал 1го провайдера.

Надеюсь объяснил понятно.
Вот такой получился конфиг

c2800#show run
Building configuration...

Current configuration : 2959 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname c2800
!
boot-start-marker
boot system flash c2800nm-advipservicesk9-mz.124-3a.bin
boot-end-marker
!
logging buffered 52000 debugging
enable secret 5 $1$joXB$AZf8ojex2.Ej7f95eIn4y/
!
no aaa new-model
!
resource policy
!
ip subnet-zero
!
!
ip cef
!
!
no ip domain lookup
ip domain name yourdomain.com
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ххх privilege 15 secret 5 $1$tXNf$js3PKNFNitJAvLaHpT8QP/
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0
  no ip address
  duplex auto
  speed auto
!
interface GigabitEthernet0/0.1
  description prov2
  encapsulation dot1Q 2
  ip address x.x.x.x 255.255.255.252
!
interface GigabitEthernet0/0.2
  description prov1
  encapsulation dot1Q 3
  ip address y.y.y.y 255.255.255.252
!
interface GigabitEthernet0/1
  description BKS
  ip address z.z.z.z 255.255.255.252
  duplex auto
  speed auto
!
router bgp myas123
  no synchronization
  bgp log-neighbor-changes
  network z.z.z.0 mask 255.255.248.0
  neighbor x.x.x.x remote-as pr2as123
  neighbor x.x.x.x update-source GigabitEthernet0/0.1
  neighbor x.x.x.x filter-list 23 in
  neighbor y.y.y.y remote-as pr1as123
  neighbor y.y.y.y update-source GigabitEthernet0/0.2
  neighbor y.y.y.y filter-list 23 in
  no auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 x.x.x.x
ip route 0.0.0.0 0.0.0.0 y.y.y.y
ip route z.z.z.0 255.255.248.0 Null0
!
ip as-path access-list 23 permit ^$
!
ip http server
ip http authentication local
no ip http secure-server
ip http timeout-policy idle 5 life 86400 requests 10000
!
!
snmp-server enable traps cpu threshold
snmp-server manager
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
  login local
line aux 0
line vty 0 4
  privilege level 15
  login local
  transport input telnet
line vty 5 15
  privilege level 15
  login local
  transport input telnet
!
scheduler allocate 20000 1000
!
end

Что посоветуете???

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от Wowa (??) on 18-Янв-07, 14:06 
>Ситуация такая - работаем с 2мя провайдерами по BGP, анонсировали свою PI
>сеть. Весь исходящий траф уходит обоим провайдерам, и приходит (примерно) поровну
>на 2 канала.
>Задача в следующем - проанонсировать свою AS'ку 2му провайдеру таким образом, что
>бы траффик от него приходил лишь в том случае, когда пропал
>(или загружен) канал 1го провайдера.
>
>Надеюсь объяснил понятно.
>
>Что посоветуете???

Вам поможет Conditional Advertisement
http://www.cisco.com/en/US/tech/tk365/technologies_configuration_example09186a0080094309.shtml

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от SergT email(??) on 18-Янв-07, 16:27 
через кого получали AS-ку если не секрет?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от SergT email(??) on 18-Янв-07, 16:34 
interface GigabitEthernet0/0.1
  description prov2
  bandwidth 20000  

interface GigabitEthernet0/0.2
  description prov1
  bandwidth 10000  

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от Wowa (??) on 18-Янв-07, 16:55 
>interface GigabitEthernet0/0.1
>  description prov2
>  bandwidth 20000
>
>interface GigabitEthernet0/0.2
>  description prov1
>  bandwidth 10000
>

А зачем bandwidth ставить?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от SergT email(??) on 18-Янв-07, 17:08 
разные стоимости.
ADVERTISE правильнее


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от Wowa (??) on 18-Янв-07, 17:13 
>разные стоимости.
>ADVERTISE правильнее

BGP bandwidth не учитывает

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от ivanbks email(ok) on 18-Янв-07, 17:14 
>разные стоимости.
>ADVERTISE правильнее

почитал я одну доку, но андестенда не хватило. :-(

Если кому нетрудно, объясните плз "на пальцах" что он дает

И еще мне посоветовали "AS-PATH prepend".

Что лучше???

>>через кого получали AS-ку если не секрет?
контора у которой мы покупали биллинг. Если что - советую http://www.nic.ru/ip-reg/service/FAQ/as.html

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от routercs email on 18-Янв-07, 19:49 
>>разные стоимости.
>>ADVERTISE правильнее
>
>почитал я одну доку, но андестенда не хватило. :-(
>
>Если кому нетрудно, объясните плз "на пальцах" что он дает
>
>И еще мне посоветовали "AS-PATH prepend".
>
>Что лучше???
>
>>>через кого получали AS-ку если не секрет?
>контора у которой мы покупали биллинг. Если что - советую http://www.nic.ru/ip-reg/service/FAQ/as.html
Уважаемые коллеги!

Самый верный способ - это prepend, но на 100% Вы с помощью них не добьетесь результата, так как есть пиринговые связи одних провайдеров с другими.

Есть еще один вариант, как по мне, немного кривоват, но все же:
http://www.opennet.ru/openforum/vsluhforumID6/4996.html

И такой (я выбрал именно его):
http://www.opennet.ru/openforum/vsluhforumID6/8312.html

Удачи!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от root (??) on 20-Янв-07, 17:32 
убери статик роутинг прими default-originate
расставь препенды
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от ivanbks email(ok) on 20-Янв-07, 18:39 
2 All
прежде всего хочу поблагодарить всех за участие - благодаря вам всем теперь я на правильном пути

Итак, добавил препенд на свою ас 10 раз(больше нельзя). Основной траф пошел (спустя некоторое время) ч/з 1го прова, а часть трафа ч/з 2го.
Т.е. балансировка на 1го была достигнута.

Вдобавок убрал статические маршруты. Т.е. при дисконнекте 1пр вместе с ним теряются БГПшные маршруты 1пр, и траф уходит как надо на 2пр.

Настало время боевых испытаний - вытаскиваю провод 2пр, по холдтайму выжидаю падение пира 1пр(или ресечу его вручную) и у меня остается 1 маршрут по умолчанию - на 2пр.
. . .
барабанная дробь
. . .
яндекс не пингуеццо

Осталось решить проблему возвращения траффика из инета ко мне. Т.е. в инетовских роутерах содержится инфа - что кратчайший путь ко мне - ч/з 1провайдера. Вопрос - через сколько времени в интернете обновится инфа, что кратчайший путь ко мне - ч/з 2 пр, и что связь м/д мной и 1пр потеряна???

Заранее благодарю.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

11. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от cMex email(ok) on 20-Янв-07, 22:10 
>Осталось решить проблему возвращения траффика из инета ко мне. Т.е. в инетовских
>роутерах содержится инфа - что кратчайший путь ко мне - ч/з
>1провайдера. Вопрос - через сколько времени в интернете обновится инфа, что
>кратчайший путь ко мне - ч/з 2 пр, и что связь
>м/д мной и 1пр потеряна???
>
>Заранее благодарю.

На практике по всему инету маршруты сходятся через 3-5 минут, после того, как ваш первый апстрим проадейтит свои маршруты, убрав из них, анонсируемые вами.

Кстати, возвращаясь к разговору о препендах. Не дают они 100% гарантии хождения трафика, так как хочется вам, так как есть пиринг и сладкие товарно-денежные отношения между провайдерами, которые позволят им несколько изменить ваши ожидания :). 100%-ный вариант - анонс на разных апстримов префиксов с разной длиной. Это для входящего трафика, а для исходящего - накручивание разного weight на маршруты, получаемые от разных апстримов.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от c0re (??) on 21-Янв-07, 15:13 
1)Тупо занизить local_pref через bgp-community своего резервного апстрима, если он конечно такое умеет..а если не умеет то зачем он вам ;))
2) на основного апстрима завысить local_pref на своём br.

Таким образом будет симметрично ходить трафик)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

13. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от ivanbks email(??) on 21-Янв-07, 23:26 
доброго времени суток всем читающим.

Вчера столкнулся еще с одной проблемой проблемой:
Удалил статические маршруты, перестал отфильтровывать анонсируемые мне маршруты, накрутил weight на найтбор 1п.
Вобщем все в порядке - трафф уходит куда надо, приходит откуда надо. Переконфигурил кипалив и холдтайм на найтбор 1пр - 10 и 20 секунд соответственно.

И тут все началось. Сначала все работало нормально, но потом пропала связь натирующего сервера с некоторыми забугорными сайтами. Как-то не отвечали ebay.com microsoft.com, не работала icq. Трейсы останавливались за пределами моих провайдеров. Причем с моей циски все пинговалось на ура.

Через некоторое время связь странным образом восстанавливалась.
Причем как-то разумно объяснить происходящее не получается. пробовал менять статические/динамические маршруты, отправлять ч/з 1го или 2го проавйдера - никакой зависимости не наблюдается.

Кто-нибудь может объяснить в чем дело ???


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Балансировка входящего траффика с использованием BGP на Cisc..."  
Сообщение от cMex email(??) on 22-Янв-07, 15:08 
Хм, а после того, как ты удалил статические маршруты - много времени прошло? Это к тому, что анонсируемые вами маршруты по BGP к апстримам должны быть подтверждены IGP-муршрутами, т. е. в вашем случае - статическими маршрутами на маршрутизаторе ко всем анонсируемым подсетям.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру