The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Проблема с установкой пакета на OpenBSD"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на рабочей станции (Public)
Изначальное сообщение [Проследить за развитием треда]

"Проблема с установкой пакета на OpenBSD"  
Сообщение от black_jackal (ok) on 12-Янв-07, 21:24 
Здравствуйте, поставил OpenBSD 3.8 на VMware. До этого не использовал ни FreeBSD Ни OpenBSD. Устал пользоваться консолью, решил поставить файловый менеджер. На OpenBSD.org нашел ссылку на http зеркало скачал пакеты mc-4.6.1.tgz и .deco-3.8.3.tgz для соотвествующей версии OpenBSD. Зашел под root, cкопировал файлы в /root и набрал команду:
#pkg_add ./mc-4.6.1.tgz   далее следует вывод этой команды.
mc-4.6.1:Can't find unzip-5.52
/usr/sbin/pkg_add: unzip-5.52:Fatal error
, после чего попробовал сам распаковал архив и выполнил команду:
#pkg_add ./mc-4.6.1.tar
Can't find ./mc-4.6.1.tar
/usr/sbin/pkg_add: ./mc-4.6.1.tar:Fatal error
Почитал информацию по установке пакетов, которую нашел, но ничего по этому поводу не обнаружил. И так как раньше никакие пакеты не ставил, то даже не знаю где искать ошибку.
P.S. Заранее благодарен за любую помощь.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Проблема с установкой пакета на OpenBSD"  
Сообщение от by_ (??) on 13-Янв-07, 13:05 
>Здравствуйте, поставил OpenBSD 3.8 на VMware. До этого не использовал ни FreeBSD
>Ни OpenBSD. Устал пользоваться консолью, решил поставить файловый менеджер. На OpenBSD.org
>нашел ссылку на http зеркало скачал пакеты mc-4.6.1.tgz и .deco-3.8.3.tgz для
>соотвествующей версии OpenBSD. Зашел под root, cкопировал файлы в /root и
>набрал команду:
>#pkg_add ./mc-4.6.1.tgz   далее следует вывод этой команды.
>mc-4.6.1:Can't find unzip-5.52
          ^^^^^^^^^^^^^^^^^^^^^
Для установки он требуе пакет unzip-5.52, т.е уго тоже нужно скачать и
положить в туже папку, а вообще у mc в зависимостях около 5 пакетов и
все их нужно качать...
>/usr/sbin/pkg_add: unzip-5.52:Fatal error
>, после чего попробовал сам распаковал архив и выполнил команду:
>#pkg_add ./mc-4.6.1.tar
>Can't find ./mc-4.6.1.tar
>/usr/sbin/pkg_add: ./mc-4.6.1.tar:Fatal error
>Почитал информацию по установке пакетов, которую нашел, но ничего по этому поводу
>не обнаружил. И так как раньше никакие пакеты не ставил, то
>даже не знаю где искать ошибку.
>P.S. Заранее благодарен за любую помощь.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Проблема с установкой пакета на OpenBSD"  
Сообщение от Sergey email(??) on 14-Янв-07, 19:44 
а в опене нету чтонить типа портов или паков?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Проблема с установкой пакета на OpenBSD"  
Сообщение от Graf email(??) on 15-Фев-07, 14:02 
>Здравствуйте, поставил OpenBSD 3.8 на VMware. До этого не использовал ни FreeBSD
>Ни OpenBSD. Устал пользоваться консолью, решил поставить файловый менеджер. На OpenBSD.org
>нашел ссылку на http зеркало скачал пакеты mc-4.6.1.tgz и .deco-3.8.3.tgz для
>соотвествующей версии OpenBSD. Зашел под root, cкопировал файлы в /root и
>набрал команду:
>#pkg_add ./mc-4.6.1.tgz   далее следует вывод этой команды.
>mc-4.6.1:Can't find unzip-5.52
>/usr/sbin/pkg_add: unzip-5.52:Fatal error
>, после чего попробовал сам распаковал архив и выполнил команду:
>#pkg_add ./mc-4.6.1.tar
>Can't find ./mc-4.6.1.tar
>/usr/sbin/pkg_add: ./mc-4.6.1.tar:Fatal error
>Почитал информацию по установке пакетов, которую нашел, но ничего по этому поводу
>не обнаружил. И так как раньше никакие пакеты не ставил, то
>даже не знаю где искать ошибку.
>P.S. Заранее благодарен за любую помощь.

Три варианта развития событий:
1. Смотреть какие пакеты требуются для установки, скачивать и по новому pkg_add -v ./mc-4.6.1.tgz
2. Ставить прямо с FTP pkg_add -v ftp://ftp.OpenBSD.org/pub/4.0/packages/i386/mc-4.6.1.tgz
(путь может быть не точен, уточни сам)
3. Поставить коллекцию портов.

Разработчиками рекомендуется 2 способ.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Проблема с установкой пакета на OpenBSD"  
Сообщение от vista email on 22-Фев-07, 10:00 
http://vistawallpaper.8m.com

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Проблема с установкой пакета на OpenBSD"  
Сообщение от Refraine (ok) on 24-Фев-07, 15:55 
>Здравствуйте, поставил OpenBSD 3.8 на VMware. До этого не использовал ни FreeBSD
>Ни OpenBSD. Устал пользоваться консолью, решил поставить файловый менеджер. На OpenBSD.org
>нашел ссылку на http зеркало скачал пакеты mc-4.6.1.tgz и .deco-3.8.3.tgz для
>соотвествующей версии OpenBSD. Зашел под root, cкопировал файлы в /root и
>набрал команду:
>#pkg_add ./mc-4.6.1.tgz   далее следует вывод этой команды.
>mc-4.6.1:Can't find unzip-5.52
>/usr/sbin/pkg_add: unzip-5.52:Fatal error
>, после чего попробовал сам распаковал архив и выполнил команду:
>#pkg_add ./mc-4.6.1.tar
>Can't find ./mc-4.6.1.tar
>/usr/sbin/pkg_add: ./mc-4.6.1.tar:Fatal error
>Почитал информацию по установке пакетов, которую нашел, но ничего по этому поводу
>не обнаружил. И так как раньше никакие пакеты не ставил, то
>даже не знаю где искать ошибку.
>P.S. Заранее благодарен за любую помощь.
Это значит, нужен для mc-4.6.1 - unzip-5.52
Cкачиваешь unzip-5.52, пишешь pkg_add -v unzip-5.52.tgz
Возможно этот пакет не потребует другого, но зачастую разные пакеты требуют вспомогательные библиотеки\пакеты...


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Проблема с установкой пакета на OpenBSD"  
Сообщение от black_jackal (ok) on 03-Мрт-07, 23:30 
Спасибо за все, разобрался. В целом пакеты оставили приятное впечатление, только зависимости не отображаются в info пакета, а жаль. Вот теперь бы ещё настроить цвета как надо. Перешел на wsvt25, в MC все цвета нормальные, но в deco ничего не получается. В deco цвета становятся нормальные при использовании xterm, однако в таком случае MC не запускается :( Буду использовать что то одно(если так ничего и не выйдет).
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Проблема с установкой пакета на OpenBSD"  
Сообщение от ночной админ on 29-Мрт-07, 02:28 
В .profile добавляем :
export PKG_PATH=ftp://ftp.chg.ru/pub/OpenBSD/4.0/packages/i386/
Указвает где лежат пакеты, версию системы и тип архитектуры.
После этого pkg_add mc-4.6.1.tgz выполнится успешно,
выкачав и установив все зависимости.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "Проблема с установкой пакета на OpenBSD"  
Сообщение от weris (??) on 29-Мрт-07, 05:59 
>В .profile добавляем :
>export PKG_PATH=ftp://ftp.chg.ru/pub/OpenBSD/4.0/packages/i386/
>Указвает где лежат пакеты, версию системы и тип архитектуры.
>После этого pkg_add mc-4.6.1.tgz выполнится успешно,
>выкачав и установив все зависимости.


эток конечно удобно, для одного раза.
но лучше скачивать необъодимое и сохранять локально,
чтобы в будущем не качать снова то же самое.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Проблема с установкой пакета на OpenBSD"  
Сообщение от FelixS email(??) on 04-Апр-07, 21:19 
>Здравствуйте, поставил OpenBSD 3.8 на VMware. До этого не использовал ни FreeBSD
>Ни OpenBSD. Устал пользоваться консолью, решил поставить файловый менеджер. На OpenBSD.org
>нашел ссылку на http зеркало скачал пакеты mc-4.6.1.tgz и .deco-3.8.3.tgz для
>соотвествующей версии OpenBSD. Зашел под root, cкопировал файлы в /root и
>набрал команду:
>#pkg_add ./mc-4.6.1.tgz   далее следует вывод этой команды.
          ^^ что это?
>mc-4.6.1:Can't find unzip-5.52
>/usr/sbin/pkg_add: unzip-5.52:Fatal error
>, после чего попробовал сам распаковал архив и выполнил команду:
>#pkg_add ./mc-4.6.1.tar
>Can't find ./mc-4.6.1.tar
>/usr/sbin/pkg_add: ./mc-4.6.1.tar:Fatal error
>Почитал информацию по установке пакетов, которую нашел, но ничего по этому поводу
>не обнаружил. И так как раньше никакие пакеты не ставил, то
>даже не знаю где искать ошибку.
>P.S. Заранее благодарен за любую помощь.

Просто набираешь
pkg_add mc-4.6.1.tgz
и все. Каталог с пакаджами должен находится в /usr/packages. Еще лучше устанавливать из портов.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру