The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не получается регулировать скорость в KVM-машине"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Виртуализация / Linux)
Изначальное сообщение [ Отслеживать ]

"Не получается регулировать скорость в KVM-машине"  +/
Сообщение от Ilya Evseev on 01-Окт-11, 00:47 
Имеется Debian 6.0.2, ядро 2.6.39-bpo.2-amd64

Запускаю KVM:
kvm \
-net "nic,vlan=100,model=virtio" \
-net "tap,vlan=100,ifname=tap100,script=/tmp/kvm-if-up.sh" \
...

Базовая система работает роутером: eth0 - внешний интерфейс, tap100 - локальный для связи с виртуальной машиной.

=======================

kvm-if-up.sh:

KVMNET="192.168.0"
EXT_IFACE="eth0"

SPEED_IN="2mbit"
SPEED_OUT="3mbit"

iface="$1"
index="${iface#tap}"
ip="$KVMNET.$index"
me="$KVMNET.1"

tc class  add dev $EXT_IFACE parent 1: classid "1:$index" htb rate $SPEED_OUT
tc filter add dev $EXT_IFACE protocol ip parent 1:0 prio 1 u32 match ip src $ip/32 flowid 1:$index
tc class  add dev $iface parent 1: classid "1:$index" htb rate $SPEED_IN
tc filter add dev $iface protocol ip parent 1:0 prio 1 u32 match ip dst $ip/32 flowid 1:$index

=======================

После этого запускаю "iperf -c 10.20.30.40 -d".
Если внутри KVM запущен SystemRescue-CD с ядром 2.6.38-std231, то iperf показывает ту скорость, которая назначена в kvm-if-up.
Если запускаю внутри KVM дебиановское ядро 2.6.39.2, то входящая скорость не превышает 25-30% от исходящей (установленной на eth0).

Настройки по "ethtool -k" одинаковые.
Замена virtio-nic на e1000, rtl8139 и ne2k_pci не помогает.
В SysRCD "lsmod | grep virt" показывает virtio_net, в дебиане -  virtio_net и virtio_pci, зависящие от virtio_ring и virtio.

Вопрос: чем можно объяснить неправильную зарезку скорости во второй системе и что ещё в них имеет смысл сравнить?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не получается регулировать скорость в KVM-машине"  +/
Сообщение от Аноним (??) on 02-Окт-11, 21:49 
Попробуй подать туда больше питания.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2018 by Maxim Chirkov  
ДобавитьПоддержатьВебмастеруГИД  
Hosting by Ihor