The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не получается натроить роутер"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"Не получается натроить роутер"  
Сообщение от yudinvs (ok) on 14-Фев-08, 16:35 
Исходные данные:
сеть1 192.168.1.* (255.255.255.0)
сеть2 192.168.100.* (255.255.255.0)

Сеть1 имеет выход в инет через NAT - адрес шлюза 192.168.1.1

Хочу сделать шлюз из сети2 в сеть1 на freebsd 6.2

Соответственно машины с freebsd 2 сетевых карты.
192.168.1.66 и 192.168.100.87

С машины из сети2 пингую 192.168.100.87 и 192.168.1.66, а вот 192.168.1.1 и все что за ним уже нет.

естественно 192.168.1.1 живой, если подключаюсь к 1 сети, все работает.

Помогите понять в чем дело...

вот мой rc.conf

defaultrouter="192.168.1.1"
font8x14="cp866-8x14"
font8x16="cp866b-8x16"
font8x8="cp866-8x8"
hostname="test.altair.local"
ifconfig_rl0="inet 192.168.100.87  netmask 255.255.255.0"
ifconfig_rl1="inet 192.168.1.66  netmask 255.255.255.0"
gateway_enable="YES"
inetd_enable=YES
keymap="ru.koi8-r"
linux_enable="YES"
mousechar_start="3"
moused_enable=YES
nfs_client_enable=YES
nfs_server_enable=YES
rpcbind_enable=YES
scrnmap="koi8-r2cp866"
sshd_enable=YES
usbd_enable=YES


вот netstat -rn

Routing tables

Internet:
Destination        Gateway            Flags    Refs      Use  Netif Expire
default            192.168.1.1        UGS         0      752    rl1
127.0.0.1          127.0.0.1          UH          0      250    lo0
192.168.1          link#2             UC          0        0    rl1
192.168.1.1        00:1b:11:78:76:41  UHLW        2        4    rl1    911
192.168.1.11       00:c0:26:a5:b1:5d  UHLW        1       24    rl1   1027
192.168.1.21       00:07:e9:2f:c4:e4  UHLW        1       39    rl1    641
192.168.1.66       00:80:48:15:82:e0  UHLW        1        9    lo0
192.168.1.255      ff:ff:ff:ff:ff:ff  UHLWb       1      506    rl1
192.168.100        link#1             UC          0        0    rl0
192.168.100.2      00:02:b3:b0:d7:41  UHLW        1     1360    rl0   1196
192.168.100.81     00:19:d2:96:d1:a6  UHLW        1      312    rl0    909
192.168.100.113    00:16:76:17:b8:3c  UHLW        1      766    rl0    474
192.168.100.255    ff:ff:ff:ff:ff:ff  UHLWb       1       32    rl0

Internet6:
Destination                       Gateway                       Flags      Netif Expire
::1                               ::1                           UHL         lo0
fe80::%lo0/64                     fe80::1%lo0                   U           lo0
fe80::1%lo0                       link#4                        UHL         lo0
ff01:4::/32                       fe80::1%lo0                   UC          lo0
ff02::%lo0/32                     fe80::1%lo0                   UC          lo0

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не получается натроить роутер"  
Сообщение от adews (ok) on 14-Фев-08, 18:24 
Поскольку ваша бсд работает как роутер, пакеты уходят в сеть1 с адресами источника 100.*. Для того, чтобы отвечать на Ваши пинги(и другие запросы) из сети2, машины в сети1 (включая шлюз 1.1) должны знать, что шлюз в сеть 100.0/24 это 192.168.1.66, а так они просто отправляют ответные пакеты в шлюз по умолчанию, а уж куда оно улетает дальше,- одному биллу известно.

На бсд ставьте trafshow, очень помогает в таких ситуациях.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Не получается натроить роутер"  
Сообщение от kailex (ok) on 14-Фев-08, 18:25 
у пользователей в сети 2 в качестве шлюза по умолчанию стоит 192.168.100.87?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Не получается натроить роутер"  
Сообщение от yudinvs (ok) on 14-Фев-08, 18:27 
>у пользователей в сети 2 в качестве шлюза по умолчанию стоит 192.168.100.87?
>
>

Все, уже разобрался, вопрос закрыт - на 192.168.1.1 не было прописано шлюза на сетку 192.168.100.*, а роутер то как раз работал нормально. Всем спасибо.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру