The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Не могу подключиться через Xnest!"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Не могу подключиться через Xnest!"  
Сообщение от Joy (??) on 10-Дек-06, 12:52 
Добрый день!
Debian. Xnest работал нормально, пока не обновил xorg c 7.0 до 7.1.

$ dpkg -l|grep xserver
ii  xserver-xorg                           7.1.0-7                         the X.Org X server
ii  xserver-xorg-core                      1.1.1-11                        X.Org X server -- core server
ii  xserver-xorg-input-all                 7.1.0-7                         the X.Org X server -- input driver metapackage
ii  xserver-xorg-input-evdev               1.1.2-6                         X.Org X server -- evdev input driver
ii  xserver-xorg-input-kbd                 1.1.0-4                         X.Org X server -- keyboard input driver
ii  xserver-xorg-input-mouse               1.1.1-3                         X.Org X server -- mouse input driver
ii  xserver-xorg-input-synaptics           0.14.6-1                        Synaptics TouchPad driver for X.Org/XFree86 server
ii  xserver-xorg-input-wacom               0.7.4.1-5                       X.Org X server -- wacom input driver
ii  xserver-xorg-video-chips               1.1.1-4                         X.Org X server -- Chips display driver
ii  xserver-xorg-video-cirrus              1.1.0-3                         X.Org X server -- Cirrus display driver
ii  xserver-xorg-video-cyrix               1.1.0-4                         X.Org X server -- Cyrix display driver
ii  xserver-xorg-video-dummy               0.2.0-3                         X.Org X server -- dummy display driver
ii  xserver-xorg-video-i128                1.2.0-3                         X.Org X server -- i128 display driver
ii  xserver-xorg-video-i740                1.1.0-3                         X.Org X server -- i740 display driver
ii  xserver-xorg-video-i810                1.7.2-1                         X.Org X server -- Intel i8xx, i9xx display driver
ii  xserver-xorg-video-imstt               1.1.0-3                         X.Org X server -- IMSTT display driver
ii  xserver-xorg-video-neomagic            1.1.1-4                         X.Org X server -- Neomagic display driver
ii  xserver-xorg-video-savage              2.1.2-1                         X.Org X server -- Savage display driver
ii  xserver-xorg-video-sisusb              0.8.1-3                         X.Org X server -- SiS USB display driver
ii  xserver-xorg-video-tseng               1.1.0-3                         X.Org X server -- Tseng display driver
ii  xserver-xorg-video-vmware              10.13.0-3                       X.Org X server -- VMware display driver


Пытаюсь подключиться к серверу используя Xnest:
Xnest :1 -query <ip_server>
не подключается, а в логи /var/log/Xorg.0.log попадает следующее:
    xkb_types                { include "%" };
    xkb_compatibility        { include "%" };
    xkb_symbols              { include "%" };
    xkb_geometry             { include "%" };
(EE) Error loading keymap /var/lib/xkb/server-0.xkm

я на каком-то форуме вычитал, что можно было сделать вот так:
xkbcomp -xkm $DISPLAY - после выполнения этой команды в каталоге появлется файл server-0_0.xkm - его я переместил в /var/lib/xkb/ и переименовал в server-0.xkm. Но, при запуске Xnest - в Xorg.0.log лезут те же ошибки, а сам файл server-0.xkm просто удаляется.

Кто-нибудь может помочь моей проблеме?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Не могу подключиться через Xnest!"  
Сообщение от ruzarkh on 11-Дек-06, 20:46 
>Добрый день!
>Debian. Xnest работал нормально, пока не обновил xorg c 7.0 до 7.1.
>
>
>$ dpkg -l|grep xserver
>ii  xserver-xorg          
>          
>      7.1.0-7    
>          
>         the X.Org
>X server
>ii  xserver-xorg-core          
>          
> 1.1.1-11          
>          
>   X.Org X server -- core server
>ii  xserver-xorg-input-all          
>       7.1.0-7    
>          
>          the
>X.Org X server -- input driver metapackage
>ii  xserver-xorg-input-evdev          
>     1.1.2-6      
>          
>        X.Org X server
>-- evdev input driver
>ii  xserver-xorg-input-kbd          
>       1.1.0-4    
>          
>          X.Org
>X server -- keyboard input driver
>ii  xserver-xorg-input-mouse          
>     1.1.1-3      
>          
>        X.Org X server
>-- mouse input driver
>ii  xserver-xorg-input-synaptics          
> 0.14.6-1          
>          
>   Synaptics TouchPad driver for X.Org/XFree86 server
>ii  xserver-xorg-input-wacom          
>     0.7.4.1-5      
>          
>      X.Org X server -- wacom
>input driver
>ii  xserver-xorg-video-chips          
>     1.1.1-4      
>          
>        X.Org X server
>-- Chips display driver
>ii  xserver-xorg-video-cirrus          
>    1.1.0-3      
>          
>       X.Org X server --
>Cirrus display driver
>ii  xserver-xorg-video-cyrix          
>     1.1.0-4      
>          
>        X.Org X server
>-- Cyrix display driver
>ii  xserver-xorg-video-dummy          
>     0.2.0-3      
>          
>        X.Org X server
>-- dummy display driver
>ii  xserver-xorg-video-i128          
>      1.2.0-3    
>          
>         X.Org X
>server -- i128 display driver
>ii  xserver-xorg-video-i740          
>      1.1.0-3    
>          
>         X.Org X
>server -- i740 display driver
>ii  xserver-xorg-video-i810          
>      1.7.2-1    
>          
>         X.Org X
>server -- Intel i8xx, i9xx display driver
>ii  xserver-xorg-video-imstt          
>     1.1.0-3      
>          
>        X.Org X server
>-- IMSTT display driver
>ii  xserver-xorg-video-neomagic          
>  1.1.1-4        
>          
>     X.Org X server -- Neomagic display
>driver
>ii  xserver-xorg-video-savage          
>    2.1.2-1      
>          
>       X.Org X server --
>Savage display driver
>ii  xserver-xorg-video-sisusb          
>    0.8.1-3      
>          
>       X.Org X server --
>SiS USB display driver
>ii  xserver-xorg-video-tseng          
>     1.1.0-3      
>          
>        X.Org X server
>-- Tseng display driver
>ii  xserver-xorg-video-vmware          
>    10.13.0-3      
>          
>     X.Org X server -- VMware display
>driver
>
>
>Пытаюсь подключиться к серверу используя Xnest:
>Xnest :1 -query <ip_server>
>не подключается, а в логи /var/log/Xorg.0.log попадает следующее:
>    xkb_types        
>        { include "%"
>};
>    xkb_compatibility        
>{ include "%" };
>    xkb_symbols        
>      { include "%" };
>    xkb_geometry        
>     { include "%" };
>(EE) Error loading keymap /var/lib/xkb/server-0.xkm
>
>я на каком-то форуме вычитал, что можно было сделать вот так:
>xkbcomp -xkm $DISPLAY - после выполнения этой команды в каталоге появлется файл
>server-0_0.xkm - его я переместил в /var/lib/xkb/ и переименовал в server-0.xkm.
>Но, при запуске Xnest - в Xorg.0.log лезут те же ошибки,
>а сам файл server-0.xkm просто удаляется.
>
>Кто-нибудь может помочь моей проблеме?


может быть
aptitude update
aptitude upgrade
помогут?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Партнёры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2024 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру