The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"php и установка oci8"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (PHP)
Изначальное сообщение [ Отслеживать ]

"php и установка oci8"  +/
Сообщение от astashov (ok) on 20-Май-11, 08:19 
День добрый
Уперся в небольшую проблемку. Надо прикрутить к php5 oci8 чтоб подключаться к оракловой базе. База работает. Перловка через dbd-oracle с базой работает(это так, для информации). А при устнавки oci8 возникают немного непонятные мне ошибки. Просветите пожалуйста.

OS: Debian Lenny/Squeeze 32 (пробывал на двух серверах)
php5 установлена через apt

Установка oci8
=========================================
http://paste.org.ru/?79zynr
=========================================

Про то что он в начале не может найти три файла в /usr/include/php видел, но ума не приложу откуда их взять.

Пакеты php которые установлены на системе:
======================================
dpkg --list |grep php | grep ii| awk '{print $2" - "$3}'
libapache2-mod-php5 - 5.3.3-7
php-pear - 5.3.3-7
php5-cli - 5.3.3-7
php5-common - 5.3.3-7
php5-curl - 5.3.3-7
php5-dev - 5.3.3-7
php5-gd - 5.3.3-7
php5-imap - 5.3.3-7
php5-mcrypt - 5.3.3-7
php5-memcache - 3.0.4-4
php5-mysql - 5.3.3-7
php5-ps - 1.3.6-3+b1
php5-pspell - 5.3.3-7
php5-recode - 5.3.3-7
php5-snmp - 5.3.3-7
php5-suhosin - 0.9.32.1-1
======================================

Прошу помощи. Очень надо прикрутить оси к пхп
В инете ничего толком не нашел. Все только пишут что поставите пакеты, запустите пекл и будет Вам счастье. А его нет.

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "php и установка oci8"  +/
Сообщение от Аноним (??) on 20-Май-11, 11:39 
Гуглить наверное религия не позволяет...
одна из первых ссылок
http://www.howforge.com/how-install-oci8-php-5-ubuntu
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "php и установка oci8"  +/
Сообщение от astashov (ok) on 20-Май-11, 13:37 
> Гуглить наверное религия не позволяет...
> одна из первых ссылок
> http://www.howforge.com/how-install-oci8-php-5-ubuntu

Да нет. Религия то у меня правильная. Я же написал что искал. А везде только есть как установить. И еще, гуглить это еще пол религии. Если нагуглили имейте честь прочесть, перед тем как ссылку постить. В данной ссылке человек жалуется что не может поставить из-за ошибки. А ошибка там совершенно другая. На либу ругается. А у меня как Вы наверное могли заметить уважаемый "Аноним", оракл скушал прекрасно и ругается на определение переменных или функций. Даже не знаю что именно.

Так что понимать надо что и где пишете.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "php и установка oci8"  +/
Сообщение от ast82 on 22-Май-11, 09:27 
все. решено. Наконец то я отдохнул и заметил что эти файлы не в пхп, а в пхп5 лежат. Симлинк все решает. Всем кто хотел помочь, но не подсказал, так как это выше их и они рождены только решать глобальные задачи СПАСИБО.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру