The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не запускается скрипт cgi"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [ Отслеживать ]

"Не запускается скрипт cgi"  
Сообщение от bodom email(ok) on 19-Авг-08, 07:45 
Всем привет! Требуется запускать атоматически cgi скрипт при открытии страницы, но этого не происходит. Вот кусок httpd.conf:
<VirtualHost [ip address]:80>
    ServerAdmin webmaster@domain.com
    DocumentRoot "/usr/local/apache/cgi-bin/utm5"
    ServerName domain.com
    <Directory "/usr/local/apache/cgi-bin/utm5">
    Options ExecCGI
    SetHandler cgi-script
    DirectoryIndex aaa5
    AddDefaultCharset KOI8-R
        AllowOverride All
        Order Allow,Deny
        Allow from all
    </Directory>
</VirtualHost>

Т.е. при отктытии domain.com он пытается отобразить содержимое каталога /usr/local/apache/cgi-bin/utm5, но скрипт aaa5 не запускает. Соответсвенно при запросе
domain.com/aaa5 - скрипт срабатываетю.
Может в конфу еще что-нибудь дописать надо?

Высказать мнение | Ответить | Правка | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не запускается скрипт cgi"  
Сообщение от Pahanivo email(ok) on 20-Авг-08, 10:42 
типо так
<Directory "your_directory">
   #Set handler for aaa5 cgi
   <Files aaa5>
      SetHandler cgi-script
   </Files>
</Directory>

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру