The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Из rate-limit в policy-map"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 10-Фев-06, 18:05 
Добрый день,
Подскажите, как такую конструкцию:

rate-limit input dscp 12 128000 96000 128000 conform-action transmit exceed-action continue
rate-limit input dscp 10 128000 96000 128000 conform-action transmit exceed-action continue
rate-limit input 128000 32000 48000 conform-action transmit exceed-action drop

написать в терминах Modular QoS Interface, тоесть с помощью классов и полиси мап. Смотрел даже иерархические полиси-мап, но вроде даже ими не получается. Вопрос почти теоретический, вышеописанная конструкция удовлетворяет почти полностью, но вот заело, хочется разобраться до конца.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Из rate-limit в policy-map"  
Сообщение от FPF on 10-Фев-06, 21:31 
Лично я предпочитаю использовать именно CAR в таких случаях, в отличие от  MQC.
А зачем ты ставишь такие цифры? 128000 96000 128000? Ты их различаешь?
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 10-Фев-06, 21:57 
>Лично я предпочитаю использовать именно CAR в таких случаях, в отличие от
> MQC.
>А зачем ты ставишь такие цифры? 128000 96000 128000? Ты их различаешь?
>


Конкретно здесь я их подбирал. Для моего трафика они оказались получше стандарных х/8*1.5.

Просто не хочется верить, что средствами MQC эта конструкция неосуществима. Потом, я использую cacti для рисования графиков, там есть рисовать полиси-мапы и классы, а рейтлимиты неправильно реализованы. Если бы имел эквивалентную конструкцию с классами, рисовал бы нужные графики.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 09:15 
Передать в точности заданную конструкцию через MQC, по моему скромному мнению, не получится. А может этого и не требуется? Опишите задачу, которую призвана решать эта конструкция, может её получится реализовать и как-нибудь иначе.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 11:34 
Как я уже отмечал, интерес почти теоретический. Для рисования графиков импользую cacti, рисование классов и полиси-мап там реализовано, а CAR - нет. Вот и хочется перевести в удобный вид.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 12:01 
Зачем Вам MQC вместо CAR я прекрасно понял.
Я не понял зачем
rate-limit input dscp 12 128000 96000 128000 conform-action transmit exceed-action continue
rate-limit input dscp 10 128000 96000 128000 conform-action transmit exceed-action continue
rate-limit input 128000 32000 48000 conform-action transmit exceed-action drop


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 12:34 
Трафик на других рутерах красится и попадает на вход уже этого маршрутизатора. Тут каждому цвету отведена своя полоса, но излишки не просто дропаются, а собираются со всех цветов и режутся уже в сумме. То есть пакетам дается лишний шанс проскочить, это позволяет гибче распределить полосу пропускания.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 14:23 
Ясно, значит такая конструкция действительно была необходима.
Реализовать это в качестве единственного input policy на MQC, как мне кажется, не получится.

Однако, если Вы представите дополнительные подробности схемы прохождения трафика, то , возможно, это может быть реализовано парой policy - на входе и на выходе (это реализуемо, если весь этот трафик выходит из маршрутизатора по одному интерфейсу).


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

8. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 14:41 
Трафик выходит по одному интерфейсу - раньше как раз были полиси на выходе, что по моему конечно правильнее. Но тогда был очен плохой эффект - выходной интерфейс Е1, когда загрузка канала доходила до 75% или полтора мегабит, резко возрастала задержка от 1-4 мс до нескольких сотен. Причем почти не имеет значения, что в полиси написано. Вот я и был вынужден фильтровать на входе, а на выходе реализовал приоритетную очередь. Киска 7513, RSP4, VIP2-50, IOS 12.4(1).

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

9. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 14:57 
Можно взглянуть на текущую конфигурацию очереди на выходном интерфейсе?


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

10. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 15:08 
>Можно взглянуть на текущую конфигурацию очереди на выходном интерфейсе?

interface Serial8/1/1:1
description Uplink
ip address xxx.xx.xx.xx 255.255.255.252
no ip redirects
no ip proxy-arp
ip pim sparse-mode
ip route-cache flow
ip mroute-cache
no fair-queue
priority-group 1
no cdp enable


priority-list 1 protocol ip high list 2100
priority-list 1 protocol ip medium list 2120
priority-list 1 protocol ip medium list 2130
priority-list 1 protocol ip medium list 20

Если надо, могу и списки доступа выложить, но в них ничего интересного

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

11. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 15:26 
И в какую очередь, в данном случае, попадает трафик с dscp 12 и 10?
Какая примерно конфигурация очереди вызывала у Вас проблемы с задержкой и для какого трафика?
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

12. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 16:22 
Проблемы как раз не с этой очередью, эта как раз работает. Не работала полиси-мап на выходе этого интерфейса, вследствии чего перешел на этот конфиг.

Я точно не помню (дело с полгода назад было), но по моему даже простой любой оператор в полиси-мап типа резервирования полосы или policy приводил к задержкам.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

13. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 14-Фев-06, 16:40 
>Проблемы как раз не с этой очередью, эта как раз работает. Не
>работала полиси-мап на выходе этого интерфейса, вследствии чего перешел на этот
>конфиг.
Это я понял.

>
>Я точно не помню (дело с полгода назад было), но по моему
>даже простой любой оператор в полиси-мап типа резервирования полосы или policy
>приводил к задержкам.
Приводил к задержкам какого трафика? Того для которого резервировалась полоса или всего остального?

И покажите аксес-листы, а то не понятно, как они пересекаются с DSCP 10 и 12.


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

14. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 14-Фев-06, 17:57 

>Приводил к задержкам какого трафика? Того для которого резервировалась полоса или всего
>остального?
>
всего трафика, кроме LLQ, насколько я помню.

>И покажите аксес-листы, а то не понятно, как они пересекаются с DSCP
>10 и 12.

Да аксес-листы выбирают как раз эти DSCP

access-list 2120 permit ip any any dscp af11

access-list 2130 permit ip any any dscp af12

access-list 2100 permit ip any any dscp ef
access-list 2100 permit tcp any any eq bgp
access-list 2100 permit udp any any eq domain
access-list 2100 permit tcp any any eq domain
access-list 2100 permit tcp any any eq telnet
access-list 2100 permit tcp any any eq 22
access-list 2100 permit udp any any eq 22

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

15. "Из rate-limit в policy-map"  
Сообщение от chingachguk (ok) on 15-Фев-06, 07:39 
Ну тогда, например, так

class-map match-all dscp10
  match ip dscp af11
class-map match-all dscp12
  match ip dscp af12
class-map match-any excess_burst
  match ip dscp af13
class-map match-any network_ctrl
  match access-group 2100
class-map match-any critical_data
  match access-group 2120
  match access-group 2130
  match access-group 20
!
!
policy-map output
  class network_ctrl
    priority 256
  class excess_burst
     police 128000 32000 48000 conform-action transmit exceed-action drop
  class critical_data
   bandwidth 512
  class class-default
   fair-queue 512
   random-detect
policy-map input
  class dscp12
     police 128000 96000 128000 conform-action transmit exceed-action set-dscp-transmit af13
  class dscp10
     police 128000 96000 128000 conform-action transmit exceed-action set-dscp-transmit af13
  class class-default
   set ip dscp af13

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

16. "Из rate-limit в policy-map"  
Сообщение от Misak email(ok) on 15-Фев-06, 09:04 
Спасибо, попробую, примерно такая-же конструкция у меня была, но была задержка. Скоро поменяю IOS, сразу и это сделаю, может глюк конкретного IOS.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру