The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"NAT/PAT"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Безопасность)
Изначальное сообщение [ Отслеживать ]

"NAT/PAT"  +/
Сообщение от minimax_07 (ok) on 26-Июн-12, 11:47 
Доброго всем дня.Помогите,чем сможете, мозг кипит. Задача не стандартная. Есть некая рабочая станция во внутренней сети, которая производит закачку файлов с ftp серверов из разных внешних подсетей. Соединение устанавливается по 21 порту, а сама закачка через порты, выделяемыми серверами. Каким образом мне организовать трансляцию, чтобы все ЭТО заработало. Планируется использование cisco 2811.Заранее благодарен за ваши ЦЕННЫЕ советы.    
Ответить | Правка | Cообщить модератору

Оглавление

  • NAT/PAT, McS555, 12:59 , 26-Июн-12, (1)  
    • NAT/PAT, minimax_07, 16:26 , 26-Июн-12, (3)  
  • NAT/PAT, Andrey, 13:29 , 26-Июн-12, (2)  
    • NAT/PAT, minimax_07, 09:53 , 27-Июн-12, (4)  
      • NAT/PAT, Valery12, 15:59 , 27-Июн-12, (5)  
        • NAT/PAT, minimax_07, 09:59 , 28-Июн-12, (6)  
          • NAT/PAT, minimax_07, 13:52 , 28-Июн-12, (7)  

Сообщения по теме [Сортировка по времени | RSS]


1. "NAT/PAT"  +/
Сообщение от McS555 (ok) on 26-Июн-12, 12:59 
> Доброго всем дня.Помогите,чем сможете, мозг кипит. Задача не стандартная. Есть некая рабочая
> станция во внутренней сети, которая производит закачку файлов с ftp серверов
> из разных внешних подсетей. Соединение устанавливается по 21 порту, а сама
> закачка через порты, выделяемыми серверами. Каким образом мне организовать трансляцию,
> чтобы все ЭТО заработало. Планируется использование cisco 2811.Заранее благодарен за ваши
> ЦЕННЫЕ советы.

!
interface FastEthernet0/0
description -=[ LAN ]=-
ip address 192.168.1.0 255.255.255.0
ip nat inside
duplex auto
speed auto
!
!
interface FastEthernet0/1
description -=[ internet ]=-
ip address xx.xx.xx.xx 255.255.255.252
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
!
ip nat inside source list NAT interface FastEthernet0/1 overload
!
ip access-list extended NAT
permit ip host 192.168.1.XX any
!


92.168.1.XX - тачка котороя будет по фтп шариться

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "NAT/PAT"  +/
Сообщение от minimax_07 (ok) on 26-Июн-12, 16:26 
Все это замечательно, но по ходу моя циска 2801 (version 7) команду ip virtual-reassembly не поддерживает. Даже в списке ее нет. IOS 12.4 (13r)T.
Наверное надо IOS обновить. Качать для 2801 последнюю версию?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "NAT/PAT"  +/
Сообщение от Andrey (??) on 26-Июн-12, 13:29 
> Доброго всем дня.Помогите,чем сможете, мозг кипит. Задача не стандартная. Есть некая рабочая
> станция во внутренней сети, которая производит закачку файлов с ftp серверов
> из разных внешних подсетей. Соединение устанавливается по 21 порту, а сама
> закачка через порты, выделяемыми серверами. Каким образом мне организовать трансляцию,
> чтобы все ЭТО заработало. Планируется использование cisco 2811.Заранее благодарен за ваши
> ЦЕННЫЕ советы.

Для работы через NAT используйте FTP в пассивном режиме.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "NAT/PAT"  +/
Сообщение от minimax_07 (ok) on 27-Июн-12, 09:53 
> Для работы через NAT используйте FTP в пассивном режиме.

К сожалению, сервера не мои режим работы ftp я изменить не могу...


Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

5. "NAT/PAT"  +/
Сообщение от Valery12 (??) on 27-Июн-12, 15:59 
>> Для работы через NAT используйте FTP в пассивном режиме.
> К сожалению, сервера не мои режим работы ftp я изменить не могу...

ip inspect name <name> ftp

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "NAT/PAT"  +/
Сообщение от minimax_07 (ok) on 28-Июн-12, 09:59 
Тогда следующий вопрос: как быть, если внутренний адрес 1 и он должен транслироваться в разные адреса, в зависимости от того, в какую сеть надо попасть.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "NAT/PAT"  +/
Сообщение от minimax_07 (ok) on 28-Июн-12, 13:52 
Спасибо огромное за советы, все сделал. Использовал route-map

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру