The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  правила/FAQ  поиск  регистрация  вход/выход  слежка  RSS
"Проблема с роутингом при настройке STUN (детский вопрос)"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Cisco CCNA Routing & Switching версия 3.0 - новые курсы и экзамены
"Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 05-Окт-17, 14:29 
Уважаемые гуру сетевых технологий (увы, я к ним не отношусь)! Есть вопрос, который, как я полагаю, весьма детский и связан с непониманием принципов работы устройств и маршрутизацией.

Имеются 2 шт. Cisco 2811 с IOS 15.x AES. Они включены в одноранговую сеть 192.168.1.0/24 через неуправляемый коммутатор, для чего используются порты FE0/0. FE0/1 висят в воздухе. Установлены модули HWIC-1T для того, чтобы получить интерфейс RS-232. Как вы знаете, STUN позволяет пробросить последовательные протоколы, такие как V.24, через IP. В HWIC-1T включены родные кабели DCE и DTE. Статусы S-портов up/up, светятся зеленым, так что тут проблем нет. Роутеры пингуют друг друга в сети 192.168.1.0/24 и между роутерами работают другие IP-сервисы.

Проблема: данные в туннеле не идут, пакеты всегда на нулях, диагностика хождение данных в STUNе не видит. Я думаю, что проблема детская, и заключается в том, что я не понимаю как именно должна быть настроена маршрутизация, и пиры STUN тупо не видят друг друга через сеть.

Я был бы рад целиком повторить https://www.cisco.com/c/en/us/support/docs/ip/serial-tunnel-... пример конфигурации Cisco, но они там показывают только конфигурацию STUN, умалчивая о конфигурации FE и настройках роутинга. Я бы сделал по полному образцу, но его тупо нет. Так как интерфейсы loopback нельзя поместить в ту же сеть, что и FE0/0, а именно в 192.168.1.0/24, то я поместил их в 192.168.168.0/24. И у меня в роутере нет NAT, указаний на его нахождение, а также статических маршрутов. Полагаю, что у STUN-пиров нет связи на уровне IP.

Далее прилагаю диаграмму моей сети. Она не сильно профессиональная, но я старался соблюдать минимальные стандарты и указать все данные.

Да, и еще один момент. Пример Cisco показывает 2 serial-туннеля, а мне хватит и одного Я упростил конфигурацию, срезав все то, что относится ко второму туннелю (группа 13).

Очень прошу помочь. Ниже даю свои конфиги и связанную диагностику. Если нужно, то могу дать удаленный доступ по TV на оба роутера, и можно будет продиагностировать и копнуть в живую. Заранее спасибо!

Вот тут СХЕМА МОЕЙ СЕТИ: http://www.netfiles.ru/share/linked/cisco/STUN.gif

R1 STUN section

stun peer-name 192.168.1.143 
stun protocol-group 9 basic

interface serial 0
encapsulation stun
stun group 9
stun route all tcp 192.168.1.144

interface loopback 0
ip address 192.168.1.144 255.255.255.0


R2 STUN section
stun peer-name 192.168.1.144
stun protocol-group 9 basic

interface serial 0
encapsulation stun
stun group 9
stun route all tcp 192.168.1.143

interface loopback 0
ip address 192.168.1.144 255.255.255.0


R1 show stun
2811_1#show stun
This peer: 192.168.168.143

Serial0/3/0  (group 9 [basic])
                              state       rx_pkts   tx_pkts     drops
all     TCP 192.168.1.144    closed              0         0         0


R2 show stun
This peer: 192.168.168.144

Serial0/3/0  (group 9 [basic])
                              state       rx_pkts   tx_pkts     drops
all     TCP 192.168.1.143    closed              0         0         0


R1 interface s0/3/0
2811_1#
2811_1#show interface serial 0/3/0
Serial0/3/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 2104 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation STUN, loopback not set
  Keepalive not set
  Last input never, output 02:53:18, output hang never
  Last clearing of "show interface" counters 02:50:42
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     1 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=up  CTS=up

R2 interface s0/3/0
2811_2#
2811_2#show interface serial 0/3/0
Serial0/3/0 is up, line protocol is up
  Hardware is GT96K Serial
  MTU 2104 bytes, BW 1544 Kbit/sec, DLY 20000 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation STUN, loopback not set
  Keepalive not set
  Last input never, output never, output hang never
  Last clearing of "show interface" counters 02:52:28
  Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
  Queueing strategy: fifo
  Output queue: 0/40 (size/max)
  5 minute input rate 0 bits/sec, 0 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     0 packets input, 0 bytes, 0 no buffer
     Received 0 broadcasts (0 IP multicasts)
     0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort
     0 packets output, 0 bytes, 0 underruns
     0 output errors, 0 collisions, 1 interface resets
     0 unknown protocol drops
     0 output buffer failures, 0 output buffers swapped out
     0 carrier transitions
     DCD=up  DSR=up  DTR=up  RTS=down  CTS=up

R1 running conf
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811_1
!
boot-start-marker
boot system usbflash1:c2800nm-adventerprisek9-mz.151-4.M12a.bin
boot-end-marker
!
logging buffered 4096
!
no aaa new-model
!
dot11 syslog
ip source-route
!
ip cef
!
ip domain name somedom.com
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
crypto pki token default removal timeout 0
!
redundancy
!
ip tftp source-interface FastEthernet0/0
!
stun peer-name 192.168.168.143
stun protocol-group 9 basic
!
interface Loopback0
ip address 192.168.168.143 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.143 255.255.255.0
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0
mtu 2104
no ip address
encapsulation stun
stun group 9
stun route all tcp 192.168.1.144
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
access-list 23 permit 192.168.1.0 0.0.0.255
!
snmp-server community someSTRINGhere RW
!
control-plane
!
mgcp profile default
!
line con 0
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 1440 0
privilege level 15
password somePASS
logging synchronous
login local
transport input ssh
line vty 5 15
access-class 23 in
exec-timeout 1440 0
privilege level 15
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
end

R2 running conf
version 15.1
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2811_2
!
boot-start-marker
boot system usbflash1:c2800nm-adventerprisek9-mz.151-4.M12a.bin
boot-end-marker
!
logging buffered 4096
!
no aaa new-model
!
dot11 syslog
ip source-route
!
ip cef
!
ip domain name somedom.com
no ipv6 cef
!
multilink bundle-name authenticated
!
voice-card 0
!
crypto pki token default removal timeout 0
!
redundancy
!
ip tftp source-interface FastEthernet0/0
!
stun peer-name 192.168.168.144
stun protocol-group 9 basic
!
interface Loopback0
ip address 192.168.168.144 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.1.144 255.255.255.0
duplex full
speed auto
no mop enabled
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/3/0
mtu 2104
no ip address
encapsulation stun
stun group 9
stun route all tcp 192.168.1.143
!
ip forward-protocol nd
ip http server
no ip http secure-server
!
access-list 23 permit 192.168.1.0 0.0.0.255
!
snmp-server community someSTRINGhere RW
!
control-plane
!
mgcp profile default
!
line con 0
line aux 0
line vty 0 4
access-class 23 in
exec-timeout 1440 0
privilege level 15
password somePASS
logging synchronous
login local
transport input ssh
line vty 5 15
access-class 23 in
exec-timeout 1440 0
privilege level 15
logging synchronous
login local
transport input ssh
!
scheduler allocate 20000 1000
end

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от k.d. on 05-Окт-17, 16:21 
>[оверквотинг удален]
> line vty 5 15
>  access-class 23 in
>  exec-timeout 1440 0
>  privilege level 15
>  logging synchronous
>  login local
>  transport input ssh
> !
> scheduler allocate 20000 1000
> end

на R1
conf term
int lo 0
ip address 192.168.168.143 255.255.255.255
ip route 192.168.168.144 255.255.255.255 192.168.1.144
end
copy run start
ping 192.168.168.144 so lo0

на R2
int lo 0
ip address 192.168.168.144 255.255.255.255
ip route 192.168.168.143 255.255.255.255 192.168.1.143
end
copy run start
ping 192.168.168.143 so lo0

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 05-Окт-17, 16:52 
Спасибо большое. Теперь есть ping между двумя lo-интерфейсами в сети 168.168.

Но связи через serial нет. В дебаге видно, что интерфейс S0/3/0 на R2 рабочий, и адекватно реагирует на открытие COM-порта программой WinSDD. Потому, как при изменении DTR в низкое/высокое состояние в отладке видно следующее:

*Oct  5 14:14:21.215: %LINK-3-UPDOWN: Interface Serial0/3/0, changed state to down
*Oct  5 14:14:22.215: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3/0, changed state to down
2811_2(config-if)#
*Oct  5 14:14:34.151: %LINK-3-UPDOWN: Interface Serial0/3/0, changed state to up
*Oct  5 14:14:35.151: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/3/0, changed state to up
Проблема в том, что в show stun по-прежнему все счетчики пакетов по нулям, то есть, активность локального порта на R2 не лезет в туннель.

Дебажу так. Других вариантов не знаю.

show stun
и
debug stun packet
debug stun event
terminal monitor

В show stun видно, что туннель закрыт (closed), но это вроде как нормально. Так как в STUN-типе basic статус не известен, поэтому это нормально (об этом я читал на Циске).

А STUN по идее должен давать данные в дебаге, когда serial поднялся и ломится в туннель: https://www.cisco.com/c/en/us/support/docs/ip/serial-tunnel-... (здесь, правда, на примере SDLC, но принцип, думаю, один).

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от yur (??) on 05-Окт-17, 22:00 
Не занимайтесь ерундой.

https://www.cisco.com/c/en/us/support/docs/dial-access/async...

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 05-Окт-17, 22:04 
Юрий, а вы сами это делали? В таком канале, брошенном на порт AUX, не определяется скорость и прут битовые ошибки. Подробности тут: https://www.opennet.ru/openforum/vsluhforumID6/2213.html
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от yur (??) on 06-Окт-17, 10:44 
Делали.
Настройте нормально параметры aux порта
speed
databits
stopbits
parity
flowcontrol
и будет вам счастье.

И да, вы собственно задачу то какую пытаетесь решить?

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 06-Окт-17, 20:38 
> Делали.
> Настройте нормально параметры aux порта
> speed
> databits
> stopbits
> parity
> flowcontrol
> и будет вам счастье.
> И да, вы собственно задачу то какую пытаетесь решить?

Ну вы через чур очевидные вещи говорите, я не же идиот, я с serial-интерфейсами работаю не 3 недели (как с Cisco), а 20 лет :) Даже при ручных настройках COM-порта на ПК, которые абсолютно верные (9600 8 None 1 None None), в канале прут ошибки. Тест loopback проходит, синхронизация есть. На физическом канале, когда из цепочки убираются маршрутизаторы, все часами работает без единой ошибки. Диагностика выполняется программой WinSDD с диагностической заглушкой COM-порта. Возможно, что этот telnet-линк передает какие-то искажающие символы, или же не является полноценным интерфейсом RS-232.

Задача решается по удлинению COM-порта через IP. Через этот тоннель должны передаваться данные не только при фиксированной скорости, но и с программно-определяемыми скоростями, когда софт начинает на 9600, потом повышается на 57600, и т.п. Например, на коробочках MOXA это работает без единой настройки - достаточно настроить адресацию. Но хочется уйти от MOXA, так как их надо покупать, а Циски есть, и они решают другую задачу, для которой Циски будут нужны всегда.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

10. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от yur (??) on 09-Окт-17, 10:17 
Уперся вам этот stun.
1. Первая фраза в цискиной доке: Serial Tunneling (STUN) is the tunneling of SDLC frames across a WAN. Ключевое слово здесь - SDLC frames, что явно не ваш случай.
2. Из п. 1 следует, что stun применим только на синхронных интерфейсах, что тоже, похоже, не ваш случай.
3. Для случаев, в которых нельзя воспользоваться рекомендуемым циской решением - reverse telnet, есть возможность воспользоваться BSTUN туннелем. Там тоже есть свои приколы, о чем циска честно предупреждает:
Dedicated and native async protocols are not directly supported with any Cisco implementation. However, Block Serial Tunnel (BSTUN) async-generic tunneling can provide limited ability to tunnel this data.

Ключевые слова - bstun protocol-group async-generic.

Пример конфигурации - https://www.cisco.com/c/en/us/support/docs/ip/serial-tunnel-...

Удачи.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

12. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 09-Окт-17, 12:47 
Спасибо. Вы обратили внимание на очень важный момент, который меня также мучил во все, но в 2 часа ночи мне было уже лениво бежать включать ПК - кто дает клокинг и как он идет. Сегодня гуглинг показал, что для итоговой задачи мне нужен тоннель и интерфейсы, которые могут давать synchronous serial & true full-duplex. Карта может давать sync/async, то есть, работает в обоих режимах, который определяется программно.

Мой текущий тестовый стенд может быть некорректен, так как дальний конец не дает клокинг (ведь тестовая заглушка не может его давать). Но сам выбор типа конфигурации в STUN должен быть правильным для задачи. Теперь осталось понять как подручными средствами протестировать синхронный serial-линк.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

7. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 08-Окт-17, 19:50 
Ребята,

Пилю STUN. Взял конфиг человека, у которого это все типа работало:

hostname ROUTER-A
ip subnet-zero
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.254 255.255.255.255
no ip red
no ip directed-broadcast
!
stun peer-name 10.255.255.254
stun protocol-group 100 basic
!
interface Serial0/3/0
desc *** LINK TO ROUTER B ***
bandwidth 2048
ip address 10.255.255.1 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0/2/0
desc *** STUN LINK TO MY OLD BOX A - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/3/0 direct
!
interface fast 0/0
desc *** LAN ON ROUTER A ***
ip address 10.1.1.1 255.255.255.0
!
ip route 10.255.255.253 255.255.255.255 10.255.255.2 name LOOPBACK-B
ip route 10.1.1.0 255.255.255.0 10.255.255.2 name LAN-B

hostname ROUTER-B
ip subnet-zero
interface loopback 100
desc *** LOOPBACK 100 FOR STUN PEERING ***
ip address 10.255.255.253 255.255.255.255
no ip red
no ip directed-broadcast
!
stun peer-name 10.255.255.253
stun protocol-group 100 basic
!
interface Serial0/3/0
desc *** LINK TO ROUTER A ***
bandwidth 2048
ip address 10.255.255.2 255.255.255.252
no ip directed-broadcast
no ip mroute-cache
!
interface Serial0/2/0
desc *** STUN LINK TO MY OLD BOX B - THIS IS THE DCE END ***
no ip address
no ip directed-broadcast
encapsulation stun
no ip mroute-cache
clockrate 9600
stun group 100
stun route all interface serial 0/3/0 direct
!
interface fast 0/0
desc *** LAN ON ROUTER B ***
ip address 10.1.1.2 255.255.255.0
!
ip route 10.255.255.254 255.255.255.255 10.255.255.1 name LOOPBACK-A
ip route 10.1.1.0 255.255.255.0 10.255.255.1 name LAN-A

Есть проблема - STUN не работает :) А также смущает, что 10.255.255.253 не пигнуется с роутера "A". А хост 10.255.255.254 не пингуется с "B". Автору конфига отписал, но он писал давно и предупреждал, что уже давно не молод. Не факт, что он ответит.

Будут к.л. идеи, советы по изменению конфига? Роутера между Cisco у меня нет, они включены в один неуправляемый свитч.

Спасибо!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 08-Окт-17, 21:49 
И как вы вообще думаете, этот конфиг засовывает serial (V24) в LAN (Ethernet), или все же организует сеть по кабелю между serial-интерфейсами? Я смотрю на него как баран на новые ворота, и не уверен. А именно, смущает строчка stun route all interface serial 0/3/0 direct. Reference прочитал, но не пойму затею автора.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от eek (ok) on 09-Окт-17, 08:39 
Это смотрели?

https://www.cisco.com/c/ru_ru/support/docs/ip/serial-tunnel-...

BTW: ping между loopback должен быть.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

11. "Проблема с роутингом при настройке STUN (детский вопрос)"  +/
Сообщение от EIKA (ok) on 09-Окт-17, 12:20 
Да, видел на английском. Там чутка другая схема сети и инкапсуляция, поэтому чутка другой вывод диагностики. Не смог ничего извлечь из статьи :(
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor