The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]

форумы  правила/FAQ  поиск  регистрация  вход/выход  слежка  RSS
"PBR. Пропадаение второго канала при отключении основного"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Маршрутизация)
Изначальное сообщение [ Отслеживать ]
Курсы Сisco по безопасности (CCNA и CCNP Security, Сisco ISE 2.1, ASA, IronPort)
"PBR. Пропадаение второго канала при отключении основного"  +/
Сообщение от install on 19-Май-17, 10:06 
  Здравствуйте, уважаемые.

  Есть cisco 2951 (IOS 15.2), 2 внешних канала от разных провайдеров (стандартно: 1-й - "x", 2-й - "y"). Настроен PBR для некоторых адресов из пула провайдера "x", чтобы ходили через "y" постоянно. Все работает. Но, при пропадании основного канала через провайдера "x", и через "y" ничего не бегает, хотя должно.

Кусок конфига:

interface GigabitEthernet0/0.10
description "Link to 2-ISP"
encapsulation dot1Q 10
ip address y.y.y.138 255.255.255.252
ip accounting output-packets
ip flow ingress
ip nat outside
ip virtual-reassembly in
!
interface GigabitEthernet0/0.11
description "Link to 1-ISP"
encapsulation dot1Q 11
ip address x.x.x.42 255.255.255.252
ip accounting output-packets
ip flow ingress
!
interface GigabitEthernet0/2
description "Link to local net"
ip address 192.168.1.1 255.255.255.0 secondary
ip address y.y.y.209 255.255.255.248 secondary
ip address x.x.x.145 255.255.255.240
ip accounting output-packets
ip flow ingress
ip policy route-map PBR
duplex auto
speed auto

ip nat inside source list 10 interface GigabitEthernet0/0.10 overload
ip route 0.0.0.0 0.0.0.0 x.x.x.41
ip route 0.0.0.0 0.0.0.0 Null0 255

access-list 1 permit x.x.x.147
access-list 1 permit x.x.x.156
access-list 1 deny   any
access-list 10 permit any

route-map PBR permit 10
match ip address 1
set ip default next-hop y.y.y.137

  Замена "set ip default next-hop" на "set ip next-hop" ничего не дала. Куда копать?

show ip policy

Interface      Route map
Gi0/2          PBR

show route-map

route-map PBR, permit, sequence 10
  Match clauses:
    ip address (access-lists): 1
  Set clauses:
    ip default next-hop y.y.y.137
  Policy routing matches: 135666636 packets, 35375331105 bytes  

  

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "PBR. Пропадаение второго канала при отключении основного"  +/
Сообщение от Andrey (??) on 19-Май-17, 11:13 
>   Здравствуйте, уважаемые.
>   Есть cisco 2951 (IOS 15.2), 2 внешних канала от разных
> провайдеров (стандартно: 1-й - "x", 2-й - "y"). Настроен PBR для
> некоторых адресов из пула провайдера "x", чтобы ходили через "y" постоянно.
> Все работает. Но, при пропадании основного канала через провайдера "x", и
> через "y" ничего не бегает, хотя должно.

Не должно. Изучайте IP SLA.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "PBR. Пропадаение второго канала при отключении основного"  +/
Сообщение от ShyLion (ok) on 19-Май-17, 13:25 
> некоторых адресов из пула провайдера "x", чтобы ходили через "y" постоянно.

А с какого перепугу провайдер "y" вообще пропускает траффик с соурс-адресами провайдера "х" ?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема



  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor TopList