The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"NAT+PBR помогите понять"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 06-Май-07, 00:26 
Здравствуйте.
Помогите, пожалуйста, разобраться как работает.

Имею внешний и внутренний интерфейсы:
interface FastEthernet0/1
description WAN
ip address 10.1.0.2 255.255.255.252
ip nat outside
!

interface FastEthernet0/1
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
!

Хочу занатить локальную сеть 192.168.1.0/24 через глобальные адреса 10.1.0.3 - 10.1.0.5.

Объявляю пул:
ip nat pool WAN-pool 10.1.0.3 10.1.0.5

Описываю правило NAT:
ip nat inside source route-map WAN-NAT pool WAN-pool overload

И вот на этом моменте, объясните алгоритм работы маршрутизатора.
Допустим приходит пакет от адреса 192.168.1.5 на некий адрес в Интернете. Поскольку на интерфейсе включен nat (ip nat inside), маршрутизатор пытается найти правило трансляции. Встречает route-map и срабатывает так, как в нем указано. Это я правильно понимаю?

Опишите пожалуйста, как будет выглядеть route-map WAN-NAT, чтобы все корректно занатилось.
Какую роль в натовском route-map играет строка "match ip address Х"? А какую "set interface INT"?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 06-Май-07, 09:14 
Вообще, задача у меня такая:
Есть локальная сеть и два внешних интерфейса, которые смотрят к двум разным провайдерам. Нужно сеть 192.168.1.0/24 занатить через FastEthernet0/1, а если этот провайдер отвалится, то чтобы локалка натилась через FastEthernet0/2. Помогите, пожалуйста, разобраться.

interface FastEthernet0/1
description WAN
ip address 10.1.0.2 255.255.255.252
ip nat outside
!

interface FastEthernet0/2
description WAN2
ip address 10.2.0.2 255.255.255.252
ip nat outside
!

interface FastEthernet0/3
description LAN
ip address 192.168.1.1 255.255.255.0
ip nat inside
!

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "NAT+PBR помогите понять"  
Сообщение от onanymous on 06-Май-07, 16:02 
access-list 99 permit 192.168.1.0 0.0.0.255

route-map WAN-NAT
match ip address 99

ip nat pool WAN-pool 10.1.0.3 10.1.0.5 prefix-length 24

match - проверяет, set - устанавливает.
при настройке ната set не нужен. по крайней мере я не могу придумать как его можно использовать

и рут-мап в твоем случае не для PBR используется.
если у тебя один интерфейс с ip nat outside, то можно и без мапы обойтись

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "NAT+PBR помогите понять"  
Сообщение от CompeR email on 07-Май-07, 10:38 
почитай вот эту ветку https://www.opennet.ru/openforum/vsluhforumID6/10358.html
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 07-Май-07, 10:54 
>почитай вот эту ветку https://www.opennet.ru/openforum/vsluhforumID6/10358.html
Читал. Такую схему у меня нет возможности использовать.

track 123 rtr
                 ^
% Invalid input detected at '^' marker.

Видимо, IOS маловат...

А как бы иначе это сделать?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 07-Май-07, 10:56 
>access-list 99 permit 192.168.1.0 0.0.0.255
>
>route-map WAN-NAT
> match ip address 99
>
>ip nat pool WAN-pool 10.1.0.3 10.1.0.5 prefix-length 24
>
>match - проверяет, set - устанавливает.
>при настройке ната set не нужен. по крайней мере я не могу
>придумать как его можно использовать
>
>и рут-мап в твоем случае не для PBR используется.
>если у тебя один интерфейс с ip nat outside, то можно и
>без мапы обойтись

Насколько я понял, в применении маршрутной карты в NAT, ключевое слово set, так же как и match, носит определяющий характер. Знающе люди, исправьте, пожалуйста, если я ошибаюсь.

Возможно кто-то может дать ссылку на документацию сайта cisco.com об использовании NAT+PBR?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 07-Май-07, 11:00 
Читал http://cisco.far.ru/2isp.html
В этой реализации мне не понятно, как циска поймет, что шлюз не отвечает и туда слать не нужно и будет слать на работающий шлюз.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "NAT+PBR помогите понять"  
Сообщение от CompeR email on 07-Май-07, 15:49 
а какой у вас маршрутизатор/ios ?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "NAT+PBR помогите понять"  
Сообщение от CompeR email on 07-Май-07, 15:53 
>Читал http://cisco.far.ru/2isp.html
>В этой реализации мне не понятно, как циска поймет, что шлюз не
>отвечает и туда слать не нужно и будет слать на работающий
>шлюз.

В данном случае только если линк физически упадет.

В иос 12.4 и выше, можно использовать ip sla.

В этом случае можно например пинговать шлюз isp. и в зависимости от результата выбирать маршрут.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "NAT+PBR помогите понять"  
Сообщение от Monty email(ok) on 07-Май-07, 16:28 
>>Читал http://cisco.far.ru/2isp.html
>>В этой реализации мне не понятно, как циска поймет, что шлюз не
>>отвечает и туда слать не нужно и будет слать на работающий
>>шлюз.
>
>В данном случае только если линк физически упадет.
>
>В иос 12.4 и выше, можно использовать ip sla.
>
>В этом случае можно например пинговать шлюз isp. и в зависимости от
>результата выбирать маршрут.

Именно поэтому у меня он и не давал мониторить роутер.
У меня: ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
Интересно, можно ли в c2620 залить 12.4?..

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

10. "NAT+PBR помогите понять"  
Сообщение от CompeR email on 07-Май-07, 22:17 
>У меня: ROM: System Bootstrap, Version 12.1(3r)T2, RELEASE SOFTWARE (fc1)
>Интересно, можно ли в c2620 залить 12.4?..

нет, если у вас не 2620XM

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2023 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру