The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"871 migration from 12.3 to 12.4: QoS - service-policy + VLAN"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"871 migration from 12.3 to 12.4: QoS - service-policy + VLAN"  
Сообщение от MarkyBoy email(??) on 17-Фев-07, 21:28 
Прошу помощи в правильной перенастройке QoS на своей циске 871 после перехода на версию 12.4 (9) T с версии 12.3(8)YI2.
Суть проблемы, как я ее вижу в запрете использования service-policy для VLAN интерфесов в версии 12.4. Все по порядку:
Имеется следующее разделение траффика (по приоритетности – 1 – самый высокий):
1)    Траффик сисадмина (telnet, RDesktop)
2)    Рабочие сервисы (Oracle, WWW/issue tracking host, version control system)
3)    Внутренняя сетка (192.168.0.0/16; VPN на 5 офисов + подключение по Cisco VPN Client)
4)    Базовые сервисы (www, ftp, icq, skype,…)
5)    Все остальное (eMule, bittorrent,…)
Идеал в том, что бы траффик с большим приоритетом не перекрывался низшим, а при наличии свободного канала позволять использовать его полностью (то есть если нет траффика приоритетов 1-4 позволить траффику приоритета 5 взять все под себя, но только до момента появления пакетов с более высоким приоритетом). Но это идеал.
После прочтения некоторых докуметов по QoS у меня создалось впечатление что это возможно и достаточно просто, НО! На практике оказалось не все так прозрачно (для меня во всяком случае - в циске я дилетант, в общем то и не сисадмин даже), я пробовал разные варианты, и остановился на следующем: Class based service policy на оба интерфейса – на внешний (FastEthernet4) и на внутренний (VLAN). Таким образом у меня траффик шейпился как на вход, так и на выход сетки (выход на WAN, выход на LAN):
!
class-map match-all NetworkTraffic
match access-group 121
match not access-group 122
match not access-group 123
class-map match-all BasicTraffic
match access-group 120
match not access-group 121
match not access-group 122
match not access-group 123
class-map match-all AdminServicesTraffic
match access-group 123
class-map match-all DevServicesTraffic
match access-group 122
match not access-group 123
!
policy-map WANOutbound
class AdminServicesTraffic
  bandwidth percent 30
  shape peak percent 90
class DevServicesTraffic
  bandwidth percent 20
  shape peak percent 90
class NetworkTraffic
  bandwidth percent 15
  shape peak percent 80
class BasicTraffic
  bandwidth percent 7
  shape peak percent 40
class class-default
  bandwidth percent 3
  shape peak percent 30
policy-map LANOutbound
class AdminServicesTraffic
  bandwidth percent 30
  shape peak percent 90
class DevServicesTraffic
  bandwidth percent 20
  shape peak percent 90
class NetworkTraffic
  bandwidth percent 15
  shape peak percent 80
class BasicTraffic
  bandwidth percent 7
  shape peak percent 50
class class-default
  bandwidth percent 3
  shape peak percent 30
!
interface FastEthernet4
description $ES_WAN$$FW_OUTSIDE$
bandwidth 512
ip address XXX.XXX.XXX.XXX 255.255.255.0
ip access-group 101 in
ip verify unicast reverse-path
no ip redirects
no ip unreachables
no ip proxy-arp
ip wccp web-cache redirect out
ip nbar protocol-discovery
ip flow egress
ip nat outside
ip inspect DEFAULT100 out
ip virtual-reassembly
max-reserved-bandwidth 95
service-policy output WANOutbound
ip route-cache policy
ip route-cache flow
ip policy route-map VPN-Client
duplex auto
speed auto
no cdp enable
crypto map OdysseyVPNCryptoMap
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$ES_LAN$$FW_INSIDE$
bandwidth 512
ip address 192.168.50.1 255.255.255.0
ip access-group 100 in
no ip redirects
no ip unreachables
no ip proxy-arp
ip nbar protocol-discovery
ip flow egress
ip nat inside
ip virtual-reassembly
max-reserved-bandwidth 95
service-policy output LANOutbound
ip route-cache policy
ip route-cache flow
ip tcp adjust-mss 1452
!
В один прекрасный день я пришел на работу и мне сообщили что все инета нет – в результате оказалось, что у циски слетела флешка (не может прочитать бут-имидж). Ок, нашел новый, более свежий имидж 12.4 (в котором вроде как NetFlow работает без ошибок уже), залил, обновил конфиги – НО! Вот тут возникла проблема – с новой версией циска перестала понимать “service-policy output LANOutbound” – то есть совсем – нет такой команды в пинципе под VLAN… и теперь мой шейпинг канала не работает. 
Попробовал переставить этот service-policy на физ.интерфейс FastEthernet0 (VLAN это у меня все FastEthernet0-3) – не работает – при sh policy-map int fa0 – все по нулям.. что же делать?

Надеюсь, что для этой проблемы уже есть решений – ведь я не первый кто переходит с 12.3 на 12.4 с траффик-шейпингом на внутренние интерфейсы.

Кроме того, может более грамотный народ, который я уверен тут есть, подскажет более оптимальное решение для моей задачи?

Заранее спасибо!

PS. Ответы велкам и на имейл m_lazarenko@ukr.net

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "871 migration from 12.3 to 12.4: QoS - service-policy + VLAN"  
Сообщение от routercs email on 21-Фев-07, 20:25 
Почитайте http://www.cisco.com/warp/public/473/134.html
Там есть такая фраза - Note that when a port is in VLAN based QoS mode, but no service policy is applied to the corresponding VLAN, the switch will follow the service policy (if any) applied on a physical port. This allows additional flexibility in combining port-based and VLAN-based QoS.

Можете попробовать иерархическую политику, у меня так настроено на саб-интерфейсах:
police-map ABC
class class-default
  shape average _your bandwidth_
   service-policy LANOutbound

Или покажите конфиг полностью.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру