The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Cisco 871 - можно ли назначить service-policy output на LAN?"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Cisco 871 - можно ли назначить service-policy output на LAN?"  
Сообщение от Антон email(??) on 19-Дек-06, 17:55 
Здравствуйте,

в порядке ознакомления с QoS пытаюсь решить несложную "лабораторную" задачу - ограничить, например, скорость для HTTP трафика, который из Интернет попадает в локальную сеть.

Думаю, задачу можно решить двумя способами - либо настроить service-policy input на WAN интерфейсе, либо service-policy output на LAN. Второй вариант я бы полагал более предпочтительным, поскольку прочитал, что политики QoS на входящих интерфейсах не будут приводить к образованию очереди и шейпингу, а будут приводить к отбросу пакетов. А, поскольку пакет уже "пришел" на WAN-интерфейс, то канал уже им загрузился, и отбрасывать его не хочется :)

У Cisco 871 интерфейсы FastEthernet0, 1, 2, 3 - свитч в локальную сеть (=Vlan 1), FastEthernet 4 - WAN-порт.

На интерфейсе Vlan1 команда service-policy не доступна вообще.

На интерфейсе FastEthernet0, куда физически подключена локальная сеть, service-policy применяется, но не дает никакого эффекта...

Отсюда вопрос - команда к интерфейсу применяется, но может ли она работать? Или есть некие аппаратные препятствия?

Заранее признателен,
Антон


!пакеты с порта tcp80 на любой хост
ip access-list extended HTTP_acl
permit tcp any eq 80 any
exit

class-map match-any HTTP_cm
match access-group name HTTP_acl
exit

!ограничить 64 килобита в секунду
policy-map HTTP_pm
class HTTP_cm
shape average 64000
exit
exit

int fa 0
service-policy output HTTP_pm
exit

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Cisco 871 - можно ли назначить service-policy output на LAN?"  
Сообщение от xxx (??) on 20-Дек-06, 08:52 
>Здравствуйте,
>
>в порядке ознакомления с QoS пытаюсь решить несложную "лабораторную" задачу - ограничить,
>например, скорость для HTTP трафика, который из Интернет попадает в локальную
>сеть.
>
>Думаю, задачу можно решить двумя способами - либо настроить service-policy input на
>WAN интерфейсе, либо service-policy output на LAN. Второй вариант я бы
>полагал более предпочтительным, поскольку прочитал, что политики QoS на входящих интерфейсах
>не будут приводить к образованию очереди и шейпингу, а будут приводить
>к отбросу пакетов. А, поскольку пакет уже "пришел" на WAN-интерфейс, то
>канал уже им загрузился, и отбрасывать его не хочется :)
>
>У Cisco 871 интерфейсы FastEthernet0, 1, 2, 3 - свитч в локальную
>сеть (=Vlan 1), FastEthernet 4 - WAN-порт.
>
>На интерфейсе Vlan1 команда service-policy не доступна вообще.
>
>На интерфейсе FastEthernet0, куда физически подключена локальная сеть, service-policy применяется, но не
>дает никакого эффекта...
>
>Отсюда вопрос - команда к интерфейсу применяется, но может ли она работать?
>Или есть некие аппаратные препятствия?
>
>Заранее признателен,
>Антон
>
>
>!пакеты с порта tcp80 на любой хост
>ip access-list extended HTTP_acl
>permit tcp any eq 80 any
>exit
>
>class-map match-any HTTP_cm
>match access-group name HTTP_acl
>exit
>
>!ограничить 64 килобита в секунду
>policy-map HTTP_pm
>class HTTP_cm
>shape average 64000
>exit
>exit
>
>int fa 0
>service-policy output HTTP_pm
>exit


Мда..
s/permit tcp any eq 80 any/permit tcp any any eq 80
С 80-го порта никто не должен соединяться...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Cisco 871 - можно ли назначить service-policy output на LAN?"  
Сообщение от Антон email(??) on 20-Дек-06, 10:48 
>Мда..
>s/permit tcp any eq 80 any/permit tcp any any eq 80
>С 80-го порта никто не должен соединяться...

Видимо, не понимаю мысль, но:

1) fa 0 - интерфейс 871 в локальную сеть (один из четырех);
2) permit tcp any eq 80 any - под этот acl попадают tcp датаграммы с порта 80, т.е., наример, из Интернет, следующие в локальню сеть;
3) access-list включаем в class-map, настраиваем policy-map, ограничивающую пропускную способность 64000 бит в секунду, применяем ее на "выход" с интерфейса fa 0 в локальную сеть;
4) эффекта никакого нет.

Отсюда - вопрос: команда к интерфейсу применяется, но может ли она работать?
Или есть некие аппаратные препятствия?

Спасибо,
Антон

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Cisco 871 - можно ли назначить service-policy output на LAN?"  
Сообщение от Сайко on 20-Дек-06, 11:07 
show policy-map interface FastEthernet0
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру