The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Cat3750 + Policy-Based Routing"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"Cat3750 + Policy-Based Routing"  
Сообщение от Borodiychuck email(ok) on 19-Июл-06, 01:16 
Есть Catalyst 3750 WS-C3750G-24TS-S (c3750-i9-mz.121-19.EA1c.tar).

Стоит задача - поднять на порту Policy-Based
Routing

Для начала я обращаюсь в мануал, и
узнаю что:
To use PBR, you must have the IP services image installed on the stack master.

Я прошиваю в него c3750-ipservicesk9-tar.122-25.SEE1.tar

конфигурирую:


interface GigabitEthernet1/0/24
no switchport
ip address 10.2.5.254 255.255.255.0 secondary
ip address 10.0.5.254 255.255.255.0
ip helper-address 10.0.0.1
no mdix auto
...
access-list 110 permit ip 10.0.5.31 0.0.0.0 any
route-map unlim permit 10
match ip address 110
set ip default next-hop 10.0.0.254
interface GigabitEthernet1/0/24
ip policy route-map unlim

после последней команды получаю в
логах:
%PLATFORM_PBR-3-UNSUPPORTED_RMAP: Route-map unlim not supported for
Policy-Based Routing

Снова обращаюсь в мануал. Вижу
небольшую приписку:
Note This software release does not support Policy-Based Routing (PBR)
when processing IPv4 and IPv6 traffic.

Ковыряю мануалы более раннних версий.
В мануале на c3750-ipservices-tar.122-25.SEC.tar такой
приписки нет. Прошиваю его,
перегружаюсь - та же проблема.

С чем такое может быть связано? Заранее
благодарю.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Cat3750 + Policy-Based Routing"  
Сообщение от ilya email(ok) on 19-Июл-06, 08:27 
>Есть Catalyst 3750 WS-C3750G-24TS-S (c3750-i9-mz.121-19.EA1c.tar).
>
>Стоит задача - поднять на порту Policy-Based
>Routing
>
>Для начала я обращаюсь в мануал, и
>узнаю что:
> To use PBR, you must have the IP services image installed
>on the stack master.
>
>Я прошиваю в него c3750-ipservicesk9-tar.122-25.SEE1.tar
>
>конфигурирую:
>
>
>interface GigabitEthernet1/0/24
> no switchport
> ip address 10.2.5.254 255.255.255.0 secondary
> ip address 10.0.5.254 255.255.255.0
> ip helper-address 10.0.0.1
> no mdix auto
>...
>access-list 110 permit ip 10.0.5.31 0.0.0.0 any
>route-map unlim permit 10
> match ip address 110
> set ip default next-hop 10.0.0.254
>interface GigabitEthernet1/0/24
> ip policy route-map unlim
>
>после последней команды получаю в
>логах:
>%PLATFORM_PBR-3-UNSUPPORTED_RMAP: Route-map unlim not supported for
>Policy-Based Routing
>
>Снова обращаюсь в мануал. Вижу
>небольшую приписку:
>Note This software release does not support Policy-Based Routing (PBR)
>when processing IPv4 and IPv6 traffic.
>
>Ковыряю мануалы более раннних версий.
>В мануале на c3750-ipservices-tar.122-25.SEC.tar такой
>приписки нет. Прошиваю его,
>перегружаюсь - та же проблема.
>
>С чем такое может быть связано? Заранее
>благодарю.

странно, фьюченавигатор выдает что в 12.2.25.SEC есть полиси роутинг....
а применение на влан роут-мапа дает такой же результат?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Cat3750 + Policy-Based Routing"  
Сообщение от vgray email(ok) on 19-Июл-06, 08:58 
>route-map unlim permit 10
> match ip address 110
> set ip default next-hop 10.0.0.254
>interface GigabitEthernet1/0/24
> ip policy route-map unlim
>
>после последней команды получаю в
>логах:
>%PLATFORM_PBR-3-UNSUPPORTED_RMAP: Route-map unlim not supported for
>Policy-Based Routing
>
>Снова обращаюсь в мануал. Вижу
>небольшую приписку:

На самом деле, если еще раз обратиться в мануал, то можно найти абзац

"Policy-based routing based on packet length, IP precedence and TOS, set interface, set default next hop, or set default interface are not supported. Policy maps with no valid set actions or with set action set to Don't Fragment are not supported."

те переписываем роут меп как

route-map unlim permit 10
match ip address 110
set ip next-hop 10.0.0.254

если это удовлетворяет условиям задачи то оставляем,если нет то ищем другие пути решения.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Cat3750 + Policy-Based Routing"  
Сообщение от Borodiychuck (ok) on 19-Июл-06, 09:17 

>те переписываем роут меп как
>
>route-map unlim permit 10
> match ip address 110
> set ip next-hop 10.0.0.254
>
>если это удовлетворяет условиям задачи то оставляем,если нет то ищем другие пути
>решения.


Спасибо, это решение помогло.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру