The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"ip policy route-map на cat3550"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 22-Мрт-06, 21:05 
Задача следующая:
Есть catalyst-3550
(IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(19)EA1c, RELEASE SOFTWARE (fc2))

он должен отрправлять на разные шлюзы в зависмости от какого ИП поступил пакет
1. 172.16.200.5 (для сети 11.22.33.0/24)
2. 192.168.61.201 (для всех остальных IP)

ip subnet-zero
ip routing
!
ip route 0.0.0.0 0.0.0.0 192.168.61.201
!
interface Vlan465
ip address 172.16.200.6 255.255.255.252
!
interface Vlan466
ip address 192.168.61.202 255.255.255.252
no ip route-cache cef
ip route-cache policy
no ip mroute-cache
!
ip access-list standard ISP1
permit 11.22.33.0 0.0.0.255
!
route-map MAP1 permit 10
match ip address ISP1
set ip next-hop 172.16.200.5
!
помимо этого есть куча ВЛАНОВ, которые он роутит.

когда для vlan465 говорю
ip policy route-map MAP1
он не ругается, но и ничего не происходит. (в sh run этой командв не видно...)

в чем грабли?
и на какие интерфесы вешать этот route-map


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 23-Мрт-06, 17:58 
>Задача следующая:
>Есть catalyst-3550
>(IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(19)EA1c, RELEASE SOFTWARE (fc2))
>
>он должен отрправлять на разные шлюзы в зависмости от какого ИП поступил
>пакет
>1. 172.16.200.5 (для сети 11.22.33.0/24)
>2. 192.168.61.201 (для всех остальных IP)
>
>ip subnet-zero
>ip routing
>!
>ip route 0.0.0.0 0.0.0.0 192.168.61.201
>!
>interface Vlan465
> ip address 172.16.200.6 255.255.255.252
>!
>interface Vlan466
> ip address 192.168.61.202 255.255.255.252
> no ip route-cache cef
> ip route-cache policy
> no ip mroute-cache
>!
>ip access-list standard ISP1
> permit 11.22.33.0 0.0.0.255
>!
>route-map MAP1 permit 10
> match ip address ISP1
> set ip next-hop 172.16.200.5
>!
>помимо этого есть куча ВЛАНОВ, которые он роутит.
>
>когда для vlan465 говорю
>ip policy route-map MAP1
>он не ругается, но и ничего не происходит. (в sh run этой
>командв не видно...)
>
>в чем грабли?
>и на какие интерфесы вешать этот route-map

ну неужели никто не знает как с этим бороться?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "ip policy route-map на cat3550"  
Сообщение от Олег email(??) on 24-Мрт-06, 10:06 
Он, случайно, в логах ничего не пишет?


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "ip policy route-map на cat3550"  
Сообщение от Helper on 24-Мрт-06, 11:07 
Вроде для policy-роутинга SDM должен быть extended.
Посмотрите, что покажет
sh sdm prefer
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "ip policy route-map на cat3550"  
Сообщение от Alien (??) on 24-Мрт-06, 16:32 
одно из:
· sdm prefer extended−match
· sdm prefer access extended−match
· sdm prefer routing extended−match

и перегрузите

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 24-Мрт-06, 16:35 
>одно из:
>· sdm prefer extended−match
>· sdm prefer access extended−match
>· sdm prefer routing extended−match
>
>и перегрузите

такого там тоже нет.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 24-Мрт-06, 16:35 
>Вроде для policy-роутинга SDM должен быть extended.
>Посмотрите, что покажет
>sh sdm prefer
там вообще нет такой команды.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 24-Мрт-06, 16:36 
sh ver

Cisco Internetwork Operating System Software
IOS (tm) C3550 Software (C3550-I5Q3L2-M), Version 12.1(19)EA1c, RELEASE SOFTWARE (fc2)
Copyright (c) 1986-2004 by cisco Systems, Inc.
Compiled Tue 03-Feb-04 05:31 by yenanh
Image text-base: 0x00003000, data-base: 0x0080DFF0

ROM: Bootstrap program is C3550 boot loader

Spalernaya-3550 uptime is 43 weeks, 3 days, 8 hours, 18 minutes
System returned to ROM by power-on
System restarted at 08:17:13 MSK Tue May 24 2005
System image file is "flash:c3550-i5q3l2-mz.121-19.EA1c/c3550-i5q3l2-mz.121-19.EA1c.bin"

cisco WS-C3550-24 (PowerPC) processor (revision M0) with 65526K/8192K bytes of memory.
Processor board ID CAT0822N1KJ
Last reset from warm-reset
Bridging software.
Running Layer2/3 Switching Image

Ethernet-controller 1 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 2 has 12 Fast Ethernet/IEEE 802.3 interfaces

Ethernet-controller 3 has 1 Gigabit Ethernet/IEEE 802.3 interface

Ethernet-controller 4 has 1 Gigabit Ethernet/IEEE 802.3 interface

24 FastEthernet/IEEE 802.3 interface(s)
2 Gigabit Ethernet/IEEE 802.3 interface(s)

The password-recovery mechanism is enabled.
384K bytes of flash-simulated non-volatile configuration memory.
Base ethernet MAC Address: 00:11:21:9D:18:80
Motherboard assembly number: 73-5700-11
Power supply part number: 34-0966-04
Motherboard serial number: CAT08210HSN
Power supply serial number: DTH08213RK2
Model revision number: M0
Motherboard revision number: A0
Model number: WS-C3550-24-EMI
System serial number: CAT0822N1KJ
Configuration register is 0x10F

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

8. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 24-Мрт-06, 17:02 
вот что пишет в логах:

interface vlan 116
ip policy route-map MYMAP
%L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

9. "ip policy route-map на cat3550"  
Сообщение от Олег email(??) on 24-Мрт-06, 17:22 
>вот что пишет в логах:
>
>interface vlan 116
>ip policy route-map MYMAP
>%L3TCAM-3-SIZE_CONFLICT: PBR requires enabling extended routing

Сделай:
CAT3550# conf t
Enter configuration commands, one per line. End with CNTL/Z.
CAT3550(config)# sdm prefer extended-match
Changes to the running SDM preferences have been stored, but cannot take effect
until the next reload.
Use 'show sdm prefer' to see what SDM preference is currently active.
CAT3550(config)# end

CAT3550# write
06:14:11: %SYS-5-CONFIG_I: Configured from console by console
Building configuration...
[OK]

CAT3550# reload
Proceed with reload? [confirm]
(http://www.cisco.com/en/US/tech/tk364/technologies_configuration_example09186a00802135d3.shtml)

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

10. "ip policy route-map на cat3550"  
Сообщение от HackerCB email(ok) on 24-Мрт-06, 18:26 
разобрался.
sdm prefer extended-match
reload

:)

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру