The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от opennews (??), 24-Авг-21, 09:11 
Компания GitHub приняла решение прекратить поддержку протоколов  TLS 1.0 и 1.1 в репозитории пакетов NPM и на всех сайтах, связанных с пакетным менеджером NPM, включая npmjs.com. Начиная с 4 октября для подключения к репозиторию, в том числе для  установки пакетов, потребуется клиент с поддержкой как минимум TLS 1.2. На самом GitHub поддержка TLS 1.0/1.1 была прекращена ещё в феврале 2018 года. В качестве мотива называется забота о безопасности своих сервисов и конфиденциальности данных пользователей. По данным GitHub около 99% запросов к репозиторию NPM уже совершается с использованием TLS 1.2 или 1.3, а Node.js включает поддержку TLS 1.2 c 2013 года (начиная с выпуска 0.10), поэтому изменение затронет лишь незначительную часть пользователей...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=55673

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +16 +/
Сообщение от Аноним (1), 24-Авг-21, 09:11 
В качестве зеркально ответной меры, TLS 1.0 прекращает поддержку NPM.
Ответить | Правка | Наверх | Cообщить модератору

9. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +1 +/
Сообщение от Аноним (9), 24-Авг-21, 10:08 
> В качестве зеркально ответной меры

* симметричной

Ответить | Правка | Наверх | Cообщить модератору

10. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от OnTheEdgeemail (ok), 24-Авг-21, 10:08 
* аналогичной
Ответить | Правка | Наверх | Cообщить модератору

2. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +1 +/
Сообщение от Оффтоп (?), 24-Авг-21, 09:13 
Невозможность использовать github cli без авторизации тоже ради безопасности?
Ответить | Правка | Наверх | Cообщить модератору

3. Скрыто модератором  –1 +/
Сообщение от Вадик (??), 24-Авг-21, 09:19 
Ответить | Правка | Наверх | Cообщить модератору

4. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +3 +/
Сообщение от Аноним (4), 24-Авг-21, 09:22 
А что, цифровую подпись нельзя сделать у пакетов? Вот, например, apt можно хоть по ftp качать и всё безопасно
Ответить | Правка | Наверх | Cообщить модератору

5. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +1 +/
Сообщение от Аноним (5), 24-Авг-21, 09:30 
У Apt с модерацией и мэйнтейнерами дела лучше
Ответить | Правка | Наверх | Cообщить модератору

7. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +3 +/
Сообщение от Аноним (7), 24-Авг-21, 09:47 
Так посмотреть - в NPM вообще в plain-text могут отдавать - один хрен там помойка.
Ответить | Правка | Наверх | Cообщить модератору

6. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  –2 +/
Сообщение от Enamel (ok), 24-Авг-21, 09:32 
Ну что сказать, поздравление в связи с отказом от устаревших технологий
Ответить | Правка | Наверх | Cообщить модератору

8. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Рач (?), 24-Авг-21, 09:55 
Js не выглядит стильно и молодёжно.
Ответить | Правка | Наверх | Cообщить модератору

11. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Аноним (11), 24-Авг-21, 11:30 
А я то думал, это один из оплотов стильности, модности и молодёжности.
Ответить | Правка | Наверх | Cообщить модератору

16. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +2 +/
Сообщение от Аноним (16), 24-Авг-21, 16:20 
Какая iPonyтовская глупость

Когда вы уже из пелёнок вылезете iPony всякие

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

12. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Аноним (11), 24-Авг-21, 11:31 
Ждём поха с нытьём о том, что TLS 1.3 ничем не лучше предыдущих версий, а всем его навязывают, плак плак
Ответить | Правка | Наверх | Cообщить модератору

13. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +3 +/
Сообщение от Аноним (13), 24-Авг-21, 13:12 
Репозиторию NPM это не поможет
Ответить | Правка | Наверх | Cообщить модератору

14. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +1 +/
Сообщение от Аноним (14), 24-Авг-21, 14:17 
Я бы для безопасности ещё добавил обязательную авторизацию через аккаунт микрософт для скачки пакетов.
Ответить | Правка | Наверх | Cообщить модератору

17. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от пох. (?), 24-Авг-21, 18:39 
Ну зачем вы так, ведь npm же ж кроссплатформенная технология, не принадлежащая одной компании!
Надо предоставить пользователю выбор - live, facebook или гугль!

(твиттер, наверное, излишне?)

Ответить | Правка | Наверх | Cообщить модератору

18. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Однокнопочный (?), 24-Авг-21, 19:03 
А где tiktok и дискорд?
Ответить | Правка | Наверх | Cообщить модератору

19. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +2 +/
Сообщение от муу (?), 24-Авг-21, 22:11 
и госуслуги!
Ответить | Правка | Наверх | Cообщить модератору

15. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Аноним (16), 24-Авг-21, 16:18 
Прекратите поддержку NPM
Ответить | Правка | Наверх | Cообщить модератору

20. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +4 +/
Сообщение от YetAnotherOnanym (ok), 24-Авг-21, 22:31 
Стальная дверь при картонных стенах.
Ответить | Правка | Наверх | Cообщить модератору

21. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +1 +/
Сообщение от Аноним (21), 25-Авг-21, 20:53 
> В самих протоколах TLS 1.0/1.1 отсутствуют критические уязвимости, которые можно использовать для осуществления практических атак.

Поэтому корпорасты и выпиливают - тов. Маер попросил всунуть хомячкам новые модно-молодёжные зонды.

Ответить | Правка | Наверх | Cообщить модератору

22. "Репозиторий NPM прекращает поддержку TLS 1.0 и 1.1"  +/
Сообщение от Аноним (-), 28-Авг-21, 14:25 
Товарищ маЙОр недоволен.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру