The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Выпуск spaCy 3.0, библиотеки для обработки информации на естественном языке"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Выпуск spaCy 3.0, библиотеки для обработки информации на естественном языке"  +/
Сообщение от opennews (?), 01-Фев-21, 23:17 
Компания Explosion AI опубликовала выпуск свободной библиотеки spaCy с реализацией алгоритмов обработки текста на естественном языке (NLP, Natural Language...

Подробнее: https://www.opennet.ru/opennews/art.shtml?num=54505

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –6 +/
Сообщение от Корец (?), 01-Фев-21, 23:17 
Я гляжу, что даже сложный софт пишется на таких языках, как пайтон. Но ведь 2.7 закопали, так? Значит весь софт, который был написан под старую версию нужно переписывать. Значит со временем текущие реализации пайтона тоже закопают и софт придётся переписывать.

Объясните мне суть. Почему для подобных проектов не используются более "стабильные" языки?

Ответить | Правка | Наверх | Cообщить модератору

2. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +13 +/
Сообщение от Урри (ok), 01-Фев-21, 23:25 
Потому что буяк-буяк и в продакшен.
А если взлетит, то потом желающие могут и переписать на нормальном быстром языке.

Лично я такой подход поддерживаю (с одним единым исключением - лишь бы не на джаваскрипте).

Ответить | Правка | Наверх | Cообщить модератору

4. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Корец (?), 01-Фев-21, 23:34 
Звучит разумно, наверное вы правы.
Ответить | Правка | Наверх | Cообщить модератору

6. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (6), 02-Фев-21, 00:24 
Сабж очень быстрый и эффективный. Альтернатив подобного уровня на других языках я не знаю, куда ты там переписывать собрался?
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

20. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +2 +/
Сообщение от iCat (ok), 02-Фев-21, 03:48 
Ну он же сказал: на стабильный язык. На ассемблер. ;)
Ответить | Правка | Наверх | Cообщить модератору

38. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +2 +/
Сообщение от Аноним (38), 02-Фев-21, 10:17 
ассемблер нифига не стабильный. на разных процах он отличается. выходят новые процы с еще более расширенными наборами инструкция
Ответить | Правка | Наверх | Cообщить модератору

53. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Массаракш (?), 02-Фев-21, 17:14 
В пайтон удобно выбрасывать высокоуровневую логику, API, и вообще не ждать миллиард лет после каждой компиляции... а оптимизированные куску можно невозбранно переписывать на Cython - который таки компилится в Cи и машинный код и из остального кода питона дергать их.

Ответить | Правка | К родителю #6 | Наверх | Cообщить модератору

56. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Анонимemail (56), 02-Фев-21, 21:29 
На Delphi пишу. Агонь. Компиляция самая быстрая на этой планете.
Ответить | Правка | Наверх | Cообщить модератору

61. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Анонимный_анон (?), 03-Фев-21, 08:04 
Не перепишут, потому что переписать такой слой brainware это очень большая работа, тем более с языка на язык
Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

3. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +9 +/
Сообщение от Аноним (3), 01-Фев-21, 23:28 
Почему не на латыни комментарии пишете?
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

5. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +6 +/
Сообщение от Аноним (5), 01-Фев-21, 23:46 
Caput tuum in ano est
Ответить | Правка | Наверх | Cообщить модератору

7. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (7), 02-Фев-21, 00:30 
>Значит весь софт, который был написан под старую версию нужно переписывать.

Всяким ретроградам прошивку надо перешивать. С ферритовых сердечников на магниторезистивную память.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

34. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (34), 02-Фев-21, 09:56 
Весь питон на стимпанк смахивает. Во времена, когда кругом электроника, эти жрут кактусы и делают "продакшн прожекты" на пару.....
Ответить | Правка | Наверх | Cообщить модератору

8. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Ordu (ok), 02-Фев-21, 00:36 
> Почему для подобных проектов не используются более "стабильные" языки?

Это какие, например?

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

12. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +3 +/
Сообщение от FractaL (ok), 02-Фев-21, 00:50 
Конечно же это Rust. Нормальные проекты можно писать только на Rust. Всё остальное еритики.

На расте тоже ничего не работает но зато безопасно неработает.

Ответить | Правка | Наверх | Cообщить модератору

19. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –2 +/
Сообщение от Ordu (ok), 02-Фев-21, 01:15 
> Конечно же это Rust. Нормальные проекты можно писать только на Rust. Всё
> остальное еритики.

Что серьёзно?

> На расте тоже ничего не работает но зато безопасно неработает.

Ты хочешь сказать, что эта модель в новости не работает? Скачал и попробовал? Прям брекинг ньюс, дополни новость.

Ответить | Правка | Наверх | Cообщить модератору

15. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (15), 02-Фев-21, 00:54 
> Значит со временем текущие реализации пайтона тоже закопают и софт придётся переписывать.

Это из ваших заключений никак не следует, но не суть. Любой живой язык развивается, и в нём депрекейтят устаревший мусор. И любой живой софт не испытывает проблем с тем чтобы за этими изменениями следовать. В питоне просто не испугались пойти на кардинальные решения и выкинуть гнильё, а не копить залежи совместимости, которые уже терминально изурововали плюсы, например. Именно и только такие языки и должны использоваться и для подобный проектов и для любых других.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

18. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Anonim (??), 02-Фев-21, 01:07 
> Я гляжу, что даже сложный софт пишется на таких языках, как пайтон

Это библиотека по сути обертка над DL моделями - в этом случаи python используется просто как frontend и на итоговую производительность влияет слабо

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

28. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (28), 02-Фев-21, 09:11 
> python используется просто как frontend и на итоговую производительность влияет слабо

Ещё как влияет. NLP-проекты очень часто требуют дополнительные операции над строками. Если на Java или на Julia потери на дополнительные проверки токенов или лексем можно и не заметить, то в питон-проекте, это легко может стать причиной тотальной просадки производительности и крахом проекта в целом.

Ответить | Правка | Наверх | Cообщить модератору

31. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (6), 02-Фев-21, 09:33 
Cython == C. C производительнее julia (не в курсе за производительность) и тем более java (раз в 1000).
Ответить | Правка | Наверх | Cообщить модератору

32. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (32), 02-Фев-21, 09:54 
Cython != Python. Желающих писать проект на Cython много не найдётся. В случае CPython же, лучше его не трогать вообще....
Ответить | Правка | Наверх | Cообщить модератору

42. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (6), 02-Фев-21, 11:06 
Единственный повод использовать Cython и получить производительность равную C, это когда у тебя уже есть проект на CPython. На Cython желают писать все, кому внезапно стало не хватать производительности питона на некоторых участках, и простота, с которой можно его применить, действительно подкупает. Многие приличные батарейки используют cython, тебе нужно только немножко оптимизировать свой код вынеся горячие участки в него и остальное можно оставить без изменений.
Ответить | Правка | Наверх | Cообщить модератору

47. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +1 +/
Сообщение от Аноним (47), 02-Фев-21, 12:52 
>> На Cython желают писать все, кому внезапно стало не хватать производительности

На Cython никто не желает писать. Просто есть современные языки программирования, а есть питон и его поклонники, уверяющие, что язык, слепленный на коленках по лекалам 70-х ещё актуален :(

Ответить | Правка | Наверх | Cообщить модератору

43. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (6), 02-Фев-21, 11:12 
Ну и ещё ты говоришь CPython ты подразумеваешь си с частью логики на питоне, писать на языке без интеграции с си это удел неполноценных языков. А у си, как известно, сишная производительность.
Ответить | Правка | К родителю #32 | Наверх | Cообщить модератору

48. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (47), 02-Фев-21, 12:56 
Вот посадить вас таких умных на годик другой писать на C.... Да, жить на C можно, но за этот годик-другой, программист на современном ЯП типа Julia, Rust, или, даже, C++, успеет столько написать, что догнать вы его не сможете никакой обвязкой на питоне. Надо понимать, что питон + С в 90-м году, может, и нормально. Но в 2021-м есть масса способов не использовать языки-нашлёпки.
Ответить | Правка | Наверх | Cообщить модератору

44. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от economist (?), 02-Фев-21, 11:42 
Верно, но отчасти. Строковые методы и re в Питоне написана на С и потому быстры. Крах проекта из-за доп. проверок? - ну это уже слишком...

Ответить | Правка | К родителю #28 | Наверх | Cообщить модератору

49. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (47), 02-Фев-21, 12:57 
Ок.... Добавьте на питоне проверку окончания, например... И посмотрите сколько процентов времени будет уходить на эту проверку по сравнению с функциями, реализованными в C-коде.
Ответить | Правка | Наверх | Cообщить модератору

55. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от economist (?), 02-Фев-21, 19:41 
А куда спешить в NLP?
Ответить | Правка | Наверх | Cообщить модератору

57. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (57), 02-Фев-21, 22:53 
Даже если спешить некуда, за вычислительные ресурсы приходится платить. Впрочем, сложно представить себе сервер, который никуда не спешит...
Ответить | Правка | Наверх | Cообщить модератору

21. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Галустян (?), 02-Фев-21, 05:03 
Ну, во-первых, если код для 2.7 написан по PEP20+PEP8 и вовремя поддерживался, избавляясь от устаревшего, то он с большой вероятностью вообще не потребует никакого рефакторинга для работы под 3.х.
Во-вторых, чтобы написать такое на стабильном си, понадобится пару десятилетий, если не больше ;).
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

33. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (7), 02-Фев-21, 09:55 
>PEP8

вообще об оформлении, на поведение не влияет.

Ответить | Правка | Наверх | Cообщить модератору

50. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Галустян (?), 02-Фев-21, 13:30 
Оформление влияет на дисциплину, дисциплина влияет на щепетильность, щепетильность - это вопрос качества в целом, качество влияет на процент ошибок и неудачных решений в коде, а эти 2 неразлучника влияют на поведение ;).
И да, кстати, если не писать по PEP8, значит автоматически не писать по PEP20. Они связаны.
Ответить | Правка | Наверх | Cообщить модератору

22. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +1 +/
Сообщение от Галустян (?), 02-Фев-21, 05:11 
Проблема не в языках, а в программистах. Их как и гитаристов - в каждом дворе не меньше пяти, да только Блэкморов и Мальмстинов среди них по 2-3 на крупный город.
Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

24. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от An O Nim (?), 02-Фев-21, 09:00 
> ... ... ... Но ведь 2.7 закопали, так? Значит весь софт, который был написан под старую версию нужно переписывать.
> ... ... ...
> ... Объясните мне суть. ... ...

В языке на первом месте удобство для решения нужного класса задач. Питон оказался удачный язык. В чём именно, какие подробности здесь не скажу, у других публикаций много.

На Питоне можно писать так, что работает одинаково и под 2.7 и под 3. Граммотный девелопер знает такие особенности и учитывает. Ещё грамотный дев берёт не все подряд пакеты из Pip, разбирается где хороший код, где поддержка кода.

Поэтому хороший код довольно легко перложить с версии на версию.

На языке Си до сих пор пишут. И архитектура железа и объём наработок на Си столь велики, что закопают, но немало поколений ИТ ещё выйдет в тираж раньше события.

P.S. Из практики: да, действительно, на иных языках употеешь там, где на Питоне через полчаса уже "Весчъ" сделана. :) А широкие возможности тяп ляп... так это сами себе злые буратино и девелопер и родители девелопера.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

40. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (6), 02-Фев-21, 10:51 
>работает одинаково и под 2.7 и под 3

Не совсем одинаково, и это надевание совы на глобус. А после 3.2 вообще не актуально, грамотный дев пошлёт нахрен таких пользователей и не будет им угождать в ущерб нормальным.

>не все подряд пакеты из Pip, разбирается где хороший код, где поддержка кода

Да, он как минимум по возможности будет обходить по стокилометровой дуге батарейки с заявленной поддержкой питона ниже 3.6 (на сегодня, и то позволительно только старым).

>довольно легко перложить с версии на версию

К сожалению, это подразумевает совершенно нездоровые объёмы рефакторинга, в противном случае не будут использованы новые, более эффективные методы и подходы. Это большая проблема для протухших проектов, у которых есть "необходимость" поддерживать доисторические. Ошибочное решение сродни оставить 2 ветку на плаву, нужно закапывать легаси как можно быстрее. Приятно, что до многих начало доходить всё же. Но это всё же достоинство языка, что питон не стоит на месте и конкуренция в лице того же жс заставляет его развиваться.

Ответить | Правка | Наверх | Cообщить модератору

52. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Галустян (?), 02-Фев-21, 15:43 
Фейспалм и ахтунг. Вы точно про синьоров с седыми волосами или всё-таки про новую волну кодеров с завышенным чсв и серверами развёрнутыми в прошлом году?
Ответить | Правка | Наверх | Cообщить модератору

54. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (6), 02-Фев-21, 18:10 
> Фейспалм и ахтунг. Вы точно про синьоров с седыми волосами или всё-таки
> про новую волну кодеров с завышенным чсв и серверами развёрнутыми в
> прошлом году?

Седым мулям пхп подавай, пусть там и остаются, на пхп3.

Ответить | Правка | Наверх | Cообщить модератору

27. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +1 +/
Сообщение от Аноним (57), 02-Фев-21, 09:05 
> Объясните мне суть. Почему для подобных проектов не используются более "стабильные" языки?

Питон и всё, что вокруг него - игрушки для детей. Поэтому, поигрались, надоело, и выбросили. Следующее поколение "детей" всё равно не будет использовать опыты предыдущих.

Ни для чего другого, питон не пригоден.

Ответить | Правка | К родителю #1 | Наверх | Cообщить модератору

37. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (7), 02-Фев-21, 10:03 
С 1990 так говорят ...
Ответить | Правка | Наверх | Cообщить модератору

39. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (34), 02-Фев-21, 10:30 
Ну так количество детей с компьютером с тех пор сильно увеличилось.
Ответить | Правка | Наверх | Cообщить модератору

9. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +1 +/
Сообщение от Аноним (9), 02-Фев-21, 00:42 
И как всегда на питоне долбануться можно пока установишь. Про эти пипы заливать не надо, нормальные люди мусор в систему не тянут.
Ответить | Правка | Наверх | Cообщить модератору

10. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Faremail (ok), 02-Фев-21, 00:47 
А использовать requirements, который присутсвует в гите, религия не позволяет?
Ответить | Правка | Наверх | Cообщить модератору

26. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от An O Nim (?), 02-Фев-21, 09:02 
Так у автора тезис: Пип - помойка.

Так и есть, в Пипе много отбросов. Увы.

Низкий порог входа дал много мусора. Вероятно.

Своё под ключ писать нормально, а вот чужое переиспользовать просто так нельзя, нужно разбираться в сортах.

Ответить | Правка | Наверх | Cообщить модератору

11. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +2 +/
Сообщение от Аноним (6), 02-Фев-21, 00:47 
Кончено же не ставят. Нормальные люди знают про venv. В одну команду ставится, с минимумом затрат, как и всегда.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

13. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (13), 02-Фев-21, 00:51 
Тот же мусор только чуть более локализованный.
Ответить | Правка | Наверх | Cообщить модератору

14. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (14), 02-Фев-21, 00:53 
Что и требовалось доказать. У питона как всегда всё через одно место.
Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

17. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (15), 02-Фев-21, 00:58 
Что доказать-то? Мы доказали что в твоём дистрибутиве spacy не опакечен из коробки, что является проблема исключительно твоего говённого дистрибутива. Но даже для таких питон позволяет установить spacy одной командой своими средствами. Что тебе не нравится?
Ответить | Правка | Наверх | Cообщить модератору

65. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (65), 03-Фев-21, 11:08 
У него NIH syndrome.
Ответить | Правка | Наверх | Cообщить модератору

35. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (7), 02-Фев-21, 09:57 
Venv, pipenv, poetry - для смузихлёбных карго-культистов - фанатов докера и снапа.
Ответить | Правка | К родителю #11 | Наверх | Cообщить модератору

41. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (6), 02-Фев-21, 10:57 
Только virtualenv, только хардкор? Просто venv штатный механизм, и остальные нет. Подобная изоляция довольно удобна, мне например нужны определённые версии для определённых проектов. И для разработки зачастую нужны предрелизные версии, либо старые версии как зависимости, у тебя вариант или копировать из гитхаба руками или использовать pip, но в любом случае без "песочницы" ты засрёшь батарейками всю систему, и в итоге ничего работать не будет.
Ответить | Правка | Наверх | Cообщить модератору

59. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (59), 03-Фев-21, 01:31 
Доверься мне.

python3 -m build -nwx
sudo pip3 install --upgrade ./dist/*whl

И никаких проблем.

Ответить | Правка | Наверх | Cообщить модератору

60. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (59), 03-Фев-21, 01:33 
>засрёшь батарейками всю систему, и в итоге ничего работать не будет.

Только /usr/local/python3*/dist-packages/. Она для этого и предназначена, вообде-то.

Ответить | Правка | К родителю #41 | Наверх | Cообщить модератору

64. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (6), 03-Фев-21, 11:04 
>>засрёшь батарейками всю систему, и в итоге ничего работать не будет.
> Только /usr/local/python3*/dist-packages/. Она для этого и предназначена, вообде-то.

Там не будет никакого разделения. Типичный хелловорлд имеет под тысячу зависимостей и они будут блокировать часть обновлений (как минимум), либо сломаются, если ты всё-таки обновишь. Вот допустим 900 пакетов из этой тысячи можно обновить спокойно, но 2 пакета (временно) блокируют тебе оставшиеся. Но они могут не использоваться в соседнем проекте, где при этом используются те 98 блокированных пакетов вместе с теми 900.

Ответить | Правка | Наверх | Cообщить модератору

16. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –2 +/
Сообщение от Аноним (15), 02-Фев-21, 00:56 
Что за чушь, ставится одной командой из родной репы дистрибутива:

https://repology.org/project/python:spacy/versions

Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

23. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –1 +/
Сообщение от Аноним (23), 02-Фев-21, 08:51 
Напиши ебылд для нормального дистра.
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

30. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  –2 +/
Сообщение от bergentroll (ok), 02-Фев-21, 09:32 
Я прошу прощения, а что для вас образец хорошего, чтоб не мусор?
Ответить | Правка | К родителю #9 | Наверх | Cообщить модератору

25. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (28), 02-Фев-21, 09:00 
Что же она такая медленная?... Даже в сравнении с OpenNLP
Ответить | Правка | Наверх | Cообщить модератору

29. Скрыто модератором  –2 +/
Сообщение от Аноним12345 (?), 02-Фев-21, 09:28 
Ответить | Правка | Наверх | Cообщить модератору

36. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (7), 02-Фев-21, 10:02 
Нет поддержки i686 - значит либа не нужна.
Ответить | Правка | Наверх | Cообщить модератору

46. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +1 +/
Сообщение от Аноним (46), 02-Фев-21, 11:49 
i686 уже не нужен.
Ответить | Правка | Наверх | Cообщить модератору

62. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (65), 03-Фев-21, 10:53 
NLP на i686 - это несерьезно.
Ответить | Правка | К родителю #36 | Наверх | Cообщить модератору

68. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (68), 05-Фев-21, 10:46 
>NLP на не суперкомпьютере - это несерьезно.

Пофиксил. Если нужно серьёзно - то это к майкрософту, гуглу, яндексу и сберу и ещё нескольким компаниям. Всё остальное несерьёзно.

Ответить | Правка | Наверх | Cообщить модератору

51. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (51), 02-Фев-21, 13:38 
Ждем реализации на нормальном языке без зависимостей и блотвари. Прототипы и концепты это не показатель и уж точно не принимо.
Ответить | Правка | Наверх | Cообщить модератору

58. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от COBA (?), 02-Фев-21, 23:15 
Вопрос только в том - для чего ждать?
Ответить | Правка | Наверх | Cообщить модератору

66. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (66), 03-Фев-21, 15:31 
Ну вот когда будет хоть какие-либо бенчмарки проходить - подумаем о применении.
Ответить | Правка | Наверх | Cообщить модератору

63. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (65), 03-Фев-21, 11:02 
>Языковые модели подготовлены для 58 языков

В новости же сказано по 59 моделей для 18 языков: "spaCy v3.0 provides retrained model families for 18 languages and 59 trained pipelines in total".

Ответить | Правка | Наверх | Cообщить модератору

67. "Выпуск spaCy 3.0, библиотеки для обработки информации на ест..."  +/
Сообщение от Аноним (67), 03-Фев-21, 23:48 
Не такой уж и постоянный у них API. Внутри меняются алгоритмы и от версии к версии эта поделка дает разный результат. Требуется корректировка моделей. Или привязку к версии, но старые версии они грохают со своего варезника ибо EoL.
В долгосрочной перспективе - так себе либа. Но для наколенных поделок, чтобы работало с понедельника и до обеда - вполне зачетно.
Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Ideco
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру