The OpenNET Project / Index page

[ новости/++ | форум | wiki | теги ]



"Опубликован план прекращения поддержки Python 2 в NumPy "
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от opennews (??) on 16-Ноя-17, 09:55 
Разработчики NumPy (http://www.numpy.org/), библиотеки для научных вычислений, ориентированной на работу с многомерными массивами, представили (https://github.com/numpy/numpy/blob/master/doc/neps/dropping...) план прекращения поддержки Python 2.  Начиная с 2010 года NumPy параллельно поддерживает ветки для Python 2 и Python 3. Полноценное развитие обеих веток будет производиться до 31 декабря 2018 года, после чего новые возможности будут добавляться только в ветку для Python 3, а в ветке для Python 2 будут только исправляться ошибки.

Выпуск обновлений с исправлениями к ветке NumPy для Python 2 будет осуществляться сообществом до 31 декабря 2019 года,  после чего возможность дальнейшей поддержки будет зависеть от активности лиц, заинтересованных в продолжении использования  Python 2. Напомним, что поддержка Python 2.7 будет прекращена (http://legacy.python.org/dev/peps/pep-0373/) сообществом разработчиков языка Python в 2020 году.

URL: https://github.com/numpy/numpy/blob/master/doc/neps/dropping...
Новость: https://www.opennet.ru/opennews/art.shtml?num=47576

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 09:55 
И всеравно маргиналы остануться кто двойкой будет пользоваться не потому что их прижал легаси, а потому что они не хотят ничего нового...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Опубликован план прекращения поддержки Python 2 в NumPy "  +2 +/
Сообщение от бедный буратино (ok) on 16-Ноя-17, 09:59 
>  И всеравно маргиналы остануться кто двойкой будет пользоваться не потому что их прижал легаси, а потому что они не хотят ничего нового...

именно. в python 2 нет проблемы, какая версия у пользователя, 3.3 или 3.6, и какие из фич там есть

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

4. "Опубликован план прекращения поддержки Python 2 в NumPy "  +14 +/
Сообщение от Аноним (??) on 16-Ноя-17, 10:00 
"Ловите некроманта!"
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

22. "Опубликован план прекращения поддержки Python 2 в NumPy "  +2 +/
Сообщение от Аноним (??) on 16-Ноя-17, 15:16 
Ну попробуй код для 2.7 исполнить в, например, 2.1
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

29. "Опубликован план прекращения поддержки Python 2 в NumPy "  +3 +/
Сообщение от бедный буратино (ok) on 16-Ноя-17, 16:31 
Python 2.7 в Debian появился в Debian Wheezy, это 2013 год. В OpenBSD он появился в 5.0, это 1 ноября 2011 года. Так что даже на системах, где давно ничего не пенялось, скорее всего именно python 2.7
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

36. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 18:15 
В SLES писал скрипты для 2.6  Python полгода назад, потому что работает - не трогай(
Хотелось расстрелять менеджеров
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

43. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 20:59 
>> В SLES писал скрипты для 2.6  Python полгода назад,

Но зачем, если родные скрипты для него должны быть написаны на Ruby?....

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

47. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от asand3r on 16-Ноя-17, 21:20 
Буквально позавчера помогал китайцу настроить Zabbix-in-Telegram на каком-то RedHat с Python 2.6.6.
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

57. "Опубликован план прекращения поддержки Python 2 в NumPy "  –1 +/
Сообщение от Аноним (??) on 17-Ноя-17, 14:28 
> Python 2.7 в Debian появился в Debian Wheezy, это 2013 год. В
> OpenBSD он появился в 5.0, это 1 ноября 2011 года. Так
> что даже на системах, где давно ничего не пенялось, скорее всего
> именно python 2.7

На самом деле решение проблемы очень простое. Нужна петиция за создание официальной репы на python.org для всех более менее популярных и перечисленных дистрибутивов, ну а если используют какие-то экзотические системы вроде NetBSD, то я подозреваю, что там люди обладают нужным уровнем квалификации, что бы выполнить ./configure, make, make install или как там в NetBSD это принято делать в какой-то специальной директории или специальным скриптом.

А для любителей-некромантов нужна просто кнопка помогите мне собрать питон для дистрибутива, который уже не поддерживается скажем за 25 долларов (как это умело делает сейчас RedHat).

Хотя конечно сейчас скажут про дистрибутивы которые в офлайн или не имеют диска и т.д. Я думаю, что если система устарела, то нужно ее заменить на новую, а не подпитывать полудохлые системы. Впрочем я думаю, что тут должно пройти поколение людей что бы бородатые админы сменились молодыми и амбициозными с мотивацией что-то менять ...

Я только не пойму в чем проблема все это сделать? Не умеют ставить repropro ?

Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

61. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от XoRe (ok) on 18-Ноя-17, 00:31 
> Впрочем я
> думаю, что тут должно пройти поколение людей что бы бородатые админы
> сменились молодыми и амбициозными с мотивацией что-то менять ...

Вот вы молоды и амбициозны? Ну так поменяйте)

Ответить | Правка | ^ к родителю #57 | Наверх | Cообщить модератору

34. "Опубликован план прекращения поддержки Python 2 в NumPy "  +4 +/
Сообщение от Онаним on 16-Ноя-17, 17:48 
А какие фичи из 3.3 отсутствуют в 3.6?
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

56. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 17-Ноя-17, 14:19 
Ну например одна из самых главных async/await
Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

26. "Опубликован план прекращения поддержки Python 2 в NumPy "  –3 +/
Сообщение от _hide_ (ok) on 16-Ноя-17, 16:15 
Не все хотят докупать оборудование, чтобы новый питон в продакшен загнать. Админы локалхоста рулят :-)
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

40. "Опубликован план прекращения поддержки Python 2 в NumPy "  +2 +/
Сообщение от Аноним (??) on 16-Ноя-17, 20:38 
Докупать? 3.x вообще производительнее из коробки.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

54. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от vit (??) on 17-Ноя-17, 08:12 
увы но старт до сих пор медленнее
Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

58. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 17-Ноя-17, 14:30 
> увы но старт до сих пор медленнее

Наблюдаю ровно противоположную картину. Старт системы на 3 змее гораздо более быстрее происходит чем на 2. Возможно проблема в использовании каких-то старых устаревших ситсем или библиотек.

Ответить | Правка | ^ к родителю #54 | Наверх | Cообщить модератору

45. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от Аноним (??) on 16-Ноя-17, 21:15 
У меня питон 3.7 на третьем пне крутится с 256 мегами, а ты мне тут такую пургу гонишь.
Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

55. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от бедный буратино (ok) on 17-Ноя-17, 08:51 
> У меня питон 3.7 на третьем пне крутится с 256 мегами, а
> ты мне тут такую пургу гонишь.

У меня и клиент и сервер на python 2 крутились на p150/24 под OpenBSD :)

Когда следующий свой веб-проект опубликую, дам доступ к нему на p2-400/64. Хотел сначала на p133/32, но там почему-то иногда (и не только в OpenBSD) скорость сети в pcmcia-сетевухе падает до 40 байт в секунду :(

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

60. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Necro Mancer on 17-Ноя-17, 16:51 
> У меня и клиент и сервер на python 2 крутились на p150/24 под OpenBSD :)

Неплохо!
...
> Хотел сначала на p133/32, но там почему-то иногда (и не только в
> OpenBSD) скорость сети в pcmcia-сетевухе падает до 40 байт в секунду :(

Вот как заработает, так и получите магистра! А пока оттачивайте ваше искуство.

Представитель Ковена

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

59. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 17-Ноя-17, 14:34 
> Не все хотят докупать оборудование, чтобы новый питон в продакшен загнать. Админы
> локалхоста рулят :-)

Дело не в докупании железа сейчас вроде как с железом особенно проблем нет. Системники не такие и дорогие для средней компании это не проблема, а вот организовать процесс разработки особенно когда уже система запущена, а подрядчик давно склеил ласты или руководство подумало, что ну а чего платить когда можно не платить ...

Так вы это значете что я думаю, что вы решаете не свою проблему. Если Вы админ идете к руководителю и говорите так и так вы вот бл% решили экономить, так что пока не поздно и до отказа от питона2 не произошлов 2020 году начинайте переделывать систему на третий питтон восстанавливайте контракты с подрядчиком и т/д/

А можете стать геройским героем за три копейки продолжая собирать второй питон из исходников и получая за это поглаживание по спинке от начальника который на экономию от ИТ отдела купит себе еще один крузак а вам будет ссать в глаза ...

Как же все это омерзительно////

Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

33. "Опубликован план прекращения поддержки Python 2 в NumPy "  –2 +/
Сообщение от Потомок изобретателя колеса on 16-Ноя-17, 16:44 
Кожен москаль повинэн знаты паскаль, а хохлы уси пишуть на Си
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

2. "Опубликован план прекращения поддержки Python 2 в NumPy "  –1 +/
Сообщение от Аноним (??) on 16-Ноя-17, 09:56 
Ок.

красношляпым вопрос, кто-нибудь может объяснить, для чего в федоре и центоси7 пакеты с 3м питоном именуются по-разному? в федоре есть python3, в центоси есть python34. И зависимости в пакетах и спеках соответствующим образом прописаны. Для чего так неодинаково?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от mumu (ok) on 16-Ноя-17, 10:05 
очевидно для того, чтобы держать несколько разных версий в одной системе.
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

9. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от Аноним (??) on 16-Ноя-17, 11:16 
Странное у вас "очевидно". Вопрос в том, почему по-разному то? Да на здоровье, пусть бы федоре были python34 python36 python38 а в центосе python34 только. Но нет! Надо сделать криво - в феде python3, в центе python34
Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

11. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 12:26 
не пользуйтесь питоном. вот и весь ответ :)
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

19. "Опубликован план прекращения поддержки Python 2 в NumPy "  +2 +/
Сообщение от Аноним (??) on 16-Ноя-17, 13:39 
> не пользуйтесь питоном

А также федорой.

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

21. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 14:56 
>> не пользуйтесь питоном
> А также федорой.

А лучше всего - компьютером.


Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

13. "Опубликован план прекращения поддержки Python 2 в NumPy "  –2 +/
Сообщение от Neptus on 16-Ноя-17, 12:29 
В Федоре вызывается, 'Python3' - общий случай. И 'Python3.6' (или дополнительные) уже конкретно.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

15. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 12:40 
я про зависимости. Вот софт, у него builddependencies стоит python3-devel. И для пересборки под центом надо делаь %if ?0rhel python34-devel . Ну тупость же.
Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

31. "Опубликован план прекращения поддержки Python 2 в NumPy "  –1 +/
Сообщение от бедный буратино (ok) on 16-Ноя-17, 16:37 
кто его знает, какой python будет через 10 лет, то ли 3.29, то ли 7.0

а в федоре есть только одна версия - последнее, и если что-нибудь отвалится. невелика беда

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

37. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 18:58 
Вопрос был к знающим ПОЧЕМУ это так. Т.е. тем, что в курсе обоих проектов и объяснит эту несуразицу. Не надо пытаться ответить там, где не компетентен, это выглядит странно. Не знаешь - промолчи. Поставь минус, если хочешь.

Да я хотел бы получить ответ от людей это сделавших или каким-то боком причастных, например "сорян, так получилось". или "есть глубокий смысл в том-то и там-то".

Ответить | Правка | ^ к родителю #31 | Наверх | Cообщить модератору

38. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от бедный буратино (ok) on 16-Ноя-17, 19:23 
и какая буква в ответе тебе непонятна?
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

51. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от mumu (ok) on 16-Ноя-17, 23:22 
Одно для серверов и там нужна стабильность и переносимость на протяжении всего жизненного цикла и даже по его окончании. Второе вечная альфа для ноутбуков, там нужно чтобы работала только последняя версия. Неужели это нужно разжевывать?
Ответить | Правка | ^ к родителю #37 | Наверх | Cообщить модератору

53. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 17-Ноя-17, 06:54 
Нужно, логики нет. Они что, не знают про метапакеты? Ломают совместимость на пустом месте... никто не мешало положить python3 в rhel\centos
Ответить | Правка | ^ к родителю #51 | Наверх | Cообщить модератору

41. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Онаним on 16-Ноя-17, 20:44 
Python 3.4. OMG.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

6. "Опубликован план прекращения поддержки Python 2 в NumPy "  –2 +/
Сообщение от Аноним (??) on 16-Ноя-17, 10:11 
Думаю, сначала следовало бы опубликовать план разработки концепции прекращения поддержки. Без этого получается скоропалительное решение, с кондачка.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

42. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Онаним on 16-Ноя-17, 20:46 
> Думаю, сначала следовало бы опубликовать план разработки концепции прекращения поддержки.
> Без этого получается скоропалительное решение, с кондачка.

Поддержку никто пока не прекращает, прекращают развитие legacy-ветки. И наверняка некоторые важные вещи всё-равно будут добавляться.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

7. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от yet another anonymous on 16-Ноя-17, 10:54 
Полетит генерация документации в Mesa, всякие преобразования в fonttools.

Если речь пойдет о "убрать python2 в пользу python3" --- идите адаптируйте asciidoc.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Опубликован план прекращения поддержки Python 2 в NumPy "  +5 +/
Сообщение от iv on 16-Ноя-17, 11:03 
Генерация документации Mesa использует NumPy? Cуровые у них там доки...
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

10. "Опубликован план прекращения поддержки Python 2 в NumPy "  –2 +/
Сообщение от yet another anonymous on 16-Ноя-17, 12:13 
Это приходит от всяких markup crap. Питонячьи петли зависимостей --- это что-то.

Принципы питонного сообщества тоже оригинальные: огромная туча модулей --- это в основном C с тонюсенькой обёрткой в питон.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

52. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 17-Ноя-17, 02:29 
Конвертация не проблема. Основная проблема - это гумнокод профнепригодных, который обычно встречается в проектах для python 2. Профпригодные давно обеспечили совместимость с 3шкой.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

12. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 12:29 
Не проще ли вообще не использовать NumPy с питоном, а сразу писать на современных языках типа Julia и не иметь проблем ни с производительностью, ни с совместимостью?....
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

14. "Опубликован план прекращения поддержки Python 2 в NumPy "  –1 +/
Сообщение от trolleybus email on 16-Ноя-17, 12:38 
Julia как бы еще не 1.0 даже, поэтому от проблем с совместимостью не застрахован никто
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

16. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Neptus on 16-Ноя-17, 12:45 
> Не проще ли вообще не использовать NumPy с питоном, а сразу писать
> на современных языках типа Julia и не иметь проблем ни с
> производительностью, ни с совместимостью?....

А что, уже появилась хоть нормальная версия. Пока даже не полуверсия...

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

17. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Neptus on 16-Ноя-17, 12:46 

> А что, уже появилась хоть нормальная версия. Пока даже не полуверсия...

Влепились лишние строки....

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

24. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от Аноним (??) on 16-Ноя-17, 15:22 
Python, в отличие от Julia, самодостаточный, не зависит от всяких LLVMов
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

44. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 21:00 
> Python, в отличие от Julia, самодостаточный, не зависит от всяких LLVMов

Это какой из его диалектов и версий самодостаточен?

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

27. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 16:21 
Not mature yet.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

49. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 21:25 
julia - это с питоном и рядом не стояла. Списана с матлаба и настолько же отвратительна.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

18. "Опубликован план прекращения поддержки Python 2 в NumPy "  +3 +/
Сообщение от Мозг email on 16-Ноя-17, 12:46 
Хватит откапывать уже стюардессу. Тройка уже десять лет как вышла, а вы все с двойкой мучаетесь.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "Опубликован план прекращения поддержки Python 2 в NumPy "  +2 +/
Сообщение от 1 (??) on 16-Ноя-17, 14:05 
Это ВЫ с 3-кой мучаетесь.
В 2ке всё работает.
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

23. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от Py3 on 16-Ноя-17, 15:18 
И будет работать!
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

25. "Опубликован план прекращения поддержки Python 2 в NumPy "  +6 +/
Сообщение от th3m3 (ok) on 16-Ноя-17, 15:23 
Всё работает? Ничего, скоро NumPy перестанет работать :) И такого будет всё больше.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

32. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от trolleybus email on 16-Ноя-17, 16:37 
В 3-ке уже тоже давно все работает (как минимум, все, что нужно)
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

35. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от vakorol on 16-Ноя-17, 18:15 
Я с тройкой не мучаюсь - там всё работает. Ни разу не было проблем ни с поддержкой модулей, ни с чем-то другим.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

28. "Опубликован план прекращения поддержки Python 2 в NumPy "  +/
Сообщение от Аноним (??) on 16-Ноя-17, 16:23 
В 2020 грянет гром, видать и что-то начнёт меняться.
Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

30. "Опубликован план прекращения поддержки Python 2 в NumPy "  +1 +/
Сообщение от бедный буратино (ok) on 16-Ноя-17, 16:32 
> В 2020 грянет гром, видать и что-то начнёт меняться.

Исходные коды превратятся в тыкву? :)

Ответить | Правка | ^ к родителю #28 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема


  Закладки на сайте
  Проследить за страницей
Created 1996-2017 by Maxim Chirkov  
ДобавитьРекламаВебмастеруГИД  
Hosting by Ihor