mkfs - construct a file system
mkfs [-F FSType] [generic_options] [-o FSType-specific_options] raw_device_file [operands]
The mkfs utility constructs a file system on the raw_device_file by calling the specific mkfs module indicated by -F FSType.
Note: ufs file systems are normally created with the newfs(1M) command.
generic_options are independent of file system type. FSType-specific_options is a comma-separated list of keyword=value pairs (with no intervening spaces), which are FSType-specific. raw_device_file specifies the disk partition on which to write the file system. It is required and must be the first argument following the specific_options (if any). operands are FSType-specific. See the FSType-specific manual page of mkfs (for example, mkfs_ufs (1M)) for a detailed description.
The following are the generic options for mkfs:
See largefile(5) for the description of the behavior of mkfs when encountering files greater than or equal to 2 Gbyte ( 2^31 bytes).
See attributes(5) for descriptions of the following attributes:
mkfs_ufs(1M), newfs(1M), vfstab(4), attributes(5), largefile(5)
Manual pages for the FSType-specific modules of mkfs.
This command might not be supported for all FSTypes.
You can use lofiadm to create a file that appears to a mkfs command as a raw device. You can then use a mkfs command to create a file system on that device. See lofiadm(1M) for examples of creating a UFS and a PC (FAT) file system (using mkfs_ufs(1M) and mkfs_pcfs(1M)) on a device created by lofiadm.
Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру