The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Установка пакетов в PHP 5"
Вариант для распечатки  
Пред. тема | След. тема 
Форум WEB технологии (PHP)
Изначальное сообщение [ Отслеживать ]

"Установка пакетов в PHP 5"  +/
Сообщение от shumsan email(ok) on 21-Июн-12, 18:22 
Здравствуйте!
Очень сожалею что приходится обращаться с таким глупым вопросом, но нигде не нашел ответа.
Есть веб-сервер с множеством сайтов, один из клиентов захотел поставить UMI.CMS.
В ходе установки UMI ругается на то что в системе не установлен пакет xsl

Я делаю:
##############
root@web:/# aptitude install php5-xsl
Следующие НОВЫЕ пакеты будут установлены:
  php5-xsl
Следующие пакеты будут обновлены:
  php5-common
1 пакетов обновлено, 1 установлено новых, 0 пакетов отмечено для удаления, и 50 пакетов не обновлено.
Необходимо получить 563 kB архивов. После распаковки 65,5 kB будет занято.
Следующие пакеты имеют неудовлетворённые зависимости:
  libapache2-mod-php5: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-gd: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-curl: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-mcrypt: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-imap: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-mysql: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-cgi: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
  php5-cli: Зависит: php5-common (= 5.3.3-7+squeeze1) но устанавливается 5.3.3-7+squeeze3.
Следующие действия разрешат зависимости:

      Удалить следующие пакеты:
1)      libapache2-mod-php5
2)      libapache2-mod-suphp
3)      php-apc
4)      php-auth
5)      php-pear
6)      php5
7)      php5-cgi
8)      php5-cli
9)      php5-curl
10)     php5-gd
11)     php5-imagick
12)     php5-imap
13)     php5-mcrypt
14)     php5-mysql
15)     php5-suhosin
16)     phpmyadmin
17)     suphp-common
      Сохранить для следующих пакетов их текущие версии:
18)     php5-xsl [Не установлен]
Принять данное решение? [Y/n/q/?] n
############

Сам вопрос: при установке пакета xsl, пакеты что идут под 1-17 пунктом будут УДАЛЕНЫ или это только РЕКОМЕНДУЕТСЯ их потом удалить самостоятельно?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Установка пакетов в PHP 5"  +/
Сообщение от zcasper email on 21-Июн-12, 18:34 
>[оверквотинг удален]
> 15)     php5-suhosin
> 16)     phpmyadmin
> 17)     suphp-common
>       Сохранить для следующих пакетов их текущие
> версии:
> 18)     php5-xsl [Не установлен]
> Принять данное решение? [Y/n/q/?] n
> ############
> Сам вопрос: при установке пакета xsl, пакеты что идут под 1-17 пунктом
> будут УДАЛЕНЫ или это только РЕКОМЕНДУЕТСЯ их потом удалить самостоятельно?

Да они удаляться, попробуй сперва обновить эти 17,  потом устанавливать уже.

Вообще странно, ругается он на php5-common но в списке на удаление его нет, могу предположить пару вариантов:

1 - у тебя разношерстные репозитарии, которые не смогли между собой объедениться.
2 - какие-то из установленных пакетов из ветки devel или non-stable
3 - пакет  5.3.3-7+squeeze3 или php5-common отсутствуют в репозитарии

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Установка пакетов в PHP 5"  +/
Сообщение от shumsan email(ok) on 21-Июн-12, 18:58 
Спасибо большое!
Соответственно вопрос - как сделать удаление/установку всего этого нового набора пакетам с наименьшими затратами?
Или легче поднять новую виртуалку-веб-сервер?:)

Я опасаюсь неработоспособности сайтов с вновь установленными пакетами.

>[оверквотинг удален]
>> Принять данное решение? [Y/n/q/?] n
>> ############
>> Сам вопрос: при установке пакета xsl, пакеты что идут под 1-17 пунктом
>> будут УДАЛЕНЫ или это только РЕКОМЕНДУЕТСЯ их потом удалить самостоятельно?
> Да они удаляться, попробуй сперва обновить эти 17,  потом устанавливать уже.
> Вообще странно, ругается он на php5-common но в списке на удаление его
> нет, могу предположить пару вариантов:
> 1 - у тебя разношерстные репозитарии, которые не смогли между собой объедениться.
> 2 - какие-то из установленных пакетов из ветки devel или non-stable
> 3 - пакет  5.3.3-7+squeeze3 или php5-common отсутствуют в репозитарии

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Установка пакетов в PHP 5"  +/
Сообщение от LSTemp (ok) on 26-Июн-12, 02:05 
> Спасибо большое!
> Соответственно вопрос - как сделать удаление/установку всего этого нового набора пакетам
> с наименьшими затратами?
> Или легче поднять новую виртуалку-веб-сервер?:)
> Я опасаюсь неработоспособности сайтов с вновь установленными пакетами.

- отключаешь все репозитории, кроме офф
- обновляеш ОС (чего ты не делал видимо оч давно)
- чекаешь , как все работает после обновления
- добавляешь нужный функционал

(или просто забиваешь на все и из сырцов собираешь, что тебе нужно)

PS
я бы послал этого клиента с такими запросами, куда все русские всех без разбора посылают. Вы что, хостинг-пров, чтоб под каждую блоху танцевать? - Левшей не наберетесь.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Установка пакетов в PHP 5"  +/
Сообщение от shumsan email(ok) on 26-Июн-12, 06:24 
>[оверквотинг удален]
>> Я опасаюсь неработоспособности сайтов с вновь установленными пакетами.
> - отключаешь все репозитории, кроме офф
> - обновляеш ОС (чего ты не делал видимо оч давно)
> - чекаешь , как все работает после обновления
> - добавляешь нужный функционал
> (или просто забиваешь на все и из сырцов собираешь, что тебе нужно)
> PS
> я бы послал этого клиента с такими запросами, куда все русские всех
> без разбора посылают. Вы что, хостинг-пров, чтоб под каждую блоху танцевать?
> - Левшей не наберетесь.

Спасибо! Как-раз таки я и есть хостинг-провайдер, так что придется танцевать:)
А что если просто обновить все что касается php? Или обновление только php потянет за собой обновление всей системы в целом?

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Установка пакетов в PHP 5"  +/
Сообщение от LSTemp (ok) on 28-Июн-12, 03:28 
>[оверквотинг удален]
>> - чекаешь , как все работает после обновления
>> - добавляешь нужный функционал
>> (или просто забиваешь на все и из сырцов собираешь, что тебе нужно)
>> PS
>> я бы послал этого клиента с такими запросами, куда все русские всех
>> без разбора посылают. Вы что, хостинг-пров, чтоб под каждую блоху танцевать?
>> - Левшей не наберетесь.
> Спасибо! Как-раз таки я и есть хостинг-провайдер, так что придется танцевать:)
> А что если просто обновить все что касается php? Или обновление только
> php потянет за собой обновление всей системы в целом?

нет. только зависимые пакеты. в которые могут войти (в том числе) системные библиотеки. что в свою очередь потребует обновление системного софта под эти новые библиотеки итд. а так - нет.

танцевать под каждого индивидуально не советую - даже если их всего 10-ть будет. умаетесь. сегодня один клиент хочет одно, завтра другое, потом третье, а потом оказывается что его хотения вступают в конфликт с хотениями клиента 2-а, а их у Вас 10. через месяц повеситесь. определите для себя какие услуги в каком виде и с каким сервисом обслуживания Вы можете оказывать - от этого и отталкивайтесь.

разберитесь со своим менеджером пакетов в конце-то концов. он же тем более все по русски Вам пишет.


Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Установка пакетов в PHP 5"  +/
Сообщение от chivan (ok) on 09-Июл-12, 20:01 
Мда. Сложно. Но изучать надо. Скоро все на нем будем.

http://22shop.ru/item/12124/supra-stv-lc1626w/

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Установка пакетов в PHP 5"  +/
Сообщение от Roma25 email(ok) on 10-Июл-12, 20:40 
Есть компания где Вам сотрудники помогут в этом!
http://www.voda-st.ru/price


Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру