The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Глюк апачи, или ошибка в настройках?"
Вариант для распечатки Архивированная нить - только для чтения! 
Пред. тема | След. тема 
Форумы WEB технологии (Public)
Изначальное сообщение [Проследить за развитием треда]

"Глюк апачи, или ошибка в настройках?"
Сообщение от bugol Искать по авторуВ закладки on 22-Мрт-01, 19:12  (MSK)
Есть перловый скрипт который принимает файл от юзера и пишет его на диск, файл - это картинка.
Дело в том что на некоторых серверах все работает прекрасно, а на некоторых картинка изменяется,
я использую CGI.pm и как-то перехватил временный файл который он создает при закачке извне. Там все символы 0x00 заменены на 0x20, я незнаю даже куда лезть чтоб найти в чем дело %((
  Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "RE: Глюк апачи, или ошибка в настройках?"
Сообщение от Dima emailИскать по авторуВ закладки on 13-Апр-01, 06:31  (MSK)
Возможно была проблема то что с униховых машин все нормально а с виндовых да еще и с кодировкой 1251
да на русский Апач ;)
он перекодирует все и ложит кривой файл в директорию (я отключал это), но тогда перекодировка вообще не работала и гнала страници такие что смотреть невозможно было
Если подвести итог, связано все было с кодовой страницей
  Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "RE: Глюк апачи, или ошибка в настройках?"
Сообщение от Maxim Chirkov Искать по авторуВ закладки on 13-Апр-01, 11:58  (MSK)
https://www.opennet.ru/base/dev/http_bin.txt.html
  Рекомендовать в FAQ | Cообщить модератору | Наверх


Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру