The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]



"Как принять мультикаст на Cisco 3750E"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Как принять мультикаст на Cisco 3750E"  +/
Сообщение от TheUrartu (ok), 21-Окт-21, 04:50 
Доброго времени суток.
Есть Cisco 3750E, к 6-и портам  подключены IP стримеры, которые между собой передают мультикаст.
Вот конфиг

Building configuration...

Current configuration : 5104 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname stream
!
boot-start-marker
boot-end-marker
!
enable password 7 023C010B585B5838441E
!
username stream privilege 15 secret 5 $1$Vyvo$t/vWoFpgvll6W1bHnYv/N1
!
!
aaa new-model
!
!
aaa authentication login default local
!
!
!
aaa session-id common
switch 3 provision ws-c3750e-24td
system mtu routing 1500
!
!
no ip domain-lookup
ip domain-name e3750.local
ip multicast-routing distributed
ip igmp snooping querier
ip igmp snooping vlan 2 querier address 10.2.2.2
ip igmp snooping vlan 255 querier address 10.255.255.255
ip igmp profile 1
permit
range 239.2.0.0 239.255.255.255
ip igmp profile 200
permit
range 239.255.0.1 239.255.0.250
ip igmp profile 255
permit
range 239.255.0.0 239.255.255.255
!
!
crypto pki trustpoint TP-self-signed-1731329792
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-1731329792
revocation-check none
rsakeypair TP-self-signed-1731329792
!
!
crypto pki certificate chain TP-self-signed-1731329792
certificate self-signed 01
3082024A 308201B3 A0030201 02020101 300D0609 2A864886 F70D0101 04050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 31373331 33323937 3932301E 170D3933 30333031 30303031
31365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D31 37333133
32393739 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100941E 22BFF34B 7EB76B04 13D570F8 5DB28037 9E3B23CA FF50E60F FA9C8C9B
015037EB 7D083595 AAF06F90 872FAAA3 037E2BD0 6C655B33 79F3C486 8FF9EE61
3AA1B71C 0B3FC852 01D39D3C FF3C26AE C22B985D FEB329B6 F59EEE0B E410E1DA
C79B0FA3 17A290E5 588B4E60 4E0E1EA0 99E7B1AE 81381E42 C3A62D40 5E933A47
C3AF0203 010001A3 72307030 0F060355 1D130101 FF040530 030101FF 301D0603
551D1104 16301482 12737472 65616D2E 65333735 302E6C6F 63616C30 1F060355
1D230418 30168014 329B1524 F474AB7F 4D211895 5AC5432F 72EBFDFD 301D0603
551D0E04 16041432 9B1524F4 74AB7F4D 2118955A C5432F72 EBFDFD30 0D06092A
864886F7 0D010104 05000381 81003F6E 5DDB52BF 73C51BB5 071B7B84 4717E21E
A73FB055 43579190 A952C9BE 213C005B CE996AFE E821D3D7 E02B0A17 2A477A1D
3BB00AAA DA73D666 17FAEB83 0D86C6C7 E2B98CD2 709EAEED 7D38B37A D936F47C
D0DBC067 22363283 D3185DDA F502DCD2 7F79C1BF C108E504 3468B640 7C3F204B
650650B9 7A6BEE4A A137A2DF 7C4E
quit
spanning-tree mode pvst
spanning-tree extend system-id
!
!
!
no errdisable detect cause gbic-invalid
no errdisable detect cause sfp-config-mismatch
errdisable recovery cause gbic-invalid
!
vlan internal allocation policy ascending
!
ip ssh version 2
!
!
interface FastEthernet0
ip address 192.168.88.50 255.255.255.0
!
interface GigabitEthernet3/0/1
switchport access vlan 2
ip igmp filter 1
!
interface GigabitEthernet3/0/2
switchport access vlan 2
ip igmp filter 1
!
interface GigabitEthernet3/0/3
switchport access vlan 2
ip igmp filter 1
!
interface GigabitEthernet3/0/4
switchport access vlan 2
ip igmp filter 2
!
interface GigabitEthernet3/0/5
switchport access vlan 2
ip igmp filter 2
!
interface GigabitEthernet3/0/6
switchport access vlan 2
ip igmp filter 2
.
Теперь есть задача, принять мультикаст от оператора.
Оператор для настройки порта дал следующие параметры
ip - 10.1.52.218-10.1.52.222

mask 255.255.255.248
gw 10.1.52.217
multicast IP 239.255.0.151:5500
Сказали, что гетвей обязателен, я сейчас принимаю стрим на сервере под ubuntu, и отправляю на Cisco, во влан 2.
Вот конфиг интерфейса на Ubuntu 

address 10.1.52.218
netmask 255.255.255.248
gateway 10.1.52.217
Все работает, но я хочу стрим принять прямо на Cisco, подскажите пожалуйста, возможно ли принять на Cisco 3750, если требуется гетвей, и если да, как это реализовать.
Заранее спасибо


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения [Сортировка по времени | RSS]


1. "Как принять мультикаст на Cisco 3750E"  +/
Сообщение от eek (ok), 21-Окт-21, 17:15 
> Все работает, но я хочу стрим принять прямо на Cisco,

Вот с этого места не понятно.

Что конкретно хотите получить в результате, если уже все работает?

Ответить | Правка | Наверх | Cообщить модератору

2. "Как принять мультикаст на Cisco 3750E"  +/
Сообщение от TheUrartu (ok), 22-Окт-21, 15:03 
>> Все работает, но я хочу стрим принять прямо на Cisco,
> Вот с этого места не понятно.
> Что конкретно хотите получить в результате, если уже все работает?

Сейчас я стрим от оператора принамаю на убунте, а потом отправляю на циско, хочу  кабель отключить от сервера и подключить прямо на циско, и на цисцо принять стрим, прямо от оператора.

Ответить | Правка | Наверх | Cообщить модератору

3. "Как принять мультикаст на Cisco 3750E"  +/
Сообщение от Andrey (??), 22-Окт-21, 17:28 
>>> Все работает, но я хочу стрим принять прямо на Cisco,
>> Вот с этого места не понятно.
>> Что конкретно хотите получить в результате, если уже все работает?
> Сейчас я стрим от оператора принамаю на убунте, а потом отправляю на
> циско, хочу  кабель отключить от сервера и подключить прямо на
> циско, и на цисцо принять стрим, прямо от оператора.

Ваша убунта работает как маршрутизатор с NAT?

Ответить | Правка | Наверх | Cообщить модератору

4. "Как принять мультикаст на Cisco 3750E"  +/
Сообщение от eek (ok), 28-Окт-21, 11:22 
>>> Все работает, но я хочу стрим принять прямо на Cisco,
>> Вот с этого места не понятно.
>> Что конкретно хотите получить в результате, если уже все работает?
> Сейчас я стрим от оператора принамаю на убунте, а потом отправляю на
> циско, хочу  кабель отключить от сервера и подключить прямо на
> циско, и на цисцо принять стрим, прямо от оператора.

Коллега, по фотографии такое обсуждать не имеет смысла, это переписка в километр.

Если это рабочая задача, то: нужно рисовать схему и разбираться. (какой multicast, как делается терминация, почему построено именно так, какие плюшки хотите получить от выключения ubuntu из схемы и далее-далее-далее).

Так-же я предполгаюа, что где-то есть человек которые это все построил. Может с ним посоветоваться (до начала изменений)? У него вероятно и ответы есть почему оно так построено, а не как-то по другому.

Если это какое-то "домашнее задание", то лучше так и написать.

Ответить | Правка | К родителю #2 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру