The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от opennews on 07-Июл-14, 10:46 
Разработчики языка программирования Ruby предупредили (https://www.ruby-lang.org/en/news/2014/07/01/eol-for-1-8-7-a.../) о завершении 31 июля расширенного цикла поддержки для веток Ruby 1.8.7 и 1.9.2. Поддержка ветки 1.9.3 продлится (https://www.ruby-lang.org/en/news/2014/01/10/ruby-1-9-3-will.../) до 24 февраля 2015 года. Пользователям рекомендуется не затягивать с переходом на Ruby 2.1.2.


Официальная поддержка Ruby 1.8.7 и 1.9.2 была прекращено ещё год назад, но была два раза продлена (https://www.ruby-lang.org/en/news/2013/12/17/maintenance-of-.../) на 6 месяцев благодаря наличию корпоративных спонсоров, заинтересованных в продолжении выпуска обновлений. Срок окончания жизненного цикла Ruby 1.8.7 и 1.9.2 решено больше не продлять, так как сопровождение устаревшей кодовой базы и бэкпортирование патчей становится слишком трудоёмкой задачей. Релиз Ruby 1.8.7 был выпущен в июне 2008 года, но ещё используется в некоторых проектах, которые оказалось невозможно без правки кода перевести на Ruby 1.9.x из-за того, что ветка Ruby 1.9 не является на 100% совместимой с более ранними версиями.

URL: https://www.ruby-lang.org/en/news/2014/07/01/eol-for-1-8-7-a.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=40149

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +2 +/
Сообщение от Журналовращатель on 07-Июл-14, 10:46 
Слишком мало версий руби!!! Используем rvm и сборки в хомяках пользователей! Да, мне нужно 5 версий редмайна, и кнечно-же 4 версии руби. Хочешь работающи1й chef-поставь еще одну версию руби.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +2 +/
Сообщение от Аноним (??) on 07-Июл-14, 10:53 
Это такое тонкое "ПРИШЛО ВРЕМЯ УСТАНАВЛИВАТЬ РУБИ!"?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

5. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Аноним (??) on 07-Июл-14, 11:31 
>"ПРИШЛО ВРЕМЯ УСТАНАВЛИВАТЬ ЕЩЁ ОДНО РУБИ!"

как-то так

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +1 +/
Сообщение от Full20inu on 07-Июл-14, 14:47 
> Это такое тонкое "ПРИШЛО ВРЕМЯ УСТАНАВЛИВАТЬ РУБИ!"?

переустанавливать

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

9. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  –2 +/
Сообщение от Аноним (??) on 07-Июл-14, 17:07 
Не путайте рельсы и руби. На последнем руби спокойно работают несколько редмайнов, ну и обратную поддержку никто не отменял.
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

15. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Журналовращатель on 08-Июл-14, 11:51 
> Не путайте рельсы и руби. На последнем руби спокойно работают несколько редмайнов,
> ну и обратную поддержку никто не отменял.

Не работают. Разным редмайнам нужны разные версии руби (там указано какие).

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

12. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +1 +/
Сообщение от Аноним (??) on 07-Июл-14, 18:01 
> Слишком мало версий руби!!!

У меня только 1 вопрос: кто у кого этому научился - рубисты у питонистов, или питонисты у рубистов?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

14. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Журналовращатель on 08-Июл-14, 11:49 
У рубероидов несовместимости добавляются в разы быстрее
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

17. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Аноним (??) on 08-Июл-14, 16:06 
> кто у кого этому научился - рубисты у питонистов, или питонисты у рубистов?

И с кого из них брали пример авторы Maven, когда принимали решение сделать обязательное прописывание в файлах проектов конкретных версий зависимостей (библиотек, плагинов и пр.) без каких-либо послаблений типа "или новее" и т.п.?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

7. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Аноним (??) on 07-Июл-14, 15:32 
Надо срочно найти новых корпоративных спонсоров! Как еще срубить бабла за 1 патч в год?
https://bugs.ruby-lang.org/projects/ruby-187/repository/chan...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от Аноним (??) on 07-Июл-14, 15:34 
1.9.2 быстрее работает всех версий Ruby 2.0/2.1 включительно плохо работают
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Уведомление о прекращении расширенной поддержки Ruby 1.8.7 и..."  +/
Сообщение от integer email(ok) on 08-Июл-14, 14:21 
Больше мажорных версий! Больше мусора и хаоса в этот мир!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру