The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"NAT между двумя подсетями на одном интерфейсе"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"NAT между двумя подсетями на одном интерфейсе"  
Сообщение от ase email(ok) on 19-Янв-06, 20:36 
Добрый день.

Имеем:
interface Ethernet0
ip address 192.168.10.0 255.255.255.0
ip address 192.168.20.0 255.255.255.0 secondary
ip nat inside

interface Ethernet1
ip address ххх.ххх.ххх.ххх 255.255.255.ххх
ip nat outside

ip nat inside source list 102 interface Ethernet1 overload
access-list 102 permit ip 192.168.10.0 0.0.0.255 any
access-list 102 permit ip 192.168.20.0 0.0.0.255 any

Работает.
Возникла дополнительная необходимость сделать NAT с 192.168.10.0/24 на 192.168.20.0/24 с сохранением работоспособности выхода наружу через Ethernet1.

Подскажите, пожалуйста, в какую сторону смотреть...

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от sh_ email(??) on 19-Янв-06, 21:20 
В сторону PBR и cisco.far.ru
Там в конфигах есть нечто похожее...
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от ase (??) on 20-Янв-06, 06:37 
>В сторону PBR и cisco.far.ru
>Там в конфигах есть нечто похожее...

То-то и оно, что похожее... :-(
У Волка описывается реализация на одном интерфейсе двух подсетей. В моем варианте их три на двух.  
Тоесть сейчас имеется:
192.168.10.0 -> ххх.ххх.ххх.ххх
192.168.20.0 -> ххх.ххх.ххх.ххх
И необходимо добавить:
192.168.10.0 -> 192.168.20.0

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

3. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от sh_ email(??) on 20-Янв-06, 09:47 
Ну так и делаешь... Добавляешь только строчки аля
route-map fuck
match ip add 100
set int lo0
access-l 100 perm ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
int e0
ip poli route-m fuck
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

4. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от ase email(ok) on 20-Янв-06, 21:00 
>Ну так и делаешь... Добавляешь только строчки аля
>route-map fuck
>match ip add 100
>set int lo0
>access-l 100 perm ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
>int e0
>ip poli route-m fuck

Правильно-ли я понял, что у меня должна получиться такая конструкция?

!
interface Loopback0
ip address 10.0.1.1 255.255.255.0
ip nat inside
!
interface Loopback1
ip address 10.0.2.1 255.255.255.0
ip nat inside
!
! LAN Iface
interface Ethernet0
ip address 192.168.10.0 255.255.255.0
ip address 192.168.20.0 255.255.255.0 secondary
ip nat outside
ip poli route-m rout10
ip poli route-m rout20
!
! WAN Iface
interface Ethernet1
ip address ххх.ххх.ххх.ххх 255.255.255.ххх
ip nat outside
!
! Route 192.168.10.0 to Lo0
route-map rout10
match ip add 101
set int lo0
access-l 101 perm ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
!
! NAT from Lo0 to 192.168.20.0 (Eth0)
ip nat pool E0NET20 192.168.20.1 192.168.20.255 netmask 255.255.255.0
ip nat inside source list 110 interface E0NET20 overload
access-l 110 perm ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
!
!
! Route 192.168.20.0 to Lo1
route-map rout20
match ip add 102
set int lo1
access-l 102 perm ip 192.168.20.0 0.0.0.255 any
!
!  NAT from Lo1 to external (Eth1)
ip nat inside source list 120 interface Ethernet1 overload
access-l 120 perm ip 192.168.20.0 0.0.0.255 any
!

Или все-таки это делается проще?

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

5. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от sh_ email(??) on 21-Янв-06, 16:14 
Типа того, только
interface Ethernet0
no ip poli route-m rout20
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

6. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от ase (??) on 21-Янв-06, 17:22 
>Типа того, только
>interface Ethernet0
>no ip poli route-m rout20

Тоесть Loopback1 не нужен, нижеприведенное избыточно?
! Route 192.168.20.0 to Lo1
route-map rout20
match ip add 102
set int lo1
access-l 102 perm ip 192.168.20.0 0.0.0.255 any


И этого вполне достаточно, чтоб натить наружу?
ip nat inside source list 120 interface Ethernet1 overload
access-l 120 perm ip 192.168.20.0 0.0.0.255 any

Но будет ли этот NAT работать, ведь
interface Ethernet0
ip nat outside
Или же это решается заменой
access-l 101 perm ip 192.168.10.0 0.0.0.255 192.168.20.0 0.0.0.255
на
access-l 101 perm ip 192.168.10.0 0.0.0.255 any
access-l 101 perm ip 192.168.20.0 0.0.0.255 any

Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

7. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от sh_ email(??) on 22-Янв-06, 09:54 
Чтобы натить наружу, ты должен натить сетку 192.168.0.0 0.0.255.255
А для внутреннего ната, только 192.168.10.0 0.0.0.255
Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

8. "NAT между двумя подсетями на одном интерфейсе"  
Сообщение от ase email(ok) on 24-Янв-06, 17:49 
>Чтобы натить наружу, ты должен натить сетку 192.168.0.0 0.0.255.255
>А для внутреннего ната, только 192.168.10.0 0.0.0.255

Все получилось. Большое спасибо.


Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ]




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру