The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Распознание версии ядра."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Ядро / Linux)
Изначальное сообщение [ Отслеживать ]

"Распознание версии ядра."  –1 +/
Сообщение от stakado email(ok) on 07-Авг-15, 10:42 
Здравствуйте!
Помогите, пожалуйста, понять какая версия ядра у меня стоит.
root@gtw-v2:/tmp# uname -a
Linux gtw-v2 3.16.0-4-amd64 #1 SMP Debian 3.16.7-ckt11-1 (2015-05-24) x86_64 GNU/Linux

3.16.0 или 3.16.7?
Очень хочется, чтобы это была версия 3.16.7, но интуиция подсказывает, что она всё же 3.16.0.
Почему в выводе uname указаны две версии ядра?

Ещё чуть инфы на всякий случай:
aptitude show linux-image-3.16.0-4-amd64
Package: linux-image-3.16.0-4-amd64
New: yes
State: installed
Automatically installed: yes
Version: 3.16.7-ckt11-1
....

Название пакета linux-image-3.16.0-4-amd64, версия же 3.16.7-ckt11-1. Какая из них есть и вправду версия ядра?

И ещё:
root@gtw-v2:/tmp# ls /boot/vmlinuz-3.*
/boot/vmlinuz-3.16.0-4-amd64  /boot/vmlinuz-3.2.0-4-amd64

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Распознание версии ядра."  +/
Сообщение от Andrey Mitrofanov on 07-Авг-15, 12:19 
> Здравствуйте!
> Помогите, пожалуйста, понять какая версия ядра у меня стоит.
> 3.16.0 или 3.16.7?
> Очень хочется, чтобы это была версия 3.16.7, но интуиция подсказывает, что она
> всё же 3.16.0.

Как дети...

> Название пакета linux-image-3.16.0-4-amd64, версия же 3.16.7-ckt11-1. Какая из них есть
> и вправду версия ядра?

Выбирай:

* Никакая.
* Это тебе не нужно.
* Марш https://www.debian.org/security/2015/dsa-3313 обновляться!
* В дебиановском пакете версии 3.16.7-ckt11-1 упаковано ядро версии 3.16.7-ckt11 от цаноникал кернел тиим, которая продолжила выпуск минорных-минорных ("стабильных") патчей ядра 3.16, когда, после 3.16.7, kernel.org (не помню уже, кто там - да, тебе и не надо) закончил выпуск минорных-стабильных патчей ядра 3.16.

> И ещё:
> root@gtw-v2:/tmp# ls /boot/vmlinuz-3.*
> /boot/vmlinuz-3.16.0-4-amd64  /boot/vmlinuz-3.2.0-4-amd64

Тут вариантов поменьше, но можно выбрать оба:
* Так надо!
* Это тебе не нужно.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Распознание версии ядра."  –1 +/
Сообщение от stakado email(ok) on 07-Авг-15, 15:02 
> * Это тебе не нужно. [2 раза]
> * Марш https://www.debian.org/security/2015/dsa-3313 обновляться!

Так не нужно (упоминалось 2 раза) или таки обновляться?!

> * В дебиановском пакете версии 3.16.7-ckt11-1 упаковано ядро версии 3.16.7-ckt11 от цаноникал
> кернел тиим

Ништяк! Очень рад, что в этом пакете (а значит и у меня) есть версия 3.16.7.

Вопрос ещё раз --- какое ядро на текущий момент запущено на моей машине?!
Если 3.16.0, то каким образом из указанного выше пакета добыть ядро 3.16.7?

PS: изначально задался вопросом прочитав новость (https://www.opennet.ru/opennews/art.shtml?num=42727), так что линками могли бы и не кидаться, сам в курсе.

PPS: Вы на форум с какой целью вообще заходите? Покрасоваться? Самооценку повысить за счёт унижения остальных? Или может всё же форумы есть для того, чтобы людям помогать? Если в Вашем ответе будет хоть маленькая доля ответа на мой вопрос (который задан изначально) - ответьте, пожалуйста. В противном случае - не надо наполнять топик левыми текстами.
Заранее благодарен.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Распознание версии ядра."  –1 +/
Сообщение от stakado email(ok) on 07-Авг-15, 15:05 
И ещё немного по теме.
В новости (https://www.opennet.ru/opennews/art.shtml?num=42727) есть ссылка на дебиановский сайт - https://lists.debian.org/debian-security-announce/2015/msg00...
Вот уж на дебиан-сайте есть такой текст:
For the stable distribution (jessie), these problems have been fixed in
version 3.16.7-ckt11-1+deb8u2.

Это речь про версию пакета linux-image-... ? Если так, то у меня версия 3.16.7-ckt11-1 и она отличается от указанной в новости "+deb8u2".
Каким образом можно обновить пакет до указанной версии?
apt-get update && apt-get upgrade не помогает.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Распознание версии ядра."  +/
Сообщение от 0000 (??) on 07-Авг-15, 15:44 
> И ещё немного по теме.
> В новости (https://www.opennet.ru/opennews/art.shtml?num=42727) есть ссылка на дебиановский
> сайт - https://lists.debian.org/debian-security-announce/2015/msg00...
> Вот уж на дебиан-сайте есть такой текст:
> For the stable distribution (jessie), these problems have been fixed in
> version 3.16.7-ckt11-1+deb8u2.
> Это речь про версию пакета linux-image-... ? Если так, то у меня
> версия 3.16.7-ckt11-1 и она отличается от указанной в новости "+deb8u2".
> Каким образом можно обновить пакет до указанной версии?
> apt-get update && apt-get upgrade не помогает.

man dpkg

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Распознание версии ядра."  +/
Сообщение от Ващенаглухо (ok) on 07-Авг-15, 17:28 
>[оверквотинг удален]
> New: yes
> State: installed
> Automatically installed: yes
> Version: 3.16.7-ckt11-1
> ....
> Название пакета linux-image-3.16.0-4-amd64, версия же 3.16.7-ckt11-1. Какая из них есть
> и вправду версия ядра?
> И ещё:
> root@gtw-v2:/tmp# ls /boot/vmlinuz-3.*
> /boot/vmlinuz-3.16.0-4-amd64  /boot/vmlinuz-3.2.0-4-amd64

cat /proc/cmdline

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру