The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"pma 4.0.x тормозит"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Др. сетевые сервисы / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"pma 4.0.x тормозит"  +/
Сообщение от MoHaX email(ok) on 10-Июн-13, 15:05 
Обновил pma (phpMyAdmin) на серверах с 3.х до 4.0.3. Теперь при открытии станицы логина, она отрывается по несколько минут, после ввода логина и пароля проходит также несколько минут, появляется интерфейс pma, в нем все работает нормально. Ситуация повторилась на нескольких серверах, если вернуть версию 3.х то все работает нормально. сталкивался кто-нить с подобным, если да, то как лечить? От версии и названия http сервера и СУБД не зависит.
ОС FreeBSD 9.1
http server: где-то апач, где-то nginx
СУБД: MariaDB и MySQL
Все ставилось и обновлялось из портов, pma тоже.
В логах ничего криминального нет...


Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "pma 4.0.x тормозит"  +/
Сообщение от wiseman (ok) on 10-Июн-13, 16:20 
>[оверквотинг удален]
> пароля проходит также несколько минут, появляется интерфейс pma, в нем все
> работает нормально. Ситуация повторилась на нескольких серверах, если вернуть версию 3.х
> то все работает нормально. сталкивался кто-нить с подобным, если да, то
> как лечить? От версии и названия http сервера и СУБД не
> зависит.
> ОС FreeBSD 9.1
> http server: где-то апач, где-то nginx
> СУБД: MariaDB и MySQL
> Все ставилось и обновлялось из портов, pma тоже.
> В логах ничего криминального нет...

Гугл рулит и педалит
http://stackoverflow.com/questions/14027351/phpmyadmin-opens...
http://future500.nl/phpmyadmin-slow-on-startup/
Ваш случай?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "pma 4.0.x тормозит"  +/
Сообщение от MoHaX (ok) on 10-Июн-13, 16:43 
>[оверквотинг удален]
>> зависит.
>> ОС FreeBSD 9.1
>> http server: где-то апач, где-то nginx
>> СУБД: MariaDB и MySQL
>> Все ставилось и обновлялось из портов, pma тоже.
>> В логах ничего криминального нет...
> Гугл рулит и педалит
> http://stackoverflow.com/questions/14027351/phpmyadmin-opens...
> http://future500.nl/phpmyadmin-slow-on-startup/
> Ваш случай?

Точно, мой. Спасибо!

Добавил в конфиг:
$cfg['MaxExactCountViews'] = 0;
$cfg['MaxExactCount'] = 0;
и все нормализовалось.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "pma 4.0.x тормозит"  +/
Сообщение от MoHaX email(ok) on 11-Июн-13, 12:33 
>[оверквотинг удален]
>>> В логах ничего криминального нет...
>> Гугл рулит и педалит
>> http://stackoverflow.com/questions/14027351/phpmyadmin-opens...
>> http://future500.nl/phpmyadmin-slow-on-startup/
>> Ваш случай?
> Точно, мой. Спасибо!
> Добавил в конфиг:
> $cfg['MaxExactCountViews'] = 0;
> $cfg['MaxExactCount'] = 0;
> и все нормализовалось.

А нет, поторопился, сегодня опять тоже самое, видимо не совсем мой случай.
При этом странно, когда захожу в pma, минуты 3 лицезрею белую страницу, до появления полей логина, пароля. При этом если посмотреть исходный код этой белой страницы, то там весь нужный html есть. Такое ощущение, что браузер пытается ещё что-то "докачать" или какой js выполнить перед тем как показать скачанный html. Есть какие-нить мысли?

В логах апача это так выглядит:
---

х.х.х.х - - [11/Jun/2013:07:31:03 +0000] "GET / HTTP/1.0" 200 2857 "-" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
х.х.х.х - - [11/Jun/2013:07:31:03 +0000] "GET /phpmyadmin.css.php?server=1&token=63c0f94b126af92f3209df001e6643d7&nocache=4112632891ltr HTTP/1.0" 200 88608 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
х.х.х.х - - [11/Jun/2013:07:31:04 +0000] "GET /js/messages.php?lang=ru&db=&server=0&token=fb39e7fe67fc4169387e8dfb2e5e1982 HTTP/1.0" 200 24674 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
--

После этой строчки висит 5 минут.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "pma 4.0.x тормозит"  +/
Сообщение от wiseman (ok) on 11-Июн-13, 15:09 
>[оверквотинг удален]
> х.х.х.х - - [11/Jun/2013:07:31:03 +0000] "GET / HTTP/1.0" 200 2857 "-" "Mozilla/5.0
> (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
> х.х.х.х - - [11/Jun/2013:07:31:03 +0000] "GET /phpmyadmin.css.php?server=1&token=63c0f94b126af92f3209df001e6643d7&nocache=4112632891ltr
> HTTP/1.0" 200 88608 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
> х.х.х.х - - [11/Jun/2013:07:31:04 +0000] "GET /js/messages.php?lang=ru&db=&server=0&token=fb39e7fe67fc4169387e8dfb2e5e1982
> HTTP/1.0" 200 24674 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
> --
> После этой строчки висит 5 минут.

запустите firefox+firebug и посмотрите, чем он занимается

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "pma 4.0.x тормозит"  +/
Сообщение от MoHaX email(ok) on 20-Июн-13, 14:42 
>[оверквотинг удален]
>> (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
>> х.х.х.х - - [11/Jun/2013:07:31:03 +0000] "GET /phpmyadmin.css.php?server=1&token=63c0f94b126af92f3209df001e6643d7&nocache=4112632891ltr
>> HTTP/1.0" 200 88608 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
>> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
>> х.х.х.х - - [11/Jun/2013:07:31:04 +0000] "GET /js/messages.php?lang=ru&db=&server=0&token=fb39e7fe67fc4169387e8dfb2e5e1982
>> HTTP/1.0" 200 24674 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
>> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
>> --
>> После этой строчки висит 5 минут.
> запустите firefox+firebug и посмотрите, чем он занимается

Поставил firefox, а в нем все быстро открывается и работает. А в хроме и IE тормозит. В общем фик знает чего это значит.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "pma 4.0.x тормозит"  +/
Сообщение от lavr email on 20-Июн-13, 15:17 
>[оверквотинг удален]
>>> HTTP/1.0" 200 88608 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
>>> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
>>> х.х.х.х - - [11/Jun/2013:07:31:04 +0000] "GET /js/messages.php?lang=ru&db=&server=0&token=fb39e7fe67fc4169387e8dfb2e5e1982
>>> HTTP/1.0" 200 24674 "http://pma.host.ru/" "Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36
>>> (KHTML, like Gecko) Chrome/27.0.1453.110 Safari/537.36"
>>> --
>>> После этой строчки висит 5 минут.
>> запустите firefox+firebug и посмотрите, чем он занимается
> Поставил firefox, а в нем все быстро открывается и работает. А в
> хроме и IE тормозит. В общем фик знает чего это значит.

всего лишь предположение - наличие java-script, который по разному отрабатывается
в разных браузерах, ну и соответственно как написан java-скрипт.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру