The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"NVIDIA пока не может решить проблему с совместимостью с новы..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от opennews (??) on 01-Ноя-13, 19:27 
Уже третий месяц длится эпопея, связанная с тем, что из состава ядра Linux была удалена функциональность, критичная для закрытых драйверов NVIDIA. Это уже привело к тому, что на официальном форуме компании, посвященном Linux, создано не менее десятка тем, где люди пытаются собственными силами решить проблему совместимости с ядрами Linux версии 3.11 и выше. Сегодня NVIDIA опубликовала (https://devtalk.nvidia.com/default/topic/628864/unix-graphic.../) набор патчей для драйверов версий 304.xx, 319.xx и 325.xx, прикрепив к нему достаточно неприятный анонс, перевод которого представлен ниже:

<blockquote>

Закрытый драйвер NVIDIA для Linux пытается гарантировать адекватное поведение видеоадаптера путём проверки того, что память, выделенной ядром для драйвера, может быть адресована установленным в систему GPU. В противном случае, отсутствие проверки может привести к тому, что GPU обрежет адреса или будет пытаться обращаться к неверным адресам в системной памяти. Обычно драйвер NVIDIA проверял это, вычисляя самый высокий адрес в системной памяти, доступный для адресации, используя число фреймов страниц, которое можно получить с помощью переменной ядра num_physpages. Если этот адрес превышает возможности GPU, то драйвер переходит в режим 32-битного DMA, чтобы обеспечить стабильность системы.


В ядрах Linux 3.11 и выше, доступ к максимальному числу фреймов страниц был удалён и заменён на get_num_physpages(), который рапортует полное число физических страниц памяти. Хотя максимальное число фреймов страниц и объём памяти в системе связаны, это совершенно разные значения, и их нельзя заменять. Информация об объёме памяти недостаточна, чтобы идентифицировать всю память, которая может быть адресована GPU.


NVIDIA может предложить ограниченную поддержку 3.11 и более новых ядер, используя get_num_physpages() и переходя в 32-битный режим DMA  более агрессивно, и этот подход будет использован в настоящее время. Это временная мера, которая должна быть достаточна для большинства пользователей NVIDIA, однако системы с очень большим количеством оперативной памяти (128GB и выше) могут столкнуться с отрицательными эффектами, поэтому им рекомендуется использовать ядро 3.10 или более ранние. Более правильный и устойчивый подход для решения этой проблемы сейчас находится в разработке, но мы не сможем предложить его в ближайшем будущем.


Выходящие в будущем драйверы будут включать новое правильное исправление, а документация будет обновлена для более подробного объяснения, касающегося адресации системной памяти видеоадаптером, пока же вы можете воспользоваться официальными патчами (https://devtalk.nvidia.com/default/topic/628864/unix-graphic.../), которые добавляют поддержку Linux 3.11 и выше. Их можно применить к с помощью команды инсталлятора --apply-patch.

</blockquote>

URL: https://devtalk.nvidia.com/default/topic/628864/unix-graphic.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=38316

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:27 
Ща набегут злорадствующие АМДшники)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

17. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +12 +/
Сообщение от Anonplus on 01-Ноя-13, 20:11 
AMD-шникам нет нужды злорадствовать.
Вот я сейчас выбираю видеокарту для игр в пределах до 7 тысяч.
Самое мощное, что может предложить нвидия в этом диапазоне - GTX660
Самое мощное у амд - новенький R270X, который во всех тестах опережает конкурента и даже подбирается к GTX660Ti (а это уже другой ценовой диапазон).
Так что AMD банально выгоднее в настоящий момент по соотношению цена/производительность. Нвидии надо или снижать цены на старые карты, или выкатывать какую-нибудь недорогую карту серии 7xx, чтобы заполнить этот сегмент
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

19. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –5 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:19 
Это выбор между "работает но чуть-чуть медленнее" и "не работает"
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

25. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +22 +/
Сообщение от Crazy Alex (ok) on 01-Ноя-13, 20:38 
Судя по новости - "не работает" - это про нвидиа?
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

26. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –4 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:38 
> Это выбор между "работает но чуть-чуть медленнее" и "не работает"

Ну ведь врешь, а?

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

163. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от lucentcode (ok) on 02-Ноя-13, 15:00 
В своё время перешёл на AMD, и не жалею. Всегда есть дрова, даже на новые иксы и новые ядра. И при том есть выбор между свободным драйвером, и не свободным.
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

235. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от rt (??) on 02-Ноя-13, 21:59 
750 задерживается.
Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

24. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:38 
>  NVIDIA пока не может решить проблему с совместимостью с новыми ядрами Linux

Самое интересное, что решение данной проблемы по силам любому (!) пользователю. Это решение очевидно - переход на ATI/AMD. Впрочем, для офисных машин, да и домашних (не геймерских) встроенного Intel уже выше крыши по производительности.

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

104. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от рвв on 02-Ноя-13, 08:43 
встроенного - это имеется в виду в процессор?
Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

107. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от unscrubber on 02-Ноя-13, 09:29 
>>  NVIDIA пока не может решить проблему с совместимостью с новыми ядрами Linux
> Самое интересное, что решение данной проблемы по силам любому (!) пользователю. Это
> решение очевидно - переход на ATI/AMD. Впрочем, для офисных машин, да
> и домашних (не геймерских) встроенного Intel уже выше крыши по производительности.

у АМД не меньше проблем с драйверами проприетарными - то s3tc нет в проприетарных дровах то иксы виснут, в открытых радеон-дровах тоже не все так гладко , шедеров 3lvl не было раньше (мож щас и есть - давно непробовал)

Ответить | Правка | ^ к родителю #24 | Наверх | Cообщить модератору

110. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 10:48 
> у АМД не меньше проблем с драйверами проприетарными

У них нынче открытые уже столь приличные, что в 90% случаев забить на проприетарь болт.

Ответить | Правка | ^ к родителю #107 | Наверх | Cообщить модератору

210. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от Raiden (ok) on 02-Ноя-13, 18:25 
>> у АМД не меньше проблем с драйверами проприетарными
>У них нынче открытые уже столь приличные, что в 90% случаев забить на проприетарь болт.

А забить на проприетарь хочется, т.к. он глючный, верно? Вот поэтому лучше nvidia.

Ответить | Правка | ^ к родителю #110 | Наверх | Cообщить модератору

216. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +8 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:20 
> А забить на проприетарь хочется, т.к. он глючный, верно?

А забить на проприетарь хочется, потому что:
1) Очень здорово когда майнтайнеры и разработчики могут чинить проблемы.
2) Хорошо когда баги можно футболить в нормальный багтрекер, а не на деревню дедушке. И потом еще и их статус мониторить и ретестануть что баг зачинен.
3) Если кусок драйвера это часть ядра - он, определенно, не должен отвалиться при обновлении. Не выпускают ядро которое само с собой не работает, знаете ли. А вот сторонний довесок который седьмая вода на киселе - отвалиться может. О чем, собственно, сабж и есть.
4) Кроме того все это синхронизировано с остальными открытыми проектами - MESA и прочая. Если вон там MESA драйверу надо нечто в ядре - ну и ядерный выносок допилят.
5) В лине делают крутой и могучий графический бэкэнд. Его наиболее известными частями являются KMS и DRM. Открытые драйвера нормально интегрируются со всем этим. Нотификатор паники с показом на фреймбуферобразную консоль? Kdb отрисованный на фреймбуфер-подобную консольку? Можно! Консольку через KMS рисовать? Логично. Перекидывать данные между GPU через буфер подпертый DMA (DMA-BUF) - а клево придумано, черт возьми. Так можно делать немало интересных финтов ушами. Типа обсчета сцены на сразу нескольких GPU (даже разных производителей) или рендер на одном и вывод через другой (актуально для нотиков с дискретной графикой).
6) Стопроцентный plug-n-play. Никаких долбаных скачек дров откуда-то сбоку, ребутов, xorg.conf и какой там еще фигни. Можно загрузить дистр с ливфлехи и полноценно работать будет, итить. Выносок ядерный вгрузится,юзермод типа MESA его поюзает. Телемаркет - машина наконец сама знает что в нее воткнуто и грузит драйвер.

> Вот поэтому лучше nvidia.

Фанатики - они такие.

Ответить | Правка | ^ к родителю #210 | Наверх | Cообщить модератору

260. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Адекват (ok) on 03-Ноя-13, 17:05 
> 6) Стопроцентный plug-n-play. Никаких долбаных скачек дров откуда-то сбоку, ребутов, xorg.conf
> и какой там еще фигни. Можно загрузить дистр с ливфлехи и
> полноценно работать будет, итить. Выносок ядерный вгрузится,юзермод типа MESA его поюзает.
> Телемаркет - машина наконец сама знает что в нее воткнуто и
> грузит драйвер.

Вот за это отдельное спасибо.

Ответить | Правка | ^ к родителю #216 | Наверх | Cообщить модератору

265. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 03-Ноя-13, 18:17 
> Вот за это отдельное спасибо.

Да просто проприерасы заманали уже. Ставить дрова с дискетке, заранее зная что за железка - я и в DOS умел, 20 лет назад. Как-то не прикольно слышать от них те же увещевания что и 20 лет назад.

Нет, парни. Настоящий плагнплей - это когда я воткнул в USB usb2uart конвертор на FTDI232 и у меня без шума и пыли отрос /dev/ttyUSB0 с которым можно просто начать работать, здесь и сейчас. Ну и вот так хотелось бы и для всего остального. А вот тасовать какую-то проблемную проприетару, вкрячиваемую откуда-то сбоку и отпадающую при попытке юзать вон то ядро, иксы и прочая - вот как-то совсем не вдохновляет, скажу прямо. Я не хочу чтобы какие-то п...сы из нвидии смели мне диктовать какие ядра, иксы и что там еще мне использовать.

Ответить | Правка | ^ к родителю #260 | Наверх | Cообщить модератору
Часть нити удалена модератором

288. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:33 
мы тут не про винду говорим, если ты не заметил. понятно, что на винде так не будет никогда. если качественно порыдаешь — можем тебя немножко даже пожалеть за это.
Ответить | Правка | Наверх | Cообщить модератору

291. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 04-Ноя-13, 11:17 
> Если ты действительно в ЭТО веришь,

Вопросы веры тут не при чем. Это то как плагнплей должен был работать с самого начала, чтобы быть фактическим состоянием дел а не маркетинговым булшитом.

> - Шигорина - синдром вахтёра. Психические заболевания они такие, их не выбирают.

Психические заболевания - это когда белое называют черным. А диджейство дискетками и сидюками - плагнплеем.

Ответить | Правка | Наверх | Cообщить модератору

278. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от anonymus on 04-Ноя-13, 03:38 
> 6) Стопроцентный plug-n-play. Никаких долбаных скачек дров откуда-то сбоку, ребутов,
> xorg.conf и какой там еще фигни. Можно загрузить дистр с ливфлехи и
> полноценно работать будет, итить.

А что, muxless гибриды на ноутах уже заработали с открытыми дровами? Амд, конечно, раньше нвидии научилось это поддерживать, но и тогда, и сейчас - исключительно посредством проприетарных дров. Открытые дрова с проприетарным блобом, которые xf66-video-ati, до сих пор не умеют перенаправлять поток рендеринга с одной видюхи на другую.

Ответить | Правка | ^ к родителю #216 | Наверх | Cообщить модератору

292. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 04-Ноя-13, 12:48 
> А что, muxless гибриды на ноутах уже заработали с открытыми дровами?

Честно? Не знаю: у меня их нет. Но как минимум хотелось бы чтобы именно так и работали. С открытыми дровами. Без приседаний и танцев с бубнами. Сразу. Я помню что амдшники что-то такое пилили в открытых драйверах на эту тему, но не очень интересовался т.к. у меня этого нет.

> Амд, конечно, раньше нвидии научилось это поддерживать, но и тогда, и сейчас
> - исключительно посредством проприетарных дров.

Помнится что-то такое в открытых драйверах они делали.

> до сих пор не умеют перенаправлять поток рендеринга с одной видюхи на другую.

Насколько я понимаю, открытые драйвера если и не доделали это то уже достаточно близки. При том когда это добьют - у амдшников рррраз и уже есть вполне нормальный открытый драйвер. Как и у интеля. А для нвидий только нуво, показывающий 20% от проприетари по скорости...

Ответить | Правка | ^ к родителю #278 | Наверх | Cообщить модератору

298. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от anonymus on 04-Ноя-13, 16:11 
>> А что, muxless гибриды на ноутах уже заработали с открытыми дровами?
> Честно? Не знаю: у меня их нет.

А у меня есть. А вот описанного волшебного plug-n-play пока ещё нет. Приходится возиться с проприетарными дровами. Хотя я бы тоже предпочёл открытые дрова с блобом.

> Помнится что-то такое в открытых драйверах они делали.

Это называется vga switcheroo и работает только там, где есть физический переключатель потока видеоданных. В современных ноутах предпочитают перенаправлять данные программно.

>> до сих пор не умеют перенаправлять поток рендеринга с одной видюхи на другую.
> Насколько я понимаю, открытые драйвера если и не доделали это то уже
> достаточно близки.

Ну когда доделают, тогда может и nvidia снова станет отлично поддерживать новые ядра

Ответить | Правка | ^ к родителю #292 | Наверх | Cообщить модератору

301. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 05-Ноя-13, 19:14 
> А у меня есть. А вот описанного волшебного plug-n-play пока ещё нет.

Ну так это баг. Его надлежит чинить. Насколько я понимаю по текущей активности (запилили динамическое включение-выключение дискретного GPU, куча возни с DMA-BUF, render nodes и прочая) - данную точку зрения вполне разделяют и разработчики ядра и графической подсистемы. Просто мир не идеален и не все и не всегда сразу имеется в том виде каком хотелось бы.

> Приходится возиться с проприетарными дровами. Хотя я бы тоже предпочёл открытые
> дрова с блобом.

Ну так я о чем. При том понимание того что для линуха надо открытые драйвера - к амд и интелю таки пришло. И да, они сделали ряд довольно generic механизмов которые явно могут в том числе взять картинку из headless GPU и через подпертый DMA буфер гнать данные в GPU у которого есть видеовыход. То что оно не допинано пока до состояния когда конечные юзеры поимеют с этого профит - ну да. Но думается мне что этот момент уже не столь далек.

>> Помнится что-то такое в открытых драйверах они делали.
> Это называется vga switcheroo

Я про редирект данных средствами буферов подпертых DMA вообще-то. Как я понимаю - данный забавный механизм может кроме всего прочего и данные из одного GPU в другой гонять. Как раз из того кто рендерил - в того у кого видеовыход есть. Одна из причин по которым это делалось.

> Ну когда доделают, тогда может и nvidia снова станет отлично поддерживать новые ядра

А у нвидии пока не заметно команды разработчиков работающих над открытым драйвером. А блоба кусок - всегда будет хорошей заявкой на проблемы. Просто потому что его существование в майнлайновом ядре никто не учитывал и не собирается.

Ответить | Правка | ^ к родителю #298 | Наверх | Cообщить модератору

30. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от AnonuS on 01-Ноя-13, 20:54 
Набежал владелец NVidia...

Патчи наложил на 331.17 и 325.15, оба обламываются при установке:

ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources, with a version of gcc that differs from the one used to build the target kernel, or if a driver such as rivafb, nvidiafb, or nouveau is present and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA graphics device(s), or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Please see the log entries 'Kernel module load error' and 'Kernel messages' at the end of the file '/var/log/nvidia-installer.log' for more information.
-> Kernel module load error: Invalid argument
-> Kernel messages:
[  894.714708] nvidia: Unknown symbol drm_fasync (err -22)
[  894.714720] nvidia: disagrees about version of symbol drm_poll
[  894.714722] nvidia: Unknown symbol drm_poll (err -22)
[  894.714739] nvidia: disagrees about version of symbol drm_pci_init
[  894.714741] nvidia: Unknown symbol drm_pci_init (err -22)
[  894.714812] nvidia: disagrees about version of symbol drm_gem_prime_handle_to_fd
[  894.714813] nvidia: Unknown symbol drm_gem_prime_handle_to_fd (err -22)
[  894.714831] nvidia: disagrees about version of symbol drm_gem_private_object_init
[  894.714833] nvidia: Unknown symbol drm_gem_private_object_init (err -22)
[  894.714853] nvidia: disagrees about version of symbol drm_gem_mmap
[  894.714855] nvidia: Unknown symbol drm_gem_mmap (err -22)
[  894.714861] nvidia: disagrees about version of symbol drm_ioctl
[  894.714863] nvidia: Unknown symbol drm_ioctl (err -22)
[  894.714892] nvidia: disagrees about version of symbol drm_read
[  894.714894] nvidia: Unknown symbol drm_read (err -22)
[  894.714911] nvidia: disagrees about version of symbol drm_gem_handle_create
[  894.714913] nvidia: Unknown symbol drm_gem_handle_create (err -22)
[  894.714919] nvidia: disagrees about version of symbol drm_prime_pages_to_sg
[  894.714921] nvidia: Unknown symbol drm_prime_pages_to_sg (err -22)
[  894.714975] nvidia: disagrees about version of symbol drm_pci_exit
[  894.714976] nvidia: Unknown symbol drm_pci_exit (err -22)
[  894.714996] nvidia: disagrees about version of symbol drm_release
[  894.714998] nvidia: Unknown symbol drm_release (err -22)
[  894.715001] nvidia: disagrees about version of symbol drm_gem_prime_export
[  894.715002] nvidia: Unknown symbol drm_gem_prime_export (err -22)

Кто знает как победить ???


Система: openSUSE 13.1, ведро 3.11.6

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

34. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от vitalif email(ok) on 01-Ноя-13, 21:14 
Ты его собрал не туда (не с теми хедерами), судя по всему...
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

38. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от AnonuS on 01-Ноя-13, 21:22 
> Ты его собрал не туда (не с теми хедерами), судя по всему...

Ща попробую непатченную версию


Ответить | Правка | ^ к родителю #34 | Наверх | Cообщить модератору

52. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от pavlinux (ok) on 01-Ноя-13, 23:40 

diff -ur a/kernel/nv-drm.c b/kernel/nv-drm.c
--- a/kernel/nv-drm.c   2013-08-14 06:33:23.000000000 +0400
+++ b/kernel/nv-drm.c   2013-09-26 02:46:03.528914493 +0400
@@ -106,7 +106,9 @@
     .unlocked_ioctl = drm_ioctl,
     .mmap = drm_gem_mmap,
     .poll = drm_poll,
+#if LINUX_VERSION_CODE < KERNEL_VERSION(3, 11, 0)
     .fasync = drm_fasync,
+#endif
     .read = drm_read,
     .llseek = noop_llseek,
};
@@ -202,13 +204,6 @@
     memset(&nv_obj->base, 0, sizeof(nv_obj->base));
     nv_obj->pages = pages;

-    ret = drm_gem_private_object_init(nvl->drm, &nv_obj->base, size);
-    if (ret)
-    {
-        status = RM_ERR_OPERATING_SYSTEM;
-        goto done;
-    }
-
     ret = drm_gem_handle_create(file_priv, &nv_obj->base, handle);
     if (ret)
     {
@@ -216,6 +211,7 @@
         goto done;
     }

+    drm_gem_private_object_init(nvl->drm, &nv_obj->base, size);
     drm_gem_object_unreference_unlocked(&nv_obj->base);

     status = RM_OK;

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

91. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от AnonuS on 02-Ноя-13, 03:56 
>
 
> diff -ur a/kernel/nv-drm.c b/kernel/nv-drm.c

. . .

>      status = RM_OK;
>

Павлик, это чего ?

Ответить | Правка | ^ к родителю #52 | Наверх | Cообщить модератору

242. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от pavlinux (ok) on 03-Ноя-13, 01:18 
> Павлик, это чего ?

nv-drm ... в общем забей, это тебя ещё ждёт впереди :)

Ответить | Правка | ^ к родителю #91 | Наверх | Cообщить модератору

90. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от AnonuS on 02-Ноя-13, 03:55 
Елы-палы, заколдованный круг какой-то с NVidia дровами в этот раз, первый раз такая лажа...

openSUSE 12.3 ( ведро 3.11.6 )

1. Дрова собрались и установились после переустановки "ядерных" заголовков и символов.
2. Иксы не стартуют, ибо segmentation fault...
3. Откатил иксы на предыдущую версию
4. Заработало


openSUSE 13.1 ( ведро 3.11.6 )

1. Дрова собрались и установились после переустановки "ядерных" заголовков и символов.
2. Иксы не стартуют, ибо segmentation fault...
3. Плюнул, выкинул блоб накатил нуво
4. Заработало, буду ждать пока у них там утрясётся потом опять NVidia накачу

Ответить | Правка | ^ к родителю #38 | Наверх | Cообщить модератору

94. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 05:14 
И у меня то же самое, openSUSE 12.2 и ядро 3.7.10.

[   346.928] (II) Loading sub module "dri2"
[   346.928] (II) LoadModule: "dri2"
[   346.928] (II) Module "dri2" already built-in
[   346.928] (II) NVIDIA(0): [DRI2] Setup complete
[   346.928] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[   346.929] (--) RandR disabled
[   346.941] (II) Initializing extension GLX
[   346.942] (EE)
[   346.942] (EE) Backtrace:
[   346.942] (EE) 0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x5915f6]
[   346.942] (EE) 1: /usr/bin/Xorg (0x400000+0x195429) [0x595429]
[   346.942] (EE) 2: /lib64/libpthread.so.0 (0x7f9440547000+0xf140) [0x7f9440556140]
[   346.942] (EE) 3: /usr/bin/Xorg (RROutputChanged+0x85) [0x4fe6f5]
[   346.942] (EE) 4: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f943aa50000+0x4ffd55) [0x7f943af4fd55]
[   346.942] (EE) 5: /usr/lib64/xorg/modules/drivers/nvidia_drv.so (0x7f943aa50000+0x4eb44f) [0x7f943af3b44f]
[   346.942] (EE) 6: /usr/bin/Xorg (0x400000+0x2c036) [0x42c036]
[   346.942] (EE) 7: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x7f943f1c6455]
[   346.942] (EE) 8: /usr/bin/Xorg (0x400000+0x2c4c1) [0x42c4c1]
[   346.942] (EE)
[   346.942] (EE) Segmentation fault at address 0x110
[   346.942] (EE)
Fatal server error:
[   346.942] (EE) Caught signal 11 (Segmentation fault). Server aborting
[   346.942] (EE)
[   346.942] (EE)
Please consult the The X.Org Foundation support
         at http://wiki.x.org
for help.
[   346.942] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   346.942] (EE)
[   347.099] (EE) Server terminated with error (1). Closing log file.

Началось после того как скачал обновления с репозитория X11:Xorg. Решил откатом пакета xorg-x11-server с 1.14.3 на 1.14.1.

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

100. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от AnonuS on 02-Ноя-13, 06:54 
Ага, так и есть, тоже на 1.14.1 откатился и тоже из "X11:Xorg" эта зараза прилетела.
Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

206. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 18:14 
А я думал, я один пользуюсь этим сторонним репозиторием. Мой совет кому-то помог! Неожиданно и приятно...
Ответить | Правка | ^ к родителю #100 | Наверх | Cообщить модератору

111. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 10:50 
Нвидия - беспроблемные видеоадаптеры, ага. То иксы падают, то модуль не собирается...
Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

114. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 11:14 
> Нвидия - беспроблемные видеоадаптеры, ага. То иксы падают, то модуль не собирается…

что характерно — «видеоадаптер» к этому отношения не имеет.

Ответить | Правка | ^ к родителю #111 | Наверх | Cообщить модератору

124. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:50 
> что характерно — «видеоадаптер» к этому отношения не имеет.

Зато его производитель и политика оного - очень даже. А поскольку железка без софта - куча металлолома, довольно странно рассматривать их совсем уж в отрыве друг о друга.

Ответить | Правка | ^ к родителю #114 | Наверх | Cообщить модератору

137. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:11 
довольно странно — это ставить чисто программные проблемы в вину железу.
Ответить | Правка | ^ к родителю #124 | Наверх | Cообщить модератору

164. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 15:00 
> довольно странно — это ставить чисто программные проблемы в вину железу.

Еще раз:
1) Железо без софта всего лишь кусок хлама, не имеющий практического применения. Железо может быть трижды замечательным, но если нет софта который его оживляет и позволяет использовать - это лишь кусок кремния, металла и пластмассы. Технологичный, но бесполезный артефакт. Т.к. ты в 1 лицо софт такого плана скорее всего не напишешь за разумное время - достаточно странно рассматривать железо совсем в отрыве от софта в комплект к нему.

2) Насчет замечательности железа нвидии тоже можно поспорить. Обычно нвидия делает весьма горячие чипы, работающие на пределе. Улучшать техпроцессы им обломно, так что логика такая что "через год-два все-равно выбросят". Так что средние и топовые GPU не зря при печати GTX на русском называются словом ПЕЧ. Хорошо отражает суть дела. Кроме того, архитектурно оно больше всего заточено на игры. Параллельные вычисления - до кучи. В общем выбор дeбилoватых геймеров, которым не в облом менять GPU раз в пару лет и главное - FPS в крысисе, и чтоб длиннее чем у Васи с соседней парты. А чего такого позитивного можно сказать о железе от нвидии - вообще малопонятно.

Ответить | Правка | ^ к родителю #137 | Наверх | Cообщить модератору

174. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от arisu (ok) on 02-Ноя-13, 16:25 
294-й, дорогой, посмотри, пожалуйста, с чего всё началось. ладно, я даже упрощу задачу: с комментария «Нвидия - беспроблемные видеоадаптеры, ага. То иксы падают, то модуль не собирается…»

а теперь поясни мне, будь любезен: какое отношение *видеоадаптер* имеет к падению иксов и/или несобираемости модулей? если я этот видеоадаптер выйму — модуль внезапно соберётся, а кривой код починится?

Ответить | Правка | ^ к родителю #164 | Наверх | Cообщить модератору

217. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:27 
> если я этот видеоадаптер выйму — модуль внезапно соберётся, а кривой код починится?

Все гораздо проще: тебя перестанут @#$ть данные проблемы. Нет адаптера - нет проблем с глючным кодом под него. А у интеля и амд все как-то более культутно нынче :). Ну ок, за HD7000+ амдшники пока еще заслуживают волшебных пендалей. Но в целом прогресс весьма радует.

Ответить | Правка | ^ к родителю #174 | Наверх | Cообщить модератору

219. "NVIDIA пока не может решить проблему с совместимостью с..."  –3 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 19:33 
> А у интеля и амд
> все как-то более культутно нынче :). Ну ок, за HD7000+ амдшники
> пока еще заслуживают волшебных пендалей.

Неужели встроенная в CPU AMD графика в линуксе не работает и нужно ставить дискретную видеокарту и/или проприетарный блоб Каталист?

> Но в целом прогресс весьма радует.

Так в чём он, этот прогрес? Разверните мысль. В каком состоянии поддержка HD7000+ на массовых десктопах от AMD с линуксом на борту?


Ответить | Правка | ^ к родителю #217 | Наверх | Cообщить модератору

246. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 03-Ноя-13, 09:31 
> Неужели встроенная в CPU AMD графика в линуксе не работает

Работает. Просто она дохлая, как и графика от интеля. Чудес не бывает: мощный CPU и мощный GPU на одном кристалле просто не выдержат собственного тепла. Тем более что развести из 1 чипа еще и широкую шину памяти под GDDR5 - выглядит как mission impossible. А без нее толку то с мощного GPU?

> и нужно ставить дискретную видеокарту

Дискретную видеокарту нужно ставить если хочется получить сколь-нибудь вменяемую производительность (в играх, вычислениях, etc). Скоростной GDDR5 на выделенной широкой шине идущей прямиком в GPU сложно чем-то сэмулировать. А в интеграте - DDR3 надрывается на CPU и GPU сразу. Что, ессно, тормозно. И GPU урезанный - на мощный TDP не хватит.

> и/или проприетарный блоб Каталист?

Да нафиг, как минимум HD4000-HD6000 и младшие 7000 и без него хорошо работают. С HD7000+ на GCN пока сложнее, да.

> Так в чём он, этот прогрес?

1) Запилили хорошо работающее динамическое управление частотами и вольтажами, на уровне каталиста практически. Без глюков и побочных эффектов. Хорошо работает. Как минимум на 5770 - просто сказка, температура #$нулась на 15 градусов вниз в простое, при том что потерь в производительности не обнаружено - при нагрузке GPU быстро валит на максимум.
2) Запилили декодирование видео через UVD, вывесив через VDPAU. Реально работает, без дypаков. Не то что без него жить нельзя, но какойнить HTPC сможет играть видео не раскручивая процовый вентилятор.
3) Впилили оптимизатор шейдеров от Vadim Girlin. При том универсальный - он оптимизит что за LLVM, что за местечковым кодогенератором. Выигрывают все.
4) Убер-дохрена доработок, так что драйвер стал на уровне OpenGL3.1 примерно и основательно прибавил в скорости. Этого хватает даже для довольно тяжелых двигунов.

> Разверните мысль. В каком состоянии поддержка
> HD7000+ на массовых десктопах от AMD с линуксом на борту?

Зависит от того что именно понимается под 7000+. Младшие модели - на основе традиционного VLIW и цепляются драйвером R600, так что работать будут на ура. Средние и старшие GPU 7000 серии (HD77xx и мощнее) - это GCN, там уже RadeonSI. Который тоже основательно прибавил, но пока не так хорош как драйвер R600 и там Catalyst имеет больше смысла. Тем не менее, динамическое управление питанием, UVD и прочие полезности - будут работать и на GCN. Да и 3D приближается к GL 3.1 уже все-таки. Просто пока слабо оптимизировано и все-таки проигрывает R600 по полноте фич. Но опять же, прогресс за последние месяцы - весьма внушительный.

Ответить | Правка | ^ к родителю #219 | Наверх | Cообщить модератору

229. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от arisu (ok) on 02-Ноя-13, 20:27 
вопрос был совсем другой.
Ответить | Правка | ^ к родителю #217 | Наверх | Cообщить модератору

266. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 03-Ноя-13, 18:27 
> вопрос был совсем другой.

Вопрос был по сути о том что железо без софта - ни о чем. Пара примеров.

Вот лежит у меня на столе микроконтроллер. Сам по себе - довольно бесполезный кусок пластмассы, кремния и металла. "По дефолту" не может вообще ничего полезного. Ну разве что брелок можно сделать. Хреновенький и невзрачный. А чем он там потом станет и насколько это будет полезным - определяет зашитый в него софт.

Или вот, например, iPhone. Вроде бы само по себе железо - ничем таким особо не плохо. Но вот опаскуженный софт, начиная от загрузчика в ROM проца и далее - все сильно портит, т.к. без позволения эппла оно вообще твой код выполнять не собирается...

Ответить | Правка | ^ к родителю #229 | Наверх | Cообщить модератору

267. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от arisu (ok) on 03-Ноя-13, 18:56 
>> вопрос был совсем другой.
> Вопрос был по сути о том что железо без софта — ни о чем.

нет.

Ответить | Правка | ^ к родителю #266 | Наверх | Cообщить модератору

279. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от anonymus on 04-Ноя-13, 03:43 
> а теперь поясни мне, будь любезен: какое отношение *видеоадаптер* имеет к падению
> иксов и/или несобираемости модулей? если я этот видеоадаптер выйму — модуль
> внезапно соберётся, а кривой код починится?

Исходя из тематики ресурса, не трудно догадаться что высказывание следует интерпретировать в контексте *nix-систем, а значит успехи нвидии в тестах под виндовс хотя и позволяют говорить об успешности видеоадаптеров в общем, не позволяют сделать никаких выводов об их производительности в условиях *nix-систем.

Обычно люди, в отличие от роботов, хорошо умеют обнаруживать контекст и обрабатывать фразы, накладывая от него дополнительные ограничения.

Ответить | Правка | ^ к родителю #174 | Наверх | Cообщить модератору

285. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:25 
телепаты в отпуске.
Ответить | Правка | ^ к родителю #279 | Наверх | Cообщить модератору

224. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Michael Shigorin email(ok) on 02-Ноя-13, 19:43 
> Решил откатом пакета xorg-x11-server с 1.14.3 на 1.14.1.

http://lists.altlinux.org/pipermail/sisyphus/2013-November/3... :)

Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

234. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от AnonuS on 02-Ноя-13, 21:44 
>> Решил откатом пакета xorg-x11-server с 1.14.3 на 1.14.1.
> http://lists.altlinux.org/pipermail/sisyphus/2013-November/3... :)

Мишаня у вас там, в Сизифе, версии другие ( скопировал со странички по ссылке ):

"Добрый день.

В обновлениях, которые сегодня приехали ко мне из сизифа, были и

xorg-server-2:1.14.4-alt1, xorg-xvfb-2:1.14.4-alt1,
xorg-server-common-2:1.14.4-alt1

Эта версия xorg падает из-за модуля nvidia. Пришлось откатиться на 1.14.3"


У нас 1.14.3 уже падучая. Ты не дебажил случаем, интересно где там лошадь порылась?

Ответить | Правка | ^ к родителю #224 | Наверх | Cообщить модератору

304. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Michael Shigorin email(ok) on 06-Ноя-13, 02:30 
> У нас 1.14.3 уже падучая. Ты не дебажил случаем, интересно где там
> лошадь порылась?

Не-а, у меня десять лет спустя плавно повывелись нвидии на основном рабочем железе.  Это надо стенд собирать, что бы и хорошо вместе с майнтейнером xorg сделать, но не в приоритете...

Ответить | Правка | ^ к родителю #234 | Наверх | Cообщить модератору

228. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 20:21 
> Решил откатом пакета xorg-x11-server с 1.14.3 на 1.14.1.

Микробенчмарк gears из mesa-demos какие показатели выдаёт?


Ответить | Правка | ^ к родителю #94 | Наверх | Cообщить модератору

303. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Michael Shigorin email(ok) on 06-Ноя-13, 02:15 
> Микробенчмарк gears из mesa-demos какие показатели выдаёт?

http://wiki.cchtml.com/index.php/Glxgears_is_not_a_Benchmark

Ответить | Правка | ^ к родителю #228 | Наверх | Cообщить модератору

262. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним_тот_же on 03-Ноя-13, 17:27 
> Елы-палы, заколдованный круг какой-то с NVidia дровами в этот раз, первый раз
> такая лажа...
> openSUSE 12.3 ( ведро 3.11.6 )

В openSUSE 12.3 ядро 3.7.10. Ручки зачесались, вот и лажа.

> openSUSE 13.1 ( ведро 3.11.6 )

И что там такого супер полезного. Я не вижу никакой разницы между openSUSE 12.3 и openSUSE 13.1. Или плохо спится без обновлений.

Ответить | Правка | ^ к родителю #90 | Наверх | Cообщить модератору

271. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Led (ok) on 03-Ноя-13, 20:54 
> Я не вижу никакой разницы между openSUSE 12.3 и openSUSE 13.1.

Это что-то говорит о тебе, но не об openSUSE

Ответить | Правка | ^ к родителю #262 | Наверх | Cообщить модератору

41. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от grem on 01-Ноя-13, 22:18 
> Набежал владелец NVidia...

Печально :(
Не понимаю, почему NVidia просто не выпустила пропатченные версии тех же самых драйверов просто с этим исправлением? И почему они заранее к этому не подготовились?


Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

45. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +10 +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:21 
>  И почему они заранее к этому не подготовились?

Потому что нормальные компании - заинтегрировались в процесс и пилят драйвера вместе с ядерщиками. А нвидия получила то что заслужила: благодаря своей политике они для разработчиков ядра - никто. И звать никак. Раз они такие сами с усами - пусть и выруливают теперь как умеют. Да-да, чтобы иметь влияние на процесс разработки - в нем надо принимать участие, хотя-бы. А это совсем не про пиление в свое загоне проприетарной фигни, которая всем майнлайновым програмерам довольно-таки по барабану.

Ну и результат не заставил себя ждать
- У амд открытый драйвер начинает местами даже обгонять проприетару по скорости (!!! - http://www.phoronix.com/vr.php?view=19288). Ну и разумеется, открытый драйвер не имеет таких проблем - ядерный модуль часть ядра, сие не может отвалиться ВНЕЗАПНО.
- А у нвидии открытый драйвер показывает 1/5 от производительности блоба (http://www.phoronix.com/scan.php?page=news_item&px=MTQ5NTA), а блоб - ВНЕЗАПНО отваливается, т.к. на него в майнлайне всем сильно перпендикулярно.

Ответить | Правка | ^ к родителю #41 | Наверх | Cообщить модератору

58. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от iZEN (ok) on 01-Ноя-13, 23:48 
>>  И почему они заранее к этому не подготовились?
> Потому что нормальные компании - заинтегрировались в процесс и пилят драйвера вместе с ядерщиками.

Нормальные системы не ломают ABI между ядром и сторонними модулями ядра. (Что-то во FreeBSD при переходе с версии на версию нет проблемы с nvidia.ko, а у Linux есть).

Ответить | Правка | ^ к родителю #45 | Наверх | Cообщить модератору

62. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:59 
Правильно! Мы - лучшие друзья проприетарщиков. И мы гордимся этим!
Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

112. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 10:52 
> Правильно! Мы - лучшие друзья проприетарщиков. И мы гордимся этим!

Поэтому им диктуют и проприетарщики из нвидии (упрввление памятью в amd64), и линуксоиды(KMS придумали они). Тряпки без собственного вектора развития и возможности менять мир под себя.

Ответить | Правка | ^ к родителю #62 | Наверх | Cообщить модератору

233. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Фтщтнь on 02-Ноя-13, 21:17 
>> Правильно! Мы - лучшие друзья проприетарщиков. И мы гордимся этим!
> Поэтому им диктуют и проприетарщики из нвидии (упрввление памятью в amd64), и
> линуксоиды(KMS придумали они). Тряпки без собственного вектора развития и возможности
> менять мир под себя.

Менять мир это ломать ABI от версии к версии? У меня для вас плохие новости, это называется по-другому, если быть точным, то отсутствие долгосрочной стратегии развития.

Ответить | Правка | ^ к родителю #112 | Наверх | Cообщить модератору

247. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 03-Ноя-13, 09:35 
> Менять мир это ломать ABI от версии к версии?

Это возможность развивать и изменять свою систему не строясь под каких-то левых проприетарщиков.

> долгосрочной стратегии развития.

Угу, расскажите Торвальдсу о управлении проектами. А что, у вас есть не менее успешный проект, где стратегия выстрелила?

Ответить | Правка | ^ к родителю #233 | Наверх | Cообщить модератору
Часть нити удалена модератором

286. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:27 
> иной подход к разработке и достигнутые ими результаты ЗНАЧИТЕЛЬНО превосходят достижения
> Торвальдса.

это да: победоносное шествие m$ на мобильном фронте мы можем наблюдать прямо сейчас. а сервера на макоси просто таки заполонили датацентры.

Ответить | Правка | ^ к родителю #137 | Наверх | Cообщить модератору

293. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от Аноним (??) on 04-Ноя-13, 12:51 
> это да: победоносное шествие m$ на мобильном фронте мы можем наблюдать прямо
> сейчас. а сервера на макоси просто таки заполонили датацентры.

Да, и миллионы юнитов эмбедовки типа всяких насов и точек доступа - повально все с макосью и виндами. И вон там в топ500 - одни винды. Действительно - одни. На 1 суперкомпьютере. Из 500.

Ответить | Правка | ^ к родителю #286 | Наверх | Cообщить модератору

63. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Crazy Alex (ok) on 02-Ноя-13, 00:00 
Ну если "нормальными" считать системы, в которых проприетарщика защищают от пользователя, а не наоборот...

Как по мне - очень удачно надавили на NVidia, может дойдёт наконец, по каким правилам в линуксе играть.

Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

69. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Куяврик on 02-Ноя-13, 00:13 
> Нормальные системы не ломают ABI между ядром и сторонними модулями ядра.

А я, бедолага, всегда думал, что важнее API... для sourcebased-то систем.

>  а у Linux есть

справедливости ради: уже давно не было проблем с nvidia в лялихе.  вот только вылезла, да.

Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

74. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от vitalif (ok) on 02-Ноя-13, 01:30 
Ага, совсем не было. а оптимус не в счёт?
Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

89. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от ананим on 02-Ноя-13, 03:41 
А в бзде значится оно работает?

Зыж
Айзену подачку дали и он теперь опу рвёт, лояльность показывает... а то вдруг обратно заберут.
Линух то свою позицию продавит (см. последний абзец), а бздя так и будет к технологиям 90-х прикручивать костыли, линуксуляторы и тд... приговаривая — Спасибо, барин, кормилец ты наш.

Ответить | Правка | ^ к родителю #74 | Наверх | Cообщить модератору

113. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:12 
> справедливости ради: уже давно не было проблем с nvidia в лялихе.  

И Торвальдс волшебной палочкой махал чисто для антуража...


Ответить | Правка | ^ к родителю #69 | Наверх | Cообщить модератору

95. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +5 +/
Сообщение от Медсестра on 02-Ноя-13, 05:19 
(ласковым голосом)
Ах, вы опять вышли из палаты, товарищ iZEN! Конечно-конечно! Разумеется, в FreeBSD нет никаких проблем! А теперь скушайте таблеточек и давайте я проводу вас обратно в вашу палату. Говорите, у вас под койкой линуксоиды? Скушайте таблеточки и линуксоиды уйдут, обещаю вам!
Ответить | Правка | ^ к родителю #58 | Наверх | Cообщить модератору

109. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от sauron (??) on 02-Ноя-13, 10:48 
Зато они по попугаям догнали закрытые. Разница стала в процентах а не порядках выражаться.
Ответить | Правка | ^ к родителю #30 | Наверх | Cообщить модератору

2. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +9 +/
Сообщение от бедный буратино (ok) on 01-Ноя-13, 19:28 
отсюда правило - драйверы должны лежать в основном дереве ядра. и быть открытыми. :)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от anonymous (??) on 01-Ноя-13, 19:37 
И как это решит проблему с сабжем?
Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

13. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:54 
Тогда бы сначала исправили драйвера, а потом уже выкидывали бы. Ну или вообще оставили.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

47. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:27 
> И как это решит проблему с сабжем?

Элементарно, ватсон: ядро не будут релизить пока проблемы в его дровах не починят. И для тех кто интегрировался в процесс разработки майнлайна вынос функциональности не является ВНЕЗАПНЫМ!!!111 сюрпризом. Там все-таки подгоняют более-менее компоненты к друг другу и конструктивно взаимодействуют. А если кто хочет пилить драйвер в своем проприетарном закоулке - ну он и получает то что заслужил...

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

51. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 01-Ноя-13, 23:39 
если удалят нужную ф-ю, то ядро не соберётся /кэп.
Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

152. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 14:10 
> И как это решит проблему с сабжем?

Так нету же сабжа - нет проблемы.

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

36. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от vitalif email(ok) on 01-Ноя-13, 21:19 
+100500!

Лучше бы nouveau реклокинг отдали, чем выпендриваться тут, мол такие нехорошие разработчики ядра всё сломали.

Нивидия это вообще... "жопе слова не давали"! оптимус хде? Сколько лет прошло с момента появления технологии?!

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

83. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от pavlinux (ok) on 02-Ноя-13, 02:28 
>  оптимус хде? Сколько лет прошло с момента появления технологии?!

Где пля AMD Dynamic Switchable Graphics, где CrossFire?
Где в Intel хоть ваще чего-нибудь, i9xx-перделко, SVGA версии 2013 года, с опенжл версии 2003 года.

Ответить | Правка | ^ к родителю #36 | Наверх | Cообщить модератору

92. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 04:47 
кросфаер фуфло, сам bridgman писал что оно 99.999% чисто программное и тупо распределяет кадры через один. Проще и нужнее параллелить еще выше уровнем, в самом приложении.
Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

97. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 05:32 
Crossfire на Catalyst есть с релиза 8.8. Работает. Переключение графики тоже есть, но не динамическое. http://s60.radikal.ru/i168/1211/39/904aa53a29b2.jpg
Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

121. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:44 
> где CrossFire?

А ты посомтри что эти господа сделали с DMA-BUF и прочими ништяками вокруг. Не удивлюсь если наступит день, когда в линухе амд, нвидия и интел смогут распилить сцену на 3 куска и посчитать в меру своих возможностей.

> Где в Intel хоть ваще чего-нибудь,

Дядьку, оно тянет коммерческие гамесы типа TF2. Железо конечно гэ, но драйвера зато хорошие.

Ответить | Правка | ^ к родителю #83 | Наверх | Cообщить модератору

3. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от ILoveMicrosoft (ok) on 01-Ноя-13, 19:28 
Жуть, как же так. Зачем вот так ломать API? Понимаю что stable nonsense, но не до такой же степени...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:32 
слишком гордые были - это им щелчок по носу))
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

18. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +5 +/
Сообщение от Mike Lee on 01-Ноя-13, 20:14 
Вобще то это щелчок по носу пользователям.
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

29. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:45 
> Вобще то это щелчок по носу пользователям.

Пользователи nvidia его заслужили :)

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

80. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от rshadow (ok) on 02-Ноя-13, 02:01 
Найди несколько друзей/знакомых/родственников кто использует нвидию и скажи им что они придурки ... а мы запасемся попкорном.
Ответить | Правка | ^ к родителю #29 | Наверх | Cообщить модератору

126. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:52 
> придyрки ... а мы запасемся попкорном.

Ну не придурки а ССЗБ.

Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

211. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от mine (ok) on 02-Ноя-13, 18:25 
Специально для этих целей добавил в закладки, скажу одминам на работе.
Ответить | Правка | ^ к родителю #80 | Наверх | Cообщить модератору

6. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +4 +/
Сообщение от ip1981 (ok) on 01-Ноя-13, 19:34 
Это не API.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

16. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Нанобот (ok) on 01-Ноя-13, 20:09 
Это API
Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

44. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Ordu email(ok) on 01-Ноя-13, 23:06 
Это внутренний API ядра. Торвальдс и Ко всегда говорили что это их вотчина, что хотим, мол, то и делаем. Никаких гарантий стабильности они не давали никому.
Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

56. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от all_glory_to_the_hypnotoad (ok) on 01-Ноя-13, 23:43 
ну вот и плохо так делать.
Ответить | Правка | ^ к родителю #44 | Наверх | Cообщить модератору

85. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от chinarulezzz (ok) on 02-Ноя-13, 02:44 
подключайся к разработке ядра. Ну или пользуйся abi. разумный компромисс.
Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

127. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:53 
> ну вот и плохо так делать.

Напротив - так проприерасты всякие не могут им диктовать что делать и как развивать систему. Очень на пользу системе, знаете ли.

Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

153. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 14:15 
> ну вот и плохо так делать.

Кто сказал? Кому плохо-то? Да-да!??

Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

226. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Ordu email(ok) on 02-Ноя-13, 19:46 
> ну вот и плохо так делать.

Почему же плохо? Это даёт пространство для манёвра разработчикам ядра. Они в меньшей степени привязаны к неудачным или устаревшим решениям из прошлого. Да, это приводит к огромным неудобствам, типа переписывания всех драйверов usb-устройств, при очередной смене архитектуры стека usb. Но для кода включённого в ядро это не настолько критично, поскольку во-первых, мнение этого кода будет учтено при принятии решения о смене внутренних API, во-вторых, если всё же API сменится, то сообщество поможет переписать код, чтобы он работал на новых версиях ядра.

nvidia же пытается усидеть на двух стульях, естественно, что от этого развивается геморрой -- сидеть-то неудобно.

А вообще, не надо нам рассказывать о том, что плохо, а что хорошо. Если ты полагаешь, что лучше окружающих понимаешь ситуацию, то расскажи о своём понимании Линусу Торвальдсу лично -- ведь никто лучше тебя не сможет ему объяснить. Он, несомненно, будет очень рад твоему компетентному мнению, учтёт и всячески поспособствует внедрению твоей, более эффективной модели разработки ядра.

Ответить | Правка | ^ к родителю #56 | Наверх | Cообщить модератору

230. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 20:29 
а чего там рассказывать-то? форкнул ядро — и все дела. коли модель-то лучше — так народ с удовольствием перейдёт, я так мыслю.
Ответить | Правка | ^ к родителю #226 | Наверх | Cообщить модератору

238. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 23:03 
> а чего там рассказывать-то? форкнул ядро — и все дела. коли модель-то
> лучше — так народ с удовольствием перейдёт, я так мыслю.

"Чтобы установить наши новые дырверы 777.77.77, скачайте исходники нашего ядра по сцылке1. Если у Вас нет компилятора, его исходники будут предоставлены Вам по сцылке2."

Ответить | Правка | ^ к родителю #230 | Наверх | Cообщить модератору

239. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 02-Ноя-13, 23:13 
> «Чтобы установить наши новые дырверы 777.77.77, скачайте исходники нашего ядра по сцылке1.
> Если у Вас нет компилятора, его исходники будут предоставлены Вам по
> сцылке2.»

оплату за скачивание вносить по сцылке3.

Ответить | Правка | ^ к родителю #238 | Наверх | Cообщить модератору

248. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 03-Ноя-13, 09:39 
> оплату за скачивание вносить по сцылке3.

Э нет! Оплату за скачивание - по сцылке 0. Во первых, настоящие инженеры - считают с ноля. Во вторых, настоящие капиталисты берут деньги утром, а стулья только вечером,

Ответить | Правка | ^ к родителю #239 | Наверх | Cообщить модератору

249. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 03-Ноя-13, 09:40 
> а чего там рассказывать-то? форкнул ядро — и все дела.

Ну так кто хочет старье таскать до посинения - пусть идут и форкаются. А разработчикам майнлайна это зачем? Они работают над текущей кодовой базой. А старый крап - ну если найдется майнтайнер - он и майнтайнит. Как с старыми ядрами.

Ответить | Правка | ^ к родителю #230 | Наверх | Cообщить модератору

7. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:35 
чтобы потом нвидиа показать фак
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

8. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Xasd (ok) on 01-Ноя-13, 19:36 
> Жуть, как же так. Зачем вот так ломать API?

это если тебя послушать -- тыг будто якобы виноваты разработчики Linux а не разработчики NVidia :D

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

14. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от Нанобот (ok) on 01-Ноя-13, 20:06 
Так и есть. Разработчики ядра не позаботились об обратной совместимости
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

20. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:21 
> Разработчики ядра не позаботились об обратной совместимости

Разработчики ядра позаботились об обратной совместимости, выпустив ядро под лицензией, прямо запрещающей его распространение со сторонними закрытыми модулями.

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

21. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от IMHO on 01-Ноя-13, 20:30 
ну так это единственная свободная лицензия, которая разрешает программировать в стиле ".. for fan"
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

28. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:44 
>  ну так это единственная свободная лицензия, которая разрешает программировать в стиле ".. for fan"

Все остальные, включая проприетарщиков, программируют в этом стиле безо всяких разрешений.

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

42. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +5 +/
Сообщение от oxyum (ok) on 01-Ноя-13, 22:21 
> for fan

Это как, накидывая на вентилятор? :-D

Ответить | Правка | ^ к родителю #21 | Наверх | Cообщить модератору

32. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:58 
кто вам сказал такую чушь? распространять ядро можно с любым модулем. Только модификации ядра надо положить рядом с модулем.
Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

40. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от IMHO on 01-Ноя-13, 21:50 
судя по zfsonlinux мы видим что с этого выходит "ни рыба и не мясо"
Ответить | Правка | ^ к родителю #32 | Наверх | Cообщить модератору

122. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:47 
> судя по zfsonlinux мы видим что с этого выходит "ни рыба и не мясо"

При том вопросы надо санкам задавать. Они специально выбирали несовместимую лицензию. Ну так было б ядро не под GPL - сани бы еще чего-нибудь в лицензии подгадили бы. Автор может писать в лицензии что хочет, в том числе и неудобное Васе Пупкину, разработчикам линукса или кому там еще. На то и автор.

Ответить | Правка | ^ к родителю #40 | Наверх | Cообщить модератору

49. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:29 
> прямо запрещающей его распространение со сторонними закрытыми модулями.

И ввинчивая TAINT при вгрузке проприетарного модуля, так что с багами в таком ядре вы потом будете жаловаться исключительно в спортлото.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

64. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 00:01 
> И ввинчивая TAINT при вгрузке проприетарного модуля, так что с багами в
> таком ядре вы потом будете жаловаться исключительно в спортлото.

В нвидию же. Сами сломали - пусть сами и чинят.

Ответить | Правка | ^ к родителю #49 | Наверх | Cообщить модератору

116. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 11:28 
>> И ввинчивая TAINT при вгрузке проприетарного модуля, так что с багами в
>> таком ядре вы потом будете жаловаться исключительно в спортлото.
> В нвидию же. Сами сломали — пусть сами и чинят.

нет, лучше в Спортлото: вероятность реакции больше.

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

123. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:48 
>> будете жаловаться исключительно в спортлото.
> В нвидию же.

А есть какая-то разница? Может даже сломали и не они. Но никто не будет разбираться. Ядро tainted? Вот сам и колупайся!

Ответить | Правка | ^ к родителю #64 | Наверх | Cообщить модератору

76. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от grem on 02-Ноя-13, 01:46 
>> Разработчики ядра не позаботились об обратной совместимости
> Разработчики ядра позаботились об обратной совместимости, выпустив ядро под лицензией,
> прямо запрещающей его распространение со сторонними закрытыми модулями.

Если бы таким образом поломалась совместимость с ati-drivers, то о поломанной обратной совместимости никто б не говорил :) Осталось подождать заявлений от поддержки Arch, что драйвера не совместимы с новыми ядрами и их нужно убрать из основного репозитория. Обычно выкидывания у них пакетов сопровождаются отмазками вида "мы написали им с просьбой о поддержке, но нам не ответили и мы выкинули пакет". Мне как-то казалось, что обычно поддержка дистрибутива должна заботиться о совместимости с другими пакетами и отслеживать зависимости, но ментейнеры Arch другого мнения - разработчики пакетов должны заботиться, чтобы пакет был совместим с тем, что запихнули в дистрибутив.

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

173. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от st (??) on 02-Ноя-13, 16:17 
так работает же все, две недели уже как ядро 3.11.6, nvidia-325.15
Ответить | Правка | ^ к родителю #76 | Наверх | Cообщить модератору

240. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним_тот_же on 02-Ноя-13, 23:56 
> так работает же все, две недели уже как ядро 3.11.6, nvidia-325.15

Все, да не все.

Ответить | Правка | ^ к родителю #173 | Наверх | Cообщить модератору

108. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 09:49 
Так говорите, будто это разработчики NVidia из ядра функционал удалили/заменили.
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

129. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:55 
> Так говорите, будто это разработчики NVidia из ядра функционал удалили/заменили.

Они допустили гораздо более глубокую и системную ошибку - не интегрировались в процесс разработки. Поэтому с ними никто не считается. Внезапно, да?

Ответить | Правка | ^ к родителю #108 | Наверх | Cообщить модератору

133. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:05 
> Так говорите, будто это разработчики NVidia из ядра функционал удалили/заменили.

нвидия просто никак не может понять, как правильно делать драйвера под линукс. руководство нвидии отчего-то до сих пор уверено, что разработчики линукс будут бегать за ними и причитать: «а проверьте, будьте такие добренькие, а ничего с обновлением у вас не сломалось? а может, вам надо что-то? может, интерфейсик какой? ну, хоть за пивком холодным сбегать, а?»

Ответить | Правка | ^ к родителю #108 | Наверх | Cообщить модератору

48. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:28 
> Жуть, как же так. Зачем вот так ломать API? Понимаю что stable
> nonsense, но не до такой же степени...

Затем что никто не собирается в открытой системе строиться под причуды проприерасов. Особенно столь некооперативных как нвидия.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

98. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Georg Rudoy on 02-Ноя-13, 05:39 
Кстати, да. Выглядит исключительно забавно, если вспомнить позицию Торвальдса пару лет назад в случае бага, открывшегося в проприетарном флешплеере при смене поведения memcpy.
Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

128. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 11:53 
> Кстати, да. Выглядит исключительно забавно, если вспомнить позицию Торвальдса пару лет
> назад в случае бага, открывшегося в проприетарном флешплеере при смене поведения
> memcpy.

ну так, видать, у торвальдса не нвидия, вот его и не волнует. а когда ютубчег работать перестал — конечно, он засуетился.

Ответить | Правка | ^ к родителю #98 | Наверх | Cообщить модератору

130. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:56 
> ну так, видать, у торвальдса не нвидия, вот его и не волнует.

Было бы странно, если бы у него была нвидия. Он что, враг себе чтоли? Довольно странно пользовать видеокарту того в чью сторону машешь факом за некооперативность. Некооперативность вендора - 100% заявка на головняк.


Ответить | Правка | ^ к родителю #128 | Наверх | Cообщить модератору

138. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:13 
> пользовать видеокарту

и чем он их пользует? таблеточками? порошками?

алё, идиоты! «пользовать» и «использовать» имеют СОВЕРШЕННО разные значения!

Ответить | Правка | ^ к родителю #130 | Наверх | Cообщить модератору

166. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 15:10 
> «пользовать» и «использовать» имеют СОВЕРШЕННО разные значения!

С местными грамотеями - в два счета папуасом станешь :(. "Пазор", да.

Ответить | Правка | ^ к родителю #138 | Наверх | Cообщить модератору

169. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 15:20 
извиняюсь за «идиотов», кстати — это не лично к тебе, это «крик души» был, так сказать.
Ответить | Правка | ^ к родителю #166 | Наверх | Cообщить модератору

10. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:38 
Получается что Nvidia использовала грязный хак. Хак выкинули и почистили API.

Всегда и всем говорил что грязные хаки это путь в ад.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

12. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –5 +/
Сообщение от Аноним (??) on 01-Ноя-13, 19:53 
>Всегда и всем говорил что грязные хаки это путь в ад.

У ядра нет API душечка. Есть огромный исходный текст который как-то работает и очень мало кто понимает как. А делать то что-то надо и драйвера писать как-то надо.

С другой стороны nvidia могла бы добавить в ядро все что её нужно для нормальной работы...

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

15. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:07 
Спасибо, повеселил. Давно я такую ахинею не читал :)
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

22. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от Аноним (??) on 01-Ноя-13, 20:31 
Он всё правильно написал, только надо было добавить "стабильного API". Там действительно много мелких изменений, и всё часто "ломается". С виду всё хорошо, так как изменяющий API всяких вспомогательных функций-макросов должен вносить изменения в весь код, который затронут. А вот разработчикам сторонних модулей -- это большая головная боль.
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

27. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Crazy Alex (ok) on 01-Ноя-13, 20:41 
Ну логично - это становится головной болью либо тех, кто кооперироватья и разрабатывать в мейнлайне не желает, либо маргинального меньшинства, у которого нет ресурсов, чтобы достаточно качественно поддерживать свой код в основной ветке. Альтернатива-  свалить головную боль на разработчиков мейнлайна и их пользователей и благополучно убить развитие системы.
Ответить | Правка | ^ к родителю #22 | Наверх | Cообщить модератору

23. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от anonimus on 01-Ноя-13, 20:36 
Ради прикола, расскажите об экспортируемых функциях в ядре.
Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

33. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от egress email(ok) on 01-Ноя-13, 21:08 
> Есть огромный исходный текст который как-то работает и очень мало кто понимает как. А делать то что-то надо и драйвера писать как-то надо.

Откройте книгу по ОС и откройте для себя чудо превращения хаоса в структурированное понимание как что работает.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

35. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 01-Ноя-13, 21:18 
> У ядра нет API душечка. Есть огромный исходный текст который как-то работает
> и очень мало кто понимает как.

да что там — вообще никто не понимает. а все контрибуторы — это на самом деле один большой ИИ.

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

131. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:57 
> У ядра нет API душечка.

А UAPI и KAPI - это чего, не API?

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

39. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от asavah (ok) on 01-Ноя-13, 21:27 
Задолбали уже эти блобо-дельцы всех сортов и мастей.
В их же блин интересах чтоб их же продукцмя работала на всех вохможных осях.
Нет, надо какие-то мутные, закрытые, индусские поделки штамповать.
А тут в ведре что-то зачистили и подшаманили и обана! начинают всплывать костыли.

Бть, не хотите сами бабло тратить на разработку дров для открытых осей - дайте спеки, сообщество потихоньку разрулит что к чему и в какую дырку пихать 220В.

(Если что у меня нвидиа 760, в данный момент на nouveau, но фанбойством не страдаю)

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

50. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от pavlinux (ok) on 01-Ноя-13, 23:30 
Ёптя, Нвидя пистит мои патычи :) http://habrahabr.ru/post/195284/
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

55. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 01-Ноя-13, 23:42 
> Ёптя, Нвидя пистит мои патычи :) http://habrahabr.ru/post/195284/

Эк тебе в карму то нагадили...

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

59. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от pavlinux (ok) on 01-Ноя-13, 23:51 
>> Ёптя, Нвидя пистит мои патычи :) http://habrahabr.ru/post/195284/
> Эк тебе в карму то нагадили...

Да и хрен с ними, народ просил патчи куда-нить накласть.  
Мне был интересе сам процесс получения инвайта - написание какой-нить куеты. Прошло! :D

Ответить | Правка | ^ к родителю #55 | Наверх | Cообщить модератору

132. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:01 
> Да и хрен с ними, народ просил патчи куда-нить накласть.

Ага, бесплатно поработать на проприерастов и потом спасибо что не хук в челюсть а только минус в карму :). Благодарная работенка - гoвнo за проприерасами убирать :).

> Мне был интересе сам процесс получения инвайта - написание какой-нить куеты. Прошло! :D

Ну это да, это ж хабрашвабра :).

Ответить | Правка | ^ к родителю #59 | Наверх | Cообщить модератору

65. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 00:03 
> Ёптя, Нвидя пистит мои патычи :) http://habrahabr.ru/post/195284/

Молодец. Хвалю. Карму ты себе подпортил. С хабрецами лучше не связываться — сольют за милую душу. Мне слили за "С.Ш.А. — тюрьма народов.". Отминусовались за критику башизмов в скриптах для администрежа PostgreSQL. Сейчас на их сайтец могу писать раз в сутки, но и этого даже не хочется делать — противно.

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

72. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Crazy Alex (ok) on 02-Ноя-13, 00:49 
О, да ты еще и борец с США! Блин, экспонат. Тебя в кунсткамеру надо.
Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

87. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от chinarulezzz (ok) on 02-Ноя-13, 02:50 
> О, да ты еще и борец с США! Блин, экспонат. Тебя в
> кунсткамеру надо.

Изя многогранен :D

Ответить | Правка | ^ к родителю #72 | Наверх | Cообщить модератору

118. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 02-Ноя-13, 11:31 
>> О, да ты еще и борец с США! Блин, экспонат. Тебя в
>> кунсткамеру надо.
> Изя многогранен :D

глупость неисчерпаема. это мудрости может не хватить, а у глупости дна нет.

Ответить | Правка | ^ к родителю #87 | Наверх | Cообщить модератору

190. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от chinarulezzz (ok) on 02-Ноя-13, 17:13 
>>> О, да ты еще и борец с США! Блин, экспонат. Тебя в
>>> кунсткамеру надо.
>> Изя многогранен :D
> глупость неисчерпаема. это мудрости может не хватить, а у глупости дна нет.

философии тред)))

Если б мы могли всегда видеть, когда идея мудрости используется для сравнения и разделения людей на "более" и "менее" мудрых. Что тогда есть мудрость, если и она, неисчерпаема, бездонна, бесконечна? В каждом мудреце довольно простоты (русск); У кого не бывает ослиных ушей? (перс);

Ответить | Правка | ^ к родителю #118 | Наверх | Cообщить модератору

75. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от vadiml (ok) on 02-Ноя-13, 01:38 

> . Мне слили за "С.Ш.А. — тюрьма народов.".

Это потому что Вы не учили матчасть: тюрьма народов тут, а Европа и США -- это кладбище народов (см. В.В.Кожинова, например)

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

119. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Онон on 02-Ноя-13, 11:35 
OpenNet — тюрьма народов? Тонко...
Ответить | Правка | ^ к родителю #75 | Наверх | Cообщить модератору

139. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:35 
> Молодец. Хвалю. Карму ты себе подпортил. С хабрецами лучше не связываться —
> сольют за милую душу. Мне слили за "С.Ш.А. — тюрьма народов.".

Если посмотреть https://www.opennet.ru/~iZEN - можно обнаружить что тебя нежно любят не только на хабре, но и тут. Ты получил в 2 раза больше минусов чем плюсов, что как бы намекает что на хабре не так уж и неправы на твой счет.

> Отминусовались за критику башизмов в скриптах для администрежа PostgreSQL.

И правильно сделали - засорение атмосферы бухтением ни о чем. И жирных трололо там не жалуют, сливая их от души. Правда, зеленый бэджик ты не получил, FAIL. Чуть менее половины от номинала - недобор, однако.

> Сейчас на их сайтец могу писать раз в сутки,

Честно говоря тебе бы такой лимит и на опеннете не помешал - полезных сообщений от тебя я вообще не припоминаю.

Ответить | Правка | ^ к родителю #65 | Наверх | Cообщить модератору

158. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 14:39 
>> Молодец. Хвалю. Карму ты себе подпортил. С хабрецами лучше не связываться —
>> сольют за милую душу. Мне слили за "С.Ш.А. — тюрьма народов.".
> Если посмотреть https://www.opennet.ru/~iZEN - можно обнаружить что тебя нежно любят не
> только на хабре, но и тут. Ты получил в 2 раза
> больше минусов чем плюсов, что как бы намекает что на хабре
> не так уж и неправы на твой счет.

Да вот не люблю подлизывать зад тем, кто движется в потоке мейнстрима. Такой уж я от рождения. Не коллаборационист совсем. Отщепенец. Изгой.

Ответить | Правка | ^ к родителю #139 | Наверх | Cообщить модератору

305. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 08-Ноя-13, 03:19 
> Такой уж я от рождения. Не коллаборационист совсем. Отщепенец. Изгой.

Латентный проприетарщик в общем - совместно работать с другими не желаешь, а свобода тебе нужна только чтобы код в свою норку можно было уволочь.

Ответить | Правка | ^ к родителю #158 | Наверх | Cообщить модератору

160. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 14:46 
> Честно говоря тебе бы такой лимит и на опеннете не помешал - полезных сообщений от тебя я вообще не припоминаю.

А это разве не конструктивные посты:
https://www.opennet.ru/openforum/vsluhforumID3/92381.html#36
https://www.opennet.ru/openforum/vsluhforumID3/92298.html#10
https://www.opennet.ru/openforum/vsluhforumID3/92236.html#76
https://www.opennet.ru/openforum/vsluhforumID3/91761.html#373
https://www.opennet.ru/openforum/vsluhforumID3/92188.html#51
https://www.opennet.ru/openforum/vsluhforumID3/92166.html#29
https://www.opennet.ru/openforum/vsluhforumID3/92170.html#25
https://www.opennet.ru/openforum/vsluhforumID3/92162.html#58
https://www.opennet.ru/openforum/vsluhforumID3/92154.html#6

Или вы меня со свином Усира, который какает в каждой теме, путаете?

Ответить | Правка | ^ к родителю #139 | Наверх | Cообщить модератору

175. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:27 
> А это разве не конструктивные посты:
> https://www.opennet.ru/openforum/vsluhforumID3/92381.html#36

Ну, ок, даже 2 кексам понравилось, а 1 не оценил. Обычный капитанинг.

> https://www.opennet.ru/openforum/vsluhforumID3/92298.html#10

Я не понял что там конструктивное. Судя по 4 минусам - не только я.

> https://www.opennet.ru/openforum/vsluhforumID3/92236.html#76

Смесь предрассудков и маркетингового буллшита. От себя могу добавить что была бы в длинках бсдшечка - ты бы вообще сорца в жизни не увидал, а колупать фирмварь на 4 метра идой - дело печальное. Нафиг-нафиг. А на дыры это никак не повлияло бы. Можно подумать длинк стал бы более нормальных програмеров нанимать.

> https://www.opennet.ru/openforum/vsluhforumID3/91761.html#373

Я тебе там же и ответил :).

> https://www.opennet.ru/openforum/vsluhforumID3/92188.html#51

Фанатский флейм жабистов - такой забавный :). К счастью мне до балды ява, эклипс и нетбинс.

> https://www.opennet.ru/openforum/vsluhforumID3/92166.html#29

Прикольное описание танцев с бубном в результате перехода на шланг. Ну ок, посчитаем за конструктив. Хоть и в контексте "почему пользоваться фряхой - мазохизм".

> https://www.opennet.ru/openforum/vsluhforumID3/92170.html#25

Это не конструктив, это анекдот. Подмахивалки проприетариев никак не договорятся между собой, так что юному падавану приходится втихомолку GCC пользоваться, пока никто не видит.

> https://www.opennet.ru/openforum/vsluhforumID3/92162.html#58

Отмазки юного наивного надмозга - они такие :). Но это не конструктив а виляние попой.

> https://www.opennet.ru/openforum/vsluhforumID3/92154.html#6

Цитата из документации, рассказывающая про то что .n кой-как вроде заработал, с рядом грабель. Ну хоть не флейм. Хоть и копипаста.

> Или вы меня со свином Усира, который какает в каждой теме, путаете?

Да не, просто из 9 сообщений хоть как-то полезными или хотя-бы не вредными можно посчитать ~3. Зато остальные 6 с лихвой перевешивают. Там такие потоки ламерского и фанатского мировоззрения попадаются что просто офигеть.

Собственно соотношение минусов и плюсов 2:1 неплохо укладывается в эту картину :).

Ответить | Правка | ^ к родителю #160 | Наверх | Cообщить модератору

264. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним_тот_же on 03-Ноя-13, 18:11 
> Ёптя, Нвидя пистит мои патычи :) http://habrahabr.ru/post/195284/

Интересно почему num_physpages заменен на get_num_physpages, а не на totalram_pages?

Ответить | Правка | ^ к родителю #50 | Наверх | Cообщить модератору

61. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –6 +/
Сообщение от iZEN (ok) on 01-Ноя-13, 23:56 
Оставайтесь ребятки на Linux 3.10. Жуйте сопли в 3D и ждите, пока NVIDIA для новых ядер Linux выпустит свой драйвер. :))
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

66. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от pavlinux (ok) on 02-Ноя-13, 00:03 
> Оставайтесь ребятки на Linux 3.10. Жуйте сопли в 3D и ждите, пока
> NVIDIA для новых ядер Linux выпустит свой драйвер. :))

Думашь у многих тут 128Gb оперативки на борту?

Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

67. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –5 +/
Сообщение от iZEN (ok) on 02-Ноя-13, 00:08 
>> Оставайтесь ребятки на Linux 3.10. Жуйте сопли в 3D и ждите, пока
>> NVIDIA для новых ядер Linux выпустит свой драйвер. :))
> Думашь у многих тут 128Gb оперативки на борту?

Так ведь показатель: "Это уже привело к тому, что на официальном форуме компании, посвященном Linux, создано не менее десятка тем, где люди пытаются собственными силами решить проблему совместимости с ядрами Linux версии 3.11 и выше.", а не то, что драйвер якобы несовместим с новыми версиями. ;)

Хомячкам нужно приложить усилия для того, чтобы впилить новый драйвер в Ослинукс v>3.10.


Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

79. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от grem on 02-Ноя-13, 01:56 
> Хомячкам нужно приложить усилия для того, чтобы впилить новый драйвер в Ослинукс
> v>3.10.

кстати, а чего они им 3.11 так упёрлось то, если вроде как на 3.10 проблемы нет? о_О


Ответить | Правка | ^ к родителю #67 | Наверх | Cообщить модератору

155. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 14:22 
> кстати, а чего они им 3.11 так упёрлось то

Пиво, семки и 3.12-rc7. Уважуха во дворе.

Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

176. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:31 
> кстати, а чего они им 3.11 так упёрлось то, если вроде как
> на 3.10 проблемы нет? о_О

Самый троллфейс - у бетаверсия каталиста работает даже с ядром 3.12 (которое еще -RC).

Ответить | Правка | ^ к родителю #79 | Наверх | Cообщить модератору

78. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от grem on 02-Ноя-13, 01:53 
>> Оставайтесь ребятки на Linux 3.10. Жуйте сопли в 3D и ждите, пока
>> NVIDIA для новых ядер Linux выпустит свой драйвер. :))
> Думашь у многих тут 128Gb оперативки на борту?

я бы даже добавил, что не во всех дистрибутивах 3.11 имеет статус stable

Ответить | Правка | ^ к родителю #66 | Наверх | Cообщить модератору

177. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:33 
> я бы даже добавил, что не во всех дистрибутивах 3.11 имеет статус stable

Слоупочность майнтайнеров не имеет никакого отношения к стабильности ядра.

Ответить | Правка | ^ к родителю #78 | Наверх | Cообщить модератору

68. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от crypt (ok) on 02-Ноя-13, 00:09 
я вообще не понимаю, чего волноваться. все эти последние он-лайн войны под знаменами "убунту внедрило то", "убрали се", "поломали это", "обнаружили эксплойт в rc"... меня совершенно не касаются - установил EL и все работает на 2.6.32...
Ответить | Правка | ^ к родителю #61 | Наверх | Cообщить модератору

181. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:43 
> на 2.6.32...

Только на десктопе этим окаменелым куском г-на мамонта пользоваться не особо удобно, знаете ли. Как и вообще RHEL-based.

Ответить | Правка | ^ к родителю #68 | Наверх | Cообщить модератору

70. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 00:29 
Теперь очередь Нвидии показывать фак Торвальдсу!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

88. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от chinarulezzz (ok) on 02-Ноя-13, 02:52 
> Теперь очередь Нвидии показывать фак Торвальдсу!

а значит и своим пользователям заодно :)

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

178. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:33 
> Теперь очередь Нвидии показывать фак Торвальдсу!

Не получится: он себе не враг и нвидией нигде не пользуется.

Ответить | Правка | ^ к родителю #70 | Наверх | Cообщить модератору

73. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 01:24 
Снова Fuck You, Nvidia?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

77. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от клоун Стаканчик on 02-Ноя-13, 01:48 
С прошлого раза они так и не стали платиновыми спонсорамр. Урок не изучен, проблемы будут повторяться. Это для вас опен и фри, а кое для кого это зарплата.
Ответить | Правка | ^ к родителю #73 | Наверх | Cообщить модератору

140. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:38 
> С прошлого раза они так и не стали платиновыми спонсорамр.

О, хорошая идея. Такие как нвидия заслуживают максимально болезненного пендаля под зад. Ну раз по хорошему не понимают.

Тут и китайцы ушли с заказом на полмиллиарда баксов, потому что в невидии не могут собрать драйвер под MIPSовые компьютеры. Торвальдс показал фак. Теперь вот это. Походу так нвидии гораздо понятнее получается :).

Ответить | Правка | ^ к родителю #77 | Наверх | Cообщить модератору

141. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:40 
что характерно: страдают всё равно пользователи. паны дерутся — у холопов чубы трещат.
Ответить | Правка | ^ к родителю #140 | Наверх | Cообщить модератору

145. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:46 
> что характерно: страдают всё равно пользователи.

Те кто вляпывается в проприетару - должны страдать. By design.

Ответить | Правка | ^ к родителю #141 | Наверх | Cообщить модератору

147. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:49 
>> что характерно: страдают всё равно пользователи.
> Те кто вляпывается в проприетару — должны страдать. By design.

я так понимаю, ты свой комментарий написал с лично тобой сдизайненого и спаянного компьютера?

Ответить | Правка | ^ к родителю #145 | Наверх | Cообщить модератору

157. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 14:38 
> я так понимаю, ты свой комментарий написал с лично тобой сдизайненого и
> спаянного компьютера?

Как бы это сказать... в моем компьютере самые большие претензии вызывает кривой проприетарный BIOS, если уж на то пошло. Потому что имеет ряд глупых и назойливых глюков, которые поправить в принципе не судьба. Хорошо что хоть линь после загрузки это кривое нечто оставляет не у дел.

Ну и как бы я рад купить компьютер с 100% открытыми спеками и bootloader'ом. Но пока с этим сложновато. Такое появляется, но выбор пока нишевой и хиловатый, в основном относительно мелкая и малорасширяемая околоэмбедовка. А вот с GPU выбор таки есть. И с драйверами тоже. Нвидия не единственный производитель GPU а их блобики не единственный драйвер в мире, работающий в линухе.

Ответить | Правка | ^ к родителю #147 | Наверх | Cообщить модератору

159. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 14:40 
я тебе мягко намекал, что в стеклянном доме кидание камнями чревато.
Ответить | Правка | ^ к родителю #157 | Наверх | Cообщить модератору

179. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 16:35 
> я тебе мягко намекал, что в стеклянном доме кидание камнями чревато.

А я тебе прозрачно намекал что я - за деблобизацию и открытые исходники.

Ответить | Правка | ^ к родителю #159 | Наверх | Cообщить модератору

182. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 16:47 
>> я тебе мягко намекал, что в стеклянном доме кидание камнями чревато.
> А я тебе прозрачно намекал что я — за деблобизацию и открытые
> исходники.

вот только к «юзеры проприетарщины должны страдать» это отношения не имеет. ты должен страдать, потому что используешь проприетарщину. и — как пользователь проприетарщины — молчи, пока не очистишься.

Ответить | Правка | ^ к родителю #179 | Наверх | Cообщить модератору

196. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от клоун Стаканчик on 02-Ноя-13, 18:00 
И, разумеется, создание проблем таким пользователям поможет повышению интереса к СПО и к продвижению Линукса в целом. Отличная идея!
Ответить | Правка | ^ к родителю #182 | Наверх | Cообщить модератору

198. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 02-Ноя-13, 18:03 
с «продвижением линукса» иди к тем, кому оно нужно. лично мне оно не нужно и я категорически против.
Ответить | Правка | ^ к родителю #196 | Наверх | Cообщить модератору

201. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 18:04 
> И, разумеется, создание проблем таким пользователям поможет повышению интереса к СПО и
> к продвижению Линукса в целом. Отличная идея!

Конечно, поможет. См. там наверху -- как инвидия заинтересовалась. Прошлый раз она была так заинтересована пальцем Линуса.

Ответить | Правка | ^ к родителю #196 | Наверх | Cообщить модератору

207. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от клоун Стаканчик on 02-Ноя-13, 18:18 
Репутация зарабатывается годами и теряется с первой ошибкой. Подумай над этим.
Ответить | Правка | ^ к родителю #201 | Наверх | Cообщить модератору

214. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Andrey Mitrofanov on 02-Ноя-13, 18:52 
> Репутация зарабатывается годами и теряется с первой ошибкой.

Репутацию средь "таких пользователей" нужно терять превентивно-проактивно. А то ж теперь не отмоешься.

> Подумай над этим.

И среди "такие" думателей.

Ответить | Правка | ^ к родителю #207 | Наверх | Cообщить модератору

221. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:40 
> вот только к «юзеры проприетарщины должны страдать» это отношения не имеет.
> ты должен страдать, потому что используешь проприетарщину.

ИЧСХ глюкавый BIOS с довольно невкусными закидонами меня как-то не радует. Думаю довольно логично что я в результате с большой симпатией отношусь к вещицам типа u-boot, и если так обратить внимание - эта вещица тихой сапой подмяла под себя уйму эмбедовки всех мастей, став "Linux в мире boot loader'ов" (кроме шуток, его апи драйверов слизано с Linux как я понимаю).

Ответить | Правка | ^ к родителю #182 | Наверх | Cообщить модератору

284. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от anonymus on 04-Ноя-13, 06:07 
> вот только к «юзеры проприетарщины должны страдать» это отношения не имеет. ты
> должен страдать, потому что используешь проприетарщину. и — как пользователь проприетарщины
> — молчи, пока не очистишься.

Странный у тебя подход. Я вот тоже несчастный пользователь проприетарщины. И не вижу почему должен молчать. Все пользователи проприетарщины должны страдать тем больше, чем больше в неё вляпались. И да, я придерживаюсь универсализма и полагаю, что в том числе страдать должен и я. И стоически переживаю все глюки и недоработки проприетарного индусостроения, сдобренного добрым менеджментом жмотов из оплота демократии.

Ответить | Правка | ^ к родителю #182 | Наверх | Cообщить модератору

287. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:31 
> Странный у тебя подход. Я вот тоже несчастный пользователь проприетарщины. И не
> вижу почему должен молчать.

потому что высказывания «проприетарщина — это как минимум неудобно, давайте по мере сил от неё избавляться» и «пользователи проприетарщины должны страдать» — совершенно разные высказывания. обсуждаем мы — если кто не заметил — именно второе.

Ответить | Правка | ^ к родителю #284 | Наверх | Cообщить модератору

294. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним (??) on 04-Ноя-13, 12:59 
На самом деле я конечно первое хотел сказать, так что спасибо за капитанинг. Но второе не настолько уж и неправда, потому что оно как-то так получается в результате. Чисто статистически с проприетарщиной постоянно какой-нибудь дурной головняк совершенно на ровном месте. Поэтому при первой же возможности данный балласт ИМХО следует скидывать за борт.
Ответить | Правка | ^ к родителю #287 | Наверх | Cообщить модератору

93. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 05:08 
Обожаю NVIDIA. Когда я пользуюсь их видеокартами в Linux, то начинает как будто легче дышаться.

На работе я могу расслабиться и поиграть в майнкрафт, такая возможность есть. Туда я принёс NVIDIA. Дома у меня Radeon. Система при этом одна, установленная на переносной HDD. Вот например Trine 2. У Radeon FPS хватает, но иногда случаются рывки. На NVIDIA FPS ниже (старая модель), но никаких рывков. Так как я запускаю игру в один и тот же день, это бросается в глаза! Но в Trine это не критично. Это же не сетевой шутер, но неприятно. Но наиболее критичны такие вещи в различных редакторах: аудио, видео и 3D. Когда нужно не играть, а работать, я советую NVIDIA и только NVIDIA.

P.S. У меня вопрос к знатокам. Я пользуюсь KDE3 из репозитория KDE:KDE3 в openSUSE. И на старом Debian 5.0 то же самое. Открытые драйверы radeon, nouveau и закрытый fglrx выдают один размер шрифтов в интерфейсах KDE3, а закрытый NVIDIA - другой. Причём NVIDIA выдаёт шрифты лучше: более сглажены и красивы. Особенно хорошо это видно на окне логина kdm: при одном и том же разрешении экрана на всех драйверах прямоугольничек окна имеет один размер, а на NVIDIA отмасштабирован в меньший размер. Почему так? И вообще, встречал ли кто-нибудь это, кроме меня?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

102. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 07:44 
Скриншоты, иллюстрирующие моё P.S.
Ссылки прямые.

Radeon (открытый драйвер):
http://img196.imageshack.us/img196/9868/79g5.png

Catalyst (закрытый драйвер):
Файлы на рабочем столе: http://img842.imageshack.us/img842/2478/o1l9.png
http://img405.imageshack.us/img405/2486/t3h9.png

Intel:
http://img36.imageshack.us/img36/7498/aqte.png

NVIDIA (резко отличается):
Файлы на рабочем столе: http://img545.imageshack.us/img545/6127/bztb.png
http://img571.imageshack.us/img571/5605/xn2z.png
http://img850.imageshack.us/img850/2334/bd0v.png

Просто сравните размер окна терминала в системе с драйвером NVIDIA и с любым другим драйвером!

Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

142. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:40 
> Обожаю NVIDIA. Когда я пользуюсь их видеокартами в Linux, то начинает как
> будто легче дышаться.

Да, САБЖ делает этот комент особенно саркастичным :).

> Но наиболее критичны такие вещи в различных редакторах: аудио, видео и 3D.

В редакторах обычно не работают в реалтайме и там можно покадрово отсмотреть.

> Когда нужно не играть, а работать, я советую NVIDIA и только NVIDIA.

"All work and no play makes Jack a dull boy".

Ответить | Правка | ^ к родителю #93 | Наверх | Cообщить модератору

96. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 05:19 
Молодцы что сказали честно.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

99. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от jOKer (ok) on 02-Ноя-13, 05:49 
Попробовал собрать для gentoo с ядром 3.11.2-pf и nvidia-drivers-319.60, но получил ошибку накладывания патчей:

* Failed Patch: get_num_physpages_319.patch !
*  ( /etc/portage/patches//x11-drivers/nvidia-drivers-319.60/get_num_physpages_319.patch )

Ну и толку с таких патчей?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

105. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от Led (ok) on 02-Ноя-13, 09:24 
> Ну и толку с таких патчей?

Ну и что толку с таких "накладывателей"?

Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

151. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 14:03 
> Попробовал собрать для gentoo с ядром 3.11.2-pf и nvidia-drivers-319.60, но получил ошибку
> накладывания патчей:
>  * Failed Patch: get_num_physpages_319.patch !
>  *  ( /etc/portage/patches//x11-drivers/nvidia-drivers-319.60/get_num_physpages_319.patch
> )
> Ну и толку с таких патчей?

Как правило это легко исправляется ручками. Смотри патч и правь ими :-) Претензии к майтейнерам ядра в генте, а не к нвидии, которая делает патч к сорцам с kernel.org


Ответить | Правка | ^ к родителю #99 | Наверх | Cообщить модератору

103. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 08:11 
Вот что f*ck животворящий делает!..
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

106. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Fracta1L (ok) on 02-Ноя-13, 09:24 
Да, доставили неприятностей на целых пять минут: гугление патча и закидывание его в /etc/portage/patches/x11-drivers/nvidia-drivers-${VER}.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

115. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:24 
Кому мешала переменная, возвращающая количество свободных страниц памяти. Думаю эта проблема может коснуться чего угодно.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

134. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:07 
> Кому мешала переменная, возвращающая количество свободных страниц памяти. Думаю эта проблема
> может коснуться чего угодно.

неверный вопрос. верный вопрос будет таким: «какие драйвера используют это и зачем?» оказалось, что драйверов, использующих это и не могущих обойтись — нет. поэтому выкинули. а кулибины, которые не хотят вливать свои наработки в mainline, пусть сами свои проблемы решают, раз сотрудничать не хотят.

Ответить | Правка | ^ к родителю #115 | Наверх | Cообщить модератору

120. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 11:38 
Ну кто мешает нвидии сделать nvidia-linux-kernel и забить на компанию неадекватов, которые думают только о себе?
:-)
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

135. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:09 
> Ну кто мешает нвидии сделать nvidia-linux-kernel и забить на компанию неадекватов, которые
> думают только о себе?
> :-)

и почему ты, такой весь умный, всё ещё не руководитель нвидии?

Ответить | Правка | ^ к родителю #120 | Наверх | Cообщить модератору

143. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:42 
> Ну кто мешает нвидии сделать nvidia-linux-kernel и забить на компанию неадекватов,

Наверное, конские затраты на майнтенанс и нибуйовый churn среди клиентов, которые труба шатали ставить какие-то левые кернелы от какой-то нвидии.

Ответить | Правка | ^ к родителю #120 | Наверх | Cообщить модератору

149. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 13:48 
> Наверное, конские затраты на майнтенанс и нибуйовый churn среди клиентов, которые труба
> шатали ставить какие-то левые кернелы от какой-то нвидии.

Какие затраты? Делать патч к творению этих деятелей, забить на это стадо самовлюбленных неадекватов и распространять свой nvidia-kernel, а не патч  в составе драйвера :-)
Ей-богу, так и надо сделать, чтобы научить это стадо неадекватов нормально взаимодействовать с другими людьми, а не на принципе "делай, как я хочу". Линупс драйвер для нвидии,  мягко говоря, неприоритетен, а тут еще и всякая неприоритетная шушера будет фортели выкидывать.


Ответить | Правка | ^ к родителю #143 | Наверх | Cообщить модератору

161. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 14:52 
> Какие затраты?

Вот такие - свою ветку ядра содержать, синхронизируя все это с остальными и чиня то что отвалилось при наложении своих патчей. Если это никак не синхрить, постепенно развал получается довольно большой и это все больше напоминает половину написания ядра самолично.

> Делать патч к творению этих деятелей, забить на это стадо
> самовлюбленных неадекватов и распространять свой nvidia-kernel,

Ну да, и отвечать на все предъявы по поводу ядра. Что зюзеводам, что арчеводам, что редхатовцам, что убунтуям. А ты уверен что нвидии плохо от своей крутизны не станет в попытках это сделать? И ты уверен что всех так уж пропрет перспектива ставить какой-то левый кернел от какой-то нвидии откуда-то сбоку?

> а не патч  в составе драйвера :-)

Да флаг в руки, хочу на это посмотреть, заодно на амд и интель сгонят ораву народа :). Фаны конечно будут отчаянно грызть кактус, с пеной у рта доказывая что их выбор лучший, несмотря на все тяги и невзгоды. А те кому не принципиально какой GPU - лишний раз забьют на нвидию чтоюы не иметь с ней головняка.

> Ей-богу, так и надо сделать, чтобы научить это стадо неадекватов
> нормально взаимодействовать с другими людьми,

Какая хорошая характеристика пи...сов из нвидии. И что характерно - их таки уже пару раз обучили. Довольно жестко. Китайчики прокатили на полмиллиарда, Торвальдс фак показал, а теперь вот и по чисто технической линии факап случился. Отлично. Еще пара люлей нвидии и до нее допрет нанять уже наконец команду разработчиков и пилить открытый драйвер. А то у них полбизнеса держится на пингвине а они еще и думают что кому-то смогут что-то диктовать, не участвуя в разработке. Агащаз, вторую винду из линя никто  сделать не даст. И это правильно - одной вполне достаточно. Если тебе надо винду с черти-каким кернелом где чуть ли не поддержку доса в 2013 году волокут, черти-какие блободрайвера и прочая - что ты в лине забыл? Есть же чудная максималочка :).

> а не на принципе "делай, как я хочу".

Как раз весьма нормальный принцип для разработчика. Так как правило получается довольно хороший результат. А вот подкаблучные индусы в офисе, над которыми манагер с плеткой стоял - пишут такой дец, что волосы дыбом.

> Линyпс драйвер для нвидии,  мягко говоря, неприоритетен,

Вот я и говорю - некоторым надо чтобы жизнь помела, тогда приоритеты начинают расставляться куда правильнее. А то у нвидии нынче полбизнеса на линухе, а тонуть вместе с MS они кажеся не очень хотят.

> а тут еще и всякая неприоритетная шушера будет фортели выкидывать.

Ну так не выкидывай фортели. А ядерщикам у тебя чисто технически ничего не получится диктовать, что прикольно :). А вот они зато отдиктовать нвидии при желании как видишь очень даже могут.

Ответить | Правка | ^ к родителю #149 | Наверх | Cообщить модератору

168. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –5 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 15:12 
Все , что вы написали, лишь иллюстрирует, почему у линуксятников репутация самовлюбенных и недалеких неадекватов :-)
Сначала какой-то дятел, подумав задницей, убрал из кода пару строчек, которые никому не мешали, но были нужны другим. Потом, когда ему сказали, что он своей дуростью мешает не только другим, но и, по сути, самому линуксу, встал в позу "будет так, как я хочу"
В нормальном обществе это называется см выше :-)
Ответить | Правка | ^ к родителю #161 | Наверх | Cообщить модератору

171. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 02-Ноя-13, 16:09 
и что в итоге характерно — прогибается нвидия, а не «самовлюблённые и недалёкие неадекваты».

а бараны типа тебя, пользуясь линуксом, не желают понять, почему он стал таким, как стал.

хотя пардон: ты не баран, ты свинья. та самая, которая «под дубом».

Ответить | Правка | ^ к родителю #168 | Наверх | Cообщить модератору

184. "NVIDIA пока не может решить проблему с совместимостью с..."  –2 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 16:48 
> и что в итоге характерно — прогибается нвидия, а не «самовлюблённые и
> недалёкие неадекваты».

Она уже вошла в "сообщество"? :-)
Ты органически не можешь понять, что такое "нормальное взаимодействие людей". Социопат? :-)

> а бараны типа тебя, пользуясь линуксом, не желают понять, почему он стал
> таким, как стал.
> хотя пардон: ты не баран, ты свинья. та самая, которая «под дубом».

Лучший способ отвратить людей от линукса, это показать им тебя - "вот таким станешь, если линукс поставишь" :-)


Ответить | Правка | ^ к родителю #171 | Наверх | Cообщить модератору

186. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 02-Ноя-13, 16:58 
> Ты органически не можешь понять, что такое «нормальное взаимодействие людей». Социопат?
> :-)

это ты отчего-то считаешь, что «мы корпорация и у нас дофига бабла, поэтому все прыгайте» — это «нормальное взаимодействие людей». смею тебя уверить: это не так.

> Лучший способ отвратить людей от линукса, это показать им тебя — «вот
> таким станешь, если линукс поставишь» :-)

так показывай же! чем больше дураков «отвратятся» — тем лучше.

Ответить | Правка | ^ к родителю #184 | Наверх | Cообщить модератору

189. "NVIDIA пока не может решить проблему с совместимостью с..."  –3 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 17:08 
> это ты отчего-то считаешь, что «мы корпорация и у нас дофига бабла,
> поэтому все прыгайте» — это «нормальное взаимодействие людей».

Я именно о том и писал, ты органически не можешь понять что такое "взаимодействие людей". Загляни в словарь, что такое вообще ""взаимодействие " :-)


Ответить | Правка | ^ к родителю #186 | Наверх | Cообщить модератору

193. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 02-Ноя-13, 17:46 
опа! после хитрого движения руки из словосочетания «нормальное взаимодействие людей» пропало одно слово. действительно, ведь «взаимодействие людей» и «нормальное взаимодействие людей» — это одно и то же!

нет, я понимаю, что у тебя в голове не мозги, а кю. я другое понять не могу: как ты дожил-то до своего возраста с кю в голове?! такой запас везения не каждому отводится.

Ответить | Правка | ^ к родителю #189 | Наверх | Cообщить модератору

185. "NVIDIA пока не может решить проблему с совместимостью с..."  –2 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 16:56 
> а бараны типа тебя, пользуясь линуксом, не желают понять, почему он стал
> таким, как стал.

Почему он стал таким, как раз понятно :-) Вложили компании гиганстские средства, по сути взяли линукс под свою опеку,  а многие линуксятники именно как ты свинья "пусти ее за стол, она и ноги на стол" :-)

Ответить | Правка | ^ к родителю #171 | Наверх | Cообщить модератору

187. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 02-Ноя-13, 17:01 
действительно, свинья под дубом. один-в-один.
Ответить | Правка | ^ к родителю #185 | Наверх | Cообщить модератору

215. "NVIDIA пока не может решить проблему с совместимостью с..."  –5 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 19:18 
> действительно, свинья под дубом. один-в-один.

Хочешь я тебе скажу, что такое был линукс в середине 90-ых? Тут просто нечего сказать - это было ни "нечто", ни "ничего", это было "ничто" :-)


Ответить | Правка | ^ к родителю #187 | Наверх | Cообщить модератору
Часть нити удалена модератором

222. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:43 
Ишь правдорубов то понабежало, как будто дустом посыпали прямо.
Ответить | Правка | ^ к родителю #193 | Наверх | Cообщить модератору

231. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 20:32 
> Хочешь я тебе скажу, что такое был линукс в середине 90-ых?

спасибо, не надо мне испорченого телефона. я ещё пока не склеротик.

Ответить | Правка | ^ к родителю #215 | Наверх | Cообщить модератору

241. "NVIDIA пока не может решить проблему с совместимостью с..."  –3 +/
Сообщение от SergMarkov email(ok) on 03-Ноя-13, 00:41 
> спасибо, не надо мне испорченого телефона. я ещё пока не склеротик.

Ты очень крупно ошибаешься, если думаешь что факи линуса и поведение самовлюбленных дятлов поспособствовало продвижению линукса.
Корпорации взяли линукс под свое крыло потому, что он был им выгоден, а вовсе не потому, что какой дятел размахивал факами. Линукс корпорациям выгоден, поэтому они и терпят самовлюбленных социопатов с их факами, бессмысленной руганью и прочими фокусами.
Но такое поведение называется именно что "пусти свинью за стол, она и ноги на стол"


Ответить | Правка | ^ к родителю #231 | Наверх | Cообщить модератору

244. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 03-Ноя-13, 01:52 
попробуй меньше дискутировать с голосами в твоей голове, и больше — с оппонентом. я бы предположил, что ты используешь демагогический приём приписывания оппоненту того, что он не говорил, а потом «громления» этого, но увы: я уже знаю, что ты слишком туп для этого. поэтому остаются только голоса в голове.
Ответить | Правка | ^ к родителю #241 | Наверх | Cообщить модератору

254. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Аноним (??) on 03-Ноя-13, 12:21 
> Ты очень крупно ошибаешься, если думаешь что факи линуса и поведение самовлюбленных
> дятлов поспособствовало продвижению линукса.

Ты очень крупно ошибаешься. Потому что "самовлюбленные дятлы" не ставили себе цель куда-то продвигаться и кого-то ублажать. Они делают систему и делают это хорошо. За это их ценят. А за продвижением - это к маркетологам. Вот например какой-нибудь Canonical - уже может и продвижением заморочиться. Но у них все просто: они ввинтят ядра, иксы и дрова нвидии совместимые между собой. Возможно это будут не самые последние версии. Ну и что? Майнтайнеры системы и нужны как буфер между разработчиками in the wild и юзерями на чью голову подборка компонентов свалится.

> Корпорации взяли линукс под свое крыло потому, что он был им выгоден,

Они решают при помощи линукса свои задачи, как и все остальные участники процесса. Поэтому никто никого под крылья не брал - они интегрировались в процесс на общих основаниях, делая ту часть работы которая нужна для достижения их целей и задач. Все остальные участники процесса делают то же самое.

> а вовсе не потому, что какой дятел размахивал факами.

А нвидия вообще не часть процесса. Поэтому их мнение вообше не котируется. А как они там с своей клиентурой утрясают - сугубо проблемы нвидии. Всем остальным на это до лампочки.

> выгоден, поэтому они и терпят самовлюбленных социопатов с их факами,
> бессмысленной руганью и прочими фокусами.

Нвидии никто не запрещает писать свою операционку, с шахматами и поэтессами. Вот только создание одного только кернела такой сложности оценивается в несколько миллиардов баксов. Не говоря о майнтенансе всего остального. Сомнительно что нвидия так уж захочет вынуть несколько миллиардов.

> Но такое поведение называется именно что "пусти свинью за стол, она и
> ноги на стол"

Это к корпорациям разве что относится - они пришли после "дятлов" и "социопатов". Поэтому или интегрируются в процесс, или идут лесом с интересом.

Ответить | Правка | ^ к родителю #241 | Наверх | Cообщить модератору

255. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от SergMarkov email(ok) on 03-Ноя-13, 12:27 
Где то то чуть ниже или выше сказано точь в точь тоже самое. Я там сказал, что нет смысла спорить с пением мантр, здесь даже этого говорить не буду.
Если вы не понимаете что такое "нормальное взаимодействие людей",  бестолку что либо объяснять.
Ответить | Правка | ^ к родителю #254 | Наверх | Cообщить модератору

259. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Аноним (??) on 03-Ноя-13, 15:54 
> Где то то чуть ниже или выше сказано точь в точь тоже
> самое. Я там сказал, что нет смысла спорить с пением мантр,
> здесь даже этого говорить не буду.

Здесь нет никакого пения мантр. Просто констатация простого факта: твоей нвидии никто ничего не должен. Если они хотят с кем-то результативно взаимодействовать - пусть проявляют инициативу. Ядерщиков самих по себе мало волнуют проблемы нвидии, ее бинарного драйвера и клиентуры вляпавшейся во все это. А чего ради это должно быть не так? Если ты мнишь что у всех единственная цель - это обслуживать нужды твоего троллиного окорока, ты чего-то сильно недопонял в этой жизни и "нормальном взаимодействии людей" и тебя будет ждать немало интересных обломов по этому поводу :)


> Если вы не понимаете что такое "нормальное взаимодействие людей",  бестолку что
> либо объяснять.

Обычно так говорят или дypаки, которые сами не могут объяснить что они имели в виду, или подлецы, полагающие что попользоваться индивидуалом, подтереться им и выбросить - это и есть "нормальное взаимодействие людей".

Ответить | Правка | ^ к родителю #255 | Наверх | Cообщить модератору

188. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 17:01 
> Все , что вы написали, лишь иллюстрирует, почему у линуксятников репутация самовлюбенных
> и недалеких неадекватов :-)

Нормальные люди. Вполне адекватно и логично себя ведут, кстати: пилят систему так как надо участникам процесса, а не каким-то левым прихлебателям откуда-то сбоку. Заметь - они не бегали за нвидией. Это нвидия решила что ей и ее клиентуре что-то надо. А вот интегрироваться в процесс нормально - не смогли или не захотели. FAIL.

Внезапно, никто не хочет делать из проблем нвидии и ее клиентуры свои проблемы, неизвестно ради чего. И уж разумеется ядерщикам пофиг на существование блоба от нвидии. Они к нему никакого отношения не имеют и это частная инициатива нвидии. С разработчиками ядра эту инициативу никто не согласовывал, а их позиция насчет бинарных драйверов проста как топор. Даже просто легальность проприетарных драйверов - под большим сомнением, а чтоб добавочно наподдать - явно сделали многие символы GPL_ONLY, так что разработчики явно декларируют: "мой код не должен использоваться с проприетарщиной". Ну, копирасы-проприерасы настаивали что слово автора - закон? Окей, пусть получат и распишутся. Так что нвидия с своим блобьем давно нарывалась, балансируя на кромке ножа и используя подходы которые разработчики ядра поддерживать никогда и не планировали. Жаловаться тут можно только на самих себя.

> Сначала какой-то дятел, подумав задницей, убрал из кода пару строчек, которые никому
> не мешали, но были нужны другим.

Они никому в майнлайне не требовались. А за сторонние инициативы по созданию каких-то блобиков использующих внутреннюю кухню ядра ядерщики не могут отвечать.

> он своей дуростью мешает не только другим, но и, по сути, самому линуксу,

Это какому еще линуксу? Линукс - это ядро и его разработчики. А всякие левые прихлебатели типа нвидии - вообще побочная хрень, которую никто из разработчиков не звал.

> встал в позу "будет так, как я хочу"
> В нормальном обществе это называется см выше :-)

Нет, это называется немного не так: "в чужой монастырь со своим уставом не ходят". Ну вот если нвидия думала что под них кто-то будет подстраиваться - пусть дальше думает. И дальше обламывается.

Ответить | Правка | ^ к родителю #168 | Наверх | Cообщить модератору

191. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 17:24 
Не разочаровывайте меня еще больше в подтверждении вышеприведенной характеристики :-)
Ответить | Правка | ^ к родителю #188 | Наверх | Cообщить модератору

223. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:43 
> Не разочаровывайте меня еще больше в подтверждении вышеприведенной характеристики :-)

Ну то-есть по делу тебе возразить нечего, мистер жирное трололо? Ну я как-то так и подумал :)

Ответить | Правка | ^ к родителю #191 | Наверх | Cообщить модератору

245. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –3 +/
Сообщение от SergMarkov email(ok) on 03-Ноя-13, 04:16 
>> Не разочаровывайте меня еще больше в подтверждении вышеприведенной характеристики :-)
> Ну то-есть по делу тебе возразить нечего, мистер жирное трололо? Ну я
> как-то так и подумал :)

Сколько раз можно возражать на одни и те же мантры? :-) Я вам сказал, как характеризуется такое поведение, затем вы принялись эту характеристику подтверждать. Спасибо, конечно, за подтверждение, но в характеристике ничего не изменилось, она благодаря вашим многократно повторенным мантрам только приобрела дополнительную достоверность :-)


Ответить | Правка | ^ к родителю #223 | Наверх | Cообщить модератору

250. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 03-Ноя-13, 09:52 
Ну это уже какие-то гнилые отмазки пополам с жирным троллингом. Займись физкультурой для троллей или GTFO.

Кстати вышеупомянутое было вообще на правах капитанинга. Странно мне что-то предъявлять за то что я сообщил что солнце - светит, трава - зеленая, а дважды два - четыре. Просто улови простую мысль: ядерщики линуха нвидии ничем таким не обязаны. Особенно если нвидия сами с усами и считают что могут пилить нечто за закрытыми дверями. Пусть идут и пилят. А ядерщикам будет до лампочки на активность нвидии, соответственно. Потому что не часть процесса.

Ответить | Правка | ^ к родителю #245 | Наверх | Cообщить модератору

251. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 03-Ноя-13, 10:17 
спорим, что не уловит?
Ответить | Правка | ^ к родителю #250 | Наверх | Cообщить модератору

125. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 11:51 
Торвальдс начинает напрягать уже. Понятно что он линуксовый пуп, но если он будет так менять логику, то разрабы забьют на линь, и он никого не станет крутой игровой платформой. Добавляя новое, нужно заботиться о функционировании старого!
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

136. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:09 
> не станет крутой игровой платформой

это было бы просто здорово. жаль, что ты бред написал. но всё равно — было бы здорово.

Ответить | Правка | ^ к родителю #125 | Наверх | Cообщить модератору

144. "NVIDIA пока не может решить проблему с совместимостью с..."  –1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 12:44 
Не, фиг тебе. Здорово - это если бы допилили открытые драйвера. К тому же ими можно пользоваться не только для игр. Но и для ускорения вычислений, например. Или, допустим, авиасимулятор типа flightgear.
Ответить | Правка | ^ к родителю #136 | Наверх | Cообщить модератору

146. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 12:46 
против драйверов я ничего не имею, вообще-то. а вот против превращения в «крутую игровую платформу» — имею, и многое.
Ответить | Правка | ^ к родителю #144 | Наверх | Cообщить модератору

148. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 13:12 
линукс крут на серверах, на мобилах, на воркстанциях. так почему бы ему и не стать крутой платформой для игр?
Ответить | Правка | ^ к родителю #146 | Наверх | Cообщить модератору

150. "NVIDIA пока не может решить проблему с совместимостью с..."  –4 +/
Сообщение от SergMarkov email(ok) on 02-Ноя-13, 13:56 
> линукс крут на серверах, на мобилах, на воркстанциях. так почему бы ему
> и не стать крутой платформой для игр?

Первое заслуга IBM, второе гугля, "крут на воркстанциях" это фантазия.
Осталось найти компанию, которая будет делать из линукса игровую платформу :-) Валве тут не помощник.


Ответить | Правка | ^ к родителю #148 | Наверх | Cообщить модератору

225. "NVIDIA пока не может решить проблему с совместимостью с..."  +4 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:45 
> Первое заслуга IBM, второе гугля,

...а Торвальдс вообще так, погулять вышел. Ну ок, тебе нравится пресмыкаться перед корпорациями. Правда почему-то OS/2 от IBM скопытился, а гугл вообще сам не рискнул операционку с нуля писать.

Ответить | Правка | ^ к родителю #150 | Наверх | Cообщить модератору

263. "NVIDIA пока не может решить проблему с совместимостью с..."  –3 +/
Сообщение от Аноним_тот_же on 03-Ноя-13, 17:54 
> Правда почему-то OS/2 от IBM скопытился

Не, ну точно правда?
> а гугл вообще сам не рискнул операционку с нуля писать

если завтра гугл перейдет на бсд, пользователи этого и не заметят.

Ответить | Правка | ^ к родителю #225 | Наверх | Cообщить модератору

269. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от Аноним (??) on 03-Ноя-13, 19:44 
>> Правда почему-то OS/2 от IBM скопытился
> Не, ну точно правда?

Ну как-то вот инсталляций линукса - сильно больше. Даже на десктопах, э-хе-хе.

> если завтра гугл перейдет на бсд, пользователи этого и не заметят.

А если упадет 100-километровый метеорит - тогда заметят. Вероятность IMHO примерно одинаковая.

Ответить | Правка | ^ к родителю #263 | Наверх | Cообщить модератору

276. "NVIDIA пока не может решить проблему с совместимостью с..."  +/
Сообщение от Аноним_тот_же on 03-Ноя-13, 22:17 
> А если упадет 100-километровый метеорит - тогда заметят. Вероятность IMHO примерно одинаковая.

Вероятность идентична. Вы правы. Метеорит заметят (особенно если взорвется в густонаселенном месте), а переход с одной оси на другую заметят единицы. У гугла сама ось спрятана подальше от пользователя, да и большинство из них не заходят на вкладку "Об устройстве".

Ответить | Правка | ^ к родителю #269 | Наверх | Cообщить модератору

295. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 04-Ноя-13, 13:09 
> гугла сама ось спрятана подальше от пользователя,

А NDK позволяющий ей пользоваться - все-таки есть...

Ответить | Правка | ^ к родителю #276 | Наверх | Cообщить модератору

302. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Michael Shigorin email(ok) on 06-Ноя-13, 02:10 
> если завтра гугл перейдет на бсд, пользователи этого и не заметят.

Да вот что-то не наблюдаются такие процессы, скорее обратные.  Несмотря на то, что какая-то обезьяна со стойким BSD-like отношением к GPL в гугле засела, а то и не одна.

Ответить | Правка | ^ к родителю #263 | Наверх | Cообщить модератору

275. "NVIDIA пока не может решить проблему с совместимостью с..."  –4 +/
Сообщение от Адекват (ok) on 03-Ноя-13, 21:43 
> линукс крут на серверах, на мобилах, на воркстанциях. так почему бы ему
> и не стать крутой платформой для игр?

И сделаем его б"№ть платным - у вас нет аккоунта в steam ? ну все, идите лесом.

Ответить | Правка | ^ к родителю #148 | Наверх | Cообщить модератору

296. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от Аноним (??) on 04-Ноя-13, 13:12 
> И сделаем его б"№ть платным - у вас нет аккоунта в steam
> ? ну все, идите лесом.

Да не, что там, вас еще и развлекать все должны забесплатно. А чего б вам не пойти в парк с аттракционами и не потребовать вас покатать бесплатно? Ну и что что электричество жрется и люди на ваше обслуживание работают.

Ответить | Правка | ^ к родителю #275 | Наверх | Cообщить модератору

204. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от Zenitur (ok) on 02-Ноя-13, 18:12 
Когда бета-тестировал Steam, каким-то образом получил отладочную информацию Steam Overlay. Там было много вызовов функций иксов. Почему-то мне кажется что среди них есть такие, которые не использует ни одна программа, кроме Steam Overlay. Ведь через него можно запустить игру, и Alt-Tab будет работать! В тот момент я испугался что разработчики иксов возьмут да и уберут одну-две из этой тучи функций, потому что Derpecated и "никому не нужно". И тогда Steam Overlay отвалится, или будет работать только на играх SDL 2. Но это случилось там, где не ожидал никто.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

227. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 02-Ноя-13, 19:47 
Рассуждения папуаса о принципах работы микроволновки. Chapter I. Описание интерфейса пользователя. "Если нажать на кнопочку - зажигается свет и готовится жратва".
Ответить | Правка | ^ к родителю #204 | Наверх | Cообщить модератору

232. "NVIDIA пока не может решить проблему с совместимостью с..."  +1 +/
Сообщение от arisu (ok) on 02-Ноя-13, 20:40 
chapter II: жратву надо обязательно засовывать внутрь, а то не сработает.
Ответить | Правка | ^ к родителю #227 | Наверх | Cообщить модератору

277. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от Zenitur (ok) on 04-Ноя-13, 00:11 
Я и не скрываю что ничего не понимаю в программировании - я _пользователь_. Однако даже моих пользовательских знаний хватает чтобы понять то что эта гора вызовов иксов принадлежит оверлею, а не самой игре. Видя как убирают функции из открытых программ, ломая совместимость, я огорчился тому что и Steam Overlay могут таким же образом сломать.
Ответить | Правка | ^ к родителю #227 | Наверх | Cообщить модератору

289. "NVIDIA пока не может решить проблему с совместимостью с..."  +2 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:37 
нет ничего хуже, когда дилетант начинает рассуждать про специфические области, требующие специфических знаний. если он это делает в обществе тех, кто знания имеет — над дилетантом смеются. психотравма. а если в обществе тех, у кого знаний нет — получается FUD. за это можно и прямые травмы наносить.
Ответить | Правка | ^ к родителю #277 | Наверх | Cообщить модератору

306. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +2 +/
Сообщение от Аноним (??) on 08-Ноя-13, 16:27 
> Я и не скрываю что ничего не понимаю в программировании - я _пользователь_.

Ну так и нефиг рассуждать о областях в которых ты ноль без палочки.

> что и Steam Overlay могут таким же образом сломать.

А жить вообще страшно - от этого умирают.

Ответить | Правка | ^ к родителю #277 | Наверх | Cообщить модератору

236. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +3 +/
Сообщение от wiseman (ok) on 02-Ноя-13, 22:05 
> Более правильный и устойчивый подход для решения этой проблемы

Открыть исходники? Нет, не слышали

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

237. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 02-Ноя-13, 22:57 
Надо было участвовать в разработке ведра и не дать убрать нужную функцию.
Выглядит как попытка подстроиться под какой-то закрытый непредсказуемый продукт.
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

243. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от KT315 (ok) on 03-Ноя-13, 01:25 
>> Хотя максимальное число фреймов страниц и объём памяти в системе связаны

СТОП! Они не осилили запилить пересчет обьема памяти в число страниц фреймов в драйвере, имея исходники на руках?!
Ох ЛОЛ))))

>> Хотя максимальное число фреймов страниц и объём памяти в системе связаны, это совершенно разные значения, и их нельзя заменять. Информация об объёме памяти недостаточна, чтобы идентифицировать всю память, которая может быть адресована GPU.

Где-то тут противоречия или умалчивания... Они же связаны, а значит можно пересчитать.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

256. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +/
Сообщение от некто email(ok) on 03-Ноя-13, 13:38 
очередной раз убеждаюсь, что не ошибся с выбором в сторону радеона
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

273. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Адекват (ok) on 03-Ноя-13, 21:02 
Я может чего не понимаю, но УМВСР:

[user0@homelinux ~]$ pacman -Q nvidia
nvidia 325.15-10
[user0@homelinux ~]$ pacman -Q linux
linux 3.11.6-1
[user0@homelinux ~]$

Что за проблема, как она проявляется ? нипананта.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

283. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –2 +/
Сообщение от клоун Стаканчик on 04-Ноя-13, 04:55 
в связи с тем, что из состава ядра Linux была удалена функциональность
...
NVIDIA может предложить только ограниченную поддержку 3.11 и более новых ядер
...
системы с очень большим количеством оперативной памяти (128GB и выше) могут столкнуться с отрицательными эффектами
...
Это временная мера, которая должна быть достаточна для большинства пользователей


Драйвер будет работать медленнее и хуже, но работать будет. Проблема здесь не столько в функциональности, сколько в анонсе. Обычно драйвер переставал работать и ругали за это nVidia. Теперь nVidia выпустила официальный (!) пресс-релиз в котором прямым текстом указано почему не работает драйвер. Этот пресс-релиз кое-кого задел за живое. А фраза "мы не сможем предложить [лучшее решение] в ближайшем будущем" прямо указывает, что nVidia продолжит разрабатывать драйвера для Линукс (ещё бы, если Линукс от Valve добъётся успеха...), но не изменит модель разработки на открытую как этого от неё добиваются Торвальдс и Ко.

Ответить | Правка | ^ к родителю #273 | Наверх | Cообщить модератору

290. "NVIDIA пока не может решить проблему с совместимостью с..."  +3 +/
Сообщение от arisu (ok) on 04-Ноя-13, 09:38 
вкусный кактус, видать. ну, пусть едят дальше, их право.
Ответить | Правка | ^ к родителю #283 | Наверх | Cообщить модератору

300. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Grindz on 05-Ноя-13, 03:00 
Аналогично:

cat /etc/debian_version
jessie/sid

uname -rom
3.12.0 x86_64 GNU/Linux

dpkg -l nvidia-glx
nvidia-glx              331.17-1         amd64            transition to nvidia-driver

Всё работает.

Ответить | Правка | ^ к родителю #273 | Наверх | Cообщить модератору

274. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Аноним (??) on 03-Ноя-13, 21:42 
>Ну кто мешает нвидии сделать nvidia-linux-kernel и забить на компанию неадекватов, которые думают только о себе?
>забить на это стадо самовлюбленных неадекватов
>чем "нормальное взаимодействие людей" отличается от "глупейших выходок самовлюбленных пустых дятлов"

http://ltsi.linuxfoundation.org/

Удобно забытый неудобный факт наличия лтс в отчаянно нелюбимом майнлайне.

Совместимый с 3.11 блоб амд тоже не представлен. Уже бегу выбрасывать свои 3.5 cgn и 1.5 нвидии. Только хардкор, только кровоточащие углы!

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

297. "NVIDIA пока не может решить проблему с совместимостью с новы..."  +1 +/
Сообщение от Аноним (??) on 04-Ноя-13, 13:17 
> Совместимый с 3.11 блоб амд тоже не представлен.

У них бета каталиста даже с 3.12 уже работает. Чем их бета от релиза отличается - хз. Еще споорный вопрос где багов больше.

Ответить | Правка | ^ к родителю #274 | Наверх | Cообщить модератору

299. "NVIDIA пока не может решить проблему с совместимостью с новы..."  –1 +/
Сообщение от Онанимус on 04-Ноя-13, 20:39 
http://support.amd.com/en-us/kb-articles/Pages/latest-linux-...
>Linux kernel 2.6 or above (up to 3.10)

че без гона работает с 3.12? O_o

Ответить | Правка | ^ к родителю #297 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру