The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Quagga Ospfd+cisco"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Маршрутизация, NAT / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 13:47 
Привет , такой вопрос  , есть BSD , поднят Quagga c Ospfd и Zebra . С дургой стороны стоить Cisco 1720 , между ними тунель gif , ospf работает как точка точка по этому тунелю . Включаем , все видется и работает , в процессе работы идет отвал gif интефайса (у прова допустим проблемы ) после gif поднимается ,а вот ospf уже нет . Хотя две тачки видет друг друга пингуются и если смотреть пакеты на интерфэйсе то 224.0.0.5 и та и другая скидывают , но через ospf в упор друг друга не видят , на циске состояние INIT,на BSD вообще тишина .
Перегружаем демон quagg-и и все поднимается . Как лечить уже незнаю кроме как рестартовать демон , есть мысли ??
Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Quagga Ospfd+cisco"  +/
Сообщение от ALex_hha (ok) on 28-Дек-10, 14:01 
Версия quagga какая?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 14:25 
> Версия quagga какая?

99.17 ver3, последная .  

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 14:26 
>> Версия quagga какая?
> 99.17 ver3, последная .

Добавлю что ещеесть vtund  , и все тунели на нем работают на ура , отвалилось само поднялось , только проблема с gif

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Quagga Ospfd+cisco"  +/
Сообщение от Anatoliy (??) on 28-Дек-10, 16:10 
>>> Версия quagga какая?
>> 99.17 ver3, последная .
> Добавлю что ещеесть vtund  , и все тунели на нем работают
> на ура , отвалилось само поднялось , только проблема с gif

После подняти gif hello (224.0.0.5) пакетки бегают от циски и от Quagga ?
init, насколько я помню, это циско получила hello от соседа и ждет опять же от соседа второй hello пакет с ROUTER ID циски (2way).  

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 16:13 
>>>> Версия quagga какая?
>>> 99.17 ver3, последная .
>> Добавлю что ещеесть vtund  , и все тунели на нем работают
>> на ура , отвалилось само поднялось , только проблема с gif
> После подняти gif hello (224.0.0.5) пакетки бегают от циски и от Quagga
> ?
> init, насколько я помню, это циско получила hello от соседа и ждет
> опять же от соседа второй hello пакет с ROUTER ID циски
> (2way).

Да , после поднятия бегают и от cisco и от BSD .
Так то оно так . Кошка получила , а вот BSD нет , если посмотреть соседей на BSD , пусто просто . Плосему и обратился , может быть проблемы с 224.0.0.5 ? Хотя после рестарта то все поднимается !

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Quagga Ospfd+cisco"  +/
Сообщение от Anatoliy (??) on 28-Дек-10, 16:17 
>>> Версия quagga какая?
>> 99.17 ver3, последная .
> Добавлю что ещеесть vtund  , и все тунели на нем работают
> на ура , отвалилось само поднялось , только проблема с gif

Опять же возможно у Вас на циске не задан ROUTER ID, либо нет loopback интерфейсов.
Когда падает интерфейс на циске ospf не занет какой, что использовать в качестве router id.

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

7. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 16:22 
>>>> Версия quagga какая?
>>> 99.17 ver3, последная .
>> Добавлю что ещеесть vtund  , и все тунели на нем работают
>> на ура , отвалилось само поднялось , только проблема с gif
> Опять же возможно у Вас на циске не задан ROUTER ID, либо
> нет loopback интерфейсов.
> Когда падает интерфейс на циске ospf не занет какой, что использовать в
> качестве router id.

Ответ ясен , вот конфиг кошки

interface Tunnel0
description to aaaa
ip address 10.13.### 255.255.255.252
ip ospf network point-to-point
ip ospf cost 1
ip ospf mtu-ignore
tunnel source Ethernet0
tunnel destination 10###
tunnel mode ipip
!
interface Ethernet0 WAN
description IP-VPN
ip address 10.0.#### 255.255.255.252
full-duplex
!
interface FastEthernet0 LAN
ip address 192.#### 255.255.255.0
speed auto
!
router ospf 10100
router-id 192.####
log-adjacency-changes
network 10.13.#### 0.0.0.3 area 0.0.0.0
network 192.127.#### 0.0.0.255 area 0.0.0.0

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Quagga Ospfd+cisco"  +/
Сообщение от Anatoliy (??) on 28-Дек-10, 16:29 
>[оверквотинг удален]
> !
> interface FastEthernet0 LAN
>  ip address 192.#### 255.255.255.0
>  speed auto
> !
> router ospf 10100
>  router-id 192.####
>  log-adjacency-changes
>  network 10.13.#### 0.0.0.3 area 0.0.0.0
>  network 192.127.#### 0.0.0.255 area 0.0.0.0

router id есть, ip адреса на интерфейсах есть... дело в не нем.
А что дебаг на циске выдает?
# debug ip ospf ?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 16:34 
>[оверквотинг удален]
>>  speed auto
>> !
>> router ospf 10100
>>  router-id 192.####
>>  log-adjacency-changes
>>  network 10.13.#### 0.0.0.3 area 0.0.0.0
>>  network 192.127.#### 0.0.0.255 area 0.0.0.0
> router id есть, ip адреса на интерфейсах есть... дело в не нем.
> А что дебаг на циске выдает?
> # debug ip ospf ?

В вот тут то и проблема , что такой момент когда происходит отвал поймать проблема , и чаще они происходить когда уже не на месте ,а в дороге  иоттуда сами помнимаете смотреть трудновато , а вот сети висят поэтому перегруз и дебаг смотреть не возможно . По конфигу все правильно я так понимаю ?

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Quagga Ospfd+cisco"  +/
Сообщение от Anatoliy (??) on 28-Дек-10, 16:45 
>[оверквотинг удален]
>>>  network 10.13.#### 0.0.0.3 area 0.0.0.0
>>>  network 192.127.#### 0.0.0.255 area 0.0.0.0
>> router id есть, ip адреса на интерфейсах есть... дело в не нем.
>> А что дебаг на циске выдает?
>> # debug ip ospf ?
> В вот тут то и проблема , что такой момент когда происходит
> отвал поймать проблема , и чаще они происходить когда уже не
> на месте ,а в дороге  иоттуда сами помнимаете смотреть трудновато
> , а вот сети висят поэтому перегруз и дебаг смотреть не
> возможно . По конфигу все правильно я так понимаю ?

Да вроде все нормально. Мона включить дебаг и WAN интерфейсе дать sh, затем no sh, либо clear ip ospf proc.
А 224.0.0.5 и 224.0.0.6 адреса ни кто не фильтрует?  



Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

11. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 28-Дек-10, 16:55 
>[оверквотинг удален]
>>> А что дебаг на циске выдает?
>>> # debug ip ospf ?
>> В вот тут то и проблема , что такой момент когда происходит
>> отвал поймать проблема , и чаще они происходить когда уже не
>> на месте ,а в дороге  иоттуда сами помнимаете смотреть трудновато
>> , а вот сети висят поэтому перегруз и дебаг смотреть не
>> возможно . По конфигу все правильно я так понимаю ?
> Да вроде все нормально. Мона включить дебаг и WAN интерфейсе дать sh,
> затем no sh, либо clear ip ospf proc.
> А 224.0.0.5 и 224.0.0.6 адреса ни кто не фильтрует?

Есть PF , но он тут не причем , так как при перезагрузе демона ospfd все же работает и цепляется . Если бы фильтр был то и презагрузка не помогла .
А еще вопрос заметил тут вот что

LSA[Type5:224.0.0.5]: Not originate AS-external-LSA, Prefix belongs multicast
2010/12/28 13:31:59 OSPF: LSA[Type5:224.0.0.6]: Not originate AS-external-LSA, Prefix belongs multicast
2010/12/28 13:31:59 OSPF: LSA[Type5:0.0.0.0]: Not originate AS-exntenal-LSA for default

Что это ? почему 0.0.0.0 а не 224.0.0.5 или 6 ?

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

12. "Quagga Ospfd+cisco"  +/
Сообщение от Anatoliy (??) on 29-Дек-10, 19:36 
>[оверквотинг удален]
>> А 224.0.0.5 и 224.0.0.6 адреса ни кто не фильтрует?
> Есть PF , но он тут не причем , так как при
> перезагрузе демона ospfd все же работает и цепляется . Если бы
> фильтр был то и презагрузка не помогла .
> А еще вопрос заметил тут вот что
> LSA[Type5:224.0.0.5]: Not originate AS-external-LSA, Prefix belongs multicast
> 2010/12/28 13:31:59 OSPF: LSA[Type5:224.0.0.6]: Not originate AS-external-LSA, Prefix
> belongs multicast
> 2010/12/28 13:31:59 OSPF: LSA[Type5:0.0.0.0]: Not originate AS-exntenal-LSA for default
> Что это ? почему 0.0.0.0 а не 224.0.0.5 или 6 ?

Коллега, LSA5 грит Вам, насклько я понимаю, что есть маршруты из другой арии (ASBR, xBSD), но почему у Вам не связывается hello-advertise я понять не могу. У Вас после подняти gif интерефеса роутеры не видят друг-друга по hello-пакетам (224.0.0.5). Почему? Увы, не пойму. Уж, извините....

Ответить | Правка | ^ к родителю #11 | Наверх | Cообщить модератору

13. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 30-Дек-10, 11:17 
>[оверквотинг удален]
>> А еще вопрос заметил тут вот что
>> LSA[Type5:224.0.0.5]: Not originate AS-external-LSA, Prefix belongs multicast
>> 2010/12/28 13:31:59 OSPF: LSA[Type5:224.0.0.6]: Not originate AS-external-LSA, Prefix
>> belongs multicast
>> 2010/12/28 13:31:59 OSPF: LSA[Type5:0.0.0.0]: Not originate AS-exntenal-LSA for default
>> Что это ? почему 0.0.0.0 а не 224.0.0.5 или 6 ?
> Коллега, LSA5 грит Вам, насклько я понимаю, что есть маршруты из другой
> арии (ASBR, xBSD), но почему у Вам не связывается hello-advertise я
> понять не могу. У Вас после подняти gif интерефеса роутеры не
> видят друг-друга по hello-пакетам (224.0.0.5). Почему? Увы, не пойму. Уж, извините....

После нашего первого разговора , я решил поглядеть сами интерфэйсы на двух хостах , поглядел и меня смутил немного размер MTU , на кошке он был 1508 а на NIX был 1280 , вроде бы в конфиге самих интерфэйсах указанно что IP MTU IGNORE , но я решил указать явно с двух строн на 1495. И замечю что уже как третий день , явных признаков не поднятия не наблюдаю !! Сам так же ручками эммулировал падения тунеля , после его поднимал и все сразу виделось . Может быть в этом проблема  была сказать точно не могу , пока еще понаблюдаю .

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

14. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 30-Дек-10, 15:08 
>[оверквотинг удален]
> После нашего первого разговора , я решил поглядеть сами интерфэйсы на двух
> хостах , поглядел и меня смутил немного размер MTU , на
> кошке он был 1508 а на NIX был 1280 , вроде
> бы в конфиге самих интерфэйсах указанно что IP MTU IGNORE ,
> но я решил указать явно с двух строн на 1495. И
> замечю что уже как третий день , явных признаков не поднятия
> не наблюдаю !! Сам так же ручками эммулировал падения тунеля ,
> после его поднимал и все сразу виделось . Может быть в
> этом проблема  была сказать точно не могу , пока еще
> понаблюдаю .

Короче не помогло , все так же не пашет , но зато точно на все сто могу сказать что перегруз gif интерфэйса помогает . Не стал парицо , просто скрипт сделал который пингает хост удаленный и если тот не отвечает то просто сам удалет gif и создает его снова , после этого OSPF видецо и все обновляется !!! Может кому то поможет такой вариант .

Peer=`/sbin/ping -c 3 192.127.####.## | grep "64 bytes" | wc -l`
if !(test $peer -gt "0")
then
echo ## is down
ifconfig gif3 destroy
ifconfig gif3 create
ifconfig gif3 10.13.### 10.13.### netmask 255.255.255.252 tunnel 10.3.### 10.3.###
ifconfig gif3 mtu 1495
ifconfig gif3 up
fi

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

15. "Quagga Ospfd+cisco"  +/
Сообщение от RSG (ok) on 30-Дек-10, 17:12 
> тачки видет друг друга пингуются и если смотреть пакеты на интерфэйсе
> то 224.0.0.5 и та и другая скидывают , но через ospf
> в упор друг друга не видят , на циске состояние INIT,на
> BSD вообще тишина .

А что если сеть объявить как non-broadcast и соседий прописать руками?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

16. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 30-Дек-10, 17:21 
>> тачки видет друг друга пингуются и если смотреть пакеты на интерфэйсе
>> то 224.0.0.5 и та и другая скидывают , но через ospf
>> в упор друг друга не видят , на циске состояние INIT,на
>> BSD вообще тишина .
> А что если сеть объявить как non-broadcast и соседий прописать руками?

Про 224 это другое дело , это у меня два роутера стоят в одном сегменте , оба с ospf-ом , и они переодический переставали друг друга тоже видеть , но тут проблема вроде как решилась , раньше на 99.12 Quagga , была проблема с VLAN-ом , а так как у меня на одном из роутеров vlan-ы и есть , то вместо публикации ospf на vlan приходилось делать на общем физическом интерфэйсе тобишь скока на нем vlan висело во все пакеты мультикаст и бегали .Так вот обновил quaggу до 99.17 , а конфиг осталься старый , и перодичский между двумя машинками отваливался OSPF , после того как все же переписал конфиг и сделал как должно быть тобишь не на физике а на vlan-е, все заработало , и две машин в одном сигменте сети видять друг друга на ура , но вот проблема появилась еще одна с gif интерфэйсом о коей я описал выше и уж какое не какое но решение сделал , хоть и криво :))

Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

17. "Quagga Ospfd+cisco"  +/
Сообщение от RSG (ok) on 30-Дек-10, 17:44 
>>> но через ospf
>>> в упор друг друга не видят , на циске состояние INIT,на
>>> BSD вообще тишина .
>> А что если сеть объявить как non-broadcast и соседий прописать руками?
> Про 224 это другое дело , это у меня два роутера стоят
> в одном сегменте , оба с ospf-ом , и они переодический
> переставали друг друга тоже видеть , но тут проблема вроде как
> решилась , раньше на 99.12 Quagga , была проблема с VLAN-ом
> , а так как у меня на одном из роутеров vlan-ы

Не совсем понял про виланы. :-)
Мое предложение было избавиться от мультикастов, сказав,  что сеть на интерфейсе gif non-broadcast.

Что-то типа :

R1(config-if)# ip ospf network non-broadcast

и прописать соседей:

R1(config-router)# neighbor A.B.C.D

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

18. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 30-Дек-10, 17:46 
>[оверквотинг удален]
>> переставали друг друга тоже видеть , но тут проблема вроде как
>> решилась , раньше на 99.12 Quagga , была проблема с VLAN-ом
>> , а так как у меня на одном из роутеров vlan-ы
> Не совсем понял про виланы. :-)
> Мое предложение было избавиться от мультикастов, сказав,  что сеть на интерфейсе
> gif non-broadcast.
> Что-то типа :
> R1(config-if)# ip ospf network non-broadcast
> и прописать соседей:
> R1(config-router)# neighbor A.B.C.D

ААА , понял , делал , не дает на кошке это протисать , кричит что для того тчо бы соседей явно указать надо что бы ip ospf network был point-to-multipoint , но у меня то ptp !

Ответить | Правка | ^ к родителю #17 | Наверх | Cообщить модератору

19. "Quagga Ospfd+cisco"  +/
Сообщение от RSG (ok) on 30-Дек-10, 17:55 
> ААА , понял , делал , не дает на кошке это протисать
> , кричит что для того тчо бы соседей явно указать надо
> что бы ip ospf network был point-to-multipoint , но у меня
> то ptp !

point-to-multipoint интерпретируется как множество ptp линков, так что можно смело менять, эффект один и то же.

Ответить | Правка | ^ к родителю #18 | Наверх | Cообщить модератору

20. "Quagga Ospfd+cisco"  +/
Сообщение от RSG (ok) on 30-Дек-10, 17:59 
>> ААА , понял , делал , не дает на кошке это протисать
>> , кричит что для того тчо бы соседей явно указать надо
>> что бы ip ospf network был point-to-multipoint , но у меня
>> то ptp !
> point-to-multipoint интерпретируется как множество ptp линков, так что можно смело менять,
> эффект один и то же.

В циске надо будет писать
R1(config-if)#ip ospf network point-to-multipoint non-broadcast

В кваге
R1(config-if)# ip ospf network non-broadcast

Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

21. "Quagga Ospfd+cisco"  +/
Сообщение от genyas email(??) on 11-Янв-11, 15:23 
>>> ААА , понял , делал , не дает на кошке это протисать
>>> , кричит что для того тчо бы соседей явно указать надо
>>> что бы ip ospf network был point-to-multipoint , но у меня
>>> то ptp !
>> point-to-multipoint интерпретируется как множество ptp линков, так что можно смело менять,
>> эффект один и то же.
> В циске надо будет писать
> R1(config-if)#ip ospf network point-to-multipoint non-broadcast
> В кваге
> R1(config-if)# ip ospf network non-broadcast

Вроде бы помогло ! Спасибо .

Ответить | Правка | ^ к родителю #20 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру