The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Ошибка при инстале mplayer`а"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (Видео, изображения, потоковое вещание / FreeBSD)
Изначальное сообщение [ Отслеживать ]

"Ошибка при инстале mplayer`а"  +/
Сообщение от WhiteO (ok) on 27-Июн-10, 08:49 
искал искал этот гребаный cairo-xxxlib не нашел:(

checking for CAIRO_BACKEND... configure: error: Package requirements (cairo-xlib >= 1.6) were not met:

gnome-config: not found
No package 'cairo-xlib' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables CAIRO_BACKEND_CFLAGS
and CAIRO_BACKEND_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

===>  Script "configure" failed unexpectedly.
Please run the gnomelogalyzer, available from
"http://www.freebsd.org/gnome/gnomelogalyzer.sh", which will diagnose the
problem and suggest a solution. If - and only if - the gnomelogalyzer cannot
solve the problem, report the build failure to the FreeBSD GNOME team at
gnome@FreeBSD.org, and attach (a)
"/usr/ports/x11-toolkits/gtk20/work/gtk+-2.20.1/config.log", (b) the output
of the failed make command, and (c) the gnomelogalyzer output. Also, it might
be a good idea to provide an overview of all packages installed on your system
(i.e. an `ls /var/db/pkg`). Put your attachment up on any website,
copy-and-paste into http://freebsd-gnome.pastebin.com, or use send-pr(1) with
the attachment. Try to avoid sending any attachments to the mailing list
(gnome@FreeBSD.org), because attachments sent to FreeBSD mailing lists are
usually discarded by the mailing list software.
*** Error code 1

Stop in /usr/ports/x11-toolkits/gtk20.
*** Error code 1

Stop in /usr/ports/devel/gconf2.
*** Error code 1

Stop in /usr/ports/devel/gconf2.
*** Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** Error code 1

Stop in /usr/ports/audio/pulseaudio.
*** Error code 1

Stop in /usr/ports/devel/sdl12.
*** Error code 1

Stop in /usr/ports/devel/sdl12.
*** Error code 1

Stop in /usr/ports/multimedia/mplayer.
*** Error code 1

Stop in /usr/ports/multimedia/mplayer.

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Ошибка при инстале mplayer`а"  +/
Сообщение от Xaionaro email(ok) on 29-Июн-10, 17:07 
Port:   mplayer-0.99.11_15
Path:   /usr/ports/multimedia/mplayer
Info:   High performance media player supporting many formats
Maint:  riggs@rrr.de
B-deps: atk-1.28.0 bitstream-vera-1.10_4 cairo-1.8.8,1 compositeproto-0.4 damageproto-1.1.0_2 dri2proto-2.1 encodings-1.0.2,1 expat-2.0.1_1 fixesproto-4.0 font-bh-ttf-1.0.0 font-misc-ethiopic-1.0.0 font-misc-meltho-1.0.0_1 font-util-1.0.1 fontconfig-2.8.0,1 freetype2-2.3.11 gamin-0.1.10_3 gettext-0.17_1 gio-fam-backend-2.22.4 glib-2.22.4 glproto-1.4.10 gmake-3.81_3 gtk-2.18.6_1 hicolor-icon-theme-0.12 inputproto-1.5.0 intltool-0.40.6 jasper-1.900.1_9 jbigkit-1.6 jpeg-8 kbproto-1.0.3 libGL-7.4.4 libICE-1.0.4_1,1 libSM-1.1.0_1,1 libX11-1.2.1_1,1 libXau-1.0.4 libXcomposite-0.4.0,1 libXcursor-1.1.9_1 libXdamage-1.1.1 libXdmcp-1.0.2_1 libXext-1.0.5,1 libXfixes-4.0.3_1 libXft-2.1.14 libXi-1.2.1,1 libXinerama-1.0.3,1 libXrandr-1.3.0 libXrender-0.9.4_1 libXv-1.0.4,1 libXxf86dga-1.0.2 libXxf86vm-1.0.2 libdca-0.0.5 libdrm-2.4.12 libfontenc-1.0.4 libiconv-1.13.1_1 libogg-1.1.4,4 libpthread-stubs-0.3_3 libungif-4.1.4_5 libvorbis-1.2.3_1,3 libxcb-1.5 libxml2-2.7.6_1 mkfontdir-1.0.4 mkfontscale-1.0.6 p5-XML-Parser-2.36_1 pango-1.26.2 pcre-8.00 perl-5.10.1 pixman-0.16.0 pkg-config-0.23_1 png-1.2.42 python26-2.6.4 randrproto-1.3.0 renderproto-0.9.3 shared-mime-info-0.70 speex-1.2.r1_2,1 tiff-3.9.2_1 videoproto-2.2.2 xcb-util-0.3.6_1 xextproto-7.0.5 xf86dgaproto-2.0.3 xf86vidmodeproto-2.2.2 xineramaproto-1.1.2 xorg-fonts-truetype-7.4 xproto-7.0.15 xvid-1.2.2_1,1


Просто проследи, чтобы указанные в зависимости пакеты были установлены правильно. В частности из лога можно предположить, что тебе требуется корректно установить "cairo".

Кстати говоря, в "ports/ports-mgmt/" были порты к программкам, которые отлаживают и исправляют зависимости.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру