The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"MikroTik и BGP"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Открытые системы на сервере (Маршрутизация, NAT / Другая система)
Изначальное сообщение [ Отслеживать ]

"MikroTik и BGP"  +/
Сообщение от GunnerAVS email(??) on 25-Фев-10, 06:02 
История вопроса - мы провайдер с 1 аплинком, вышестоящий аплинк выдал /28 для внутренних служб. И для обеспечения устойчивой работы своего канала рекомендовал получить AS и настроить BGP. С этим пришла мысль раз уж покупать AS купить блок PI адрессов. Бордером работает MikroTik. Приходится срочно осваивать его настройку. Требуется совет все ли я сделаю правильно.

/routing bgp instance set default as="моя AS" redistribute-static=no
/routing bgp peer add remote-address="ип шлюза провайдера" remote-as="AS провайдера"

это я настрою само подключение по BGP со своим пиром, а то нежно для того чтоб анонсировать свой блок PI адрессов ?

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

  • MikroTik и BGP, Александр Лейн, 09:09 , 25-Фев-10, (1)  
    • MikroTik и BGP, GunnerAVS, 10:46 , 25-Фев-10, (2)  
      • MikroTik и BGP, Александр Лейн, 10:56 , 25-Фев-10, (3)  
        • MikroTik и BGP, GunnerAVS, 11:43 , 25-Фев-10, (4)  
          • MikroTik и BGP, vpnet, 23:03 , 25-Фев-10, (5)  
            • MikroTik и BGP, GunnerAVS, 05:23 , 26-Фев-10, (6)  

Сообщения по теме [Сортировка по времени | RSS]


1. "MikroTik и BGP"  +/
Сообщение от Александр Лейн email on 25-Фев-10, 09:09 
микротиг не знаю, но вы для начала объясните, что вам нужно?

Порядок действий: Получили АС и блок адресов, анонсировали свои адреса вышестоящему (читай АС). Радуемся.

> /routing bgp peer add remote-address="ип шлюза провайдера" remote-as="AS провайдера"

не ип-шлюз провайдера, а BGP роутер провайдера

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "MikroTik и BGP"  +/
Сообщение от GunnerAVS email(ok) on 25-Фев-10, 10:46 
>микротиг не знаю, но вы для начала объясните, что вам нужно?
>
>Порядок действий: Получили АС и блок адресов, анонсировали свои адреса вышестоящему (читай
>АС). Радуемся.
>
>> /routing bgp peer add remote-address="ип шлюза провайдера" remote-as="AS провайдера"
>
>не ип-шлюз провайдера, а BGP роутер провайдера

Да чуть ошибся. Нужно чтоб купленый нами блок был доступен снаружи.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "MikroTik и BGP"  +/
Сообщение от Александр Лейн email on 25-Фев-10, 10:56 

>
>Да чуть ошибся. Нужно чтоб купленый нами блок был доступен снаружи.

именно по этому и надо анонсировать свою таблицу вверх, чтобы с помощью бгп до вас могли достучаться из вне. Для этого нужно просто анонсировать свой блок адресов, заюзать под это дело транк и будет работать.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "MikroTik и BGP"  +/
Сообщение от GunnerAVS email(ok) on 25-Фев-10, 11:43 
>
>>
>>Да чуть ошибся. Нужно чтоб купленый нами блок был доступен снаружи.
>
>именно по этому и надо анонсировать свою таблицу вверх, чтобы с помощью
>бгп до вас могли достучаться из вне. Для этого нужно просто
>анонсировать свой блок адресов, заюзать под это дело транк и будет
>работать.

Ясно. Тогда вопрос к специалистам по МикроТику что еще кроме настройки сессии БГП нужно сделать ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

5. "MikroTik и BGP"  +/
Сообщение от vpnet email(ok) on 25-Фев-10, 23:03 

>
>Ясно. Тогда вопрос к специалистам по МикроТику что еще кроме настройки сессии
>БГП нужно сделать ?

стандартных настроек сессии и обмена для бгп вам вполне хватит. дело в том, что вы говорите о "стандарте" понимаете меня, так ведь ;). как поднимать бгп на микротном рутере - навалом доков, вам скорее нужно понимание принципов маршрутизации. для глубокого понимания оно рекомендую к прочтению курс по CCNA, хоть речь тамедется о циско - матрица одна и та-же.

теперь еще раз:

1. делаете транк с верхним провом,  транк вам вполне хватит 2-х рабочих адресов.


2. внутри транка поднимаете бгп. в качестве ремот-ас указываете вашего аплинк-прова и его ас.


3. принимаете от прова по транку "фулл-таблицу" ( грубо говоря - дефолт роут, тк он у вас один и тут особо не развернешся)


4. через несколько минут, тк бгп довольно медленный, смотрите подобие "show ip bgp". если видите тьмы ас-ок и адресов - значит бгп транк поднялся и заработал.

5. менять внутреннюю маршрутизацию в ваших сетях скорее всего не прийдется - всеовно все полетит на дефоллтный шлюз. однако, если вы захотите использовать свои белые адреса - может потребоваться небольшая рихтовка ваших вланов, натов и маршрутов.

вроде ни чего не упустил. А какими коммандами это сделать - хелп в помощь. =))

Успехов!

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "MikroTik и BGP"  +/
Сообщение от GunnerAVS email(ok) on 26-Фев-10, 05:23 
>[оверквотинг удален]
>и маршрутов.
>
>
>
>
>
>вроде ни чего не упустил. А какими коммандами это сделать - хелп
>в помощь. =))
>
>Успехов!

Спасибо уже что-то конкретное, а с реальниками выданными аплинком мы уже справлемся тотже pptp на микротике

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Слёрм
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру