The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Корректирующий релиз офисного пакета LibreOffice 3.6.4"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от opennews (ok) on 05-Дек-12, 21:01 
Организация Document Foundation выпустила (http://blog.documentfoundation.org/2012/12/05/the-document-f.../) корректирующий релиз офисного пакета LibreOffice 3.6.4 (http://www.libreoffice.org/), в котором представлены исправления около 60 ошибок и обновлены файлы с переводами. Начиная с прошлого выпуска ветка LibreOffice 3.6.x позиционируется (http://www.libreoffice.org/download/release-notes/) как стабильная и пригодная для внедрения на предприятиях и в организациях любого размера. Готовые установочные пакеты подготовлены (http://www.libreoffice.org/download/) для платформ Linux, Mac OS X и Windows.


В выпуск LibreOffice 3.6.4 вошли исправления подготовленные в результате проведённого несколько недель назад мероприятия LiMux HackFest, на котором более 30 разработчиков собрались вместе для улучшения кода (http://wiki.documentfoundation.org/Hackfest/Munich2012#Achie...)  LibreOffice и разработки патчей.  Для желающих принять участие в проекте сторонних разработчиков несколько участников мероприятия  подготовили видеоролик, демонстрирующий как легко собирается LibreOffice из исходных текстов.

<center><iframe width="640" height="360" src="http://www.youtube.com/embed/2gIqOOajdYQ?rel=0" frameborder="0" allowfullscreen></iframe></center>

URL: http://blog.documentfoundation.org/2012/12/05/the-document-f.../
Новость: https://www.opennet.ru/opennews/art.shtml?num=35514

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +1 +/
Сообщение от GentooBoy (ok) on 05-Дек-12, 21:01 
Что зы композиция играет?
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

4. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +3 +/
Сообщение от Аноним (??) on 05-Дек-12, 21:03 
Song is »Dubstep took Our Virginity« by Omekkron (aka sssShawnnnn aka Psyche Fix)
Описание к ролику, удивительно да?
Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

6. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +2 +/
Сообщение от Аноним (??) on 05-Дек-12, 21:44 
блин не развернул описание ((
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

2. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +2 +/
Сообщение от Аноним (??) on 05-Дек-12, 21:02 
Вот она суть д-д-д-дабстепа - 5 минутное (не считая времени сборки) натягивание свежей минорщины в бинарном дистре
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от Аноним (??) on 05-Дек-12, 21:03 
Ага, то-то порт Libreoffice в FreeBSD постоянно ломается...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

5. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +2 +/
Сообщение от George (??) on 05-Дек-12, 21:36 
"Для желающих принять участие в проекте сторонних разработчиков" подготовлен видеоролик как сделать обновление убунты и поставить git...
Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

7. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –8 +/
Сообщение от iZEN (ok) on 05-Дек-12, 21:54 
% portinstall -F editors/libreoffice
[Gathering depends for editors/libreoffice .....................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
................................................................................
.................................................. done]
--->  Installing 'glproto-1.4.15' from a port (x11/glproto)
--->  Fetching '/usr/ports/x11/glproto'
=> SHA256 Checksum OK for xorg/proto/glproto-1.4.15.tar.bz2.
--->  Installing 'font-amsfonts-3.02_1' from a port (print/font-amsfonts)
--->  Fetching '/usr/ports/print/font-amsfonts'
=> SHA256 Checksum OK for teTeX/amsfonts-3.02.tar.gz.
--->  Installing 'lp_solve-5.5.2.0' from a port (math/lp_solve)
--->  Fetching '/usr/ports/math/lp_solve'
=> SHA256 Checksum OK for lp_solve_5.5.2.0_source.tar.gz.
--->  Installing 'mdds-0.6.1' from a port (devel/mdds)
--->  Fetching '/usr/ports/devel/mdds'
===>  License MIT accepted by the user
=> mdds_0.6.1.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://multidimalgorithm.googlecode.com/files/mdds_0.6.1.tar...
mdds_0.6.1.tar.bz2                            100% of  125 kB  203 kBps
=> SHA256 Checksum OK for mdds_0.6.1.tar.bz2.
--->  Installing 'cmake-modules-2.8.9' from a port (devel/cmake-modules)
--->  Fetching '/usr/ports/devel/cmake-modules'
===>  License BSD accepted by the user
=> SHA256 Checksum OK for cmake-2.8.9.tar.gz.
--->  Installing 'cmake-2.8.9' from a port (devel/cmake)
--->  Fetching '/usr/ports/devel/cmake'
===>  License BSD accepted by the user
=> SHA256 Checksum OK for cmake-2.8.9.tar.gz.
--->  Installing 'libtool-2.4.2' from a port (devel/libtool)
--->  Fetching '/usr/ports/devel/libtool'
===>  License GPLv2 accepted by the user
=> SHA256 Checksum OK for libtool-2.4.2.tar.gz.
--->  Installing 'libsigsegv-2.10' from a port (devel/libsigsegv)
--->  Fetching '/usr/ports/devel/libsigsegv'
=> SHA256 Checksum OK for libsigsegv-2.10.tar.gz.
--->  Installing 'xf86bigfontproto-1.2.0' from a port (x11-fonts/xf86bigfontproto)
--->  Fetching '/usr/ports/x11-fonts/xf86bigfontproto'
=> SHA256 Checksum OK for xorg/proto/xf86bigfontproto-1.2.0.tar.bz2.
--->  Installing 'xdg-utils-1.0.2_7' from a port (devel/xdg-utils)
--->  Fetching '/usr/ports/devel/xdg-utils'
=> SHA256 Checksum OK for xdg-utils-1.0.2.tgz.
--->  Installing 'hdf5-1.8.9' from a port (science/hdf5-18)
--->  Fetching '/usr/ports/science/hdf5-18'
=> hdf5-1.8.9.tar.bz2 doesn't seem to exist in /usr/ports/distfiles/.
=> Attempting to fetch http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-1.8.9.tar.bz2
fetch: http://www.hdfgroup.org/ftp/HDF5/current/src/hdf5-1.8.9.tar.bz2: Not Found
=> Attempting to fetch ftp://ftp.hdfgroup.org/HDF5/current/src/hdf5-1.8.9.tar.bz2
fetch: ftp://ftp.hdfgroup.org/HDF5/current/src/hdf5-1.8.9.tar.bz2: File unavailable (e.g., file not found, no access)
=> Attempting to fetch http://www.hdfgroup.org/ftp/HDF5/releases/hdf5-1.8.9/src/hdf...
hdf5-1.8.9.tar.bz2                            100% of 5865 kB  302 kBps 00m00s
=> SHA256 Checksum OK for hdf5-1.8.9.tar.bz2.
--->  Installing 'boost-jam-1.48.0' from a port (devel/boost-jam)
--->  Fetching '/usr/ports/devel/boost-jam'
=> SHA256 Checksum OK for boost_1_48_0.tar.bz2.
--->  Installing 'xorg-macros-1.16.1' from a port (devel/xorg-macros)
--->  Fetching '/usr/ports/devel/xorg-macros'
=> SHA256 Checksum OK for xorg/util/util-macros-1.16.1.tar.bz2.
--->  Installing 'bigreqsproto-1.1.1' from a port (x11/bigreqsproto)
--->  Fetching '/usr/ports/x11/bigreqsproto'
=> SHA256 Checksum OK for xorg/proto/bigreqsproto-1.1.1.tar.bz2.
--->  Installing 'xcmiscproto-1.2.1' from a port (x11/xcmiscproto)
--->  Fetching '/usr/ports/x11/xcmiscproto'
=> SHA256 Checksum OK for xorg/proto/xcmiscproto-1.2.1.tar.bz2.
--->  Installing 'xtrans-1.2.6' from a port (x11/xtrans)
--->  Fetching '/usr/ports/x11/xtrans'
===>  License MIT accepted by the user
=> SHA256 Checksum OK for xorg/lib/xtrans-1.2.6.tar.bz2.
--->  Installing 'ilmbase-1.0.2' from a port (graphics/ilmbase)
--->  Fetching '/usr/ports/graphics/ilmbase'
=> SHA256 Checksum OK for ilmbase-1.0.2.tar.gz.
--->  Installing 'qt4-qmake-4.8.2_3' from a port (devel/qmake4)
--->  Fetching '/usr/ports/devel/qmake4'
=> qt-everywhere-opensource-src-4.8.2.tar.gz doesn't seem to exist in /usr/ports/distfiles/KDE.
=> Attempting to fetch http://releases.qt-project.org/qt4/source/qt-everywhere-open...
qt-everywhere-opensource-src-4.8.2.tar.gz       8% of  228 MB  569 kBps 06m17s^C
fetch: transfer interrupted
** Command failed [exit code 2]: /usr/bin/script -qa /tmp/portinstall20121205-23478-1ytcnkn env make -DBATCH checksum
** Fix the problem and try again.
--->  Skipping 'devel/qt4-moc' because a requisite port 'devel/qmake4' failed (specify -k to force)
--->  Installing 'gperf-3.0.3' from a port (devel/gperf)
--->  Fetching '/usr/ports/devel/gperf'
===>  License GPLv2 accepted by the user
=> SHA256 Checksum OK for gperf-3.0.3.tar.gz.
--->  Skipping 'devel/qt4-rcc' because a requisite port 'devel/qmake4' failed (specify -k to force)
^C
Interrupted.
** Listing the failed packages (-:ignored / *:skipped / !:failed)
    ! devel/qmake4    (interrupted by user)
    * devel/qt4-moc
    * devel/qt4-rcc

Не стану даже связываться с этой гадостью.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от grem on 05-Дек-12, 22:01 
> Не стану даже связываться с этой гадостью.

Хе, а я то как удивился, когда он про phonon окошко выдал в том ролике :)
хотя у меня KDE. Но на самом деле, судя по USE-флагам в gentoo, можно и gtk использовать при сборке.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –1 +/
Сообщение от iZEN (ok) on 05-Дек-12, 22:13 
После запуска установки portmaster'ом вот что предложило поставить:

===>>> editors/libreoffice >> (38)

===>>> The following actions will be taken if you choose to proceed:
    Install editors/libreoffice
    Install archivers/p5-Archive-Zip
    Install devel/bison
    Install devel/cppunit
    Install devel/libtool
    Install devel/dmake
    Install devel/gmake
    Install devel/gperf
    Install devel/mdds
    Install devel/patch
    Install graphics/vigra
    Install devel/cmake
    Install devel/cmake-modules
    Install graphics/OpenEXR
    Install graphics/ilmbase
    Install science/hdf5-18
    Install textproc/intltool
    Install textproc/p5-XML-Parser
    Install graphics/graphite2
    Install graphics/libwpg
    Install textproc/libwpd
    Install graphics/sampleicc
    Install math/lp_solve
    Install net/libcmis
    Install textproc/hyphen
    Install lang/gawk
    Install devel/libsigsegv
    Install textproc/libexttextcat
    Install textproc/libvisio
    Install textproc/libwps
    Install textproc/mythes
    Install textproc/redland
    Install textproc/raptor2
    Install devel/yajl
    Install textproc/rasqal
    Install x11-fonts/gentium-basic
    Install x11-fonts/liberation-fonts-ttf
    Install x11-fonts/linuxlibertine-g
    Install x11-toolkits/gtk30

Никакого Qt не замечено.
Запустил сборку. Надеюсь, 8ГБ пространства на HDD хватит.

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

18. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –2 +/
Сообщение от iZEN (ok) on 06-Дек-12, 00:12 
> Запустил сборку. Надеюсь, 8ГБ пространства на HDD хватит.

% pkg_info -Ex libreoffice
libreoffice-3.5.7
libreoffice-i18n-3.5.7
ru-libreoffice-3.5.7
— собралось.

Интерфейс виджетов в диалоговых окнах как у Windows 95. Это наверно из-за выбора опции Gtk3 вместо Gtk2?

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

10. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от Змей email(??) on 05-Дек-12, 22:29 
У меня почему-то влетело без проблем.

% pkg_info | grep libreoffice
libreoffice-3.5.7   Full integrated office productivity suite
ru-libreoffice-3.5.7 ru language pack for libreoffice

FreeBSD 9.1-RELEASE amd64
На 3-х машинах работает, есть мелкие гадости, но не мешают.


Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

15. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –2 +/
Сообщение от grem on 05-Дек-12, 23:58 
> есть мелкие гадости, но не мешают.

не знаю, описал ли кто эти баги (я в основном OpenOffice использую), но при открытии простого документа сохранённого из MS Word 2010

1. Не отображаются границы ячеек в таблице (они есть, но отображаются как невидимые).
2. Если в тексте вдруг идёт блок из двух колонок, то после него почему-то словно вставлен разрыв страницы, хотя его нет. Да и сам блок с двумя колонками странно выглядит.

Ответить | Правка | ^ к родителю #10 | Наверх | Cообщить модератору

26. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +3 +/
Сообщение от Аноним (??) on 06-Дек-12, 11:08 
MS Word 2010 вообще очень странный текстовый процессор.
Ответить | Правка | ^ к родителю #15 | Наверх | Cообщить модератору

28. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –1 +/
Сообщение от Аноним (??) on 07-Дек-12, 11:09 
> MS Word 2010 вообще очень странный текстовый процессор.

Может, у тебя просто руки под куй заточены?


Ответить | Правка | ^ к родителю #26 | Наверх | Cообщить модератору

12. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от soshial on 05-Дек-12, 23:25 
а чем qt плох? я не троллю, просто мнению хочу составить разностороннее.
Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

17. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от grem on 06-Дек-12, 00:06 
> а чем qt плох? я не троллю, просто мнению хочу составить разностороннее.

я вот тоже не знаю, так как использую программы, которые мне кажутся более удобными, а используют они qt (да хоть kde-libs, хотя у меня и так KDE, но когда стоял Gnome тоже ничуть не мешало) они или gtk - значения не имееет :\

Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

19. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от iZEN (ok) on 06-Дек-12, 00:15 
> а чем qt плох? я не троллю, просто мнению хочу составить разностороннее.

Дело в том, что LibreOffice перед сборкой предлагает сконфигурировать себя с привязкой к следующим тулкитам: Qt4, Gtk2 и Gtk3. При использовании только Gtk-программ и DE как-то неуместно завязываться на чужеродный Qt4.


Ответить | Правка | ^ к родителю #12 | Наверх | Cообщить модератору

29. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от KDE Boy on 07-Дек-12, 17:25 
Я сам кдешник, и я тебя в данном случае понимаю. Ладно бы если бы разработчики сторонних по отношению к DE тулкитов работали в направлении интеграции их в разноообразные DE. Разработчики 4-го Qt, в бытность их ещё Троллтехом, работали над проблемой нативного отображения в GNOME, а вот разрабы Gtk ничего не сделали в данном направлении. А существующие сторонние костыли решают проблему лишь частично или только для одной определённой темы. И то не полностью решают: напрмер, нативного файлового диалога всё равно нет.
Ответить | Правка | ^ к родителю #19 | Наверх | Cообщить модератору

14. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +2 +/
Сообщение от Аноним (??) on 05-Дек-12, 23:49 
> portinstall -F editors/libreoffice
> Не стану даже связываться с этой гадостью.

Да, ладно, freebsd местами не такая уж и гадость. Хотя, в целом - согласен.

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

21. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +2 +/
Сообщение от arisu (ok) on 06-Дек-12, 01:40 
> Да, ладно, freebsd местами не такая уж и гадость. Хотя, в целом
> - согласен.

WIN!

Ответить | Правка | ^ к родителю #14 | Наверх | Cообщить модератору

13. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +7 +/
Сообщение от Аноним (??) on 05-Дек-12, 23:33 
У меня 2 вопроса:

1. Что такое дабстеп?

2. Когда появится новый UI в либре?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

22. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +8 +/
Сообщение от arisu (ok) on 06-Дек-12, 01:40 
> 1. Что такое дабстеп?

это инопланетяне сношают корову.

Ответить | Правка | ^ к родителю #13 | Наверх | Cообщить модератору

16. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +/
Сообщение от filosofem (ok) on 06-Дек-12, 00:04 
Были новости, что радикально чистили, рефакторили код, но судя по размеру, зависимостям и весу относительно фич, там ещё ~70% мусора, который надо вычищать и переписывать.
Соответственно вопрос, что уже вычистили, а что ещё предстоит убрать и будут ли ещё чистить, или оставят как есть и не проще ли с нуля всё написать без атавизмов и тормозов, или адаптировать Calligra, чем доводить до ума это чудище?

PS ни разу не Миша Рыцарев, но все эти офисы они навевают такое настроение, не люблю я их.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

20. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  +1 +/
Сообщение от Led (ok) on 06-Дек-12, 01:21 
>ни разу не Миша Рыцарев, но все эти офисы они навевают такое настроение

Он вас укусил? Обратисесь к врачу, а то мало ли что...

Ответить | Правка | ^ к родителю #16 | Наверх | Cообщить модератору

24. "Корректирующий релиз офисного пакета LibreOffice 3.6.4"  –1 +/
Сообщение от Аноним (??) on 06-Дек-12, 09:07 
> Начиная с прошлого выпуска ветка LibreOffice 3.6.x позиционируется как стабильная и пригодная для внедрения на предприятиях и в организациях любого размера.

В 3.6 проблемы с форматами docx и xlsx. Так что ни разу не стабильная и не пригодная. Что и помешало внедрить ее на предприятии.  Вернулся на 3.4 там с этим более-менее хорошо.

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
PostgresPro
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру