The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Линковка либы, использующей Qt3 к коду на Qt4"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Программирование под UNIX (GUI, XWindow, Qt, GTK)
Изначальное сообщение [ Отслеживать ]

"Линковка либы, использующей Qt3 к коду на Qt4"  +/
Сообщение от redcore on 17-Фев-10, 17:29 
В общем проблема такая: есть либы, в которых используется Qt3. Их исходники недоступны.
Также есть проект на Qt4, который использует функции из этих либ.
В Makefile добавил -DQT3_SUPPORT, а также -lmylib и тд.
ld ругается на разные мемберы классов Qt3, которых в Qt4 нет.
Можно ли слинковать всё так, чтобы либы использующие Qt3, получили нужные функции из библиотек от Qt3, и всё это дело прилинковалось бы к проджекту на Qt4?
Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Линковка либы, использующей Qt3 к коду на Qt4"  +/
Сообщение от anarsoul on 17-Фев-10, 17:52 
>В общем проблема такая: есть либы, в которых используется Qt3. Их исходники
>недоступны.
>Также есть проект на Qt4, который использует функции из этих либ.
>В Makefile добавил -DQT3_SUPPORT, а также -lmylib и тд.
>ld ругается на разные мемберы классов Qt3, которых в Qt4 нет.
>Можно ли слинковать всё так, чтобы либы использующие Qt3, получили нужные функции
>из библиотек от Qt3, и всё это дело прилинковалось бы к
>проджекту на Qt4?

Нет, нельзя, бинарной совместимости нет, как и нет полной совместимости по исходникам.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

2. "Линковка либы, использующей Qt3 к коду на Qt4"  +/
Сообщение от ws (ok) on 17-Фев-10, 18:09 
>В общем проблема такая: есть либы, в которых используется Qt3. Их исходники
>недоступны.
>Также есть проект на Qt4, который использует функции из этих либ.
>В Makefile добавил -DQT3_SUPPORT, а также -lmylib и тд.
>ld ругается на разные мемберы классов Qt3, которых в Qt4 нет.
>Можно ли слинковать всё так, чтобы либы использующие Qt3, получили нужные функции
>из библиотек от Qt3, и всё это дело прилинковалось бы к
>проджекту на Qt4?

Нельзя.
Надо две версии библиотеки использовать - qt3 и qt4, т.к. сказали выше, нет не только бинарной совместимости, но и на уровне исходников (интерфейс классов qt3_support поменялся).

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Линковка либы, использующей Qt3 к коду на Qt4"  +/
Сообщение от redcore on 17-Фев-10, 19:12 
Понятно, спасибо.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру