The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Вопрос новичка по FreeBSD. Сединение с провайдером"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Открытые системы на сервере (BSD привязка)
Изначальное сообщение [ Отслеживать ]

"Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от sherem email(ok) on 21-Фев-09, 10:34 
Хочу сделать маршрутизатор на FreeBSD.
Сейчас стоит аппаратный роутер (D-LINK DI-804HV), работает без проблем.

Собрал железку, установил версию FreeBSD 7.1

С провайдером соединен по витой паре
Провайдер выдаёт свой IP по DHCP, базируясь на MAC. Изменил MAC внешнего интерфейса в соответствии с зарегистрированным у провайдера.

Соединения нет.

ifconfig выдаёт:

em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
        ether 00:15:f2:c0:81:14
        inet <правильный ip> netmask 0xffffff00 broadcast <правильный broadcast>
        media: Ethernet autoselect
        status: no carrier

Визуально интерфейс мигает индикаторами с частотой раз в 2 секунды. Такое ощущение, что он ложится а потом поднимается.

Делал вторую сетевую карту внешним интерфейсом, а первую - внутренним результат аналогичный.

Какое несоответствие в настройках интерфейса может давать подобный результат?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от kam (ok) on 21-Фев-09, 12:58 
>em0: flags=8843<UP,BROADCAST,RUNNING,SIMPLEX,MULTICAST> metric 0 mtu 1500
>        options=19b<RXCSUM,TXCSUM,VLAN_MTU,VLAN_HWTAGGING,VLAN_HWCSUM,TSO4>
>        ether 00:15:f2:c0:81:14
>        inet <правильный ip> netmask 0xffffff00 broadcast <правильный broadcast>
>        media: Ethernet autoselect
>        status: no carrier

Этот статус означает, что твоя сетевуха (гигабитный интел)не договорилась с коммутатором (каким-нибудь Д-линком) на физическом уровне. Попробуй явно задать скорость (провайдеры обычно лочат акцесс порты на 10Мбит) и режим работы. Если не поможет, поставь что-нибудь на базе Realtek 8139 (драйвер rl) и попробуй с ним.


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от GD on 21-Фев-09, 17:11 
>[оверквотинг удален]
>        media: Ethernet autoselect
>        status: no carrier
>
>Визуально интерфейс мигает индикаторами с частотой раз в 2 секунды. Такое ощущение,
>что он ложится а потом поднимается.
>
>Делал вторую сетевую карту внешним интерфейсом, а первую - внутренним результат аналогичный.
>
>
>Какое несоответствие в настройках интерфейса может давать подобный результат?

уверен что смена MAC адреса прошла успешно, там где надо и на то что надо?

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

3. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от Alex Shepovalov email on 22-Фев-09, 02:20 
>[оверквотинг удален]
>>Визуально интерфейс мигает индикаторами с частотой раз в 2 секунды. Такое ощущение,
>>что он ложится а потом поднимается.
>>
>>Делал вторую сетевую карту внешним интерфейсом, а первую - внутренним результат аналогичный.
>>
>>
>>Какое несоответствие в настройках интерфейса может давать подобный результат?
>
>уверен что смена MAC адреса прошла успешно, там где надо и на
>то что надо?

если уверены задайте попробуйте скорость явно

ifconfig em0 media 100BaseTX mediaopt full-duplex up
если у вас 10мбит то догадаетесь где поменять ;)

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от sherem (ok) on 24-Фев-09, 10:49 
>[оверквотинг удален]
>>>
>>>Какое несоответствие в настройках интерфейса может давать подобный результат?
>>
>>уверен что смена MAC адреса прошла успешно, там где надо и на
>>то что надо?
>
>если уверены задайте попробуйте скорость явно
>
>ifconfig em0 media 100BaseTX mediaopt full-duplex up
>если у вас 10мбит то догадаетесь где поменять ;)

Спасибо... попробую, а то я сходу не нашел как залочить скорость, я полез искать конфигурацию дайвера

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от sherem (ok) on 24-Фев-09, 10:57 
>[оверквотинг удален]
>>Визуально интерфейс мигает индикаторами с частотой раз в 2 секунды. Такое ощущение,
>>что он ложится а потом поднимается.
>>
>>Делал вторую сетевую карту внешним интерфейсом, а первую - внутренним результат аналогичный.
>>
>>
>>Какое несоответствие в настройках интерфейса может давать подобный результат?
>
>уверен что смена MAC адреса прошла успешно, там где надо и на
>то что надо?

IP адрес я получил верный, я его нигде не прописывал, а ifconfig мне его правильно выдаёт, значит MAC правильный, кроме того, я сперва неправильно менял MAC, тогда IP не было.

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

6. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от tzuken on 06-Апр-09, 17:33 
столкнулся с той же проблемой (мигающий раз в 2 секунды индикатор link и status: no carrier)
использовал RTL8139D и freeBSD 6.2
вся физика проверена.
на другом конце кабеля коммутатор.
пытался проставлять разные параметры media и mediaopt в ifconfig - не помогает
в полудуплексе работать отказывается с сообщением

ifconfig: SIOCSIFMEDIA (media): device not configured

впрочем свитч на том конце работает в 100BaseTX фулл-дуплексе, виндовые машины сконфигурированы как раз на фулл.

уже не знаю, на что грешить.. может подобное быть из-за irq?
пожалуйста, посоветуйте что-нибудь для решения ситуации.

Ответить | Правка | ^ к родителю #5 | Наверх | Cообщить модератору

7. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от sherem (ok) on 07-Апр-09, 06:25 
>[оверквотинг удален]
>
>в полудуплексе работать отказывается с сообщением
>
>ifconfig: SIOCSIFMEDIA (media): device not configured
>
>впрочем свитч на том конце работает в 100BaseTX фулл-дуплексе, виндовые машины сконфигурированы
>как раз на фулл.
>
>уже не знаю, на что грешить.. может подобное быть из-за irq?
>пожалуйста, посоветуйте что-нибудь для решения ситуации.

У меня полечилось после того, как я по советам старших товарищей железно указал скорость и дуплексность. Но не сразу, пришлось поиграть настройками.

Ответить | Правка | ^ к родителю #6 | Наверх | Cообщить модератору

8. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от tzuken on 08-Апр-09, 15:06 

>У меня полечилось после того, как я по советам старших товарищей железно
>указал скорость и дуплексность. Но не сразу, пришлось поиграть настройками.

подскажите, с какими настройками?

Ответить | Правка | ^ к родителю #7 | Наверх | Cообщить модератору

9. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от tzuken on 22-Апр-09, 14:33 
проблему "поборол" переустановкой на версию 7.1
на той же карте интерфейс взлетел самостоятельно.
вывод: неверно скомпиленый rl драйвер
Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

10. "Вопрос новичка по FreeBSD. Сединение с провайдером"  +/
Сообщение от Hanggard on 26-Май-11, 22:33 
> проблему "поборол" переустановкой на версию 7.1
> на той же карте интерфейс взлетел самостоятельно.
> вывод: неверно скомпиленый rl драйвер

А мог бы и ядро пересобрать…

Ответить | Правка | ^ к родителю #9 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2020 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру