The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Не могу настроить тегированный VLAN Mikrotik + CISCO"
Вариант для распечатки  
Пред. тема | След. тема 
Форум Маршрутизаторы CISCO и др. оборудование. (Cisco Catalyst коммутаторы)
Изначальное сообщение [ Отслеживать ]

"Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от Spar (??) on 24-Май-13, 17:04 
странная проблема с  Микротиком (RouterBOARD CCR1016-12G) ...  почти новый... купленный  пару месяцев назад. Паршивка последняя,  6.0.  поставил 8 гб озу вместо штатных 2-ух.   До  сего момента  на "боевое дежурство" железку не ставил. Постоянно тестировал и эксперементировал.  Работаю с Cisco и OC Linux  лет 10,  с Микротиком познакомился недавно.

Вот какая у меня проблема.   НЕ МОГУ НАСТРОИТЬ тегированный VLAN в связке со свичами CISCO.
Просто бред какойто.  С д-линками - всё ок.  С Цисками - нивкакую!

Циска:

interface GigabitEthernet0/19
description Miktotik_downlink
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 18,40
switchport mode trunk
switchport nonegotiate (пробовал и без него)

на Микротике на интерфейс etherX вешаю  два влана (пробовал и с одним и с тремя ит.д.)
с тегами 18 и 40 соответсвенно  (разумеется  номера  тегов пробовал разные  и свичи (циски) пробовал разные)
на  эти вланы вешаю  ip адреса из соотв. подсетей. Адреса недоступны.

ИНОГДА (!!) если  повесить ip address не на vlan  а на etherX -  то он начинает пинговаться (о, чудо!). Работает это только с одноим вланом и одним адресом. Второй ip уже не повесишь.


повторюсь, если настраивать связку  mikrotik + свич dlink , то всё работает.


на  микротике  вланы настраивал и через  winbox и через  командную  строку. вот так:

/interface vlan
add name=VLAN18 vlan-id=18 interface=ether1 disabled=no
add name=VLAN40 vlan-id=40 interface=ether1 disabled=no

/ip address
add address=10.1.18.1/24 interface=VLAN18
add address=10.1.40.1/24 interface=VLAN40


В винбоксе есть галочка что-то типа  "use service tag"  - пробовал и с ней и без нее.
---------------------------

это первая проблема. вторая, возможно произрастающая из нее:

НЕ МОГУ НАСТРОИТЬ БРИДЖ в связке с CISCO.  На длинках опять же всё работает,  Подключаю бридж к  циске - не  идёт трафик. При том что   вланов нкиаких уже нет, просто  два  порта в   режиме   "switchport mode access"


---------------------------

Единственное что еще не пробовал -  поменять оперативку обратно на родную (т.к. стоит в стойке и сложно достать). И еще одно.. иногда  во_время_настройки_через_winbox теряется связь с миктотиком и до него не достучаться. приходится ребутить по питанию :(

Перерыл гугл и яндекс,  нигде похожих проблем не находил. Может надо  чинить  железку ?

Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от Ash (??) on 24-Май-13, 17:47 
Попробуй на циске указать натив влан


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

2. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от Spar (??) on 24-Май-13, 18:17 
> Попробуй на циске указать натив влан

спасибо, попробую!
думаешь это поможет ?   и с  бриджем в том числе ?

Ответить | Правка | ^ к родителю #1 | Наверх | Cообщить модератору

3. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от pavel (??) on 24-Май-13, 23:39 
>> Попробуй на циске указать натив влан
> спасибо, попробую!
> думаешь это поможет ?   и с  бриджем в том
> числе ?

Я бы еще vtp отключил и vtp transparent сказал.И убедился что на циске созданы такие vlan

Ответить | Правка | ^ к родителю #2 | Наверх | Cообщить модератору

4. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от jied83 (ok) on 27-Май-13, 17:16 
>>> Попробуй на циске указать натив влан
>> спасибо, попробую!
>> думаешь это поможет ?   и с  бриджем в том
>> числе ?
> Я бы еще vtp отключил и vtp transparent сказал.И убедился что на
> циске созданы такие vlan

я бы удалил и заново создал все на микротике, я также мучался целый день, не работает и все!
хотя настроено было правильно, удалил все что настроил на микротике, создал заново и заработало!

Ответить | Правка | ^ к родителю #3 | Наверх | Cообщить модератору

5. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от dee on 27-Май-13, 20:13 
conf t
no spanning-tree vlan XXX
Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

6. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от Евгений (??) on 12-Июн-13, 16:16 
>>>> Попробуй на циске указать натив влан
>>> спасибо, попробую!
>>> думаешь это поможет ?   и с  бриджем в том
>>> числе ?
>> Я бы еще vtp отключил и vtp transparent сказал.И убедился что на
>> циске созданы такие vlan
> я бы удалил и заново создал все на микротике, я также мучался
> целый день, не работает и все!
> хотя настроено было правильно, удалил все что настроил на микротике, создал заново
> и заработало!

У меня тоже была аналогичная ситуация.
Вообще микротик понравился и тегированный трафик пропускал. Попробуйте обнулить все. Там есть спец комбинация хардварных кнопок. И потом постепенно настраивать и проверять каждую фичу. Добавляя по одной. Сначала 1 влан в транк, потом еще один.
И доку перечитайте еще раз по микротику. Я помню там идеология другая. Там вроде влан как контейнер создается а потом в него порты добавляются.

Ответить | Правка | ^ к родителю #4 | Наверх | Cообщить модератору

7. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  –1 +/
Сообщение от gilroy (ok) on 26-Июн-13, 10:33 
>[оверквотинг удален]
>  идёт трафик. При том что   вланов нкиаких уже
> нет, просто  два  порта в   режиме  
>  "switchport mode access"
> ---------------------------
> Единственное что еще не пробовал -  поменять оперативку обратно на родную
> (т.к. стоит в стойке и сложно достать). И еще одно.. иногда
>  во_время_настройки_через_winbox теряется связь с миктотиком и до него не достучаться.
> приходится ребутить по питанию :(
> Перерыл гугл и яндекс,  нигде похожих проблем не находил. Может надо
>  чинить  железку ?

soo nice and good taking

Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

8. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от Роман email(??) on 28-Ноя-13, 17:46 

>[оверквотинг удален]
> add address=10.1.40.1/24 interface=VLAN40
> В винбоксе есть галочка что-то типа  "use service tag"  -
> пробовал и с ней и без нее.
> ---------------------------
> это первая проблема. вторая, возможно произрастающая из нее:
> НЕ МОГУ НАСТРОИТЬ БРИДЖ в связке с CISCO.  На длинках опять
> же всё работает,  Подключаю бридж к  циске - не
>  идёт трафик. При том что   вланов нкиаких уже
> нет, просто  два  порта в   режиме  
>  "switchport mode access"

1). ПРоверь чтобы на циске nativ vlan не был ни одним из тех виланов что ты хочешь получить... пусть он будет например 1.
2). На микротике создай бридж добавь в бридж добавь в бридж влан который ты хочешь видет ьна порту, потом в этот же бридж добавь порт.
3). Давай Ip > adress  не Vlan а Бриджу который ты создал по пункту 2.


Ответить | Правка | ^ к родителю #0 | Наверх | Cообщить модератору

9. "Не могу настроить тегированный VLAN Mikrotik + CISCO"  +/
Сообщение от anton (??) on 09-Ноя-15, 15:45 
>[оверквотинг удален]
>>  идёт трафик. При том что   вланов нкиаких уже
>> нет, просто  два  порта в   режиме
>>  "switchport mode access"
> 1). ПРоверь чтобы на циске nativ vlan не был ни одним из
> тех виланов что ты хочешь получить... пусть он будет например 1.
> 2). На микротике создай бридж добавь в бридж добавь в бридж влан
> который ты хочешь видет ьна порту, потом в этот же бридж
> добавь порт.
> 3). Давай Ip > adress  не Vlan а Бриджу который ты
> создал по пункту 2.

conf t
interface GigabitEthernetXXX
no switchport port-security

Ответить | Правка | ^ к родителю #8 | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру