The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"аналог SNAT и DNAT на Киске"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Маршрутизаторы CISCO и др. оборудование. (Public)
Изначальное сообщение [Проследить за развитием треда]

"аналог SNAT и DNAT на Киске" 
Сообщение от asp emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(ok) on 11-Апр-05, 15:43  (MSK)
Имеется - роутер Cisco 1721 с реальным IP, за ним, в подсети 192.168.*.* один из хостов. Требуется организовать возможность доступа к 22му порту внутреннего хоста. Раньше подобные ситуации удавалось "разруливать" на iptables чем-то подобным (могу немного ошибаться, но суть останется):
-A PREROUTING -p tcp -m tcp --dport 10000 -j DNAT --to-dest 192.168.0.1:22
-A POSTROUTING -p tcp -m tcp -s 192.168.0.1 --sport 22 -j SNAT --to-source REAL_IP:PORT
Подскажите, пожалуйста, удастся ли организовать нечто подобное на Cisco и, если да, то от чего начинать копать? То есть, требуется извне получить доступ к "серой" машине, конкретно - ее ssh консоли.
  Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

 Оглавление

Индекс форумов | Темы | Пред. тема | След. тема
Сообщения по теме

1. "аналог SNAT и DNAT на Киске" 
Сообщение от courby Найти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации. on 11-Апр-05, 19:12  (MSK)
!
interface Fa0
description inside
ip address 192.168.1.1 255.255.255.0
ip nat inside
!
interface Et0
description inet
ip access-group acl_inet in
ip address 1.1.1.1 255.255.255.252
ip nat outside
!
ip nat inside source static 192.168.1.10 2.2.2.2
!
ip access-list extended acl_inet
...
permit tcp any host 2.2.2.2 eq 22
....
!
end
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх

2. "аналог SNAT и DNAT на Киске" 
Сообщение от denn emailНайти другие сообщения данного автораПоместить сообщение в закладки. См. нижнее поле навигации.(??) on 11-Апр-05, 19:15  (MSK)
ip nat inside source static tcp 192.168.10.1 22 real_ip 22
  Удалить Правка | Высказать мнение | Ответить | Рекомендовать в FAQ | Cообщить модератору | Наверх


Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Пожалуйста, прежде чем написать сообщение, ознакомьтесь с данными рекомендациями.




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру