The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"./configure в некоторых программах завершается с ошибкой"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [ Отслеживать ]

"./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от andrystepa (ok) on 27-Апр-07, 15:05 
Установил на новый компьютер операционную систему Fedora Core 6 x64 bit. При попытке установить некоторые программы из исходных кодов возникают ошибки при конфигурировании Make файла. Сначала запуск ./configure для программы trafshow завершился так:
root@mail trafshow-5.2.3]# ./configure
checking build system type... Invalid configuration `x86_64-pc-linux-gnuoldld': machine `x86_64-pc' not recognized
configure: error: /bin/sh ./config.sub x86_64-pc-linux-gnuoldld failed

Затем, при попытке установить vqadmin произошло примерно то же самое:
[root@mail vqadmin-2.3.6]# ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/downloads/qmailrocks/vqadmin-2.3.6/missing: Unknown `--run' option
Try `/downloads/qmailrocks/vqadmin-2.3.6/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... Invalid configuration `x86_64-unknown-linuxoldld': machine `x86_64-unknown' not recognized
configure: error: /bin/sh ./config.sub x86_64-unknown-linuxoldld failed

Кто знает, почему это происходит? Помогите разобраться, как это лечить!

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от vic (??) on 27-Апр-07, 15:20 
>checking build system type... Invalid configuration `x86_64-pc-linux-gnuoldld': machine `x86_64-pc' not recognized
>configure: error: /bin/sh ./config.sub x86_64-pc-linux-gnuoldld failed
>checking build system type... Invalid configuration `x86_64-unknown-linuxoldld': machine `x86_64-unknown' not recognized
>configure: error: /bin/sh ./config.sub x86_64-unknown-linuxoldld failed
>
>Кто знает, почему это происходит? Помогите разобраться, как это лечить!


так написано же что не знает что такое x86_64. А у вас 64битная тачка. Эти программы либо не портированы под 64бита, либо у вас не те исходники. Скрипты configure в них еще не знают про 64бит вот и ругаются. Можно конечно руками пересобрать пакет, но это будет unstable.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от andrystepa (ok) on 27-Апр-07, 19:39 

>так написано же что не знает что такое x86_64. А у вас
>64битная тачка. Эти программы либо не портированы под 64бита, либо у
>вас не те исходники. Скрипты configure в них еще не знают
>про 64бит вот и ругаются. Можно конечно руками пересобрать пакет, но
>это будет unstable.

А установка 32 битной версии ОС может исправить ситуацию? Или она на железо ругается?


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от vic (??) on 28-Апр-07, 02:07 
>
>>так написано же что не знает что такое x86_64. А у вас
>>64битная тачка. Эти программы либо не портированы под 64бита, либо у
>>вас не те исходники. Скрипты configure в них еще не знают
>>про 64бит вот и ругаются. Можно конечно руками пересобрать пакет, но
>>это будет unstable.
>
>А установка 32 битной версии ОС может исправить ситуацию? Или она на
>железо ругается?

Да какое-там железо)) На железо только драйверы могут ругаться, остальной софт абстрагирован от железа системой.

32-битка может поможет. А может другие грабли вылезут. Если есть виртуальная машина - проверить за 5 мин можно. А так переставлять придется. Или искать портированную версию если она существует (авторы этих утилиты должны были позаботится об этом, если не забросили их).

p.s. trafshow на FC5 32bit x86 конфигурится и компилится без проблем. Проверил=)
vqadmin хочет qmail поэтому не проверял.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от andrystepa (??) on 28-Апр-07, 09:32 
Я ставил qmail с vqadmin на FC5 32bit - все нормально работало. Но это была другая, довольно древняя машина еще на третьем Пентиуме. А здесь стоит AMD 64x2 - поэтому и спрашивал про железо. На сайте авторов vqadmin ничего про портабельную для 64bit версию не нашел. Есть только обновленная версия vqadmin, но и она выдает ту же ошибку.


Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от Sect0R on 11-Авг-09, 18:12 
>[оверквотинг удален]
>>configure: error: /bin/sh ./config.sub x86_64-unknown-linuxoldld failed
>>
>>Кто знает, почему это происходит? Помогите разобраться, как это лечить!
>
>
>так написано же что не знает что такое x86_64. А у вас
>64битная тачка. Эти программы либо не портированы под 64бита, либо у
>вас не те исходники. Скрипты configure в них еще не знают
>про 64бит вот и ругаются. Можно конечно руками пересобрать пакет, но
>это будет unstable.

Сделай
cp ../vpopmail-5.4.9/config.sub .
Т.е. скопируй confug.sub из vpopmail в vqadmin

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от GloryS (??) on 28-Апр-07, 13:43 
Я бы попробовал поиграться с параметрами configure...типа
./configure --build=i386-pc-linux-gnu
а также с target
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от mist (ok) on 22-Авг-09, 08:45 
этот вопрос решается так, в папке где лежат сырцы и соответственно сам ./configure нужно набрать
# libtoolize --force
и заного повторить ./configure
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

8. "./configure в некоторых программах завершается с ошибкой"  +/
Сообщение от slavikdan on 09-Сен-09, 16:04 
Попробуй поставить новую русифицированную версию vqadmin-2.3.7-ru http://www.nglab.ru/opensource.shtml
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру