The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Релиз Flash Player 10.1 с исправлением критической уязвимост..."
Вариант для распечатки  
Пред. тема | След. тема 
Форум Разговоры, обсуждение новостей
Изначальное сообщение [ Отслеживать ]

"Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от opennews (??) on 11-Июн-10, 09:42 
Компания Adobe объявила о выходе (http://www.adobe.com/products/flashplayer/) релиза Flash Player 10.1 (http://www.adobe.com/products/flashplayer/) для платформ Linux, Windows и Mac OS X.  Это первый выпуск, базирующийся на инициативе Open Screen Project (https://www.opennet.ru/opennews/art.shtml?num=15651). Сборки для Solaris и мобильной платформы Android пока доступны (http://labs.adobe.com/downloads/flashplayer10.html#android) только в виде тестовых версий.


Кроме реализации ряда интересных новшеств в новой версии устранена критическая уязвимость (https://www.opennet.ru/opennews/art.shtml?num=26865), которой в силу популярности Flash-плагина присвоен (http://secunia.com/advisories/40026/) высший уровень опасности. Уязвимость присутствует в виртуальной машине ActionScript Virtual Machine 2 (AVM2) и позволяет злоумышленнику организовать выполнение своего кода в системе при открытии пользователем специально подготовленного SWF-файла.


Основные новшества (http://labs.adobe.com/tech...

URL: http://www.adobe.com/products/flashplayer/
Новость: https://www.opennet.ru/opennews/art.shtml?num=26928

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от Аноним (??) on 11-Июн-10, 09:42 
Я еще не видел ни одного релиза флеш плеера без исправления критической уязвимости? Когда уже все откажутся от этого поделия?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

3. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –3 +/
Сообщение от Mi on 11-Июн-10, 09:58 
>Я еще не видел ни одного релиза флеш плеера без исправления критической
>уязвимости? Когда уже все откажутся от этого поделия?

в пользу сильверлайт?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

13. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +5 +/
Сообщение от vadiml (ok) on 11-Июн-10, 11:32 
HTML5 -- его возможности на 99% перекрывают потребности во флеше
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

18. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 11:47 
Хорошо, что тогда остаётся на один процент?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

43. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от Имя on 11-Июн-10, 16:46 
> Хорошо, что тогда остаётся на один процент?

сверкающщие рекламные банеры?

о божи! как же я буду жить без сверкающщий рекламы!!

:-D :-D

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

44. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +3 +/
Сообщение от Имя on 11-Июн-10, 16:48 
>Хорошо, что тогда остаётся на один процент?

через`flash`ное вирусное заражение windows-компов..

...и целенаправленный взлом [любых] компов?

спасибо, не нада.. :-)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

53. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от User294 (ok) on 11-Июн-10, 17:16 
>Хорошо, что тогда остаётся на один процент?

HTML5? По идее он с его канвасами и прочая скоро даст пинка флешу под зад. Если адоба и дальше будет пи...ть про то что они не могут быстрый вывод видео, продолжат давиться жабой насчет средств разработки и прочая - сами себе могилу выроют. Уже роют семимильными шагами по мере имплементации хтмл5.

Потому что хромы и файрфосы с хтмл5 - смогут, имхо и видео играть. И архитектуру подпилят и акселерированный вывод видео наверное поюзают, как минимум через оверлеи или опенгл и прочая. И не будут лепить отмазки про отсутствие апи а просто сделают, блин. Так чтобы работало и не тормозило особо в реальных сценариях. У флеша есть весьма базовая проблема вывода видео, оно из-за дурной технологии отрисовки видеокадров тормозит на *никсах и  маках круче чем все остальное. А их архитект втирал что это by design (какой-то изврашенный вывод видео с софтовым наложением кадра на то что сам флеш нагенерячил и на вебпаге есть). И починить никак не можем дескать. А к сведению адобы - много вебразработчиков и серверадминов юзают линухи и маки. И если абоба не хочет обеспечить нормальную работу своего добра на оных без жрача мувиком на четверть скрина проца на уровне нехилого HD в нормальном плеере - тем хуже для абобы. Ее просто с такой политикой все пошлют. А с webm + HTML5 canvas это уже даже технически реально. В общем напрасно адоба столь жопой к юзерам - они ее ведь нагнут и ...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

68. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +1 +/
Сообщение от NNIIL on 11-Июн-10, 18:03 
а 1% это те, кто не могут изучить html5
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

85. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от 2Nike (ok) on 14-Июн-10, 10:50 
>HTML5 -- его возможности на 99% перекрывают потребности во флеше

Я вот терпеть не могу флэш, хотя бы потому, что он у меня в Linux тормозит. Но Вы неправы. Во первых применение Flash не ограничивается видео, яркий пример это сайты фильмов, которые почти целиком на флэше. Во вторых это сложность разработки. Вон гугл только недавно свой плеер наконец допилил.
А например делать сайт на html5 по какому нибудь фильму нет смысла. Он проживет год и все.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

21. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +3 +/
Сообщение от Аноним (??) on 11-Июн-10, 11:54 
>Я еще не видел ни одного релиза флеш плеера без исправления критической
>уязвимости? Когда уже все откажутся от этого поделия?

По-моему процесс начался. Сейчас умный программист уже не станет писать что-либо на флеше, поскольку понимает что это ходячий труп. То же самое можно сказать про сильверлайт. HTML5 уже не просто перекрывает возможности флеша, он ушёл значительно дальше.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

35. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –2 +/
Сообщение от denis111 (ok) on 11-Июн-10, 15:15 
Остаёться одна проблема: домохозяйки с ИЕ, коих большинство. Поэтому хтмл5 не катит (на рекламу/баннеры) :(
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

37. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +1 +/
Сообщение от аноним on 11-Июн-10, 15:31 
для них делаешь ссылочку на этот плагин - http://news.ferra.ru/soft/2010/06/09/100005/
с пометкой что ваш флэшь устарел/не_безопасен/..
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

45. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Имя on 11-Июн-10, 16:52 
>Остаёться одна проблема: домохозяйки с ИЕ, коих большинство. Поэтому хтмл5 не катит
>(на рекламу/баннеры) :(

наглое 4.2 .. IE (начиная с версии 6.0 ) обрабатывает HTML5 и CSS3 :-) ...

...ну вы поняли... Chrome-Frame-коппонент для IE .. который устанавливается точно таким же способом как и Adobe Flash


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

54. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:23 
>...ну вы поняли... Chrome-Frame-коппонент для IE .. который устанавливается точно таким же
>способом как и Adobe Flash

А еще топор по реке запросто плавает. Если его к спасательному кругу привязать :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

49. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от svchost (ok) on 11-Июн-10, 16:59 
>Остаёться одна проблема: домохозяйки с ИЕ, коих большинство. Поэтому хтмл5 не катит
>(на рекламу/баннеры) :(

Эту проблему решит сам Майкрософт, убивая свой IE6.

Есть еще домохозяйки с Windows98, у которых и флеш-то не устанавливается. Но мы же не берем их в расчет.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

60. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от аноним on 11-Июн-10, 17:45 
Дык пусть реклама и баннеры остаются во флеше навсегда, мы против что-ли?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

72. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 21:35 
>>Я еще не видел ни одного релиза флеш плеера без исправления критической
>>уязвимости? Когда уже все откажутся от этого поделия?
>
>По-моему процесс начался. Сейчас умный программист уже не станет писать что-либо на
>флеше, поскольку понимает что это ходячий труп. То же самое можно
>сказать про сильверлайт. HTML5 уже не просто перекрывает возможности флеша, он
>ушёл значительно дальше.

ну покажите свои разработки :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

4. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от anonymous (??) on 11-Июн-10, 10:11 
> из-за отсутствия стандартного API для обращения к функциям аппаратного
> декодирования потоков H.264.

Господа программеры помогите плиз. Вон виндузятники постояно на линукс
катят по поводу как раз этого апи, причем я их не очень понимаю :(

В к примеру в этом случае ? Что разве libvpau не в исходниках ?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

9. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от XXX (??) on 11-Июн-10, 10:37 
...vdpau оно как бы не совсем стандартно, и только для nvidia... у intel своя, у amd своя примочка для аппаратного ускорения, как называется - не скажу не помню... вот когда будет либа, а-ля "наподобие mesa, но для аппаратного ускорения видео", будет стабильный api, независимый от производителя - ati, intel, nvidia, via, etc. - тогда часть проблем пропадет само-собой... может ребята из гугля расстараются, и напишут что-нибудь на GSoC для проекта X.Org для аппаратного ускорения WebM... а уж к нему потом может кто-нить и h.264 прикрутит, по образу и подобию...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

30. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –1 +/
Сообщение от yet another anonim on 11-Июн-10, 14:23 
Да, в Винде есть такая штука, DXVA1\2 называется, которая позволяет себя использовать вне зависимости от модели - лишь бы сам DXVA поддерживался картой. И не важно какова реализация, с доп. чипом или усилием "шейдеров", какая последующая обработка (напр. деинтерлейс, уменьшение шума, деблокинг...) - всё это уже на стороне видюшки и драйверов, а DXVA только получает ответ от видюшки, мол "такой-то кодек\формат поддерживаю, принимаю, вывожу" или "нет". Что-то подобное в Линукс надо крутить, а то вроде бы есть XvMC, но его уже практически никто не использует и не развивает, практически забросили - у нВидии свой VDPAU, у Радеона - XvBA, у Интел свой, а тут уже и новый - VA API (который, я так понимаю, ни разу несовместим со стареньким XvMC) и т.п... Разработчики, не знакомые с видео под Линуксом, чую, впадают в шок, увидев такое разнообразие и "совместимость".
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

38. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от аноним on 11-Июн-10, 15:39 
пусть заюзают библу гстримера и не парятся. там lgpl.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

55. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:26 
Ну как бы если бы адоб нацелился на то чтобы сделать, а не отмазываться - сделали бы и не отмазывались бы. Благо, даже три либы для трех наиболее часто встречающихся видеокарт - вполне подъемная задача. А если цель упереться рогом и сказать "идите вы все, мордой лица не вышли" - ну так и пойдут ведь, и нефиг потом обижаться...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

70. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Wizard (??) on 11-Июн-10, 19:42 
Тю, блин... Я один, что ли, в курсе, что таки есть стандартный API (и, соответственно, библиотека) для ускорения видео - VA-API (libva)

http://freedesktop.org/wiki/Software/vaapi

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

78. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от svchost (ok) on 11-Июн-10, 22:27 
>Тю, блин... Я один, что ли, в курсе, что таки есть стандартный
>API (и, соответственно, библиотека) для ускорения видео - VA-API (libva)
>
>http://freedesktop.org/wiki/Software/vaapi

Работает как в стадии преальфы.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

15. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +9 +/
Сообщение от Zenitur email on 11-Июн-10, 11:37 
Если в Windows одно API, а в Linux три - Linux нужно ругать: зоопарк!
Если в Windows три API, а в Linux одно - Linux нужно ругать: ну нет выбора, скупой набор программ, нет гибкости, отстой в общем
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

31. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –1 +/
Сообщение от yet another anonim on 11-Июн-10, 14:35 
>Если в Windows одно API, а в Linux три - Linux нужно
>ругать: зоопарк!
>Если в Windows три API, а в Linux одно - Linux нужно
>ругать: ну нет выбора, скупой набор программ, нет гибкости, отстой в
>общем

Их не три, их больше, и при чём, все разные и туго-с-поддержкой... (Я читал, что проприетарные могут работать как "бэкэнды" для VAAPI, но что то на практике у меня это не получалось, а теперь, как обновился до 10.04 убунты и новых драйверов - даже сам VDPAU чё то вообще перестал запускаться - ну я не жалуюсь, 720p мой проц вытягивает, а выше смотреть вроде как и не приходится, хотя с VDPAU было вроде и плавнее, и симпатичнее..).
В винде есть DxVA и польностью-обратно-совместимый DxVA2, а чипмейкеры и вендоры сами заботятся о поддержке офф. API, так что ни проблем, ни нужды в альтернативах нет.
В любом случае, разработчики не хотят даже морочить голову со всеми этими *VA* на Линуксе, т.к., видимо, боятся за свою психику.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

56. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от User294 (ok) on 11-Июн-10, 17:27 
А если в линухе есть апи а в винде нет - обычно бухтят "%s не нужно!"
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

19. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 11:49 
>> из-за отсутствия стандартного API для обращения к функциям аппаратного
>> декодирования потоков H.264.
>
>Господа программеры помогите плиз. Вон виндузятники постояно на линукс
>катят по поводу как раз этого апи, причем я их не очень
>понимаю :(
>
>В к примеру в этом случае ? Что разве libvpau не в
>исходниках ?

Есть либа, называется VAAPI. Поддерживает все карты, однако пока ещё не допилен до нормального состояния

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

32. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от yet another anonim on 11-Июн-10, 14:39 
>[оверквотинг удален]
>>
>>Господа программеры помогите плиз. Вон виндузятники постояно на линукс
>>катят по поводу как раз этого апи, причем я их не очень
>>понимаю :(
>>
>>В к примеру в этом случае ? Что разве libvpau не в
>>исходниках ?
>
>Есть либа, называется VAAPI. Поддерживает все карты, однако пока ещё не допилен
>до нормального состояния

Поддерживает? Подскажите-ка, как на моём ЖиФорсе 9300GS это включить, если даже нигде не упоминается, даже в настройках самого-продвинутого SMPlayer нет? При чём ни с Nouveau, ни с проприетарными...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

66. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от master (??) on 11-Июн-10, 18:00 
>[оверквотинг удален]
>>>
>>>В к примеру в этом случае ? Что разве libvpau не в
>>>исходниках ?
>>
>>Есть либа, называется VAAPI. Поддерживает все карты, однако пока ещё не допилен
>>до нормального состояния
>
>Поддерживает? Подскажите-ка, как на моём ЖиФорсе 9300GS это включить, если даже нигде
>не упоминается, даже в настройках самого-продвинутого SMPlayer нет? При чём ни
>с Nouveau, ни с проприетарными...

в гугле забанен?
vaapi: http://www.splitted-desktop.com/~gbeauchesne/
настройка ATI : http://www.forum.free-x.de/wbb/index.php?page=Thread&postID=...
под NVIDIA вместо xvba-video юзаем vdpau-video

потом ./mplayer -va vaapi -vo vaapi:gl file.mkv и вперед и с песней

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

26. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от ононим on 11-Июн-10, 12:54 
не понятно, что они там не осилили, но gstreamer, mplayer, vlc уже умеют va-api.
у меня, например, амд видео карта с XvMC реализацией ускорения и оно работает в mplayer через va-api. на ноуте с GMA500 тоже все работает через va-api.

Более того, аппаратную акселерацию добавили даже в Gnash - свободную замену для флеш-плеера. Так что не ясно, почему эти адобовцы никак не разродятся на нормальную поддержку ускорения. Хотя если посмотреть, как долго они телятся с выпуском стабильного плеера под amd64 - этот вопрос можно считать риторическим.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

29. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –1 +/
Сообщение от strah4 on 11-Июн-10, 14:07 
>[оверквотинг удален]
>умеют va-api.
>у меня, например, амд видео карта с XvMC реализацией ускорения и оно
>работает в mplayer через va-api. на ноуте с GMA500 тоже все
>работает через va-api.
>
>Более того, аппаратную акселерацию добавили даже в Gnash - свободную замену для
>флеш-плеера. Так что не ясно, почему эти адобовцы никак не разродятся
>на нормальную поддержку ускорения. Хотя если посмотреть, как долго они телятся
>с выпуском стабильного плеера под amd64 - этот вопрос можно считать
>риторическим.

Они уже не телятся... 64 не будет, проект закрыт....


Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

34. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от wolfovich on 11-Июн-10, 15:12 
Откуда дровишки, что под amd64 не будет релиза?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

36. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от wolfovich on 11-Июн-10, 15:28 
We're working on 64-bit versions, but I'm unable to share a specific schedule at this point. We do understand the incredibly strong interest in its availability.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

57. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:29 
"Мы работаем над 64-битной версией но не можем сообщить точных дат релиза в данный момент. Мы понимаем что интерес к доступност этой [64-битной] версии растет". Вольный перевод. В каком месте тут сказано что релиза не будет? Тут сказано лишь что даты не определены.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

33. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от yet another anonim on 11-Июн-10, 14:44 
>[оверквотинг удален]
>умеют va-api.
>у меня, например, амд видео карта с XvMC реализацией ускорения и оно
>работает в mplayer через va-api. на ноуте с GMA500 тоже все
>работает через va-api.
>
>Более того, аппаратную акселерацию добавили даже в Gnash - свободную замену для
>флеш-плеера. Так что не ясно, почему эти адобовцы никак не разродятся
>на нормальную поддержку ускорения. Хотя если посмотреть, как долго они телятся
>с выпуском стабильного плеера под amd64 - этот вопрос можно считать
>риторическим.

И что толку от этого XvMC??? Он может и помагал когда-то ускорять DVD на пентиум I/II, но теперь даже первые медленные P4 (и P3 наверняка) могут справиться с MPEG2\MPEG4 SP 720p, а Core *-*** - и со всеми 1080p. Теперь ускорять нужно: H264\AVC, WMV3\VC-1, Web-M\VP-8...

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

41. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от ононим on 11-Июн-10, 16:34 
да, я старый XvMC спутал с новым XvBA. вот как раз последний у меня и работает.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

48. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от yet another anonim on 11-Июн-10, 16:58 
XvBA исключительно для Радеона. А с VA API страшные напряги - и ГУИ не знают о таком, и заработать ещё заставь на разных компах...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

52. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от yet another anonim on 11-Июн-10, 17:13 
>XvBA исключительно для Радеона. А с VA API страшные напряги - и
>ГУИ не знают о таком, и заработать ещё заставь на разных
>компах...

Просто, я хочу сказать, никто серьёзно за это не взялся и не объединил разработчиков, чтоб отшлифовать всё и заставить работать на разных архитектурах и на любом железе - настолько, насколько возможно использовать его потенциал, неплохо бы и с возможностью настройки типа:
1-галочки по декодингу,
2-выбор оптимиз. и адапт. фильтров, в т.ч. деблокинг и деинтерлейс,
3-выбор ускоряемых способов масштаб. и выводов.
Когда такое случится - то и таких многочисленных проблем, жалоб и багрепортов, с видео не будет, а заодно и всякие абобы подтянут своё "добро".

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

58. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:32 
>H264\AVC,

Те потоки которые можно прокачать через интернет - можно и не ускорять...

>WMV3\VC-1,

Эм... а вы этот VC1 вообще где-то видели? Мне он вообще не попадался ни разу в жизни. Я плохо смотрел?


>Web-M\VP-8...

Опять же - через веб такие потоки конечно что вот эти несчастные полмегабита, которые даже арм софтварно разгребет скорее всего ... просто позарез надо ускорить на мощном писюке с крутой видеокартой, ага :). Я понимаю там ускорение 30Мбит потока H.264 например, но кто ж его в веб то выложит? :)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

6. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 10:24 
Опять только 32 бита?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

8. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –2 +/
Сообщение от Аноним (??) on 11-Июн-10, 10:32 
зачем Вам 64 битный флэш?
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

10. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от Аноним (??) on 11-Июн-10, 10:39 
Чтоб использовать на 64 битной системе без всяких оберток.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

17. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Zenitur email on 11-Июн-10, 11:39 
>зачем Вам 64 битный флэш?

Надо.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

24. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 11:58 
>зачем Вам 64 битный флэш?

Вопрос надо ставить иначе: зачем вам флеш?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

61. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:51 
>зачем Вам 64 битный флэш?

Потому что на десктопе уже давно >=4Gb стало обыденным явлением и аться с 32-битным легаси на них совершенно не доставляет. Например моя домашняя система целиком 64-битная. Зачем мне в ней древнее 32-битное гуано?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

76. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +1 +/
Сообщение от Zenitur email on 11-Июн-10, 22:05 
Существуют способы адресовать более 4 гигабайт памяти приложениям, а в Линукс и подавно. Вот только крупным производителям это невыгодно
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

14. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Zenitur email on 11-Июн-10, 11:32 
Ура, наконец-то релиз! А ведь ещё вчера был только 10.0 стабильный. Единственное, что омрачает релиз, это отсутствие аппаратной декодировки видео - но зато уже года 3-4 есть аппаратное ускорение с помощью OpenGL.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

62. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:52 
А тебе так уж надо полмегабита видеопотока ускорять? :) А сильно больше как бы на ораву юзеров и не прокачаешь особо, да и каналы у многих юзеров больше не позволят...
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

20. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +2 +/
Сообщение от use (ok) on 11-Июн-10, 11:54 
Теперь нормально с кириллицей работает, и это радует.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

23. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 11:58 
>Теперь нормально с кириллицей работает, и это радует.

Причём это было не только с кириллицей

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

27. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от ононим on 11-Июн-10, 12:58 
>Для уменьшения энергопотребления теперь минимизируется нагрузка при обработке контекта в скрытых вкладках (выполнение Flash замораживается при переходе на другую вкладку и выполнение возобновляется только после возвращения к текущей вкладке).

те получается, что если у меня медленный инет, и я поставил 10 вкладок с youtube на прокачку видео, и ушел пить чай, пока это видео загружается, у меня в итоге прогрузится только одна вкладка?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

28. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от XoRe (ok) on 11-Июн-10, 13:59 
>>Для уменьшения энергопотребления теперь минимизируется нагрузка при обработке контекта в скрытых вкладках (выполнение Flash замораживается при переходе на другую вкладку и выполнение возобновляется только после возвращения к текущей вкладке).
>
>те получается, что если у меня медленный инет, и я поставил 10
>вкладок с youtube на прокачку видео, и ушел пить чай, пока
>это видео загружается, у меня в итоге прогрузится только одна вкладка?

Ну, если у вас 128 метров, то да)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

42. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Crazy Alex (??) on 11-Июн-10, 16:46 
Насколько я знаю, эта механика задействуется только для мобил. А на них 10 вкладок youtube и впрямь крутовато.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

40. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Анонимный трус on 11-Июн-10, 16:11 
Видать, сильно их Джобс припугнул.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

50. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от yet another anonim on 11-Июн-10, 17:00 
>Видать, сильно их Джобс припугнул.

Да они щас вообще под массовым обстрелом, Джобс тут даже не решает)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

65. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от User294 (ok) on 11-Июн-10, 17:58 
>Видать, сильно их Джобс припугнул.

Кроме Джоббса на абобу имеют некислый зуб вебмастера, админы и еще 100500 разных типов.
- Потому что покупать их суперредактор чтобы две анимахи и плеер сделать - не доставляет.
- Потому что под линухами и маками любимыми этим народом флеш работает хреново.
- Потому что с 64 бита у абобы все довольно плохо.
- Потому что в силу лицензии это не всем удобно поставлять в комплекте с девайсами и операционками.

Итого? Если Адоба будет Жлоба - она помрет. HTML5 закопает напрочь. Уж как видео - запросто. А остальное почти никому и не надо.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

63. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  –1 +/
Сообщение от oneonfire email on 11-Июн-10, 17:54 
Что-то при просмотре видео в контакте с новой версией оно тормозит(((
У меня Archlinux - XFCE 4.6.2, Firefox - 3.6.3, flashplugin - 10.1.53.64-1
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

83. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 13-Июн-10, 00:40 
Смотрите железо, софт видимо ни при чём
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

64. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от oneonfire email on 11-Июн-10, 17:56 
Из-за этого откатил на старую версию flashplugin - 10.0.45.2-1
Благо не очищал кеш pacman.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

67. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Tav (ok) on 11-Июн-10, 18:00 
Только i386. Получается, что для x86_64 доступна только уязвимая версия, спасибо, Адоб.

Надо будет попробовать Lightspark.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

69. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 18:43 
Обалденно радует работа кирилицы. Наконецто.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

73. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 21:38 
>Обалденно радует работа кирилицы. Наконецто.

Кирилица у меня же полгода как.
Кстати хочу сказать опять за этих бабуинов. Люди если вы высказываете свое мнение, высказывайте так чтобы остальным не было смешно. для 294, трухина и других тролей.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

75. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 21:48 
Да кстати, еще по-моему они в одной упряжке работают.
Просто это напоминает очень грамотный маркетинговый подход. То что несут эти два персонажа, реально очень круто с точки маркетинга. я просто уважаю этих троллей. Интересно сколько они зарабатывают. Рубля наверно по 3 с половинкой $ . Думаю что они даже в одном районе живут. Когда у меня была своя контора я тоже так делал. С двух сторон моск людям засирал. :) Не хило на этом поживился. народ же тупой.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

77. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Zenitur email on 11-Июн-10, 22:08 
>Да кстати, еще по-моему они в одной упряжке работают.
>Просто это напоминает очень грамотный маркетинговый подход.

Ну не )) Это параноидальные мысли, навеянные, я полагаю, скукой.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

80. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от filosofem (ok) on 12-Июн-10, 00:26 
>Когда у меня была своя контора я тоже так делал

Ключевое слово _была_.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

81. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 12-Июн-10, 07:47 
:) вот я и говорю _была_. Просто этот гон читать, жесть как раздражает.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

82. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 12-Июн-10, 08:02 
А если по новости. То конечно зря адобы, так с 64битной версией. 32битные компы уже доживают свое. Я удивился что они изначально не делали дебажную версию плейера. Но сейчас они превзошли себя. То что кто-то выберет HTML5 в замену флеша, и то что у HTML5 все круче, так во-первых это две разные технологии, на разное сориентированные. Во-вторых куда вы денете кучу приложений написанных для всяких соцсетей и всяких AIR-поделок. В корне разные. А на линуксе все нормально работает. Раньше (когда плейер был макромедиа, он был еще того качества). Я вообще никаких проблем не увидел и различий с виндой. Просто "вы не умеете его готовить".
По поводу редактора, вы что? Зачем? Откуда вы это взяли. Вам о чем нибуть flexsdk и алхимия говорит? Не пытайтесь нести всякий бред, если вы ничего не понимаете в этом.
Всё прозрачно. А про плэйер, если у когото проблемы, так помогите лайтспарку. :)
Проект реально прикольный.
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

86. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от maxkit (ok) on 15-Июн-10, 23:25 
>Раньше (когда плейер был макромедиа, он был еще того качества). Я
>вообще никаких проблем не увидел и различий с виндой. Просто "вы
>не умеете его готовить".

А Вы, стало быть, умеете? А то, что под MacOSX и Linux Flash съедает в 6-7 раз больше процессора, чем в Windows, и об этом говорят все, включая Jobs'а - это ничего?

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

79. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от ffsdmad (ok) on 11-Июн-10, 22:43 
а попробуйте вот тут http://podvignaroda.mil.ru/ в разделе обратная связь написать всё что вы о них думаете, а так же потребоваться чтобы они всё таки продолжили работу, а не ограничивались только праздником 9 мая
Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

84. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 13-Июн-10, 00:50 
>а попробуйте вот тут http://podvignaroda.mil.ru/ в разделе обратная связь написать всё что
>вы о них думаете, а так же потребоваться чтобы они всё
>таки продолжили работу, а не ограничивались только праздником 9 мая

Уже отписался, постарался быть вежливым, насколько это получилось)

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

74. "Релиз Flash Player 10.1 с исправлением критической уязвимост..."  +/
Сообщение от Аноним (??) on 11-Июн-10, 21:43 
Обновился на свою голову. Теперь ютуб в HD смотреть невозможно. Это такой хитрый ход от Nvidia, чтобы карточки их покупали?

Скорей бы уже WebM сделали.

Высказать мнение | Ответить | Правка | ^ | Наверх | Cообщить модератору

Архив | Удалить

Рекомендовать для помещения в FAQ | Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
MIRhosting
Inferno Solutions
Hosting by Ihor
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2019 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру