The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Странные зависания Gentoo Linux 2006.0"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Странные зависания Gentoo Linux 2006.0"  
Сообщение от ltyp email(ok) on 24-Июл-06, 17:54 
Всем доброго дня!

Встретился с очень странной преблеммой уже во второй раз.
Дело было так, я собрал сервер под Gentoo 2006.0 обновил его. Никаках небезопасных флагов для компиляции я не ставил. В системе используються:
Ядро gentoo-sources 2.6.16, или же hardened-sources тоже 2.6.16 (неважно)!
gcc 3.4.6 (всё пересобрано им).
используются нити ntpl, и только они - threads нет (хотя не знаю важно ли это).
glibc 2.3.6
ЖЕЛЕЗО ПРОВЕРИЛ!!! Память рабочая, диск рабочий ... (не предлогать типа мамку поменять)

Вот коротко о системе:

System uname: 2.6.16-gentoo-r12 i686 Pentium III (Coppermine)
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"

# lsmod

xt_state                1792  16
ipt_TTL                 2048  0
ipt_ttl                 1664  0
ipt_TCPMSS              3328  0
ipt_recent              8460  0
ipt_owner               1792  0
ipt_hashlimit           6664  0
ipt_esp                 1664  0
ipt_ECN                 2560  0
ipt_ecn                 1792  0
ipt_DSCP                1920  0
ipt_dscp                1536  0
ipt_CLUSTERIP           6276  0
ipt_ah                  1664  0
ipt_addrtype            1664  0
8139too                19200  0
e100                   28420  0

С системой происходило следущее. Я поставил на неё tightvnc и конектился удаленно к компу, всё было бы вроде ок. Но через несколько (2,3 или 4 как угодно дней) происходило очень странное зависание!!! Ситуация такая все процессы, которые были запущены (до момента Х..) работали нормально в штатном режиме, все новые процессы отказывались создаваться, просто не запускаясь (никакго отклика). Я это обнаружил так, у меня были залогиненные консоли, после "зависания" я мог работать в этих консолях по-минимому, например вий запускать не удовалось (новый процесс), как и все остальное. Если я пытался залогиниться getty (уже запущенная) нормально всё кушала, а процесс login не запускала, после 60ти сек выдавала Login timed out after 60 sec.
В одной из залогининых консолей у меня был запущен htop, я не помню в чем там было дело, но не понравился Xvnc (етить его), я его прямо из htop и срубил. И сразу после этого "DoS" исчез, я нормально мог залогиниться, все процессы создовались, одним словом сервер ОТВИС обратно!

Так я решил эту проблему в первый раз! Во второй раз другое железо, тоже нормальное, тажа сборка, всё как обычно. Но я встретился опять со вселенским злом! Те же симптом как и в первом случае. Но здесь нет Xvnc, как и иксов, вообщем. Из софта здесь крутяться вродебы проверенные приложения:
squid-2.5.13
apache-2.0.58
postfix-2.2.10
dovecot-1.0_beta8
bind-9.3.2
amavisd-new-2.3.3
clamav-0.88.2
spamassassin-3.1.3

Таким образом, я в недумении, я немогу идентифицировать источник проблемы (в логах ничего нет естесственно, их metalog не может записать). Подскажите кто-нибудь что-нибудь, мне такое поведение совсем непонятно. Даже если какой-то процесс засрет всю память на других приложениях это не должно сказываться, да и oomkiller (не знаю, что это) но помочь как-то должен!

Заранее всем очень благодарен!

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Странные зависания Gentoo Linux 2006.0"  
Сообщение от Free (??) on 25-Июл-06, 07:16 
Есть мнение, что это все-таки винт.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Странные зависания Gentoo Linux 2006.0"  
Сообщение от Nimdar (ok) on 25-Июл-06, 10:45 
Что говорит dmesg?
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Странные зависания Gentoo Linux 2006.0"  
Сообщение от ltyp email(ok) on 25-Июл-06, 14:44 
Товарищи!
Проверил - это не винт!
Опять произошло странное зависание, я установил следущее!!!!

Я как всегда оставил залогиненные консоли:) Всё в них работает на ура, насчет того, что не запускаються новые процессы - это я погарячился! Вроде бы работает.
Но залогиниться всё равно не удаёться - agetty висит 60 сек, логин так и не запускает!
Я потихоньку начил килять всё всё, как только срубил metalog-0.8_rc1, отвисло!

Соответсвенно вопрос, как каое-то галимое приложение может приводить к таким странным эффектам, что за дела???

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "Странные зависания Gentoo Linux 2006.0"  
Сообщение от ltyp email(ok) on 25-Июл-06, 17:04 
Вообщем разобрался с проблеммой.
Metalog вешает любого рода логины.
Полазив по форумам, нашел, что ни я один столкнулся с этой проблемой.
Говорят что надо отключить буфиризацию, и тогда всё заработает, посмотрим...
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру