The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  ВХОД  слежка  RSS
"Апгрейд портов"
Вариант для распечатки  
Пред. тема | След. тема 
Форумы OpenNET: Виртуальная конференция (Public)
Изначальное сообщение [Проследить за развитием треда]

"Апгрейд портов"  
Сообщение от SubGun email(??) on 11-Мрт-06, 14:52 
Собственно два вопроса:
1. Как заапгрейдить порты в /usr/ports я знаю. А вот как заапгрейдить уже установленные порты? Не будешь же их сносить и ставить заново?!
2. Как избавится от этих бесконечных "bsdpan.......has no origin record"? Достало уже.
Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

 Оглавление

Сообщения по теме [Сортировка по времени, UBB]


1. "Апгрейд портов"  
Сообщение от rm (??) on 11-Мрт-06, 15:06 
>Собственно два вопроса:
>1. Как заапгрейдить порты в /usr/ports я знаю. А вот как заапгрейдить
>уже установленные порты? Не будешь же их сносить и ставить заново?!
>
>2. Как избавится от этих бесконечных "bsdpan.......has no origin record"? Достало уже.
>


поиск по форуму.
cvsup, ports

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

2. "Апгрейд портов"  
Сообщение от SubGun email(??) on 11-Мрт-06, 15:14 
>поиск по форуму.
>cvsup, ports

А так нельзя ответить? Что я по поиску найду? Как cvsup выполнить? Так я это и так знаю. Лучше скажите как от сообщений избавится, которые мне /usr/ports/net/p5-URI-1.35 принес?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

3. "Апгрейд портов"  
Сообщение от funkblaster (??) on 11-Мрт-06, 15:15 
>>поиск по форуму.
>>cvsup, ports
>
>А так нельзя ответить? Что я по поиску найду? Как cvsup выполнить?
>Так я это и так знаю. Лучше скажите как от сообщений
>избавится, которые мне /usr/ports/net/p5-URI-1.35 принес?


cd /usr/ports/sysutils/portupgrade && make install clean
man portupgrade
man pkgtools.conf

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

4. "Апгрейд портов"  
Сообщение от SubGun email(??) on 11-Мрт-06, 16:45 
>Собственно два вопроса:
>1. Как заапгрейдить порты в /usr/ports я знаю. А вот как заапгрейдить
>уже установленные порты? Не будешь же их сносить и ставить заново?!
>
>2. Как избавится от этих бесконечных "bsdpan.......has no origin record"? Достало уже.
>

Так что? Как обновить, например, уже установленный perl? Его же переустановить нельзя, на нем работающие приложения держаться.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

5. "Апгрейд портов"  
Сообщение от funkblaster (??) on 11-Мрт-06, 17:31 
portupgrade perl
Чукча не читатель, чукча писатель?


Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

6. "Апгрейд портов"  
Сообщение от SubGun email(??) on 12-Мрт-06, 00:48 
>portupgrade perl
>Чукча не читатель, чукча писатель?

Сделал cvsup.
Поставил portupgrade. Вот тут ошибкаю Поставил его поле обновления.

netgenic# portversion -l
** Error occured reading /usr/local/etc/pkgtools.conf:
        undefined method `pkg_site_mirror' for main:Object
netgenic# portupgrade -arR
** Error occured reading /usr/local/etc/pkgtools.conf:
        undefined method `pkg_site_mirror' for main:Object

Как это иправить?

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

7. "Апгрейд портов"  
Сообщение от SubGun email(??) on 12-Мрт-06, 01:54 
Методом тыка закомментировал строку
pkg_site_mirror('ftp://ftp.FreeBSD.org')

netgenic# portversion -l "<"
[Updating the pkgdb <format:bdb1_btree> in /var/db/pkg ... - 92 packages found (-24 +43) (...)........................................... done]
/usr/local/lib/ruby/site_ruby/1.8/pkgdb.rb:352:in `deorigin_glob': Invalid argument (PkgDB::DBError)
        from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:177:in `config_include?'
        from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:172:in `each'
        from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:172:in `config_include?'
        from /usr/local/lib/ruby/site_ruby/1.8/pkgtools.rb:162:in `config_held?'
        from /usr/local/sbin/portversion:310:in `check_pkgs'
        from /usr/local/sbin/portversion:300:in `each'
        from /usr/local/sbin/portversion:300:in `check_pkgs'
        from /usr/local/sbin/portversion:260:in `main'
        from /usr/local/sbin/portversion:77:in `initialize'
        from /usr/local/sbin/portversion:77:in `new'
        from /usr/local/sbin/portversion:77:in `main'
        from /usr/local/sbin/portversion:347

Виг его знает. Подскажите, пожалуйста.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

8. "Апгрейд портов"  
Сообщение от SubGun email(??) on 12-Мрт-06, 14:53 
#portupgrade -arR
все равно заработал, несмотря на предыдущие ошибки. Получил вот такою ошибку в работе одного из приложений:
WARNING: CPAN Module GD::Graph::pie not installed. Obtain from www.cpan.org
WARNING: CPAN Module GD::Graph::linespoints not installed. Obtain from www.cpan.org

Ставились из пакетов:
p5-GD
p5-GD-Graph
p5-GD-TextUtil

Удалил, поставил из портов. Все равно:
WARNING: CPAN Module GD::Graph::pie not installed. Obtain from www.cpan.org
Can't locate object method "new" via package "GD::Graph::linespoints" at /usr/local/bin/eximstats line 1796.

Кстати, может кто знает, почему не ставится из портов p5-GD-TextUtil? Делаю make - ноль реакции, делаю make install - то же самое.
И, возвращаясь к старому вопросу, у меня все равно: kav4mailservers has no origin record осталось.
Я, по глупости, сделал cd /usr/local/security/openssl && make reinstall и теперь pkg_info выдает:
openssl-0.9.7g      SSL and crypto library
openssl-0.9.8a      SSL and crypto library

Помогите, пожалуйста.

Правка | Высказать мнение | Ответить | Cообщить модератору | Наверх

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема
Оцените тред (1=ужас, 5=супер)? [ 1 | 2 | 3 | 4 | 5 ] [Рекомендовать для помещения в FAQ]




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2022 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру