The OpenNET Project / Index page

[ новости /+++ | форум | wiki | теги | ]

форумы  помощь  поиск  регистрация  майллист  вход/выход  слежка  RSS
"Opera отказывается от использования библиотеки Qt в версии д..."
Вариант для распечатки  
Пред. тема | След. тема 
Форумы Разговоры, обсуждение новостей (Public)
Изначальное сообщение [ Отслеживать ]

"Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от opennews (??) on 23-Дек-09, 22:51 
Для сборок своего веб-браузера под Linux компания Opera больше не будет (http://techie-buzz.com/opera/opera-10-5-for-linux.html) использовать библиотеку Qt, а пользовательский интерфейс отныне будет отрисовываться напрямую с помощью библиотеки Xlib. Разработчики уверяют, что это позволит увеличить скорость работы программы.


Не смотря на такие кардинальные изменения, Opera будет поддерживать родные стили (http://my.opera.com/ruario/blog/unix-10-50-evenes-work-in-pr...) KDE и Gnome.

URL: http://techie-buzz.com/opera/opera-10-5-for-linux.html
Новость: https://www.opennet.ru/opennews/art.shtml?num=24798

Высказать мнение | Ответить | Правка | Cообщить модератору

Оглавление

Сообщения по теме [Сортировка по времени | RSS]


1. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Аноним (??) on 23-Дек-09, 22:51 
родной стиль KDE без QT?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

3. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от ixrws (??) on 23-Дек-09, 22:56 
Ну видимо хотят делать также, как mozilla. Только тут и стили qt и gtk+ будут поддерживаться. Поживём увидим.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

2. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от demimurych email on 23-Дек-09, 22:54 
это тем более смешно
что проблема оперы далеко не в скорости работы программы.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

5. "Opera отказывается от использования библиотеки Qt в версии д..."  –7 +/
Сообщение от Rudik on 23-Дек-09, 23:01 
На лине все медленее работает, а чтобы не бится головой о заостреный стул они хотябы чудо куте выпиляют. Правильным путем идете товарисчи.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

9. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Mike Lee on 23-Дек-09, 23:09 
Qt то чем не угодило?
Оно то по крайней мере для людей написано.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

19. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от vitek (??) on 23-Дек-09, 23:46 
хуже!.... а кто сказал что медленнее?
и медленнее чего?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

25. "Opera отказывается от использования библиотеки Qt в версии д..."  –8 +/
Сообщение от eth1 on 24-Дек-09, 00:01 
Как-будто неясно, чем.

Да и про людей - вопрос очень даже спорный.

ЗЫ оперу не использую по большей части из-за QT...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

33. "Opera отказывается от использования библиотеки Qt в версии д..."  –1 +/
Сообщение от User294 (ok) on 24-Дек-09, 01:58 
>ЗЫ оперу не использую по большей части из-за QT...

Думаете вы сильно нужны опере? Разве что как бесплатный тестер. Плюс-минус один маньяк которому влом поставить кутю для оперы - вообще ничто, а столь разборчивых не так уж и много. А вот уменьшение зависимостей опере пригодится там где она сильна (embedded хрень всякая с UI на основе браузера). Там то чем меньше барахла - тем лучше. Ну а вы будете задарма бетатестить эти технологии для оперы, хренли вы думали? :)

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

53. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от Zulu on 24-Дек-09, 13:59 
Вообще-то Qt умеет работать и без X, поверх фреймбуфера например. А вот Xlib нет.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

59. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от Keeper (??) on 24-Дек-09, 19:16 
В Unix-like системах, GUI без X'ов -- это извращение и ересь.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

61. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от mnu (??) on 24-Дек-09, 20:13 
почему же?
У меня где-то после 15-й открытой вкладки 10-е оперА тормозят дико. Со старыми оперАми (и старой Qt) такого не было до 70-й или 80-й вкладки, зато старая текла, как дырявое ведро - после 40-ка часов аптайма становилась неюзабельной.

И не надо мне говорить, что 15 вкладок - это много. Даже 30 вкладок - это не есть много. 80 - другое дело, не спорю.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

4. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Аноним (??) on 23-Дек-09, 23:00 
зачем ? если на то пошло, то пусть уж выводят напрямую через видеодрайвер
к тому же проблем со скоростью работы интерфейса я что-то у оперы не замечал
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

6. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от anatolb email on 23-Дек-09, 23:03 
Просто захотелось написать свой велосипед. Такое бывает. Правда у профессиональных разработчиков это случается всё же реже.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

34. "Opera отказывается от использования библиотеки Qt в версии д..."  –1 +/
Сообщение от User294 (ok) on 24-Дек-09, 02:11 
>Просто захотелось написать свой велосипед. Такое бывает.

При том для оперы это даже вполне оправдано с ее основными источниками доходов. Они, как бы, на десктопных хомячках только отлаживаются. А доход то у них с других областей. Вот там данный шаг оценят.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

27. "Opera отказывается от использования библиотеки Qt в версии д..."  +2 +/
Сообщение от eth1 on 24-Дек-09, 00:03 
ну а тебе-то какая разница, на чём оно будет? Если в Гноме и КДЕ нативно выглядеть будет... Вот уж люди... Другое дело, когда оно на КуТе было и тех, кто предпочитает GTK, от такого вида просто тошнило. А теперь всем хорошо будет. И интерфейс поотзывчивее.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

32. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от ss (??) on 24-Дек-09, 01:25 
>ну а тебе-то какая разница, на чём оно будет? Если в Гноме
>и КДЕ нативно выглядеть будет... Вот уж люди... Другое дело, когда
>оно на КуТе было и тех, кто предпочитает GTK, от такого
>вида просто тошнило. А теперь всем хорошо будет. И интерфейс поотзывчивее.
>

да нормально всё вырисовывается под гномом и сейчас.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

40. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Aquarius (ok) on 24-Дек-09, 08:06 
в интерфейсном плане от Qt, все равно, толку не было - шкурки то у Oper'ы свои
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

7. "Opera отказывается от использования библиотеки Qt в версии д..."  +3 +/
Сообщение от azure (ok) on 23-Дек-09, 23:08 
:\
Новость вызвала недоумение. Почему отказываться от такого замечательного тулкита? Опера летает даже шустрее чем жтк-шный файрфокс. Нет, конечно, через xlib в теории будет быстрее.. но зачем писать свой велосипед если есть хорошая кросплатформенная либа, да еще и бесплатная? Впрочем, если получится не хуже чем есть, то пусть пилят. Не теряю надежд, что десктоп-версия когданибудь будет открыта.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

41. "Opera отказывается от использования библиотеки Qt в версии д..."  –2 +/
Сообщение от www2 (ok) on 24-Дек-09, 08:38 
Эта либа бесплатная только для тех, кто согласен делиться исходниками своих поделий в соответствии с GPL. Опера не хочет делиться исходниками, а потому вынуждена пользоваться либой под другой, "более платной" лицензией.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

45. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от Wizard (??) on 24-Дек-09, 09:54 
С добрым утром!

Qt уже давно LGPL.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

66. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Smile (??) on 25-Дек-09, 18:46 
это не отменяет тезиса "опера не хочет делиться исходниками"
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

54. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от trdm (ok) on 24-Дек-09, 14:34 
>зачем писать свой велосипед

ну ответ уже дан:
>конечно, через xlib в теории будет быстрее..

а вот это:
>но если есть хорошая кросплатформенная либа, да еще и бесплатная?

Она слишком неповоротливая стала. У меня лично её неповоротливость создает проблемы в проекте. Вот думаю, а не послать ли её подальше эту монстрелку.
а насчет велосипедов: если есть ресурсы, то под задачу можно написать оптимальное решение, а не кланяться тормозному майнстриму.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

12. "Opera отказывается от использования библиотеки Qt в версии д..."  –1 +/
Сообщение от Аноним (??) on 23-Дек-09, 23:15 
таки видимо это связано с глюком Qt 4.5.3, когда opera съедала 100% CPU. Решили такой костыль написать, вместо того чтоб разбиратся)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

16. "Opera отказывается от использования библиотеки Qt в версии д..."  +5 +/
Сообщение от Aesthetus Animus on 23-Дек-09, 23:38 
А зачем разбираться с чужим костылем под названием Qt? Из любви к искусству? Но за те издевательства над Плюсами, что понаверчены в Qt, оный такой любви не заслуживает. Кроссплатформенность? Но виндовская опера никогда Qt не использовала, а использование Xlib не уменьшит (я надеюсь) кроссплатформенность на системах, использующих иксы.

Тулкит - это не священная корова, на которую надо молиться и на которую не дай бог ты подымишь руку. Вот ради чего разбирать чужие костыли? Если инструмент не устраивает - к чертовой матери его! С другой стороны, это должно быть знаком для Nokia, что их тулкит будет заменен другим при первом же удобном случае, так что надо задумываться о его качестве.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

23. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Карбофос (ok) on 23-Дек-09, 23:57 
вообще-то тролльтеховцы достаточно интенсивно работают над оптимизацией, даже разработчики КДЕ на этом не раз делали акцент.
могу, конечно, понять, если используемые Qt функции прорисовки являются прослойкой к Xlib. если там сделано пару-тройку проверок, которых нет в Xlib, то разработчиков браузера могут ожидать неприятные неожиданности.

шаг непонятен, нет деталей сравнительного анализа

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

35. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от User294 (ok) on 24-Дек-09, 02:12 
>шаг непонятен, нет деталей сравнительного анализа

Чего тут непонятного то? В эмбдеддед чем меньше зависимостей тем лучше. А десктоп... хм, для оперы оно так, орава бесплатных тестеров, а не основной рынок.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

37. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Карбофос (ok) on 24-Дек-09, 03:01 
в принципе, тогда это логическое объяснение. но опять же, в таком случае объяснение программеров от оперы по поводу "позволит увеличить производительность" - левая отмазка. хотя если уменьшать количество внешних зависимостей, то можно увеличить размер свободной памяти для самого браузера.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

44. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Сергей (??) on 24-Дек-09, 09:35 
>Чего тут непонятного то? В эмбдеддед чем меньше зависимостей тем лучше. А

В embedded иксы не нужны. Qt умеет использовать фреймбуфер ядра.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

57. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от trdm (ok) on 24-Дек-09, 16:23 
А где результаты? Чето не видать :(
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

14. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от Аноним (??) on 23-Дек-09, 23:31 
им не хватало скорости прорисовки виджетов? они Qt использовали только для меню, диалогов итп. Странные ребята, странные. финансов у них зашкаливает, занимаются всякой херней? Конкуренты в лице хрома и мозиллы не давят? Странно...
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

15. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от аноним on 23-Дек-09, 23:33 
давно было известно, что opera перейдет на свой кроссплатформенный тулкит.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

24. "Opera отказывается от использования библиотеки Qt в версии д..."  +12 +/
Сообщение от Alexey (??) on 23-Дек-09, 23:58 
Итак, для всех анонимусов проясняю ситуацию: судя по комментам многие просто не в курсе ситуации. Итак, внутри браузера Opera находится их собственный тулкит, который может юзать в качестве фронтенда любой тулкит. Например, в системе Windows используется Win32, в Linux - Qt, там, где возможности еще больше ограничены их тулкит может юзать и более маленькие библиотеки. Видимо они решили, что пришло время воспользоваться и более низкоуровневыми средствами рисования.

Таким образом никаких кардинальных изменений в коде браузера и его функциональности не произойдет.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

30. "Opera отказывается от использования библиотеки Qt в версии д..."  –1 +/
Сообщение от Ariel (??) on 24-Дек-09, 00:57 
>Итак, для всех анонимусов проясняю ситуацию: судя по комментам многие просто не
>в курсе ситуации. Итак, внутри браузера Opera находится их собственный тулкит,
>который может юзать в качестве фронтенда любой тулкит. Например, в системе
>Windows используется Win32, в Linux - Qt, там, где возможности еще
>больше ограничены их тулкит может юзать и более маленькие библиотеки. Видимо
>они решили, что пришло время воспользоваться и более низкоуровневыми средствами рисования.
>
>
>Таким образом никаких кардинальных изменений в коде браузера и его функциональности не
>произойдет.

вы имели в виду бэкенд? или я не понял; их либа работет поверх нативных API?

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

31. "Opera отказывается от использования библиотеки Qt в версии д..."  +6 +/
Сообщение от Alexey (??) on 24-Дек-09, 01:13 
Да, их либа работает поверх любого другого механизма для рисования и работы с окнами. Для Linux они выбрали Qt, вот сейчас будут избавляться от нее. Если интересна тема, то вот информация из первых рук:

http://my.opera.com/kilsmo/blog/2008/01/29/opera-is-not-base...

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

36. "Opera отказывается от использования библиотеки Qt в версии д..."  –6 +/
Сообщение от hatelinux on 24-Дек-09, 02:28 
не смешите мои тапочки
опера не использует qt?
заинстальте ее под виндовс и посмотрите на *qt*.dll который она использует

не знаю как сечас но пару лет назад опера была полностью на qt зависимой

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

42. "Opera отказывается от использования библиотеки Qt в версии д..."  +2 +/
Сообщение от Aleksey (??) on 24-Дек-09, 08:49 
А чуть выше текст по ссылке прочитать слабо?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

50. "Opera отказывается от использования библиотеки Qt в версии д..."  +3 +/
Сообщение от Аноним (??) on 24-Дек-09, 11:18 
покажи где там хоть одна *qt*.dll ? и даже в opera.dll нету никаких ссылок на Qt, даже статичную версию (дада, я предварительно распаковал dll upx'ом). А вот в Google Earth следы Qt отлично виднеются
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

29. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от ffsdmad (ok) on 24-Дек-09, 00:52 
опера начинает пиарится по чёрному: http://www.computerra.ru/terralab/softerra/490652/ и http://gs.statcounter.com/#browser_version-RU-weekly-200827-...

видимо очень хотят понравится всем когда на них появится ссылка в окошке винды, чтож, это хорошо - вместе веселее закапывать IE

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

46. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от hizel (ok) on 24-Дек-09, 10:11 
тоесть огнелису можно, а опере нельзя?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

47. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от ffsdmad (ok) on 24-Дек-09, 10:22 
лишь бы не IE
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

43. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от NNIIL on 24-Дек-09, 09:12 
Просто опера хочет завоевать рынок красивым интерфейсом, и большой скоростью работы. А огнелис количеством фич, из-за чего он такой громоздкий и неповоротливый, что с каждым днем противнее использовать. Пусть опера и закрытая, но она идет по верному пути
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

48. "Opera отказывается от использования библиотеки Qt в версии д..."  –3 +/
Сообщение от ffsdmad (ok) on 24-Дек-09, 10:23 
>Просто опера хочет завоевать рынок красивым интерфейсом, и большой скоростью работы. А
>огнелис количеством фич, из-за чего он такой громоздкий и неповоротливый, что
>с каждым днем противнее использовать. Пусть опера и закрытая, но она
>идет по верному пути

верно, в печь она идёт

какие то у вас странные пристрастия к программному обеспечению

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

49. "Opera отказывается от использования библиотеки Qt в версии д..."  +2 +/
Сообщение от аноним on 24-Дек-09, 10:51 
>верно, в печь она идёт

очень заметно, ага.

мозилла без подачек от гугла не знает как свести концы с концами. вот уже открывают магазин платных расширений.

у опера софтвер каждый год прибыль растет на десятки процентов.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

51. "Opera отказывается от использования библиотеки Qt в версии д..."  +3 +/
Сообщение от syeg (ok) on 24-Дек-09, 11:29 
Web-браузер у Opera Software как визитная карточка, а зарабатывают они другими вещами. Было недавно в интервью кого-то из их шишек. А вот Mozilla Fondation таким ведением бизнеса похвастать не может.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

67. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от User294 (ok) on 28-Дек-09, 17:02 
>у опера софтвер каждый год прибыль растет на десятки процентов.

Вот только не за счет десктопа. Потому то такие странные ходы и возникают.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

52. "Opera отказывается от использования библиотеки Qt в версии д..."  +2 +/
Сообщение от trdm (ok) on 24-Дек-09, 12:43 
Определенно "+". Как немало провозившийся с QPainter говорю.
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

55. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от pavlinux email(ok) on 24-Дек-09, 14:56 
Даёшь браузер на ассемблере!!!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

56. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Карбофос (ok) on 24-Дек-09, 16:11 
да ладно, чего там. жду от трухина браузера на дотнете
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

60. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Vortex email(??) on 24-Дек-09, 19:48 
У меня Qt4 версия Оперы постоянно "грохается", и постоянно отправляет краш-репорты. Думаю, я не один с такой проблемой.
Наверно разработчиков немного подзадрочил такой поток информации, и они решили решить радикальными методами.
Думаю это к лучшему.
Спасибо разработчикам Оперы!
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

63. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от Карбофос (ok) on 25-Дек-09, 15:22 
надо быть для начала уверенным, что Опера именно из-за Qt падает, не так ли?
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

62. "Opera отказывается от использования библиотеки Qt в версии д..."  +1 +/
Сообщение от Zenitur email on 25-Дек-09, 00:25 
Чем им не угодил Qt? Они всегда собирали сразу в трёх версиях Qt, 3 и 4. Как умудрялись, не знаю... Я за это им всегда был очень благодарен как пользователь третьих KDE и не желающий лишний раз загружать память 4-м Qt, а также постоянно следить, чтобы стояла последняя версия. А то программы не хотят работать никогда на старых. Всё же новая версия KDE - антиреклама для вполне быстрого и работоспособного Qt 4...
Плюс ещё версия для Windows не на Qt - так бы от использования именно Qt был бы смысл. А иначе нет
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

64. "Opera отказывается от использования библиотеки Qt в версии д..."  +/
Сообщение от trdm (ok) on 25-Дек-09, 16:50 
>Чем им не угодил Qt?

А почему только им? Меня тоже уже не устраивает быстродействие графической системы.
И не меня одного, вот например:
http://www.rsdn.ru/forum/cpp.applied/3650421.flat.aspx
Я уже посматриваю в стророну WTL и XLib. слава богу мне не нужны бантики Qt.

Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

65. "Opera отказывается от использования библиотеки Qt в версии д..."  –1 +/
Сообщение от trdm (ok) on 25-Дек-09, 16:57 
Гугль тоже начхал на Qt и правильно сделал.
Сбацал себе браузер с использованием wtl и не жужжит
А вы думаете почему версии для Linux и Windows отдельно тусуются? :)
Высказать мнение | Ответить | Правка | Наверх | Cообщить модератору

Архив | Удалить

Индекс форумов | Темы | Пред. тема | След. тема




Спонсоры:
Inferno Solutions
Hosting by Hoster.ru
Хостинг:

Закладки на сайте
Проследить за страницей
Created 1996-2021 by Maxim Chirkov
Добавить, Поддержать, Вебмастеру